Questions tagged [ppa]

PPAs are personal package archives that allows users and groups on Launchpad to make packages available to the public. PPAs can be added with a terminal command or through Software Sources.

Filter by
Sorted by
Tagged with
1206
votes
26answers
1.4m views

How can PPAs be removed?

I've added many PPAs using the add-apt-repository command. Is there a simple way to remove these PPAs? I've checked in /etc/apt/sources.list for the appropriate deb lines but they aren't there. This ...
536
votes
14answers
920k views

How do I resolve unmet dependencies after adding a PPA?

Occasionally, when I'm installing stuff, I get an error like the following: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the ...
506
votes
10answers
624k views

What are PPAs and how do I use them?

I keep reading about Personal Package Archives ('PPAs') and people answer questions with a link to a PPA. What's the best way to use these? There are multiple valid answers for this question ...
300
votes
8answers
142k views

Are PPAs safe to add to my system and what are some “red flags” to watch out for?

I see a lot of interesting programs out there that can only be obtained by adding a "PPA" to the system but, if I'm understanding correctly, we should stay within the official "repositories" for ...
264
votes
8answers
532k views

How can I fix a 404 Error when using a PPA or updating my package lists?

PPA seems to be constantly offline. Whenever I use sudo apt-get update, this error is shown: W: Failed to fetch http://ppa.launchpad.net/ 404 Not Found How do I fix these errors?
226
votes
2answers
308k views

How do I install different (upgrade or downgrade) PHP version in still supported Ubuntu release?

I am trying to update to install PHP 5.5, 5.6 or 7.0 in Ubuntu 12.04/14.04/16.04 LTS, and I can only get PHP 5.3.10 for Ubuntu 12.04, PHP 5.5.9 for Ubuntu 14.04 or PHP 7.0.4 for Ubuntu 16.04 using ...
213
votes
12answers
340k views

How can I get a list of all repositories and PPAs from the command line into an install script?

I know how to list all packages installed on my system. But how could I get a list of all repositories and PPA's into a script that I can run on a new machine to replicate the repository setup ...
209
votes
2answers
447k views

Error sudo: add-apt-repository: command not found

I’m running Ubuntu 14.04. When I run: sudo add-apt-repository ppa:ubuntu-wine/ppa I get the following error: sudo: add-apt-repository: command not found I tried to run sudo apt-get install ...
199
votes
18answers
491k views

How to install Eclipse?

I want to install the latest version of Eclipse but the Ubuntu Software Centre contains an older version. Is there a PPA or some other way to install latest Eclipse? Please describe the steps for ...
160
votes
6answers
211k views

How to add a PPA on a server?

The server version of Ubuntu does not have the add-apt-repository command. How can I add a Personal Package Archive (PPA) to the server without this command?
122
votes
3answers
40k views

How do I create a PPA?

How do I create my own custom PPA to share with the Ubuntu community? I am trying to create my own custom package set and I would really like to share it with the community.
104
votes
7answers
320k views

GLIBCXX_3.4.20 not found, how to fix this error?

Whey I try to run the program Layout Editor (available on this site) on Ubuntu 14.04.1 64-bit LTS I get the following output in the terminal: $ layout layout: /usr/lib/x86_64-linux-gnu/libstdc++.so.6:...
92
votes
4answers
31k views

Avoiding user interaction with tzdata when installing certbot in a docker container

I want to install certbot in a docker environment with an Ubuntu 16.04 image: For example: docker run -it ubuntu:16.04 /bin/bash When I'm inside the container, the most straightforward way to ...
90
votes
9answers
23k views

The following signatures were invalid: EXPKEYSIG 1397BC53640DB551

This is Issue 952287: [User Feedback - Stable] Reports of Chrome for Linux failing to install/update due to expired GPG signing key Today, running apt in all my machines gives this error with the ...
84
votes
6answers
56k views

Where can I find a Subversion 1.7 binary?

Does anybody know of a ppa or source I can get a subverison 1.7 deb? It was just released yesterday so I'm sure something will show up eventually. However I figure this will be a good place to post ...
83
votes
0answers
96k views

How do I remove a PPA added via command-line? [duplicate]

I added a PPA for updating my kernel for ubuntu-12.04. Later, I found that the kernel doesnot exist on the link within PPA. I used this command. sudo add-apt-repository ppa:kernel-ppa/ppa Now if I ...
80
votes
3answers
50k views

Explicitly accept change for PPA 'Label'

When I run apt-get update on my ubuntu 17.10 I receive the following error: E: Repository 'http://ppa.launchpad.net/ondrej/php/ubuntu artful InRelease' changed its 'Label' value from '***** The main ...
77
votes
2answers
25k views

How to update Google Chrome 70 after change in 'Origin' value?

I have Google Chrome Version 70.0.3538.77 (Official Build) (64-bit). Today, after running sudo apt update and sudo apt full-upgrade, I saw: E: Repository 'http://dl.google.com/linux/chrome/deb ...
66
votes
2answers
67k views

What does 'Ign' , `Get` or 'Hit' mean when running an apt-get update?

I had a bunch of errors in the output of sudo apt-get update: duplicate entries and 404 not found errors. Figured those out, I hope: I removed PPAs that didn't have any packages associated with them,...
65
votes
1answer
190k views

How to add ppa repositories? [duplicate]

Possible Duplicate: What are PPAs and how do I use them? I always like to have my programs up to date but in ubuntu software center the software aren't always up to date. I know about repositorys ...
60
votes
3answers
37k views

Should I upgrade to the “mainline” kernels?

Newer "mainline" versions of the kernel are available from the Ubuntu kernel team, e.g. 3.4 and 3.5, while Ubuntu 12.04 is on 3.2. What are the mainline kernels? Are they better than my existing ...
56
votes
3answers
118k views

How to update VLC to the latest version?

As VLC 2.0 is released, how do I get it in Ubuntu (XUbuntu actually, in my case) 11.10? Any PPAs or packages to download? The official page says "Ask your favorite packager..."
55
votes
2answers
29k views

How do I add a PPA in a shell script without user input?

Basically, I want to run add-apt-repository ppa:(whatever) without the "press Enter to continue" prompt. How would I do this? Essentially, I want to deploy adding a repository in a shell script ...
50
votes
4answers
28k views

How to update from webupd8 team PPA (Oracle JDK 8/9) that got inconsistent with its GPG key?

A few days ago, I started getting the following error when performing apt-get update: E: Repository 'http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease' changed its 'Label' value from ...
48
votes
4answers
35k views

Google Chrome PPA upgrade invalid signature

When running: sudo apt-get update && sudo apt-get dist-upgrade I got this output: Ign http://security.ubuntu.com utopic-security InRelease Ign http://gb.archive.ubuntu.com utopic InRelease ...
47
votes
3answers
2k views

Is there any guarantee that software from Launchpad PPAs is free from viruses and backdoor threats?

As Linux continues to grow and develop, and the more we use Linux, the greater the threat from viruses. We also know that a virus/threat in Linux (if any) would have difficulty running or spreading ...
46
votes
5answers
24k views

What's the difference between a PPA and a repository?

I recently posted an answer where I wrote add the PPA. But I now realize, that I have no idea what the difference between a PPA and a Repository is. So can someone please explain it to me?
45
votes
3answers
22k views

How do I cherry pick packages from a PPA?

Is there a way to cherry pick packages from a ppa repository you add? That is, to exclude some from updating while including others? For example, I want just the chromium-browser package from this ...
43
votes
4answers
114k views

What can I do if a repository/PPA does not have a Release file?

When updating, I get the following error message: W: The repository 'http://ppa.launchpad.net/mc3man/trusty-media/ubuntu xenial Release' does not have a Release file. Here, I find another statement ...
42
votes
2answers
29k views

Difference between “ppa-purge” and “add-apt-repository -r”?

What is the main difference between ppa-purge and add-apt-repository -r. Which one better clear residual items and reason to use one over another? Does add-apt-repository -r should do what ppa-purge ...
40
votes
4answers
17k views

What's the best way to re-enable PPAs/repos after an upgrade?

When I upgrade from 11.10 to 12.04, what's the best way to re-enable my PPAs and added repositories?
36
votes
2answers
47k views

How can I install and use gcc 6 on xenial? [duplicate]

I wish to test existing software with gcc 6, to ensure that it will work when the transition takes place. How can I install gcc 6? Is there a ppa available? Can I just do a "CC=gcc-6 make" ? ...
36
votes
2answers
6k views

How do I create a PPA for a working program?

Let's assume I have a working application written in C, C++ or Python. I want to create a Launchpad PPA so others can easily install it from a package. Please give step by step instructions for doing ...
35
votes
2answers
5k views

PPA & Packaging: Having versions of packages for multiple distros

(quote from chat) Got a PPA on launchpad for source packages for an IRC bot project I'm associated with (since its all the intermediate packaging for the stuff between releases, it's classified as ...
34
votes
8answers
13k views

Where can I find Vim 7.3?

Vim 7.3 is out, but not available in the sources. Where can I get an installation package for the 7.3 version? I don't want to install it manually.
33
votes
6answers
13k views

Any PPAs for Google's Go Language?

Do you know of any URLs for PPAs of Google's Go Language?
31
votes
3answers
22k views

Is there a PPA for the latest Blender version?

I am interested in trying out the Blender 2.54 beta, but don't have the time or patience to download and install all of the dependencies for it and compile it myself. Is there a PPA somewhere that I ...
29
votes
2answers
11k views

Should I install programs from a source tarball (`.tar.gz`), from the Ubuntu Software Centre, or from elsewhere?

There are several ways to install an application in Ubuntu: You can download a source tarball (generally a .tar.gz or a .tar.bz2 file) and install it manually. (See How do I install a .tar.gz (or ....
29
votes
2answers
11k views

Does someone know why the Chromium daily package isn't build anymore?

It looks like chromium-browser @ https://launchpad.net/~chromium-daily/+archive/ppa haven't been build for the past 6 weeks. I tried to get in touch with them on launchpad but I've got no answers...
27
votes
4answers
7k views

How can I backup my PPAs?

Related to this question. But my concern is that over the past year, most of my more interesting (or used) applications are from PPAs, and just backing up my sources list won't add the associated ...
27
votes
5answers
3k views

Is there an “unofficial” software center with all the PPAs?

Many questions are answered simply with add this repository and install. I understand that Ubuntu developers cannot quickly verify all packages and make them available in official repositories. But ...
26
votes
4answers
57k views

How can I install a realtime kernel?

I have read a lot of threads with similar questions, but after reading the answers, I am very confused. I have found in them lots of url's with repositories but people discusses about which ...
24
votes
7answers
21k views

How to install new tmux 1.8 on Ubuntu 12.10 or 12.04?

Are there any PPA? If no, how to make it from sources? Which dev libs I'll need to do this?
24
votes
1answer
115k views

Cannot Add PPA Behind Proxy Ubuntu 14.04 [duplicate]

I am unable to add a repository via the command line on Ubuntu 14.04. Apt-get works perfectly fine, and I am able to update the system. I have configured my /etc/apt/apt.config file as follows: ...
24
votes
4answers
54k views

How do I install the Tor Browser Bundle in Ubuntu?

In Ubuntu 13.04 I used the following PPA to install the 64-bit Tor Browser Bundle. However, in Ubuntu 13.10 it doesn't work anymore. sudo add-apt-repository ppa:upubuntu-com/tor64 sudo apt-get update ...
24
votes
3answers
24k views

Where can I find a g++ 4.7 package?

Some time ago, I managed to find PPA featuring g++-4.7 build. However, I had to reinstall everything on my machine and I lost name of that PPA. Could anyone point me to it? I tried to find it again, ...
23
votes
3answers
103k views

Cannot add PPA. Please check that the PPA name or format is correct

Internet connection is working. apt-get is working. Trying to add ppa:cooperjona/lightread but an error has raised: Cannot add PPA 'ppa:cooperjona/lightread' . Please check that the PPA name or ...
23
votes
4answers
13k views

How can I backup my Repositories?

I want to backup all the repositories I added to the Ubuntu Software Center, but apparently sources.list contains only the ones which belong to Canonical. So where do I find the other ones?
23
votes
1answer
29k views

UnicodeDecodeError: 'ascii' codec can't decode byte 0x* in position *: ordinal not in range(128)

I tried to enter the following command add-apt-repository ppa:ondrej/php5 You are about to add the following PPA to your system: This branch follows latest PHP packages as maintained by me & ...
22
votes
5answers
52k views

libimobiledevice 1.2 (iOS 8 Support) for Ubuntu 14.04 Trusty

Is there a PPA available for the most recent libimobiledevice 1.2 version with support for iOS 8 or can someone explain how to build it from source without messing up everything? https://launchpad....