Questions tagged [ppa]

PPAs are personal package archives that allows users and groups on Launchpad to make packages available to the public. PPAs can be added with a terminal command or through Software Sources.

288 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
7
votes
1answer
6k views

How do I install gcc-5.3 on Ubuntu 16.04

I'm currently running Ubuntu 16.04 and want to install gcc-5.3 from source, without disrupting thegcc-5.4 and gcc-4.9 that I have already installed using Synaptic package manager. The reason I want ...
5
votes
0answers
998 views

Can't add PPA using add-apt-repository: SSL support not available

Whenever I try to add any PPA to install any stuff, I get the following error: nikunj@nikunj-DL-H61MXE-V:~$ sudo add-apt-repository ppa:ravefinity-project/ppa Traceback (most recent call last): ...
4
votes
0answers
2k views

How to install Moksha Desktop?

I like the moksha destop which Bodhi Linux uses. Is there not a repo or snap to install moksha on Ubuntu? The Debian instructions seem a bit much for what I would naively expect to be a package, or ...
4
votes
0answers
265 views

Don't know how to remove packages to upgrade from 14.04 to 16.04

I have been trying to upgrade from 14.04 to 16.04 for a few weeks with no success. As many others (e.g., here), I get an error message saying that Ubuntu "could not calculate the upgrade". I tried to ...
4
votes
0answers
3k views

How can I upgrade to the latest wpa_supplicant?

I have (more precisely, my employer has) a machine running Ubuntu 14.04 LTS, which comes with wpa_supplicant version 2.1. There are improvements in wpa_supplicant 2.5 which I believe may help with ...
4
votes
2answers
3k views

Why did debuild fail with “configure: error: unrecognized option:”

I was trying to follow the instructions listed in this question/answer. libimobiledevice 1.2 (iOS 8 Support) for Ubuntu 14.04 Trusty The answer said : "Actually I cheated a bit. I couldn't satisfy ...
4
votes
1answer
155 views

How can I search available PPA packages and get a list sorted by version number?

It is possible to search through the available PPAs on this web page, but is there any way to perform this search and get a list of PPAs sorted according to the version number and/or date of the most ...
4
votes
2answers
8k views

Key server receive failed when installing through PPA

I'm fairly new to Linux. I have Ubuntu, and now I want to install the Pantheon desktop, but as soon I run the command sudo add-apt-repository ppa:elementary-os/daily I get an error message saying: ...
4
votes
1answer
677 views

php5 is already the newest version but in phpinfo i get 5.4

Details: Distributor ID: Ubuntu Description: Ubuntu 12.04.5 LTS Release: 12.04 Codename: precise I want to install php5.5 so i try next step: php -v PHP 5.4.26 (cli) (built: Apr 8 ...
3
votes
0answers
2k views

Retrieving gpg Key timed out - What does this mean?

I am unable to install any packages thru the terminal. After doing sudo add-apt-repository, the terminal seems to run normally (after about 5-10 minutes however) and am asked to hit enter. After I hit ...
3
votes
0answers
2k views

apt-get update fails on Ubuntu 16.04 when I enable the google music manager ppa

Seems as if the pre-16.04 security key security is no longer sufficient. I'm not sure what to do to fix this. Or is this something google needs to fix on their end? moorepants@parvati:~$ sudo ...
3
votes
1answer
5k views

SSL Certificate error when adding PPA

I've been trying to install a package from a PPA for some hours now. I am running a freshly installed version of ubuntu 14.04. I've been following these instructions: https://github.com/ethereum/go-...
3
votes
1answer
710 views

Unable to add ppa repository (14.04)

There are no proxies involved and I have already tried (repeatedly) to reinstall my ca-certificates but I still am unable to add ppa repositories. $ sudo apt-add-repository ppa:libccd-debs Cannot add ...
3
votes
0answers
177 views

Publish a package on Ubuntu Software Center?

Recent, I uploaded a package on MyApps. After uploading finished, I received a notice: Thank you for submitting a gratis Free Software application through MyApps. At this time we are unable to ...
3
votes
1answer
724 views

Apt pinning is pinning all sources

I've installed a PPA, ondrej/php5, so I can install PHP 5.5 on a Ubuntu 12.04 server. However, I want to install Apache 2.2, and the above PPA provides Apache 2.4. I created the file /etc/apt/...
3
votes
0answers
407 views

Issue Backporting SQLite 3.8.1 to Ubuntu Precise from Trusty

I'm pretty new to all of the packaging of Ubuntu applications and what not so this may not be the correct place to ask this question or there may be a more appropriate place to re-ask this question. I'...
3
votes
1answer
301 views

Get my app, having a kernel module, accepted by the review process of the Ubuntu Software Center

I have submitted an app divided in 3 parts: A kernel module A daemon A control panel The first and last parts are free and open source, and packaged in a PPA. The second one is closed source, and ...
3
votes
1answer
859 views

PPA repositories after installing kubuntu-desktop

I recently installed kubuntu-desktop in Ubuntu 12.04. But the problem is that I cannot get some software that I require. I think the reason is that the software repos are the originally provided ...
3
votes
1answer
289 views

Error Installing Grails - Unmet Dependencies

I am installing Grails on 12.10, using the instructions on grails.org, but am getting an error on the 3rd step, as outlined below. sudo add-apt-repository ppa:groovy-dev/grails sudo apt-get ...
3
votes
0answers
234 views

How to do a ppa for a java ant project?

I was doing a launchpad ppa for my ant project using jdeb. when I had the unpleasant surprise in the last step that ubuntu ppa actually builds the package from the repository, not just accepts signed ...
3
votes
1answer
3k views

How to fix “couldn't connect to host” error installing Unity Webapps?

I get the following errors when I try to install Unity Webapp on Ubuntu 12.04: root@detro-X101H:/home/detro# sudo add-apt-repository ppa:webapps/preview Traceback (most recent call last): File "/...
2
votes
0answers
23 views

Will launchpad build my PPA projects one at a time in the order I send them?

I'm managing a large PPA with about 100 packages found in about 20 projects. https://launchpad.net/~snapcpp/+archive/ubuntu/ppa Whenever I want to rebuild a project, I send it and wait for it to be ...
2
votes
0answers
55 views

Add a PPA with key completely manually, without `add-apt-repository` OR `apt-key adv --recv-keys`

I need the exact and complete series of shell incantations for adding a PPA with key in the following situation: add-apt-repository is not installed gnupg and gnupg2 are not installed, making it ...
2
votes
0answers
114 views

Trouble with Kicad PPA install

When trying to install kicad 5.0.2. from PPA as recommended in 18.04 with: sudo add-get-repository ppa:js-reynaud/kicad-5 sudo apt update sudo apt install kicad I see strange effects, none of which ...
2
votes
0answers
1k views

Cannot add PPA: user or team does not exist Ubuntu 18.04

Hi I Installed a new Ubuntu 18.04 for the first time in my VM and trying to run below command: sudo add-apt-repository ppa:ethereum/ethereum It throws below error: Cannot add PPA: 'ppa:~ethereum/...
2
votes
0answers
403 views

PPAs for updated bash and zsh shells

I would like to use newer versions of bash and zsh. I've searched google for: site:launchpad.net bash "ppa" I've also searched at: https://launchpad.net/ubuntu/+ppas?name_filter=bash Doing the ...
2
votes
0answers
1k views

Pulse Audio Equalizer

Could someone please try to help me install the above since I have been trying in vain for about a week now. I have OS Ubuntu 16.04 LTS. After consulting a few websites, it said that it was necessary ...
2
votes
0answers
405 views

Best way to install deja-dup 37 from Bionic 18.04 repo on Artful 17.10

I'd like to install deja-dup 37 for backups to use the new Google Drive backend. deja-dup 37 is in the Bionic package repository but has not been backported to Artful yet. What would be the best way ...
2
votes
0answers
135 views

Restore Ubuntu original packages after removing ppa

I'm running finally Ubuntu 16.04 and installed the PPA from "ppa:ondrej/php". Some weeks ago I remove that PPA because I changed to PHPBREW. Now tha I'm using PHPBREW with PHP 7 I got some older ...
2
votes
0answers
8k views

repository does not have a release file

I tried the solution here but I get the same error as the original error, also while exeucting it. $ sudo ppa-purge ppa:chris-lea/zeromq Updating packages lists W: The repository 'http://ppa....
2
votes
0answers
485 views

What happened with the Firefox Developer Edition (Aurora) PPA?

As you can see from the PPA, the latest build is from the 17th of October and we're stuck at 51.0a2. Does anybody have an idea about why the PPA is stale? It was pretty active; also from checking ...
2
votes
1answer
782 views

Cannot update docotormo's ppa

I just bought a Wacom Tablet but am unable to install drivers for it. The official Wacom website does not have downloads for my Intuos tablet so I googled and found a ppa from Martin Owens who got ...
2
votes
1answer
1k views

How to install ClipGrab in Ubuntu 16.10 (Yakkety Yak)

The output which I get while installing ClipGrab using ppa is :- Reading package lists... Done W: The repository 'http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu yakkety Release' does not have a ...
2
votes
1answer
3k views

Intel Graphics Update tool for Linux - Failing at signing the packages after download (Ubuntu 16.04)

When I run the graphics update tool it all works fine, until I reach the final stage, which looks like the following: Ensuring consistent system... OK Listing packages... OK Setting up repositories.....
2
votes
1answer
506 views

How to update a lib that can't be found

I am trying to build VLC player. My only hiccup is with libavcodec. It wants 57, I have 56. configure: error: Requested 'libavcodec >= 57.37.100' but version of libavcodec is 56.56.101. So I ...
2
votes
1answer
198 views

Attempting to upload to my PPA: the signature could not be verified

I've created a PPA (https://launchpad.net/~brentonhorne/+archive/ubuntu/eclipse-ide-cpp) that is presently completely empty but I have been trying to upload my .changes file to it (with dput eclipse-...
2
votes
0answers
162 views

Ubuntu will not get latest version from PPA

NOTE: I know that I am using 15.10, an EOL release, but I am developing the PPA on 15.10, and all packages are for it. This also isn't affecting any other PPAs or packages, and I think it is not ...
2
votes
0answers
608 views

Unable to downgrade GNOME from 3.20 to 3.18

I'd like to downgrade GNOME because 3.20 on my Ubuntu 16.04 is a mess. There are countless sources on the Internet (including askubuntu) saying how to do this, and it's always: sudo ppa-purge ppa:...
2
votes
0answers
78 views

Can't interact with 'Software & Updates'

As of a few weeks ago, I can no longer change anything inside 'Software & Updates'. If I click on checkboxes, select different items from a dropdown, or edit/add/remove PPAs, the fields just stay ...
2
votes
0answers
495 views

add-apt-repository producing python error

Recently I updated ubuntu 14.04 to kubuntu 16.04.Whenever I try to add ppa repositories through "add-apt-repository",its producing python error.Please help me solve this error or suggest alternative ...
2
votes
0answers
3k views

/tmp running out of space, can't umount /tmp to cleanup (device busy)

When I tried installing VLC plugin libde265 , I got this error message E: Write error - write (28: No space left on device) E: The package lists or status file could not be parsed or opened. I also ...
2
votes
0answers
63 views

How to properly manage PPAs just from the command-line

What are the recommendations for managing other repositories and PPAs without the help of Software and Updates GUI. How to know if a repository/PPA already, - exist - enabled or - disabled ? How to ...
2
votes
1answer
444 views

dependency in ppa

i have a package(fcl) in my ppa in my launchpad ppa and it depends on another package (libccd) which is in another ppa ppa:imnmfotmal/libccd. FCL has both build and run dependency in libccd. SO i ...
2
votes
1answer
2k views

Cant Downgrade php5.5 back to php5.3

I have tried to upgrade my apache2.2 to apache2.4 and php5.3 to php5.5 on my Ubuntu 12.04. For php5.5 I have used those commands below (I dont remember which PPA i used for apache upgrade) : add-apt-...
2
votes
0answers
41 views

Application rejected on myapps.developer.ubuntu.com. What can I do?

I submitted a desktop application on myapps.developer.ubuntu.com long time ago. But it was rejected today with the following reason: This package submission process is now deprecated. To provide my ...
2
votes
0answers
2k views

Upgrade Evolution in 14.04? No PPA and overwhelming dependancies to build

Is it reasonable to install a current version of Evolution (say 3.16.1) on Ubuntu 14.04? I added the recommended 'ppa:fta/gnome3', but I'm still only offered 3.10.4 from the Ubuntu archive. It seems ...
2
votes
0answers
3k views

Now when there is no neon/kf5 ppa, how can I install KDE 5 in gnome Ubuntu 14.04?

All the other posts suggest to use the neon/kf5 but that doesn't work since early December. How can I do it now?
2
votes
1answer
222 views

Has xorg deleted the nvidia 343 package?

I'm following this answer to get my GTX 970 working, however before installing nvidia-343 I noticed that I couldn't find the package on xorgs site: https://launchpad.net/~xorg-edgers/+archive/ubuntu/...
2
votes
1answer
128 views

Removing 'kubuntu-restricted-extas' (Or: Understanding 'apt-get autoremove' in general)

I'm fairly new to Ubuntu (respectively Kubuntu) and Linux in general. Yet, some thing is causing trouble to me. Excuse me, if this has been answered before, but I somehow can't put together those ...
2
votes
0answers
699 views

Not yet able to install sagemath-upstream-binary from ppa. Should I just be a little more patient and try again latter?

At this time (2014, October the 27th) I am not able to install sagemath-upstream-binary in my recently installed Ubuntu 14.10 utopic from ppa:aims/sagemath. I strongly suspect that I just need to wait ...