Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
Join us in building a kind, collaborative learning community via our updated Code of Conduct.

Questions tagged [ppa]

PPAs are personal package archives that allows users and groups on Launchpad to make packages available to the public. PPAs can be added with a terminal command or through Software Sources.

1
vote
0answers
9 views

Problem with installing LibrePlan

I am trying to install LibrePlan on Ubuntu 18.04, the instructions say that I should run sudo add-apt-repository ppa:libreplan/ppa sudo apt-get update sudo apt-get install libreplan But on the ...
1
vote
0answers
13 views

How to remove python 3.6 from deadsnakes ppa after upgrade to Ubuntu 18.04

On Ubuntu 16.04 I installed Python 3.6 from the deadsnakes ppa. Now I upgraded to Ubuntu 18.04 which builds on top of Python 3.6 but instead of removing the old version of Python 3.6 it kept the ...
1
vote
1answer
10 views

ReplicatorG Installation on Ubuntu 18.04.1 LTS

I have used ReplicatorG http://replicat.org/installation-linux to generate 3D printing files for a number of years. I have had to upgrade to 18.04 to support my Ryzen hardware, as this old code/ PPA ...
0
votes
0answers
49 views

Ubuntu 18.04 pypy3 package [duplicate]

I tried installing pypy3 after installing pypy through the regular Ubuntu 18.04 repo: E: Unable to locate package pypy3 Okay, so it's not available in the regular repos. I added the official PyPy ...
0
votes
1answer
45 views

impossible to remove a ppa

I just upgraded to xubuntu 18.04 LTS from 16.04, and I have an issue while trying to remove old obsolete PPAs : nicolas@nicolas-UX530UX:~$ sudo ls /etc/apt/sources.list.d deadsnakes-ubuntu-ppa-...
0
votes
0answers
20 views

Create snap of .deb plus ppa dependencies?

I have a proprietary program that runs on 16.04 with an additional ppa for qt5.6. It is the only app that holds me back from updating to 18.04, so my idea was to create a snap package including the ....
5
votes
1answer
135 views

Same package from 2 different PPA in sources.list.d; how to force the install from one specific PPA? [duplicate]

The issue: Let say I have a PPA for a software (i.e. Blender for example; http://ppa.launchpad.net/thomas-schiex/blender/ubuntu ) that contains for some reasons, a Python3.6 version. What I want to ...
-3
votes
0answers
37 views

Can't install pip on Ubuntu server 18.04 [duplicate]

I have a vanilla install of 18.04 server installed. When I run sudo apt-get install python3-pip or sudo apt-get install python-pip I get Reading package lists... Done Building dependency tree ...
0
votes
0answers
49 views

How do I install gcc-5.4 along side gcc-5.5? (Neither of these packages exist)

I'm on 18.04, and need to compile some custom Tensorflow Ops. I need gcc-5.4 specifically because gcc-5.5 breaks things. However, as far as package naming goes, there is only officially "gcc-5". Is ...
1
vote
0answers
31 views

Unable to install qt511-meta-full from PPA:beineri on Ubuntu 16.04: qt511doc package does not exist

After adding this PPA for Ubuntu Xenial (16.04) to install qt5.11: https://launchpad.net/~beineri/+archive/ubuntu/opt-qt-5.11.0-xenial and updating with apt-get, I encountered this issue while trying ...
3
votes
0answers
108 views

Bionic Default Repositories do not have release file - sudo apt-get update not working [closed]

I am facing an issue with apt : sudo apt-get update won't successfully complete on my Ubuntu 18.04 Desktop. First I'd like to specify that the subject Xenial repository does not have a release file ...
2
votes
1answer
2k views

How to try out Thunderbird 60?

What is the recommended way of trying out the new Thunderbird 60 release on Ubuntu 18.04? I see several options: simply download the prebuilt package from https://www.thunderbird.net/. Will it use my ...
0
votes
2answers
78 views

update problem in Ubuntu 18.04 [duplicate]

When I run sudo apt-get update I get the following output. As you can see that there are error messages at the end 'configured multiple times'. How do I solve it. I am using Ubuntu 18.04.1 Hit:1 http:...
0
votes
2answers
508 views

Unable to locate package phpmyadmin on Ubuntu Server 18.04

Whenever I try to install phpmyadmin on my ubuntu server 18.04 I get the following errors sudo apt install phpmyadmin php-mbstring php-gettext Reading package lists... Done Building dependency tree ...
0
votes
0answers
33 views

Problem trying add PPA's on ubuntu 18.04

i am trying to add PPA's to my new installation of Ubuntu 18.04 but i am having a lot of problems. For all the PPA's that i try to add i have the same problems but i'll give you an example trying to ...
0
votes
0answers
28 views

Cannot install cairo-dock because “The repository does not have a Release file” on 18.04 [duplicate]

I get an error when trying to install the cairo dock on a fresh installation of bionic : The repository 'http://ppa.launchpad.net/cairo-dock-team/ppa/ubuntu bionic Release' does not have a Release ...
0
votes
0answers
34 views

Is it possible to create a binary-only package?

I developed a program with the Unity game engine and I now want to add it to my PPA. Unity has a complex build process that only runs in the GUI editor, which is not compatible with the debuild ...
0
votes
1answer
86 views

How do I install fontforge on Kubuntu 18.04?

Very straightforward question. When I try and run the PPAs it tells me that there is no release and it won't do it for security reasons. Does it not exist? When I go to their website, they offer the ...
0
votes
0answers
30 views

How to downgrade all installed packages from LP-PPA-ubuntu-toolchain-r-test

I am not able to upgrade Ubuntu 16.04 to 17.10 due to issues with packages which I installed from LP-PPA-ubuntu-toolchain-r-test. These packages are numerous... Is there a way (using some tool or ...
0
votes
0answers
14 views

install error of massif-visualizer on 14.04 [duplicate]

I tried to install massif-visualizer. After adding the kubuntu-ppa/backports PPA and running apt-get update, apt-get install massif-visualizer still gives me an error: E: Unable to locate package ...
0
votes
1answer
99 views

Repository can not be authenticated

I was following this thread to install wine, but after I added the suggested repository and reloaded the sources list the following error message appeared: W:The repository 'http://extras.ubuntu.com/...
1
vote
1answer
89 views

Why do I get these differences on ppa vs snap Communitheme Ubuntu 18.04?

I installed Communitheme time ago by the ppa using these commands. sudo add-apt-repository ppa:communitheme/ppa sudo apt install ubuntu-communitheme-session And everything worked fine, I just had ...
0
votes
0answers
16 views

Cannot install tuxboot - repository does not have a Release file? [duplicate]

Trying to install tuxboot using Ubuntu PPA (Ubuntu 18.04), like so: sudo apt-add-repository ppa:thomas.tsai/ubuntu-tuxboot but I get Err:8 http://ppa.launchpad.net/thomas.tsai/ubuntu-tuxboot/...
1
vote
1answer
51 views

Printer HP laserjet pro M15a doesn't work on 18.04

I'm trying to get my printer to work on 18.04LTS. I have both an old laserjet 1018 and a new laserjet pro M15a. Neither are working, the 1018 was working under 12.04TLS. The printers are recognised ...
0
votes
0answers
42 views

Repository Security Problems [duplicate]

I am having problems with a couple repositories that are preventing me from doing updates and upgrades. When I do sudo apt-get update I get the following: $ sudo apt-get update [sudo] password for ...
0
votes
1answer
174 views

The repository 'http://ppa.launchpad.net/armagetronad-dev/ppa/ubuntu bionic Release' does not have a Release file [duplicate]

Any time I try to install anything or run apt update, I get this error: E: The repository 'http://ppa.launchpad.net/armagetronad-dev/ppa/ubuntu bionic Release' does not have a Release file. N: ...
0
votes
3answers
52 views

How do I mass install apt packages conditionally from a file?

Goal I would like to install multiple APT packages using a file. apt_install_from_file "packages" # assumes 'packages' is a readable file in the $PWD Note: I understand that there are other ways ...
0
votes
1answer
174 views

emacs25 and emacs26 from a PPA cannot coexist

I have installed emacs25 from this PPA: https://launchpad.net/~kelleyk/+archive/ubuntu/emacs, and it coexisted well with emacs 24 from the repositories (Ubuntu 16.04). Now that emacs26 is available ...
0
votes
1answer
40 views

Adding ppa:deadsnakes/ppa via ssh on home server 18.04

I decided to try my hand at some sys admin stuff so I put a fresh install of Ubuntu 18.04 on an old desktop computer to act as a server. That went well enough, but when I ssh to my "server" from my ...
-1
votes
2answers
39 views

unable to perform any apt-get install command [duplicate]

$ sudo apt --fix-broken install Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were ...
-3
votes
1answer
72 views

Please help me to get out of this problem [duplicate]

Err:17 http://ppa.launchpad.net/neizod/ppa/ubuntu xenial Release 404 Not Found Reading package lists... Done E: The repository 'http://ppa.launchpad.net/neizod/ppa/ubuntu xenial Release' does not ...
0
votes
0answers
27 views

Ubuntu keeps on showing an internal error with package rtl8192eu-dkms 4.4

I have tried installing this ppa but it does not have a release file and would not work for 18.04. Is there any solution for solving this or stopping Ubuntu from showing this annoying error:
0
votes
2answers
76 views

Added graphics-drivers ppa, but no packages appear

I've tried to install the 396 drivers after doing... sudo add-apt-repository ppa:graphics-drivers/ppa ...assuming that it allow me to install nvidia-graphics-drivers-396 or vulkan, but apt doesn't ...
-1
votes
1answer
49 views

Cannot install indicator-netspeed [closed]

When I try to install indicator-netspeed, the system says "The following packages have unmet dependencies". How to resolve it? The commands that I had used are:
0
votes
0answers
22 views

Upload new signature to launchpad

Sorry for a very bad "customer support" type question: I am trying to import a new key pgp key to launchpad but do not receive any e-mail. Questions: How long will it take before I get any e-mail? ...
2
votes
1answer
51 views

I used a multimedia ppa and now vlc is broken

I used this ppa, https://launchpad.net/~mc3man/+archive/ubuntu/xerus-media and to be fair it said it may conflict, but I was trying to do something else, and thought it could help me, so I installed, ...
1
vote
1answer
49 views

Disable automatic execution of apt update after running add-apt-repository on Ubuntu 18.X

Okay so it's a feature that has been added to Ubuntu 18.04 which automatically calls apt update after adding any PPA, sometimes it's a time saver as I don't have to run sudo apt update manually after ...
0
votes
0answers
15 views

Unable to perform Apt Update: Failed to Fetch Error [duplicate]

When I try to do sudo apt update on my Ubuntu 16.04 system, I get the error E: Failed to fetch http://ppa.launchpad.net/ubuntu-mate-dev/trusty-mate/ubuntu/dists/xenial/main/binary-amd64/Packages ...
1
vote
2answers
210 views

Unable to install ubuntugis

http://ppa.launchpad.net/ubuntugis/ppa/ubuntu bionic Release 404 Not Found [IP: 91.189.95.83 80] Reading package lists... Done E: The ...
0
votes
0answers
77 views

Why openjdk-10 is missing in 18.04 PPA where openjdk-11 is available? [duplicate]

$ sudo apt install openj openjade openjdk-11-jre openjdk-8-doc openjdk-8-jre-zero openjdk-11-dbg openjdk-11-jre-headless openjdk-8-jdk ...
8
votes
1answer
132 views

How do I search for a PPA via CLI, commandline?

If apt search fails me, the next step is usually look for a PPA, but ppasearch seems like abandonware, so what can I use to search for PPAs (via the commandline)?
0
votes
0answers
2k views

Removing PHP 7.2, and installing PHP 5.6 [duplicate]

I'm a new Linux user, and I'm using a web server with a software that requires PHP 5.6, creating an incompatibility issue that I have been trying to solve for at least two days now. I read up a bunch ...
2
votes
1answer
367 views

Add “Kubuntu Backports” PPA or “Kubuntu Updates” PPA? Or both?

https://launchpad.net/~kubuntu-ppa/+archive/ubuntu/backports https://launchpad.net/~kubuntu-ppa/+archive/ubuntu/ppa The first PPA is called "Kubuntu Backports" and the second PPA is called "Kubuntu ...
1
vote
2answers
305 views

How to I install unetbootin on 16.04 [duplicate]

The following repository ppa:gezakovacs/ppa is not working and when I try to install by download method. kmoin@kmoin-Inspiron-15-3567:~$ chmod +x ./unetbootin-linux chmod: cannot access './...
0
votes
1answer
191 views

Python-related errors when running apt update after adding and removing Bodhi repository

Error when running update: thufir@bot:~$ sudo apt update Get:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB] Hit:2 http://ca.archive.ubuntu.com/ubuntu bionic InRelease Get:3 ...
4
votes
0answers
272 views

How to install Moksha Desktop?

I like the moksha destop which Bodhi Linux uses. Is there not a repo or snap to install moksha on Ubuntu? The Debian instructions seem a bit much for what I would naively expect to be a package, or ...
0
votes
1answer
141 views

How to install wkhtmltopdf, specifically v0.12.4 in ubuntu server 14.04?

I know there is already a question regarding wkhtmltopdf installation, but I need the specific version 0.12.4 to be installed. Is there a way to do it . Normal apt-get installation ended up in v0.12....
0
votes
0answers
25 views

How to install Java 9 on Ubuntu? [duplicate]

I want to install Java 9 on Ubuntu and I have founnd some tutorials on Google. I use these commands to install java: sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get ...
3
votes
1answer
84 views

How to remove youtube-dlg - Ubuntu Mate

I am using Ubuntu Mate. I installed youtube-dl-gui from http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/pool/main/y/youtube-dlg/ Downloaded youtube-dlg_0.4-1~webupd8~zesty4_all.deb Then ...
2
votes
3answers
3k views

how to install Conky Manager on Ubuntu 18.04?

Recently I installed Ubuntu 18.04. Installing Conky Manager with these commands failed with "Dependency is not satisfiable: realpath". sudo apt install conky-all cp /etc/conky/conky.conf ~/.conkyrc ...