Questions tagged [pip]

Questions regarding the use of pip, a package installer for Python.

Filter by
Sorted by
Tagged with
0 votes
0 answers
40 views

Segmentation fault (core dumped) when install a package inside a python virtualenv using pip

a few days back my ubuntu 20.04 stopped working. even after reinstalling everything with GPU drivers, after restart my screen freezes on the motherboard company logo, maybe an update with a bug ...
user avatar
-3 votes
0 answers
22 views

How to install numpy 1.16.1 for python2 on Ubuntu 20.04?

Few lines with description what I already installed: Python3 was already present: python3 --version Python 3.8.10 I wanted to install numpy for python3. Followed directions from sites, first step ...
user avatar
  • 125
0 votes
0 answers
14 views

__pycache__ is not creating

I am working on Ubuntu 20.04 LTS where I am building exe file from python files. Below mentioned commands are I am using for building exe file. $ pip3 install --upgrade pip $ pip3 install --upgrade ...
user avatar
0 votes
1 answer
52 views

Python binary path in pip

When I run python it runs version 3.10.4: $ python Python 3.10.4 (main, Apr 8 2022, 17:35:13) [GCC 9.4.0] on linux Type "help", "copyright", "credits" or "license&...
user avatar
  • 1
0 votes
1 answer
59 views

Cannot create python virtual environments or use pip in Ubuntu 20.04 LTS

I'm using Ubuntu 20.04.4 LTS. When I try python3 -m venv env, I get: The virtual environment was not created successfully because ensurepip is not available. On Debian/Ubuntu systems, you need to ...
user avatar
  • 101
1 vote
1 answer
420 views

After updating to Ubuntu 22.04, I am no longer able to access Jupyter Notebook

When I try to launch Jupyter Notebook, the browser (firefox) launches and I get the following error: Access to the file was denied The file at /home/benjamin/.local/share/jupyter/runtime/nbserver-...
user avatar
  • 11
0 votes
1 answer
42 views

Giving error python3-pip

I am using Ubuntu 21.10. When I write this in command line: sudo apt-get install python3-pip It gives this: Reading package lists... Done Building dependency tree... Done Reading state information... ...
user avatar
1 vote
0 answers
462 views

ERROR in getting setup.py and project.toml

I am getting the following error using pip The error: pip install -r requirements-dev.txt . Defaulting to user installation because normal site-packages is not writeable Obtaining file:///home/...
user avatar
0 votes
0 answers
48 views

Error building wheel for manimpango

I use ubuntu and when I am getting error in installing manim, pip3 install manimpango and pip install manimpango and have tried sudo apt install libpango1.0-dev pkg-config python3-dev but getting same ...
user avatar
0 votes
0 answers
41 views

pip install or upgrade fails with - free(): invalid pointer Aborted

I get this error when trying to upgrade pip, pip3 or when I try to install a python package. What can I do? root$ sudo -H pip3 install --upgrade pip Requirement already satisfied: pip in /usr/local/...
user avatar
  • 33
0 votes
2 answers
48 views

How can I 'align' python, pip and environments? I'm trying to install certbot on ubuntu VPS

Ubuntu 20.04 VPS on hostinger $ whereis python python: /usr/bin/python2.7 /usr/bin/python /usr/bin/python3.8 /usr/bin/python3.9 /usr/bin/python3.8-config /usr/lib/python2.7 /usr/lib/python3.8 /usr/...
user avatar
0 votes
1 answer
184 views

How to uninstall pip3 from home directory?

I'm on Ubuntu 20.04.4 LTS. I was messing around in my home directory and ran pip3 install --upgrade pip trying to upgrade pip3. I got this warning: WARNING: The scripts pip, pip3 and pip3.8 are ...
user avatar
0 votes
1 answer
133 views

Python package works on the command line but cannot be found in a script

Basically from the title and the image below, I have installed pyserial and it works in the Python terminal but not in a script. I have done pip3 install pyserial, and have also tried pip install ...
user avatar
-4 votes
1 answer
174 views

Ubuntu default python3.8.10

When I install python3.9 or 3.10, there is no change in python3 command. It is still python3.8.10 and all packages will be installed for 3.8.10 unless I run a python3.9 -m pip. What is the reason that ...
user avatar
2 votes
1 answer
52 views

ffmpeg-normalize not working in Python

I have ffmpeg-normalize installed through pip3 It seems to work from the terminal but I need to run it through python subprocess. Everytime I try to run it the error says: /bin/sh: 1: ffmpeg-normalize:...
user avatar
1 vote
1 answer
694 views

/usr/bin/python: No module named pip

I am following this tutorial: https://tensorflow-object-detection-api-tutorial.readthedocs.io/en/latest/install.html#tf-models-install and more specifically: Install the Object Detection API When I ...
user avatar
4 votes
2 answers
171 views

Running a Python2 program with Python3?

EDIT: Updates below, the scenery seems to have changed significantly. I have Ubuntu 20.04, and have installed Python 3.10 manually. There's python 2 in the system already, and that's what I get if I ...
user avatar
0 votes
0 answers
937 views

Unable to install pip into WSL (Ubuntu)?

I have successfully setup WSL on my Windows 10. I have also successfully downloaded and installed Python3. However, I am unable to get pip. How do I get pip? gyu@LAPTOP-PR3:/mnt/c/Windows/system32$ ...
user avatar
1 vote
1 answer
1k views

E: Package 'python-scipy' has no installation candidate

Upon installing a software, I am finding the following error multiple times: $ sudo python setup.py install Traceback (most recent call last): File "setup.py", line 24, in <module> ...
user avatar
  • 261
1 vote
0 answers
416 views

conda create env using yml file - ResolvePackageNotFound error keeps changing

I am trying to use conda to create an environment through the yml file from this GitHub repository https://github.com/thanard/causal-infogan. The command is conda env create -f tf14.yml and the file ...
user avatar
  • 1,072
1 vote
0 answers
492 views

conda env create -f tf14.yml - ResolvePackageNotFound

I am trying to run the code from this repository https://github.com/thanard/causal-infogan. The instructions to install the python environment are as follows Create a python environment and install ...
user avatar
  • 1,072
0 votes
0 answers
36 views

Python -m venv installs a version of pip that is not upgraded. How can I upgrade it?

I often recur to the -m venv option to isolate my working environment. Python has been installed using pyenv. However, since I have migrated to Ubuntu, I noticed a strange behaviour with the Pip ...
user avatar
0 votes
0 answers
69 views

pip3 install -r requirement.txt not working

i used pip3 install -r requirement.txt but it doesn't seem to work it gives an error as follows. ERROR: Could not open requirements file: [Errno 2] No such file or directory: 'requirement.txt'
user avatar
0 votes
0 answers
24 views

Utilizing Python 2.7 features in VMware

Good afternoon, I am working on a program install in VMware15 Ubuntu (20.04). The installation instructions are causing me issues as a entry-level user, so I wanted to see if anyone could make sense ...
user avatar
0 votes
1 answer
2k views

ImportError: No module named 'pip._vendor.packaging'

I need to get some software running on Python 3.5 I am using Ubuntu 21.10. I get this error: (foobar_addressbook) guettli@p15:~/foobar/projects/foobar_addressbook$ tox -e py35-django18 py35-django18 ...
user avatar
  • 2,352
0 votes
0 answers
382 views

Ubuntu 20.04: Can't install pip for python3.10

I am using Ubuntu 20.04 TLS in Windows Terminal from on Windows 10 Pro. Ubuntu has default version of python that is 3.8, but I need 3.10, and I can easily install it with sudo apt install python3.10 (...
user avatar
0 votes
0 answers
41 views

Pipupgrade always fails

For ease of use I installed pipupgrade to my Lubuntu. Now whenever I run (sudo) pipupgrade it just hangs for a long time, and then outputs 2021-10-27 18:44:07,611 | WARNING | Unable to save package ...
user avatar
0 votes
0 answers
125 views

Unable to install sympy for Python3.8.6

I attempted to install sympy on my workstation using the instructions in this related question: How to install sympy for Python 3.4 i.e. sudo pip3 install sympy The installation completed without any ...
user avatar
  • 121
1 vote
2 answers
741 views

Why psycopg2 is not able to install in a virtual environment?

Just installed ubuntu20.04. Installed python3.10 by sudo apt install python3.10 Then created virtualenv pip install virtualenv virtualenv -p python3.10 venv Now I'm trying to install requirement for ...
user avatar
0 votes
0 answers
61 views

pip Error when using Anaconda Environment

When I have an active conda environment and I enter pip I get the following error: Traceback (most recent call last): File "/home/philip/anaconda3/bin/pip", line 7, in <module> ...
user avatar
  • 534
-1 votes
1 answer
98 views

Problem using pip3 to install mdanalysis

I am trying to install mdanalysis for a university project using the command: pip3 install --user numpy mdanalysis Numpy is already installed, so it works fine, but for mdanalysis I get: x86_64-linux-...
user avatar
0 votes
0 answers
532 views

Cannot source venv using makefile

The Makefile inside project root # Makefile .PHONY: help help: @echo "Commands:" @echo "venv : creates development environment." # Environment .ONESHELL: venv: ...
user avatar
0 votes
1 answer
83 views

Ubuntu focal fossa python3 error - Does this error happen to everyone?

Does this error happen to everyone? Install Ubuntu Focal Fossa. Then install the python3-pip (At this stage, Python3 is installed automatically) Python 3.8.10 (default, Jun 2 2021, 10:49:15) [GCC 9....
user avatar
0 votes
0 answers
117 views

Can't install `environs` with pip on Ubuntu 18.04

When I try to install environs 4.1.0 suing: pip3 install environs==4.1.0 I get: Traceback (most recent call last): File "/usr/bin/pip3", line 9, in <module> from pip import main ...
user avatar
  • 1
-3 votes
1 answer
90 views

I can not install pip3 on my Ubuntu

I need to install pip3 on my ubuntu but if i run sudo apt install python3-pip I get following error: error installing pip If I try to run sudo apt --fix-broken install to solve the error, I get the ...
user avatar
0 votes
0 answers
228 views

i can't install tensorflow. (no matching distribution found)

i am sorry to ask such question, but being new to coding, i can't solve this problem even with googling full 2 days. so here it goes. I'm trying to run a demo posted at github using ubuntu for ...
user avatar
  • 1
0 votes
0 answers
16 views

Python Environment pip installs packages in the main system

I created a new python environment a few weeks back and installed some packages in there. But now when I activate the environment and install a package with pip, it installs the new package in the ...
user avatar
  • 455
0 votes
1 answer
659 views

Can't upgrade Scipy 1.5.4 to 1.7.0 using pip

I am a new Ubuntu user and don't have much experience with how installations are done in Linux. I installed the Scipy module using pip a while ago and it downloaded version 1.5.4. Now, when I try to ...
user avatar
0 votes
0 answers
115 views

Unable to uninstall specific version of pip, Openstack Devstack Install error

I am getting this error on ./stack.sh install Devstack Error When running pip3 --version, I can verify and shows proper version pip 21.1.3 from /opt/stack/.local/lib/python3.6/site-packages/pip (...
user avatar
0 votes
0 answers
84 views

Set pip to python3.7 instead of python3.8 in ubuntu 20.04

I installed python3.7 in ubuntu 20.04 which as python3.8 installed by default. I installed pip for python3.7 already and it can be accessed using python3 -m pip --version, but pip --version will lead ...
user avatar
  • 121
0 votes
1 answer
260 views

I can't use python pip to download any tools and I don't know why

here's a picture of the error I get and the python installations i have, I tried to delete python7.2 and it seems like it's not working.. any help is highly appreciated
user avatar
  • 23
0 votes
0 answers
51 views

Package pre-installed Python module for PyPi PIP

I built a python package from the following repository on Ubuntu v.18. The real target for this was OpenWrt however OpenWrt only supports GCC 7.4 and the build file has commands which are only ...
user avatar
  • 1
0 votes
0 answers
1k views

ERROR: Could not install packages due to an OSError: [Errno 28] No space left on device

i tried to use pip3 install torch==1.8.0+cu111 torchvision==0.9.0+cu111 torchaudio==0.8.0 -f https://download.pytorch.org/whl/torch_stable.html but got Installing collected packages: torch, ...
user avatar
  • 1,017
0 votes
0 answers
42 views

Pip packages are installed but not working

I'm new to ubuntu and I've installed many packages via pip but they don't work and give me this error. zsh: command not found: ipython I have tried many ways, but after logout and login, I get the ...
user avatar
  • 1
1 vote
1 answer
281 views

Unable to install MySQL client via pip3 or pip

I get the exact same error as shown in Unable to install mysqlclient on Ubuntu 20.10 and Error installing libmysqlclient-dev on Ubuntu 20.04. But after doing all these, if I install mysqlclient via, &...
user avatar
  • 55
0 votes
1 answer
5k views

ModuleNotFoundError: No module named 'pyautogui' in all IDEs no matter what I try

I've been trying to look for a solution online for hours with no avail. I have this piece of code: #load packages import pyautogui #these are for our clicks and keystrokes! import time #...
user avatar
  • 1
0 votes
0 answers
883 views

Its shows error in import pdfkit in python

I am Using python3 for coding in Ubuntu... I have already installed pip sudo apt install python3-pip Version pip3 --version Output pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.6) Install ...
user avatar
1 vote
1 answer
1k views

how to tell pip to uninstall python modules from previous python version?

I upgraded from Ubuntu 20.10 to 21.04 & the python version changed from 3.8 to 3.9. In 20.10 I installed many python modules using pip & they are at /usr/local/lib/python3.8/dist-packages/ &...
user avatar
  • 13
0 votes
0 answers
628 views

The "six" package is install but get an error "Could not find suitable distribution for Requirement.parse('six>=1.9')"

I am running a Yocto build and sometime during the build, I see the following error Processing dependencies for protobuf==3.3.0 Searching for six>=1.9 Reading https://pypi.python.org/simple/six/ ...
user avatar
  • 21
1 vote
2 answers
12k views

Warnings during pip installs because of a package called "-etuptools"

A simple problem. When I install or upgrade packages with pip, I get a very weird error. Input: pip3 install numpy output: Defaulting to user installation because normal site-packages is not ...
user avatar

1
2 3 4 5
13