Questions tagged [php7]

Questions related to the seventh release of PHP, a server-side scripting language designed for web development, which can also be used as a general-purpose programming language

Filter by
Sorted by
Tagged with
1 vote
0 answers
11 views

Removing php7: whereis gives etc/php, not sure about nginx files

Sorry I have two questions. I want to remove php7.4 to install php8.0. I followed the link: How do I remove PHP 7 Completely? used the commands: sudo apt-get purge php7.* sudo apt-get purge `dpkg -l | ...
user avatar
1 vote
1 answer
413 views

php 7.4, ssh_connect(), "Unable to exchange encryption keys" only when connecting to ubuntu 22.04 machines

I have a PHP tool that needs SSH access to some of my servers. This is an internal only application and it works 100% fine when talking to Ubuntu 18.04 machines. I started updating my machines to 22....
user avatar
  • 691
0 votes
0 answers
36 views

need a single repository as argument

Help need to fix this problem, Error: need a single repository as argument I wrote this sudo add-apt-repository ppa:ondrej/php sudo apt-get update I am about to add php7 ppa:
user avatar
2 votes
0 answers
1k views

Should I add-apt-repository ppa:ondrej/apache2 when I add-apt-repository ppa:ondrej/php, as advised?

I am upgrading an Ubuntu 18.04 LTS server to PHP 7.4 because PHP 7.2 is no longer supported. Other public questions have directed me to add sudo add-apt-repository ppa:ondrej/php, such as How to ...
user avatar
-1 votes
1 answer
222 views

can't install php-gd ext 7.0

when i tried to install php7.0-gd i found this error dfiadm@dc2-magneto-test:~$ sudo apt-get install php7.0-gd Reading package lists... Done Building dependency tree Reading state information... Done ...
user avatar
3 votes
1 answer
980 views

Problem with libicu66 during installation php-intl extension on Ubuntu 21.10

sudo apt install php7.0-intl Output: The following packages have unmet dependencies: php7.0-intl : Depends: libicu66 (>= 66.1-1~) but it is not going to be installed E: Unable to correct problems,...
user avatar
1 vote
1 answer
33 views

UpDating .sh file to be compatible with v20.04

I'm trying to update this .sh file #!/bin/bash function pecl_install { pecl install $1 echo "extension=$2.so" | sudo tee /etc/php5/mods-available/$2.ini echo "; priority=$3&...
user avatar
  • 11
1 vote
0 answers
67 views

How do you downgrade php8.0 to php7.4 in Ubuntu 21.10 [duplicate]

Normally you would use add-apt-repository ppa:ondrej/php, however, there does not seem to be a release file for 21.10 so it does not add the repository. A few websites I have setup do not work with ...
user avatar
7 votes
3 answers
8k views

How to install php7.4, 5.6 ubuntu 21.10

How to install the old version of PHP. It does not work at the moment repository sudo add-apt-repository -y ppa:ondrej/php Then: The repository 'http://ppa.launchpad.net/ondrej/php/ubuntu impish ...
user avatar
1 vote
0 answers
682 views

Phpmyadmin to work for php 5.6 and 7.2 both on Ubuntu 20.04

I am working on Ubuntu 20.04 and have multiple PHP versions installed (5.6 - 8.0) because I need to work on Magento 1 & 2 both. When I switch to 7.2 and open PHPMyAdmin in the URL, it works fine. ...
user avatar
0 votes
0 answers
89 views

Why is my PHP CLI Curl version different from curl and libcurl even if I try to force it with --with-curl flag during compilation?

I have compiled PHP after compiling Curl 7.73 . Curl -v shows me it's 7.73, and if I go to my web server and check phpinfo() output it's also 7.73 . However, the compiled php cli is showing me that it'...
user avatar
1 vote
0 answers
302 views

PHP-FPM upstream error with ipv6

I have just installed the latest Nginx with PHP7.4-fpm on a fresh Ubuntu 20.04.2 server. I added a virtual host that has a WordPress site on it and it is loading fine but I noticed the nginx logs ...
user avatar
  • 295
0 votes
2 answers
526 views

Unable to correct problems, defective packets are in "keep as is" mode. when i tried install phpmyadmin

I tried to install phpmyadmin on ubuntu 20.10, but there are errors : $ sudo apt install phpmyadmin Lecture des listes de paquets... Fait Construction de l'arbre des dépendances Lecture des ...
user avatar
  • 111
1 vote
1 answer
3k views

php-pam : Depends: phpapi-20180731 but it is not installable

on Ubuntu Desktop 20.04 with PHP 7.4 apt install php-pam Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean ...
user avatar
  • 11
0 votes
1 answer
3k views

How to set php 8.0 as default version in ubuntu server

For some reason, i have to install PHP 7.4 and PHP 8.0 in the same ubuntu server. By default when i install php 7.4, it shows it is the default version when use the command php -v. But i want to run ...
user avatar
0 votes
1 answer
69 views

White page appearing during BASE Installation for SNORT 2.9.17.1

I am installing SNORT 2.9.17.1 using a mannual SNORT-IPS-Tutorial (https://snort-org-site.s3.amazonaws.com/production/document_files/files/000/000/069/original/Snort-IPS-Tutorial.pdf?X-Amz-Algorithm=...
user avatar
0 votes
1 answer
206 views

Whong php-config, right php -v and phpize

This is okay phpize PHP Api Version: 20170718 Zend Module Api No: 20170718 Zend Extension Api No: 320170718 This is also okay php -v PHP 7.2.34-18+ubuntu18.04.1+deb.sury.org+1 (cli) ...
user avatar
  • 196
0 votes
1 answer
355 views

do-release-upgrade fails with ubuntu 16.04 with plesk installed

I have an older Ubuntu 16.04.7 LTS server with Plesk Obsidian 18.0.34 Update #2 and I am trying to upgrade to 18.04 LTS. Everything is up to date but when I execute do-release-upgrade it complains ...
user avatar
  • 103
1 vote
1 answer
3k views

How To Configure Apache HTTP to PHP-FPM on Ubuntu 20.10

I followed directions from here to switch the server API entry will be FPM/FastCGI.from Server API Apache 2.0 Handler. When mpm_event is enabled and a2dismod php7.4 the phpinfo.php shows only: <?...
user avatar
2 votes
3 answers
1k views

Ubuntu 18.04 ondrej php7.3 - gives php8.0 as default php

Ubuntu 18.04 ondrej php7.3 - gives php8.0 as default php Error in Magento2.3 / Composer1.. phpunit/phpunit 6.5.14 requires php ^7.0 -> your PHP version (8.0.2) does not satisfy that requirement ...
user avatar
0 votes
1 answer
106 views

apache2 virtual directory with wild card certificate

I'm using Ubuntu 20.04. I created a new site with WordPress and it's not working. <IfModule mod_ssl.c> <VirtualHost _default_:443> ServerAdmin webmaster@localhost ...
user avatar
  • 422
0 votes
1 answer
154 views

Errors when installing Plesk: Depends: libodbc1 (>= 2.3.1) but it is not going to be installed

I'm trying to install Plesk, and get the following error messages: plesk-librdbmspp : Depends: libodbc1 (>= 2.3.1) but it is not going to be installed plesk-php72-odbc : Depends: libodbc1 (>= ...
user avatar
0 votes
0 answers
39 views

compulsory php7.2 settings in ubuntu 18.04 environment for web development

I have ubuntu 18.04 development environment. Is this compulsory to make change on the following lines below in php.ini file to run environment properly? $ sudo nano /etc/php/7.2/fpm/php.ini Changes ...
user avatar
  • 39
1 vote
0 answers
1k views

Many held back PHP 7.4 package updates on Ubuntu 18.04 since 3 weeks

I use PHP 7.4 on Ubuntu 18.04.5 LTS in a wp/nginx/mariadb setup. I installed it via Ondrej's main php repo and used/updated it for more than a year without any problem whatsoever. Approximately 3 ...
user avatar
2 votes
5 answers
6k views

issue when installing php-dev in ubuntu 20.04

I am getting the following error: root@56709:/etc/nginx/conf.d# apt install php7.4-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not ...
user avatar
0 votes
1 answer
116 views

16.04 LTS, `php -v` in console shows PHP 7.0.33, but PHP 7.3 *is* installed, however I can't use Composer since it needs PHP 7.2+

I'm trying to install something with Composer and am told I need PHP 7.2+. I know for a fact that PHP 7.3.22 is installed on my Ubuntu 16.04 LTS/Apache2/Plesk 18 system as reported by phpinfo(); and ...
user avatar
  • 1
0 votes
3 answers
14k views

php-curl not installed in php 7.4

I am trying to install php-curl in my terminal but this command show linux@Lenovo:~$ sudo apt-get install php-curl Reading package lists... Done Building dependency tree Reading state ...
user avatar
  • 3
2 votes
2 answers
2k views

Facing issue while installing php7.3 on Ubuntu 18.04 “Not replacing deleted config file /etc/php/7.3/apache2/php.ini,”

I am trying to install Php7.3 on Ubuntu 18.4, I am using Apache Server(2.4). My php.ini file is not getting setup at location /etc/php/7.3/apache2/php.ini. I followed the php.ini does not exist but ...
user avatar
3 votes
1 answer
9k views

Why can't I install php7.4-intl on Ubuntu 20.04?

I need the INTL module for PHP on Ubuntu 20.04. When I do $ sudo apt install php7.4-intl I get Reading package lists... Done Building dependency tree Reading state information... Done Some ...
user avatar
  • 219
0 votes
1 answer
996 views

Why is permission denied on this file?

I am having a strange problem. I am trying to include a file in one of my php files that is in my /assets folder. In the php file I have the line require "/opt/docker-substantiator2/app/...
user avatar
2 votes
0 answers
887 views

Broken php package in apt-get install [duplicate]

I want to install php7.4-soap on my Ubuntu 20.04 machine, so I ran sudo apt-get install php7.4-soap But I get following error: Reading package lists... Done Building dependency tree Reading ...
user avatar
  • 1,439
3 votes
0 answers
707 views

Ubuntu 20.04 - Can't Install Older PHP Versions

I decided to install Ubuntu 20.04 and give it a go. I am loving it so far, but I have run into an issue that may prevent me from using it. The default repositories have PHP 7.4, which is awesome, ...
user avatar
18 votes
3 answers
56k views

Cant install PHP 7.2 on Ubuntu 20.04

I added ondrej PPA. And tried install php 7.2, but looks like PPA has not been updated yet. What are my workarounds?
user avatar
1 vote
0 answers
5k views

install php 7.1 on ubuntu 20.04 [duplicate]

I have recently install ubuntu 20.04 - focal fossal. I tried to add ondrej PPA. But it is not working. I only could install php7.4 by apt get. Please help.
user avatar
0 votes
2 answers
171 views

updated Ubuntu webserver not working

I just updated an Ubuntu 16.04 server to 18.04 using sudo do-release-upgrade. Nginx is the webserver. Sites report 404. During install, I chose to keep the currently installed version. $ ps aux | ...
user avatar
  • 14k
0 votes
0 answers
45 views

very heavy php fpm processes

i have problems with heavy php-fpm on a server. Here an excerpt from top: PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND 7631 <user> 20 0 583996 88932 ...
user avatar
  • 117
3 votes
0 answers
360 views

/usr/sbin/and using up the entire CPU coure

I am running Ubuntu Server 18.04 LTS Kernel 5.5.2-050502-generic and since a while now I've seen this /usr/sbin/and popping up in htop, always using entire full core of the server, not really sure ...
user avatar
  • 31
2 votes
1 answer
421 views

How can I determine the PHP version MediaWiki is using?

Running Ubuntu 19.10 with MediaWiki 1.31.1 installed. I have a wiki that worked well under Ubuntu 19.04 but says MediaWiki 1.31 internal error Installing some PHP extensions is required. Required ...
user avatar
2 votes
1 answer
1k views

How in APT to choose a specific source to provide installation instructions for virtual package?

I'm trying to install PHP extension php-ctype. When I do apt-get install php-ctype it returns Reading package lists... Done Building dependency tree Reading state information... Done Package php-...
user avatar
  • 121
0 votes
1 answer
394 views

Ubuntu 18.04 with LAMP installed and want to upgrade from php7.2 to php7.2-fpm

I have a bare metal Ubuntu 18.04 box that I installed LAMP on for NextCloud and Minecraft dynmap install in vhosts. Everything works okay, but my NextCloud speeds are laughably slow and all the ...
user avatar
  • 155
0 votes
1 answer
821 views

Apache2 Web server is running but not serving after migrating to ubuntu 18.04

I appreciate a little help; I spent couple of days trying to rectify this issue. Basically My web server runs normally only after de-activating php7.2. First I attempt to de-activate all PHP ...
user avatar
  • 1
0 votes
0 answers
368 views

Error : Phpize failed, some packages could not be installed

I am trying to install phpize on my ubuntu but everytime am getting this error. I tried this command apt install php7.0-dev and used the sudo also: sudo apt install php7.0-dev but it doesn't work ...
user avatar
  • 101
1 vote
0 answers
1k views

Allowed memory size exhausted after switching PHP from 7.1 to 7.2

Previously, my site ran on PHP 7.1 on Ubuntu 14.04 LTS and I upgraded to Ubuntu 16.04. After upgrade, I could still access my site. Then I installed and switched to PHP 7.2 (I didn't remove PHP 7.1, ...
user avatar
0 votes
1 answer
583 views

Running Ubuntu 19.10 But phpinfo() shows v19.04

In trying to get ImageMagick to work with HEIC, I noticed that while I have Ubuntu 19.10 installed, phpinfo() shows version 19.04. This makes it difficult to know which php.ini to edit, especially as ...
user avatar
  • 295
1 vote
0 answers
155 views

Multiple ElasticSearch (6 and 7) versions in ubuntu 18.04

I would like to install two Elasticsearch versions (Elasticsearch 6.x) and Elasticsearch (7.x). Does anyone know which is the best way for Ubuntu 18.04 so it should work for both projects? I want ES ...
user avatar
  • 117
1 vote
0 answers
3k views

Ubuntu 18.04 + PHP7.3 - Unable to load dynamic library 'pdo_mysql.so'. How to solve it?

I have updated my SO form Ubuntu 16.04 to 18.04. I am using NGINX as a server and updated my php from 7.1 to 7.2 and 7.3. Now when I do php -v this is what I get: PHP Warning: PHP Startup: Unable ...
user avatar
  • 1,040
5 votes
2 answers
6k views

Ubuntu 18.04 - Following packages have unmet dependencies: php7.2-fpm: ... How to solve this error?

I have php version 7.1 in my Ubuntu 18.04. PHP 7.1.33-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Oct 26 2019 19:28:18) ( NTS ) Copyright (c) 1997-2018 The PHP Group Zend Engine v3.1.0, Copyright (c)...
user avatar
  • 1,040
1 vote
3 answers
9k views

phpmyadmin has no installation candidate

I have updated and addded repositories to my sources list, but it still doesn't work: cyan@cyanonvo:~$ sudo apt install phpmyadmin [sudo] password for cyan: Reading package lists... Done Building ...
user avatar
  • 107
5 votes
2 answers
13k views

How to install php7.2 in Ubuntu 19.10

I have recently upgraded to Ubuntu 19.10 from 19.04. When I tried to install some package it asked me to remove many packages by autoremove. So I run the command and it removed the php7.2-fpm. Now I ...
user avatar
1 vote
1 answer
1k views

PHP 7.3 update didn't take

OS: Ubuntu 16.04.6 LTS I updated to php 7.3. Everything appeared to go correctly. However when I type in php -v I get "PHP 7.2.24-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Oct 24 2019 18:28:...
user avatar
  • 23

1
2 3 4 5 6