Questions tagged [pango]

Pango is an LGPL licensed open source computing library used by software developers for laying out and rendering text in high quality, emphasising support for multilingual text.

Filter by
Sorted by
Tagged with
2 votes
0 answers
123 views

Can't install mblock. Error Pango

I am trying to install mblock. I have created a script: #!/bin/bash wget -O mblock.tar.gz https://github.com/Makeblock-official/mBlock/releases/download/V4.0.0-Linux/mBlock-4.0.0-linux-4.0.0.tar.gz ...
  • 165
2 votes
1 answer
434 views

Which package is pango that is needed to compile Qemu with --enable-gtk enabled?

I'm compiling Qemu with --enable-gtk enabled. .configure gives me the following error messages: Run-time dependency gtk+-3.0 found: NO ../meson.build:1042:2: ERROR: Could not generate cargs for gtk+-...
  • 107
1 vote
1 answer
3k views

pangocairo header files not installed

I am running Ubuntu 20.04 on WSL 2. I installed libpangocairo, but I can't find any of its header files. I should have pangocairo installed: $ apt list --installed|grep pango WARNING: apt does not ...
3 votes
0 answers
6k views

Pango-ERROR: Harfbuzz version too old (1.4.2)

I was trying to run this application but this error occurs on the startup of the application, is there a way to avoid this? (wanna:90765): Pango-ERROR **: 03:53:41.569: Harfbuzz version too old (1.4.2)...
  • 1,396
2 votes
2 answers
11k views

libpangox-1.0.so.0:i386 for Ubuntu

I need libpangox-1.0-0:i386 to build a package under Ubuntu 20.04LTS, but it is not currently available. I have libpangox-1.0-0 in my system. The 32 bit version is available for 19.10 and below at ...
0 votes
1 answer
420 views

Getting "pangoxft library not found" error when configuring wxWidgets

I'm trying to configure wxWidgets 3.0.4 on Ubuntu 18.10: $ ./configure --with-x11 But getting an error when running the config script: checking for PANGOXFT... configure: error: pangoxft library ...
7 votes
3 answers
30k views

Unable to resolve dependency for libpango-1.0-0 in 12.04

Unable to resolve dependency for libpango-1.0-0 in 12.04. This is needed while installing forticlient-sslvpn sudo dpkg -i forticlient-sslvpn_4.4.2312-1_amd64.deb Selecting previously unselected ...
  • 3,009
3 votes
0 answers
797 views

Fonts problem / debugging font-cache?

I'm currently trying to debug a font problem under 16.04 LTS. I have installed some TTF fonts in /usr/local/share/fonts, and some programs (such as gnome-specimen) correctly show all four font faces (...
  • 281
2 votes
1 answer
5k views

Can't build pango applications. Pango header not found

I am following this tutorial for writing pango applications. When I try to compile it, the compiler can't find the pangocairo.h headers. Here's my source file: #include <stdio.h> #include <...
1 vote
0 answers
1k views

How can I fix these Pango and fontconfig errors while trying to run Promethease?

I am trying to install the DNA-Analyzer Promethease but I am running into a few issues. After following the advice in How can I install a .bin file? I got the Promethease executable to run but it ...
  • 3,693
1 vote
1 answer
2k views

Pango error in Ubuntu 14.04

I can't get software-center and other Python applications to run in Ubuntu 14.04. The error I get in the terminal is: Traceback (most recent call last): File "/usr/bin/software-center", line 25, ...
0 votes
1 answer
5k views

How to update libpango and install Cairo in Ubuntu?

I want to install "php gtk", but I get the following error message: `libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed I downloaded the latest pango from here....
  • 341
0 votes
1 answer
1k views

Cannot install GTK+3.6.4

When trying to run the ./configure for gtk+-3.6.4 I get the following: Requested 'glib-2.0 >= 2.35.3' but version of GLib is 2.34.0 Requested 'atk >= 2.7.5' but version of Atk is 2.4.0 ...
  • 1
2 votes
1 answer
1k views

Gtk Textview: Pango Letter Spacing

I am desperatly trying to find some working solution on how to modify the Letter Spacing in a GTK TextView. I am using python with GTK 3.6 -- It seems that the solution is to somehow use Pango, but I ...
  • 580
0 votes
1 answer
606 views

How do I resolve "wasn't able to locate a file for the libpango1.0-0 package"?

This message came up while trying to Install (software) Updates the Update Manager said "are available for this computer". I have no idea what "the libpango1.0-0 package" is, nor how it relates to ...
1 vote
0 answers
1k views

Really impossible to have Gimp 2.8 on Ubuntu 11.10? [duplicate]

Possible Duplicate: How do I get GIMP 2.8? For days, I have been trying to find a solution and repositories to install Gimp 2.8 on Ubuntu 11.10. Each time I get this error: Tried to update pango ...
  • 2,742