2022 Developer Survey is open! Take survey.

Questions tagged [pam-environment]

In ~/.pam_environment are set the session environment variables.

Filter by
Sorted by
Tagged with
0 votes
0 answers
424 views

Local modifications to /etc/pam.d/common-*, not updating

Just like any normal day, I ran "sudo apt upgrade", but it gave me this: Local modifications to /etc/pam.d/common-*, not updating. pam-auth-update: Run pam-auth-update --force to override. What ...
user avatar
  • 1,012
0 votes
1 answer
263 views

Login Loop in Ubuntu 16.04 after editing the Path

I was editing the path as said in this page: Source After I did that, I logged out, and ever since that, I was not able to Login. I have tried various Login Loop Remedies said in this Exchange, but ...
user avatar
  • 103
0 votes
1 answer
75 views

.pam_environment not applied on first login but applied on successive logins

I have a ~/.pam_environment file. When I start my computer and login, those environment variables are not applied, but when I logout and login again they are applied.
user avatar
0 votes
0 answers
1k views

Is it safe to comment out kwallet in lightdm and lightdm-greeter?

I have a problem. I am getting some annoying logs of pam_kwallet not found. This is because of kwallet is not installed in my system. If I run the command more /etc/pam.d/* I am getting the below ...
user avatar
  • 826
3 votes
2 answers
9k views

What's the right place to set the XAUTHORITY environment variable?

I'm trying to get rid of the .Xauthority file in my home directory. The arch wiki suggests defining export XAUTHORITY="$XDG_RUNTIME_DIR"/Xauthority but neither placing this line in .profile nor ...
user avatar
  • 179
0 votes
0 answers
414 views

pam_authenticate return's PAM_MODULE_UNKNOWN ( returns 28 ), how to resolve?

Downloaded the source Linux-PAM-1.3.0.tar.gz version then, configured and compiled using command ./configure --prefix=/u02/tasks/linux-pam/Linux-PAM-1.3.0/output/pre --exec-prefix=/u02/tasks/linux-...
user avatar
  • 423
0 votes
1 answer
515 views

How do I deny a particular user from getting root ( through su ) in a terminal by changing the /etc/pam.d/su ? Pam based controlling is required [duplicate]

There are two users in ubuntu (let's call them user1 and user2). Currently, user1 can get access root access using the below commands: user1@sai:~$ su Password: root@sai:/home/user1# However, I ...
user avatar
  • 423
0 votes
0 answers
109 views

How to log into another user if the entered password is wrong?

How tp configure PAM in order to log as a special user (call it wrongpass-user) if a wrong password is entered for any other user?
user avatar
  • 2,226
4 votes
4 answers
25k views

Dollar sign in environment variable's value

Is it a bad practice to have a dollar sign in an environment variable's value? ex: MY_VAR="$toto" To be more precise, I would like to set it in the /etc/environment file to be accessible by a java ...
user avatar
  • 143
0 votes
1 answer
767 views

~/.pam_environment is not workig for root

I want to use zsh for root with oh-my-zsh. I already have oh-my-zsh cloned by my regular user, so all I need to do is to set ZSH env variable to that directory. So I put this in my /root/....
user avatar
  • 101
5 votes
3 answers
3k views

How to set session-wide environment variables and PATH?

I have seen other people on the Internet also having this problem but the solutions have been non-conclusive, so I wanted to bring it to attention again. According to this page in Ubuntu wiki: https:/...
user avatar
  • 153
2 votes
2 answers
657 views

.pam_environment not loaded in TTY

I have environment variables set in ~/.pam_environment and they exist as expected in any graphical terminal emulator I open. If I open a virtual terminal, e.g. TTY1, and login, my PAM environment ...
user avatar
  • 836
11 votes
1 answer
15k views

how to setup two factor authentication in Ubuntu for Ubuntu users using Google authenticator?

How to setup two factor authentication in Ubuntu for Ubuntu users using Google authenticator (It can also be setup for non Google accounts)?
user avatar
  • 2,233
3 votes
0 answers
602 views

nofile limit not changed for sh command in non-interactive session

Running 12.04.3 LTS A user submitting a batch job to the queue was receiving a 'too many open files error' Investigation suggested changing the /etc/security/limits.conf file which has been done ...
user avatar
  • 31
3 votes
1 answer
2k views

Why this .pam_environment setting prevents me from logging in? [duplicate]

I'm trying to move things from my .bashrc to .pam_enviroment because of this. I've put the following into my .pam_environment but this prevents me from logging in because there should be some mistake. ...
user avatar
  • 1,567
3 votes
1 answer
138 views

Help Understanding Line in .bashrc

I've tried looking everywhere to determine what this line does in my .bashrc. The reason I want to know is because now ~/.pam_environment is recommended. This is the line: [[ -s /home/$USER/.nvm/nvm....
user avatar
4 votes
2 answers
5k views

PATH is not affected by .pam_environment

Running Ubuntu 13.04, I'm trying to add variables to PATH for the session, which is recommended to do inside .pam_environment, but nothing seems to work. Here's what it looks like: JAVA_HOME ...
user avatar
  • 1,185
6 votes
1 answer
4k views

~/.pam_environment doesn't work since Ubuntu 13.04 [duplicate]

I have this line in my ~/.pam_environment: PATH DEFAULT=${HOME}/bin:${HOME}/.local/bin:${PATH} and it worked perfectly well on Ubuntu 12.10, but since I've updated to 13.04 it is ...
user avatar
  • 487