Questions tagged [package-management]

Questions about the management of software packages, in particular the APT and dpkg systems.

Filter by
Sorted by
Tagged with
0
votes
0answers
3 views

ubuntu 18.04 messed up youtube-dl upgrade result in errors

I upgraded youtube using youtube-dl -u and a bunch of other ways that I forgot because I only Copy and Paste them on my terminal. and now when I try to install other things my terminal says martin@...
0
votes
1answer
28 views

Uninstall programms installed by Ubuntu 20.04 LTS setup process

I installed programs via the setup process of Ubuntu 20.04 LTS (namely docker and prometheus). These programs do not appear to be installed in any "normal fashion", meaning I neither do find them via ...
0
votes
0answers
19 views

sudo apt-get update error ubuntu 18.10 [closed]

im using Ubuntu 18.10 and trying to update sudo but every time i try it turns back with such an error: error-screenshot i tried to add new repository but that failed again with the error below. N: ...
0
votes
0answers
22 views

Auto remove broken ppa

According to this question, i have almost 60 broken PPA based of this log file ( The apt.log file form /var/log/dist-upgrade folder) like this: , so i like to know can fix it by some app to ...
2
votes
1answer
75 views

Cannot install nohup command

I am trying to install the nohup command. When I run sudo apt-get install nohup I get: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to ...
0
votes
1answer
19 views

e2fsprogs-l10n: Depends: e2fsprogs (>= 1.44.1-1ubuntu1.3) but 1.44.1-1ubuntu1.2 is installed

I ran into this problem when updating some software packages in Ubuntu 18.04. e2fsprogs-l10n: Depends: e2fsprogs (>= 1.44.1-1ubuntu1.3) but 1.44.1-1ubuntu1.2 is installed
1
vote
0answers
16 views

Why apt install snapd before installing 3rd party software? [duplicate]

After installing Ubuntu 20.04 I removed snapd and want to use good old apt, but when I type: sudo apt install chromium-browser I get this: The following additional packages will be installed: snapd ...
0
votes
0answers
19 views

Stuck GCC version is preventing me from installing packages

I'm running a fairly fresh (not release upgraded) install of Kubuntu 20.04. I'm in a "fully updated" state, as in apt update + apt full-upgrade tell me I am up to date. I would like to install: sudo ...
0
votes
1answer
28 views

Why “repo” package available in Ubuntu 20.04? How can I install it?

I tried to install repo , but apt said that package is not available. I refreshed package lists cache by apt update , but the same message. So, I opened my browser and search Ubuntu repositories for ...
-1
votes
0answers
30 views

build-essential [duplicate]

i am not able to install build essential in ubuntu 20.04 xxx:~$ sudo apt install build-essential [sudo] password for pawan: Reading package lists... Done Building dependency tree Reading ...
0
votes
0answers
21 views

Can't install php5 on 16.04

I can't install php5. Can you help? root@localhost:~# sudo apt-get install php5 Reading package lists… Done Building dependency tree Reading state information… Done Package php5 is not available, but ...
0
votes
1answer
27 views

How to uninstall the following packages?

so I wanted to uninstall the following packages, specifically libnvidia-compute 440 one. What commands do I give to remove it and how do I zero down on its location? $ dpkg -l | grep -i nvidia rc ...
0
votes
1answer
35 views

On trying to install nvidia drivers: E: Unable to correct problems, you have held broken packages

I had purged all nvidia related drivers and dependencies on my ubuntu 18.04. However, while reinstalling the drivers I get the following error on running : sudo ubuntu-drivers autoinstall Reading ...
1
vote
1answer
22 views

Run programs installed by Pip in Ubuntu 20.04

As a newbie I try to learn new things everyday, especially when installing: apt, snap, flatpack, appimage, etc. Yesterday I found pip: Python Package Installer, but couldn't get it to work. To test ...
0
votes
0answers
37 views

problems after uninstalling python [duplicate]

I accidentally deleted python and all its dependencies and after that, I restarted my ubuntu so the desktop didn't come up and reinstalled ubuntu-desktop using tty2 after that the ubuntu came up but ...
1
vote
2answers
23 views

How to see why apt has a specific package version installed? [duplicate]

When I run sudo apt upgrade, I get the following: Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages ...
-2
votes
0answers
91 views

How can I find a software's required Libraries, dependencies, and applications [duplicate]

This is a general question. If I want to install something is there a way to determine if I have the dependencies/supporting files (like libraries) that it needs to run?
-1
votes
0answers
24 views

The repository 'http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu focal Release' does not have a Release file [duplicate]

My ubuntu 20.04 (focal) gives this error while i run sudo apt-get update E: The repository 'http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu focal Release' does not have a Release file. N: Updating ...
0
votes
1answer
24 views

How to remove ppa

I'm accessing a linux system [Ubuntu16.04 LTS] remotely. A lot of things seem to be messed up. I need to install libgmp-dev, which gives E: Sub-process /usr/bin/dpkg returned an error code (1) error. ...
0
votes
1answer
25 views

mysql installation issue - Ubuntu 18.04 bionic

On logging in to MySQL, I get the warning: mysql: [Warning] Using a password on the command line interface can be insecure. ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/...
0
votes
1answer
31 views

Is package available on Ubuntu [duplicate]

I want to find out whether a package that is not installed on Ubuntu is available in my configured repositories using a shell script, preferably not one that needs to examine the output from a command ...
2
votes
1answer
88 views

How to find which Ubuntu repo a package belongs to

Long story short, I want to install gcc, but it gave me errors, and I found it resulted in: Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.11) but 5.4.0-6ubuntu1~16.04.12 is to be installed I have ...
0
votes
1answer
36 views

how to install newly generated ubuntu kernel .deb files?

I tried building ubuntu from the source following BuildYourOwnKernel page. (https://wiki.ubuntu.com/Kernel/BuildYourOwnKernel by the way, the page needs some fix now) I did it on a virtual machine ...
2
votes
0answers
21 views

Sudo stopped working after a failed dependency update

Sudo stopped working after I have tried to update a dependency from libc6XXXX to libc6YYYY, required by an experimental text editor. On the first try, it didn't work and apt-get suggested me to use ...
1
vote
0answers
23 views

How to split a Debian package and install the split off one automatically

I have a Debian package, said A, and I would like to move some files out of A and create a new package B for the split off files. A is installed on the system and could be upgraded by "apt dist-...
1
vote
1answer
257 views

Error while installing “linux-headers-5.4.0-33-generic” and “linux-image-5.4.0-33-generic”

Today I got ubuntu updates which also included linux kernal updates. So I did sudo apt-get upgrade to install them. Some packages were installed followed by this error. /etc/kernel/postinst.d/dkms: *...
0
votes
0answers
32 views

Problems installing gcc 8 on Ubuntu 20.04 [duplicate]

I am trying to install gcc-8 and g++-8 on Ubuntu 20.04 (for CUDA) but when I try to install both gcc 8 & 9, I get an error: $ sudo apt -y install build-essential $ sudo apt -y install gcc-8 g++-...
0
votes
0answers
13 views

php-curl install after Ubuntu upgrade to 18.04 reports unmet dependencies

After dist upgrade from 16.04 to 18.04 php-curl stopped working. I tied to install it again but faced broken dependencies problems: $ sudo apt-get install php-curl Reading package lists... Done ...
-3
votes
1answer
96 views

'apt-cache policy' reports an older version of youtube-dl as candidate while newer version is installed [closed]

After updating youtube-dl by the command youtube-dl -U, I then proceeded to check the result using apt-cache policy and I got the following result: $ apt-cache policy youtube-dl youtube-dl: ...
0
votes
1answer
68 views

Steam complains it's missing 32-bit libc.so.6

I've downloaded Steam already but it gives me an error when I try to run it: "You are missing the following 32-bit libraries, and Steam may not run: libc.so.6". So I tried to download it and typed ...
1
vote
0answers
50 views

Trying to install Spek, but cannot understand the error

I am new to Linux and I have been trying to install Spek but i keep getting this error: configure: error: Package requirements (libavcodec >= 53.25 libavformat >= 53.17 libavutil >= 51.17) ...
0
votes
0answers
17 views

How to fix broken CUDA installation?

I have some problems installing CUDA on Ubuntu. I tried to install it the way it is described in the official documentation, did sudo apt -y install cuda and that worked. However after the ...
-1
votes
0answers
15 views

dpkg: unrecoverable fatal error, aborting: files list file for package 'libvisual-0.4-0:i386' is missing final newline [duplicate]

I ran the command sudo apt install snapd but encountered below error: Reading package lists... Done Building dependency tree Reading state information... Done The following packages will be ...
1
vote
0answers
23 views

How to update tracker, a package which hasn't been updated in the PPA yet for Ubuntu 18.04?

I need the tracker package 2.3.0 version for the development of the Gnome Music App. The current version of the tracker package in PPA is 2.0.3 for Ubuntu 18.04. I want to install the tracker version >...
-1
votes
0answers
23 views

LXDE does not show graphic mode [closed]

i recently started my computer and i cant login in graphic mode I use lxle 16.04.02 dual boot with windows 7, i think may be something with broken packages, what should i do to start graphic mode ?
-1
votes
1answer
55 views

security.ubuntu.com repository doesn't have a release file

Output of sudo apt update in Ubuntu 20.04: Ign:1 http://security.ubuntu.com/ubuntu focal-security InRelease Hit:2 http://np.archive.ubuntu.com/ubuntu focal InRelease Hit:3 http://np....
0
votes
0answers
19 views

How do I write this Debian package install file so it works in 16.04 and 18.04?

As I am working on a Debian package for Catch2, I wrote a debian/snapcatch2.install and my problem is that the cmake files do not get installed in the same location. This is for 16.04 usr/share/...
0
votes
0answers
17 views

Dpkg: How do I treat one package as another? [duplicate]

I'm working with a Firefly AIO-3399J, a 64-bit ARMv8 device for which the OEM provides an Ubuntu image. This particular image has a package called "rockchip-mali-midgard14" that has similar ...
1
vote
1answer
55 views

Upgrade to Ubuntu 20.04 fails because of PPAs. How to proceed?

I'm on Ubuntu 19.10 and I'm trying to upgrade to 20.04. Unfortunately the upgrade failed with a message saying that it "possibly failed because of unofficial software packages which are not provided ...
-1
votes
1answer
26 views

wine1.6-i386:i386 : Depends: wine1.6:any (= 1:1.6.2-0ubuntu14)

I have a problem with Wine. I can't install software and I these results: kamdem@kamdem-HP-EliteBook-8470p:~$ sudo apt-get --download-only dist-upgrade Reading package lists... Done Building ...
0
votes
1answer
39 views

How to install a last but one version of a package?

I use Ubuntu 18.04.4 If I want to install a specific version of a Ubuntu package, I try the next command: For example: sudo apt-get install thunderbird=1:68.7.0+build1-0ubuntu0.18.04.1 E: Version '1:...
0
votes
0answers
22 views

APT offline repository: Cannot find the packages

I trying to make an offline apt repository. I have used the apt-ftparchive command to scan and make the Packages file. I have also made Release and InRelease files and imported the key. I used the apt-...
0
votes
0answers
52 views

How do I install Windscribe VPN if their repository is forbidden in the country?

Whenever I try sudo apt-get update I get this error: W: Failed to fetch https://repo.windscribe.com/ubuntu/dists/bionic/InRelease Could not connect to repo.windscribe.com:443 (10.10.34.35), ...
0
votes
0answers
37 views

apt install, then apt update, then apt install [closed]

I'm sure it'll be a duplicate, but I was unable to phrase my question to get an answer... A lot of times, when I try installing a package named [package-name] through apt, by entering the well known ...
0
votes
1answer
273 views

How do I re-install plymouth-theme-ubuntu-logo?

I had KDE installed on my computer a bit ago. Switched back to gnome in 18.04. Recently upgraded to 20.04 and realized the Kubuntu loading screen still shows on startup. Did some research and found ...
0
votes
1answer
95 views

mysql-server-8.0 conflict, unable to install due to a conflict with “itself” [duplicate]

---I have already tried (twice)--- Install of mysql-server after mariadb fails mariadb is not the issue because although it was installed on this computer, all dependencies have already been removed, ...
0
votes
0answers
14 views

Where does libz.so exist in Ubuntu 16.04?

I am trying to build a c++ project and getting the following error... ninja: error: '/usr/lib/libz.so' needed by 'MyProject', missing and no known rule to make it. The build must be expect libz.so ...
0
votes
0answers
33 views

How to update specific packages only in a local Ubuntu mirror?

I built my own local Ubuntu mirror (bionic desktop 18.04.3 LTS) using debmirror following the instructions on this page. Now, I want to update only specific packages (and its dependencies) to specific ...
0
votes
1answer
35 views

How to install libseccomp-dev for different CPU arch

I am trying to install libseccomp-dev:armhf (and arm64) on Ubuntu bionic (same on Xenial). I'm doing this because I would like to cross compile something that depends on libseccomp-dev. This works ...
0
votes
1answer
22 views

How to install R statistics system and r-cran-tidyverse in Ubuntu 20.04?

I am trying to set up a new Ubuntu 20.04 server (to replace an older 18.04 server) which needs to have the R statistics system and, in particular, the r-cran-tidyverse package installed. I am using ...

1
2 3 4 5
166