Questions tagged [package-management]

Questions about the management of software packages, in particular the APT and dpkg systems.

2,553 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
7
votes
2answers
2k views

libMagickWand-6.Q16.so.2: cannot open shared object file

After upgrading Ubuntu 16.04 to 18.04, I can't run php commands. php -v shows me this: php: error while loading shared libraries: libMagickWand-6.Q16.so.2: cannot open shared object file: No such ...
6
votes
0answers
1k views

Package updater error

When I start package updater I have got an error window: Could not get list of distribution upgrade Failed to process request. Spawn of helper '/usr/share/PackageKit/helpers/aptcc/get-distro-upgrade....
6
votes
0answers
556 views

Latest Avogadro build- finding it impossible to install on Ubuntu 14.04

I'm on Ubuntu 14.04, trying to install the latest version of Avogadro (because the version in Software Center is showing issues) and when I get to make, it prints all these errors: [ 98%] Linking CXX ...
6
votes
0answers
3k views

error Failed to load module “overlay-scrollbar”/“unity-gtk-module” on program run

I just installed Ubuntu 15.10 yesterday and when i run a program I got the following errors: error: libgcrypt.so.11: cannot open shared object file: No such file or directory Gtk-Message: Failed to ...
6
votes
2answers
139 views

Custom repository for “click” packages

For standard deb packages we can use reprepro. Is there any custom repository related solution for "click" packages?
5
votes
0answers
2k views

How to List Installed Packages Using Snap

I'd like to get a list of packages installed manually by snap and be able to find out whether a foobar package was installed manually by system installer. For example: $ snap list Name ...
5
votes
0answers
4k views

`GLIBC_2.28' not found in Ubuntu 16.04/14.04 in Travis

I have been using a binary to test in Travis, but it's been compiled with a new version of GLIBC apparently and now I get this all the time: perl6: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2....
5
votes
0answers
2k views

Unable to install packages for different architectures using Multiarch

I've been following this guide to set up my environment in order to install packages for arm64 architecture on my amd64 machine, but I haven't been able to do so. I have added 'arm64' to my list of ...
5
votes
1answer
63 views

How can I use a local package mirror at system installation time?

I would like to use a local mirror of the Ubuntu repositories when I'm completing an Ubuntu Server installation. I have a mirror already created to serve the repository over the LAN using http, this ...
5
votes
1answer
2k views

Apt doesn't want to install an older version of package

I'm building a debian package from the source code. The package has, among the others, the following dependency (part of debian/control): libswarm-dev (>= 0.6.1.0), libswarm-dev (<< 0.7), ...
5
votes
0answers
5k views

AttributeError: 'module' object has no attribute python

I am struggling with compiling python 2.7.9 from source and have been advised to ask this question here. While installing python 2.7.9 following the steps described here the following errors ...
5
votes
2answers
25k views

apt-get package is not available but is referred to by another package - but cannot find that package

When I try to install a package with apt-get install, I'll occasionally see a message of the form Package somePackage is not available, but is referred to by another package. This may mean that the ...
4
votes
0answers
3k views

The following packages have been kept back - safe to force install?

On doing sudo apt upgrade, I get the following error (or warning, not sure what it is): Reading package lists... Done Building dependency tree Reading state information... Done Calculating ...
4
votes
0answers
809 views

Can we install older versions of gcc and g++ on ubuntu 20.04

I currently have Ubuntu 19.10 with gcc 9.1.2 I want to install previous versions of gcc for CUDA 8 (gcc 5 in this case). But I am getting this error: (base) ➜ ~ sudo apt-get install gcc-5 g++-5 ...
4
votes
0answers
3k views

How to have both arch=amd64 and trusted=yes in sources.list of apt package manager?

What do I want to do? You can have deb [trusted=yes] http://pathtoserver/ubuntu bionic main deb [arch=amd64] http://pathtoserver/ubuntu bionic main in sources.list separately. Is there a way I ...
4
votes
0answers
72 views

How to convert Git commits to an Ubuntu patch request?

After following the official guide for fixing a bug in Ubuntu I'm stuck at how to actually submit some existing work (in the form of local Git commits on an "ubuntu/devel" branch for a "main" pool* ...
4
votes
0answers
291 views

Can I purge linux-modules-4.* and linux-modules-extra-4.* packages?

I have a plenty of old config-file status linux-modules-4.xxx and linux-modules-extra-4.xxx (see the pictures). The 5.x version of the Linux kernel is already out. When I do wajig large there was a ...
4
votes
0answers
265 views

apt-get upgrade fails with “Fatal: open /boot/vmlinuz-4.18.0-20-generic: No such file or directory”

This happens on all apt-get install and apt-get upgrade. Anyone knows what's going on? biran0079@ubunduck:~$ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading ...
4
votes
0answers
50 views

Errors on https://packages.ubuntu.com/

I'm working on some offline package deployments, and usually, I grab packages from https://packages.ubuntu.com/, however it seems that the package lists for xenial, bionic, cosmic etc, are all empty. ...
4
votes
0answers
415 views

Lost my Ubuntu Software Centre; how can I get it back?

I am a new user to the Linux community and still playing with the system and IDK somehow my Software Centre is lost. I've tried updating and upgrading but I can't seem to reinstall the missing app. $...
4
votes
0answers
2k views

libwxgtk3.0-dev package not found

I have Ubuntu 12.04, and when I try this: sudo apt-get install libwxgtk3.0-dev I get a message saying package not found. I've tried sudo apt-get update & sudo apt-get upgrade And then tried ...
4
votes
0answers
1k views

How to make Aptitude clean up old kernels?

On my laptop, I have several gigs of old kernels lying around, with package names such as linux-image-some_number-generic, linux-image-extra-some_number-generic, linux-headers-some_number, linux-...
4
votes
0answers
3k views

Fatal Python error/ImportError When Upgrading

When attempting apt upgrade or apt update-manager I receive the following error: Setting up update-notifier-common (3.168.1) ... Could not find platform independent libraries <prefix> Could not ...
4
votes
1answer
634 views

List dependency changes for apt-get upgrade (reasons for packages being held back)

Just today, trying an update on Ubuntu 14.04: $ sudo apt-get update # ... $ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done ...
4
votes
1answer
207 views

List of packages filtered by last update period

Is there any way to get a list of packages (or some request/project related) filtered by last-release date period? I've found this ubuntu list but hasn't any filter by date/period option. I've also ...
4
votes
0answers
2k views

Error when using sudo apt-get update

I am using kubuntu 16.04 SSD/HDD combo and I keep getting the below error message when trying to sudo apt-get update. Reading package lists... Error! E: Could not create temporary file for /var/...
4
votes
0answers
69 views

How to request a package for Ubuntu?

I want to see Webcamoid in my Ubuntu. What is the process to request the package? There are instructions how to build the stuff manually at https://github.com/hipersayanX/webcamoid/wiki/Build-and-...
4
votes
1answer
989 views

How to preseed a package's debconf values when installed as a dependency?

I want to install packages unattended and need to store the required debconf values before installation. Is there a hook to run a command from the currently installing package that is executed ...
4
votes
0answers
88 views

Ubuntu 14.04 64bit - Provides in a package not working

I have recently switched over to 14.04 64bit from 12.04 32bit. I use packages that are built by my company and I have added architecture dependency in the sources.list file like: deb [arch=i386] ...
4
votes
2answers
237 views

Can I reset all packages to repo versions without ppa-purge?

This is just a theoretical for me (it's a real problem for another user) but let's say: I upgrade a load of packages from a PPA onto 12.04 I upgrade to 14.04 Some packages are held in because my PPA-...
4
votes
1answer
5k views

Boot Repair - 'Close all package managers…' Dual Boot Installation

After almost a week, I've just about managed to install Ubuntu 12.04.3 LTS alongside Windows 8 on a Dell XPS 14 Ultrabook. I have created a partition in Windows to store Ubuntu, rebooted from Windows ...
4
votes
1answer
4k views

libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed (on 14.04.2 64-bit)

Please do not mark this as duplicate. I already studied libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed and How do I resolve unmet dependencies after adding a PPA? and tried ...
3
votes
1answer
127 views

Upgrade from 16.04 to 18.04 has broken systemd

After upgrading from 16.04 to 18.04 right at the end it gave the following message: The upgrade has completed but there were errors during the upgrade process. To continue please press [ENTER] ...
3
votes
0answers
99 views

CUDA uninstallation, removing package not possible

On my dev system (Kubuntu 20.04) I just installed CUDA 11.3. After checking the installation, I found some older CUDA packages installed, which are remainders from experiments some time ago. That CUDA ...
3
votes
0answers
78 views

Failing to configure tex-common on Ubuntu 20.04.2 LTS

I have had a problem with my Software Updater for some time, for some reason it was producing an error message saying the problem was coming from tex-common. I can not reproduce this error because I ...
3
votes
1answer
61 views

How to install a specific version of a metapackage and its dependencies?

I'll use the NVIDIA 460 driver as an example. Here's what happens when I want to try to install version 460.67 instead of 460.80 (which is buggy, FYI). $ apt-get install -s nvidia-driver-460=460.67-...
3
votes
0answers
63 views

Multiple Repos for Linux laptops

I'm working on a project to better manage updates on our Linux (Ubuntu) laptops. Currently we already have a working solution for desktops. For our desktops, they're configured to point to a local ...
3
votes
0answers
23 views

Prevent .deb package from substituting system icons

I have installed Softmaker Office but its .deb installer has entered in every /usr/share/icons/* directory substituting the icons for .docx/.xlsx/.pptx files with its own icons. If I uninstall it, the ...
3
votes
0answers
244 views

Create debian package with relative install path

I am creating a debian package with a minimal layout (for a hypothetical package called "skate"). Here's the directory structure: ... ├── LICENSE ├── packaging │   └── debian │   └── ...
3
votes
1answer
930 views

Why can't I completely remove wayland components from a ubuntu desktop?

UBuntu 20.10 is running gnome-session on Xorg. I don't use wayland at all. But when trying to remove possible irrelevant components, I found following ones cannot be removed. aptitude search '~i' -F '%...
3
votes
0answers
248 views

How do I check license of apt packages via command line BEFORE installing?

I want to check a package's license before installing with apt and flatpak. This would be particularly useful in PPAs / custom repositories that allow non-FLOSS licenses, and may have non-FLOSS ...
3
votes
0answers
1k views

I am not able to install steam on ubuntu 20.04

I followed the following steps So first I confirmed that the multiverse Ubuntu repository is enabled: $ sudo add-apt-repository multiverse $ sudo apt update and then I installed the steam package: $ ...
3
votes
2answers
2k views

tlmgr: Local TeX Live (2019) is older than remote repository (2020)

I already tried what is suggested in the answer to the question: "I got an error when trying to install a latex package trough tlmgr on ubuntu 20.04, verify_checksum: -5 ". When I type this ...
3
votes
0answers
2k views

Apt can't find packages on Ubuntu 20.04 arm64 (Raspberry Pi 4)

I began by trying to install xubuntu-desktop, and then tried xfce4, and other packages (like GIMP) on a freshly installed Ubuntu Server 20.04 on my Raspberry Pi 4 but apt reported that it couldn't ...
3
votes
0answers
50 views

sudo stopped working after a failed dependency update

sudo stopped working after I have tried to update a dependency from libc6XXXX to libc6YYYY, required by an experimental text editor. On the first try, it didn't work and apt-get suggested I use the --...
3
votes
0answers
2k views

ImportError: No module named 'encodings' on Ubuntu 16.04

My Ubuntu 16.04 has broken packages and unmet dependencies. I tried to fix the system as suggested by using: sudo apt-get -f install Once I do that. I get these packages will be installed: The ...
3
votes
0answers
943 views

How to install python distutils

I am running ubuntu 20.04 with python 3.8, 3.7, and 3.6 installed. I am trying to install some packages using pip on 3.7 and 3.6 versions using 'python3.7 -m pip install package' but I am getting '...
3
votes
1answer
9k views

Ubuntu 20.04 broken updates libc6

in my WSL1, I update Ubuntu 18.04 to Ubuntu 20.04 from Microsoft Store. So I run the command sudo do-release-upgrade and it says to change /etc/update-manager/release-upgrades from Prompt=LTS to ...
3
votes
2answers
721 views

Installing libcairo2-dev

I am trying to install libcairo2-dev in a Ubuntu 18.04.2 LTS Bionic. I run : $ sudo apt-get install libcairo2-de Reading package lists... Done Building dependency tree Reading state ...
3
votes
0answers
363 views

Installing a package which is only available on a different version of Ubuntu

I want to use the Python wrapper PyKDL for KDL, the Kinematics and Dynamics Library. PyKDL is only packaged beginning with 19.04. I installed PyKDL using pip3 on my 18.04 system. In an interactive ...

1
2 3 4 5
52