Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [package-management]

Questions about the management of software packages, in particular the APT and dpkg systems.

2
votes
3answers
68 views

Install many applications using one command

after reinstall system I need install applications again. Is it possible to make bash script or own package where cancan I add needed application and after reinstall system will I install them all ...
1
vote
0answers
47 views

Ubuntu 18.04 updates giving me error messages about packages not being upgraded/updated

While running Ubuntu updates, I get error messages saying that some package updates have failed, including python,and that MaxReports is full so no notice is being sent anywhere. I have searched for ...
2
votes
1answer
1k views

Ubuntu 18.04 update problem [duplicate]

Everytime I try sudo apt-get update or sudo apt update, system returns following errors: Hit:1 http://ppa.launchpad.net/marutter/rrutter/ubuntu bionic InRelease Hit:2 http://archive.ubuntu.com/ubuntu ...
0
votes
0answers
25 views

Package management solution

I am a newbie to ubuntu and I am assigned to work on package management solution for end users at my company. I would like a simple way of making a package available to my endpoints. For example all ...
0
votes
0answers
54 views

Ubuntu Install Packages of Older Version

I want to install some applications/ packages that were available for Ubuntu 18.04 on Ubuntu 18.10. In my special case it is the Deepin Desktop Environment, but there are other packages, too. From ...
0
votes
0answers
6 views

to add addpkg_svn CAFAna S18-02-25 package

I want to add addpkg_svn CAFAna S18-02-25 but I am getting this error - Permission denied (publickey,gssapi-keyex,gssapi-with-mic). svn: To better debug SSH connection problems, remove the -q option ...
0
votes
0answers
21 views

Modelling of Nanoparticles

I need realistic modelling code of Nanoparticles on Geant4 package but it is not found. How to create it? Have you any NPs examples for Geant4 ?
0
votes
0answers
70 views

Which package provides lgtk-3 on Ubuntu 18.04?

Which package provides lgtk-3 on Ubuntu 18.04? Trying to compile c program "Hello World" : >> gcc -Wall -g helloworld.c -o helloworld `pkg-config --cflags gtk+-3.0` \ `pkg-config --libs gtk+...
2
votes
1answer
74 views

I cannot remove my broken package which I didn't install

sudo dpkg --remove --force-remove-reinstreq dotnet-runtime-2.0.0 dpkg: warning: ignoring request to remove dotnet-runtime-2.0.0 which isn't installed The following packages have unmet dependencies: ...
2
votes
0answers
159 views

How to install clang-format-7 from bionic-updates universe on 18.04.1 LTS?

I am on Ubuntu 18.04.1 LTS. I would like to install this package: clang-format-7. I am unable to do so in the usual way. Here is the output of sudo apt install clang-format-7 (following sudo apt ...
1
vote
1answer
124 views

Which APT repositories is required on Ubuntu 18.04

I have remove the disabled APT repositories, but as suggested here Remove APT repositories disabled after upgrade to 18.04 I didn't do this: "Some of the disabled repositories may have "xenial" in ...
0
votes
0answers
14 views

dpkg: fatal error, aborting: cannot open libmng1:armhf.list [duplicate]

Well, I tried to install some python packages and I found these errors, loading files list file for package 'libmng1:armhf': cannot open /var/lib/dpkg/info/libmng1:armhf.list (Bad message) E: Sub-...
1
vote
1answer
45 views

Converting rpm to deb error execution (ubuntu 18.04)

When I am trying to convert rpm files to deb files this error executes and I can't understand the problem LANG=C rpm -qp --queryformat %{NAME} 'adlmapps11-11.0.15-0.x86_64.rpm' sh: 1: rpm: not found ...
0
votes
1answer
57 views

Reinstalling broken xterm (Ubuntu 18.04)

So, my problem is that after a series of problems (which I'll describe bellow) I have a damage xterm package, which now always shows an error when installing new packages, updating, etc. It all ...
0
votes
0answers
129 views

dependency libusb-0.1 not satisfiable

My OS is LinuxMint 19(Ubuntu 18.04) - latest Patch Level. I am trying to install a debian Package. But there is a dependency issue: libusb-1.0 can not be found / used. deb: Architecture: amd64 ...
3
votes
1answer
1k views

I am not able to install anything in ubuntu

The following is the message I get when trying to install anything on Ubuntu, right now. Reading package lists... Done Building dependency tree Reading state information... Done You might ...
1
vote
1answer
443 views

How to uninstall Python from pip

My default Python installation is from pip which is at 2.7.10. apt-get has already Python 2.7.13 installed. I don't want to keep both installations because it's confusing, and I would prefer to keep ...
1
vote
1answer
100 views

What is the purpose of the php-cli package?

During the process of setting up a new development workstation (Kubuntu 18.10), I discovered that the php-cli package was not installed. Nevertheless, all PHP scripts are working fine, whether they ...
0
votes
1answer
273 views

ubuntu upgrade problem with py3compile not found

Ubuntu: 18.04 When I tried to do sudo apt-get upgrade it gives me this error: Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... ...
1
vote
0answers
401 views

NVIDIA Driver Installation Issue

Completely new to Linux took me a while to get everything setup the way I want it to, well not everything obviously. I'm attempting to install a new NVIDIA driver and it's not allowing me. I'm getting ...
0
votes
0answers
122 views

Ubuntu broken dpkg blocks to install or repair system

I tried to install a soft on my Ubuntu. But installation was interrupted with Processing was halted because there were too many errors. E: Sub-process /usr/bin/dpkg returned an error code (1) The ...
0
votes
1answer
35 views

Are the snap package files isolated from normal package install?

I have installed Visual studio code from a .deb package. So now that they provide a snap package, what would happen if install it as a snap package (without removing the former)? I see from this ...
5
votes
1answer
260 views

How to find program name(s) of an installed package?

When I have installed a package using apt, is there a way to find out by which command(s) I can run the installed program(s)? For instance, the package httpcode is not available as httpcode, and the ...
1
vote
1answer
67 views

install a package in different location

Generally when I run a dpkg or apt-get to install a package it copies some files to specific locations. Such as the mpv files is coppied to these locations (got by trying dpkg --listfiles mpv): /. /...
0
votes
0answers
42 views

fenics not unistalling on Ubuntu 16.04.5 LTS

I want to remove and freshly install fenics software on my system. Following the instruction on this, I tried removing only fenics by (as I'm not sure what will happen if I remove the dependent ...
0
votes
0answers
128 views

Installing libdw-dev - Can't find installed dependency [duplicate]

I'm running VirtualBox (Version 5.2.22 r126460)with Ubuntu 16.04 on my Mac (Mojave if that's of interest) and I'm trying to install the libdw-dev package. However, when trying to install the package ...
0
votes
0answers
22 views

Getting Error: “Malformed entry 59 in list file /etc/apt/sources.list” [duplicate]

I am getting this error: an error occurred please run the package manager from the right click menu or apt-get in terminal to see what is wrong. The error message was; Error:opening the cache(E:...
0
votes
0answers
3k views

How to update core-js to core-js@3 dependency

While I was trying to install and setup react native, the precaution observed about the core-js version as update your core-js@... to core-js@3 But don't know how to update my core-js. One things is ...
1
vote
1answer
63 views

how do i list package contents using apt-file?

Sometimes it's necessary to see what's inside a package which was not installed. Normally i use apt-file for this purpose. At most times this works fine, but in some cases i can't retrieve any ...
0
votes
1answer
319 views

How can I remove an updated hplip completely and replace it with the version from Ubuntu repos in 18.04? [duplicate]

I installed a more recent version of hplip than the one distributed with 18.04, which made it impossible to install hp-plugin properly. So I want to get rid of the updated version and reinstall the ...
0
votes
0answers
61 views

How to specify DEBIAN_FRONTEND on a per-package basis?

One package that I'm trying to install has (imho) broken automated installs by always prompting the frontend to confirm the update first. There is a workaround that involves setting DEBIAN_FRONTEND=...
0
votes
0answers
261 views

404 on Ubuntu 18.04 bionic-security dist

I am trying to install a fresh Ubuntu 18.04 today, with minimal install mode, and I'm having trouble with package installation. I've installed some basic things like gcc and git. On sudo apt-get ...
0
votes
1answer
289 views

How to build deb package for ubuntu 18.04

I am interested to build a deb package for ubuntu 18.04. I have found this article help me, How to create NGINX debian package from souce?. My question is, Is it safe to build deb package using root ...
1
vote
1answer
341 views

Can't fetch packages during dist-upgrade

I'm trying to upgrade from 18.04.1 to 18.04.2 and I'm getting the following errors which cause the upgrade to abort sudo apt-get dist-upgrade --fix-missing Reading package lists... Done Building ...
0
votes
1answer
356 views

ImportError: /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0: undefined symbol: FT_Get_Var_Blend_Coordinates

I'm on Ubuntu 18.10 Whilst trying to get this project from GitHub to work: https://github.com/naokishibuya/car-behavioral-cloning After running "python drive.py model.h5" I'm getting following error:...
0
votes
0answers
94 views

“initscript does not exist”, apt-get install [package] is not creating init script in `/etc/init.d/`

I am trying to install scalyr-agent-2 via the bash script provided on Scalyr's install page. It has worked on countless servers but when I finally get to the production server it seems to fail and I ...
0
votes
1answer
89 views

Fresh Ubuntu 18.04 installation has no dpkg and no internet

I've just installed Ubuntu 18.04 and it has no wifi driver installed. I know the driver is inside the bootable usb I've used to install it but my system doesn't have all dpkg's dependencies installed. ...
0
votes
1answer
288 views

Remove MikTex from Ubuntu 18.04.2

How do I remove Miktex? I need to remove MikkTex and install Texlive because of broken packages and updates issue. The following packages have unmet dependencies: miktex : Depends: libhunspell-1.3-...
0
votes
2answers
80 views

So, i want to install Spotify but it wont let me, it is a dpkg error [duplicate]

This is what it tells me anywhere I try, the store and terminal *Setting up spotify-client (1:1.0.80.480.g51b03ac3-13) ... dpkg: error processing package spotify-client (--configure): installed ...
0
votes
0answers
90 views

AWT-EventQueue-0 Exception

I get the following Exception when trying to run some apps like Meow Exception in thread "AWT-EventQueue-0" java.lang.ExceptionInInitializerError at org.medit.gui.entries.EntriesPanel$.<init&...
0
votes
0answers
148 views

how to solve unmet dependencies with libpq5

I am trying to install pgAdmin4 in ubuntu 18.04, but I get the following error: The following packages have unmet dependencies: libpq-dev : Depends: libpq5 (= 10.6-0ubuntu0.18.04.1) but 11.2-1....
0
votes
1answer
37 views

Package colord being held back due to wrong version of libsane-common

Running sudo apt upgrade reports Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following package was automatically ...
0
votes
0answers
67 views

DraftSight 2019 for Ubuntu (beta) installation error 18.04 (64bit)

I've been trying to install Draftsight 2019 (beta) and during the install I keep getting errors. (see pictures) I've tried to install using a few different methods. sudo apt install ~/Downloads/...
0
votes
0answers
52 views

Which packages digitalocean using for droplet?

I want to install droplet packages in my server then User can create droplet in my server and they can access .
1
vote
1answer
154 views

Fixing Python dependency mess

On a Raspberry Pi I installed some python software, a part with pip, and other parts with apt-get. So I am now in a situation, where there are some packaged waiting to be installed that assume python ...
0
votes
1answer
105 views

Could not get lock … Resource temporarily unavailable after running sudo apt update (Error 11) [duplicate]

I have a fresh installation of Ubuntu 18.04-x64. In the terminal I enter the command: sudo apt update And I get the following error: E: Could not get lock /var/lib/apt/lists/lock - open (11: ...
2
votes
1answer
60 views

Unable to add Ubuntu Precise (12) repositories to Ubuntu 18 (Bionic Beaver)

Due to several reasons I'm trying to install a glusterfs-client version 3.2.5 on a Ubuntu 18.04. This glusterfs-client version 3.2.5 is included on the Ubuntu Precise packages. So I add these two ...
0
votes
1answer
61 views

not possible to add repository [duplicate]

The following is the ouput how to resolve this E: The repository 'http://ppa.launchpad.net/darklin20/bomi/ubuntu bionic Release' does not have a Release file. N: Updating from such a repository can't ...
0
votes
0answers
89 views

E: Unable to locate package libesd0-dev

E: Unable to locate package libesd0-dev I'm not getting what the issue is, please help me out.
1
vote
1answer
35 views

octave from ppa with packages not possible

I installed octave using ppa, but now all octave packages (e.g. optim) have broken dependencies. I proceeded in the following way: $ sudo add-apt-repository ppa:octave/stable $ sudo apt-get update $ ...