Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [package-management]

Questions about the management of software packages, in particular the APT and dpkg systems.

0
votes
0answers
15 views

updater in ubuntu 18.04

When I click on Software Updater each new day .the first attempt always fails due to some package or other failing to load due to it being badly corrupted or spread out. Later on switching on again ...
1
vote
1answer
174 views

Upgrading to ubuntu 19.04: errorr “ Could not install 'Install-info' ”

During upgrading from 18.10 to 19.04, the error Could not install 'Install info' occured. The upgrade completed. However, when I tried install cabal, the following resulted: Reading package lists... ...
1
vote
0answers
42 views

Error while running sudo apt-get update from terminal

I'm unable to perform apt update because it throws me following error. Reading package lists... Error! W: Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/...
0
votes
1answer
81 views

Installing Offline Ubuntu 16.04 how to load apt-offline & install <14e4:43b1 system updates install

I am installing Ubuntu 16.04. I'm looking for someone who knows that offline installer and update for driver's mainly system updates and wireless drivers, perfered legacy since my wireless card is an ...
0
votes
0answers
32 views

How to install all packages listed on “apt-get list” command?

I am using Ubuntu Disco Dingo 19.04. I want to learn how to install all packages automatically that are listed by typing "apt-get list" on terminal. Not all of them are installed by default. I mean ...
1
vote
0answers
28 views

Some Debian packages, specifically Crossover, not installing on Ubuntu 18.10

Currently, I'm trying to install Crossover on my laptop running Ubuntu 18.10. However, the Debian package won't seem to install. This is not the only package that won't install. Off the top of my head ...
1
vote
0answers
56 views

apt broken install/update/remove causes input/output error for linux-image package [duplicate]

I can't install/update/remove anything because of this error, nor does google return anything specifically for linux-image-4.10.0-42-generic (It does for other things, but I am not sure what to touch ...
0
votes
0answers
28 views

ubuntu 16.04 mariadb installation dependencies

Getting following error on trying to install mariadb 10.2 on ubuntu 16.04 $ sudo apt install mariadb-server Reading package lists... Done Building dependency tree Reading state information... ...
0
votes
1answer
210 views

Unable to install libopencv-nonfree-dev in Ubuntu 16.04

I tried to install the libopencv-nonfree-dev package in Ubuntu 16.04 using the command: sudo add-apt-repository --yes ppa:xqms/opencv-nonfree sudo apt-get update sudo apt-get install libopencv-...
0
votes
0answers
43 views

Error installing libreoffice-java-common

When I run: libreoffice filename.docx I get the message: javaldx: Could not find a Java Runtime Environment! Please ensure that a JVM and the package libreoffice-java-common is installed. ...
0
votes
2answers
128 views

Error installing packages and apt-get update

I was trying to install mariadb-server but while doing it it gives me errors, trying to do apt-get update gives me more or less the same errors. This is the command output for apt-get update: root@...
0
votes
1answer
154 views

debian apt install broken after deleting python [duplicate]

Sorry my OS is in french so i hope it will not an issue for you guys. I had some trouble with python and awx install so i decided to delete all python package but i have done big foolishness. Now i ...
0
votes
0answers
33 views

Accidentaly deleted some files in var/lib

I accidentally deleted some files in var/lib. I don't know what I have deleted. Gnome-terminal too then disappeared since I messed up with Gnome-Purge. I then installed xterm using TTY. But then when ...
0
votes
0answers
48 views

I am not being able to open software and update?

I am using Ubuntu Mate. Iam unable to open Software & Updates, it simply doesn't pop up. That is why I am not being able to install Skype and other software. I followed few similar type of ...
1
vote
1answer
83 views

“ibus-qt4” package missing from disco packages

I tried to install avro. But it depends on ibus-qt4. When I searched, it is not in Disco packages. How can I install the package?
0
votes
1answer
182 views

MySQL Workbench

Just upgraded from 18.10 to 19.04. MySQL Workbench has been deleted. Will it come back in the near future? The mysql-workbench-community_8.0.15-1ubuntu18.10_amd64.deb can't install! Do I need to ...
4
votes
1answer
217 views

Is it possible to intall libXft.so.2 on WSL?

I wish to run a scientific GUI on WSL, which requires libXft.so.2 package. Used sudo apt-get command, bash returned. Reading package lists... Done Building dependency tree Reading state ...
1
vote
0answers
21 views

Upgrade blues - 14.4-16.4

I ran do-release-upgrade from command line on my medical practices server. Things were going very smoothly and then the system hung up. I did a hard restart after waiting a long while. When the system ...
0
votes
0answers
61 views

Error while installing apt,apt-get

While I am going to install any application by the command sudo apt-get install I get the error apt-get not install , while I tried to install apt-get by adding repo of wget I get 404 not found, ...
0
votes
0answers
25 views

Is there a way to disable applications on Ubuntu (similar to disabling system apps on Android)?

I recently installed 2 programs which do the same thing. However, I only want one of them to be 'enabled' i.e able to run in the background, display it's icon etc. However, if I want to run the ...
3
votes
1answer
1k views

Upgraded to 19.04 now I have Nvidia package problems

So before I format my hard drive and do a clean install (just like I did 6 months ago) is there a magical command that can fix this problem? I should point out the Nvidia driver is working great (...
0
votes
0answers
128 views

Packages held back after upgrading to 19.04

Yesterday I used sudo do-release-upgrade to upgrade Ubuntu from 18.10 to 19.04 having all my customization etc. After a few steps, I saw the download is a bit big so I cancelled the upgrade, but the ...
0
votes
0answers
49 views

Installing Program Problem on Ubuntu 18.04 on a Dell Inspiron

I'm trying to install Scid vs. PC, a chess database program. My research led me to the link provided below. I have just recently switched to Ubuntu from Windows 10 so I'm still relatively new to ...
3
votes
1answer
411 views

How to install Octave 5 on Ubuntu 18.04?

On this old question How to install Octave 4.0.0 in Ubuntu 14.04 they say to use this: sudo add-apt-repository ppa:octave/stable sudo apt-get update sudo apt-get install octave But when I run this ...
1
vote
0answers
102 views

`apt-get install software-properties-common` is broken

When running apt-get install software-properties-common, we get the following error message: Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/d/distro-info-data/distro-info-data_0.38ubuntu0....
0
votes
0answers
20 views

Why newer version of a package is not available for previous releases of Ubuntu?

Disco is out today, and I just realize this. Of course, releases which are too old lacks some sort of features to support new software, and developers can either implement workarounds or it is simply ...
0
votes
0answers
30 views

SDK Installation Issue - opensdk-package

System Information Platform - 18.04.1 LTS OS type - 64-bit we are trying to installing a SDK by command dpkg -r opensdk-package-3.50.deb and getting the error of dependency Previous steps done:...
2
votes
1answer
62 views

How to know if a package is graphical or command line application?

I am using Ubuntu Server, hence I want to know if a package is GFX or CLI before installing. Wrongly installing GFX apps will cause a lot of dependencies to be fetched, and they will not work anyway (...
0
votes
1answer
187 views

apt package `netplan` vs `netplan.io`

I see two packages in apt: netplan.io - YAML network configuration abstraction for various backends netplan - network server for `plan' I presume netplan.io is the one for dealing with /etc/netplan/...
0
votes
0answers
43 views

apt install - can't autocomplete package names (Docker)

It's the same error as in several other posts, but none of the solutions work for me. I'm typing apt-get install ar<TAB><TAB> and there's not auto-completion. I'm using an Ubuntu-...
1
vote
0answers
115 views

How to solve apt-utils : depends on: apt (= 1.6.8) but 1.6.10 is installed

These are my (german) messages translated to English via Google Translate: Package lists are read ... Done Dependency tree is set up. Status information is read .... Done Try "apt --fix-broken ...
0
votes
0answers
33 views

Installed apache open office and uninstalled it and it has killed my day

Hello guys so i tried installing apache open office and thus had to first uninstall libre office but after realising it was fake i again tried to install libre office which i did with snap but ...
0
votes
0answers
47 views

Uninstalled unity-greeter and then installed it again, but desktop is gone

Will Ubuntu be the at the same status after I deinstall and reinstall the same package? I deinstalled the unity-greeter package with apt-get remove and I reinstalled it with apt-get install. So I ...
1
vote
1answer
114 views

Automatically install packages/dependencies for installation of an arbitrary package?

Scenario When starting with a fresh Ubuntu 16.04 installation, my goal is to solely install and use the package default-jre as quickly as possible for debugging purposes. I can install this by ...
0
votes
0answers
24 views

Preventing installation of a specific package doesn't work with APT pinning with Pin: origin “”

I have installed TeX Live manually and want to prevent the installation of any of the texlive* packages. There is this question How to prevent updating of a specific package? for preventing updating/...
1
vote
1answer
310 views

Install python 3.6.7 pip3 offline

I recently installed ubuntu 18.04 on my computer. Sadly my pc does not have a wifi chip. I do not have ethernet in my house either. Is there a way to install pip3 or any package offline? I do not have ...
0
votes
1answer
17 views

Error: Uncaught Error: Undefined class constant 'MYSQL_ATTR_USE_BUFFERED_QUERY' in /var/www/html/myproject/includes/database/mysql/database.inc:56

I am working with drupal 7 and I install drush V7.4.0 but when i run drush cc all I am getting this error : Error: Uncaught Error: Undefined class constant 'MYSQL_ATTR_USE_BUFFERED_QUERY' in /var/www/...
2
votes
3answers
68 views

Install many applications using one command

after reinstall system I need install applications again. Is it possible to make bash script or own package where cancan I add needed application and after reinstall system will I install them all ...
1
vote
0answers
47 views

Ubuntu 18.04 updates giving me error messages about packages not being upgraded/updated

While running Ubuntu updates, I get error messages saying that some package updates have failed, including python,and that MaxReports is full so no notice is being sent anywhere. I have searched for ...
2
votes
1answer
1k views

Ubuntu 18.04 update problem [duplicate]

Everytime I try sudo apt-get update or sudo apt update, system returns following errors: Hit:1 http://ppa.launchpad.net/marutter/rrutter/ubuntu bionic InRelease Hit:2 http://archive.ubuntu.com/ubuntu ...
0
votes
0answers
25 views

Package management solution

I am a newbie to ubuntu and I am assigned to work on package management solution for end users at my company. I would like a simple way of making a package available to my endpoints. For example all ...
0
votes
0answers
53 views

Ubuntu Install Packages of Older Version

I want to install some applications/ packages that were available for Ubuntu 18.04 on Ubuntu 18.10. In my special case it is the Deepin Desktop Environment, but there are other packages, too. From ...
0
votes
0answers
6 views

to add addpkg_svn CAFAna S18-02-25 package

I want to add addpkg_svn CAFAna S18-02-25 but I am getting this error - Permission denied (publickey,gssapi-keyex,gssapi-with-mic). svn: To better debug SSH connection problems, remove the -q option ...
0
votes
0answers
21 views

Modelling of Nanoparticles

I need realistic modelling code of Nanoparticles on Geant4 package but it is not found. How to create it? Have you any NPs examples for Geant4 ?
0
votes
0answers
70 views

Which package provides lgtk-3 on Ubuntu 18.04?

Which package provides lgtk-3 on Ubuntu 18.04? Trying to compile c program "Hello World" : >> gcc -Wall -g helloworld.c -o helloworld `pkg-config --cflags gtk+-3.0` \ `pkg-config --libs gtk+...
2
votes
1answer
69 views

I cannot remove my broken package which I didn't install

sudo dpkg --remove --force-remove-reinstreq dotnet-runtime-2.0.0 dpkg: warning: ignoring request to remove dotnet-runtime-2.0.0 which isn't installed The following packages have unmet dependencies: ...
2
votes
0answers
149 views

How to install clang-format-7 from bionic-updates universe on 18.04.1 LTS?

I am on Ubuntu 18.04.1 LTS. I would like to install this package: clang-format-7. I am unable to do so in the usual way. Here is the output of sudo apt install clang-format-7 (following sudo apt ...
1
vote
1answer
121 views

Which APT repositories is required on Ubuntu 18.04

I have remove the disabled APT repositories, but as suggested here Remove APT repositories disabled after upgrade to 18.04 I didn't do this: "Some of the disabled repositories may have "xenial" in ...
0
votes
0answers
14 views

dpkg: fatal error, aborting: cannot open libmng1:armhf.list [duplicate]

Well, I tried to install some python packages and I found these errors, loading files list file for package 'libmng1:armhf': cannot open /var/lib/dpkg/info/libmng1:armhf.list (Bad message) E: Sub-...
1
vote
1answer
44 views

Converting rpm to deb error execution (ubuntu 18.04)

When I am trying to convert rpm files to deb files this error executes and I can't understand the problem LANG=C rpm -qp --queryformat %{NAME} 'adlmapps11-11.0.15-0.x86_64.rpm' sh: 1: rpm: not found ...