Questions tagged [package-management]

Questions about the management of software packages, in particular the APT and dpkg systems.

Filter by
Sorted by
Tagged with
0
votes
2answers
88 views

Ubuntu 16.04: gcc-5-base broken

On Ubuntu 16.04 I've problems with gcc-5-base package: user@laptop:~$ sudo apt install libgfortran3 The following packages have unmet dependencies: libgfortran3 : Depends: gcc-5-base (= 5.4.0-...
0
votes
0answers
53 views

Uninstall JDK 12 on Ubuntu 19.04

I am new to Ubuntu and have installed JDK 12 from this Linux Hint guide. However, I realise I need an earlier version of JDK for the program I want to run. How do I uninstall JDK 12?
1
vote
0answers
126 views

“Could not resolve 'proxyhost'” when I run sudo apt-get update in Ubuntu 18.04

sudo apt-get update isn't working for me in Ubuntu 18.04 LTS Err:1 http://in.archive.ubuntu.com/ubuntu bionic InRelease Could not resolve 'proxyhost' Err:2 http://in.archive.ubuntu.com/ubuntu ...
1
vote
1answer
102 views

Is it safe to remove configuration files for older kernels?

Using dpkg -l shows, that there are still configuration files for older kernels (?) available: rc linux-image-4.13.0-32-generic 4.13.0-32.35~16.04.1 rc linux-image-4.13.0-36-generic ...
1
vote
1answer
130 views

how to install pantheon-files on ubuntu 18.04.3

what i did: $ sudo add-apt-repository ppa:elementary-os/stable $ sudo apt update Ubuntu 18.04.3 Mate try install Pantheon-Files but get error: $ sudo apt-get install -f pantheon-files Reading ...
0
votes
1answer
149 views

How do I get around error 403 when installing docker CE on Ubuntu 19.04

I am trying to install docker CE on ubuntu 19.04. I am getting an error 403. Reading package lists... Done E: Failed to fetch https://apt.dockerproject.org/repo/dists/ubuntu-disco/InRelease 403 ...
2
votes
1answer
49 views

Why using `dpkg -x` killed my 19.04 system?

I have just killed my 19.04 system. I was running sudo apt-get upgrade and wanted to install atop package for monitoring purposes without interruption of upgrade process. So I decided to download ...
1
vote
0answers
31 views

Restore Ubuntu 16.04 which was corrupted by sudo apt autoremove python3 [duplicate]

I mistakenly ran the command, sudo apt autoremove python3 in Ubuntu 16.04. Because of that all software was removed, and even the terminal is not working. Debian package manager is also not working. I'...
0
votes
0answers
36 views

Unable to install packages or rload repository

I'm having issues with updating or installing all packages in ubuntu 18.04. I was trying to load openvpn so followed some instructions to edit my /etc/apt/source.list and now nothing is working. I ...
0
votes
0answers
37 views

Errors while trying to create a signed local repository in Ubuntu

I am trying to create local signed repo for debian packages on one of our build systems. The intent is that after creating this signed repo, we will ship it as part of our installer along with the ...
17
votes
1answer
1k views

Why is xterm installed when trying to uninstall gnome-terminal?

I use Alacritty as my main terminal emulator. I tried to uninstall the gnome-terminal package, but when I type apt remove gnome-terminal, it says: The following additional packages will be installed: ...
0
votes
0answers
111 views

Errors were encountered while processing: systemd E: Sub-process /usr/bin/dpkg returned an error code (1)

I know it has been asked many times before but none of those solutions helped me. Every time I am running sudo apt upgrade I get this error. dpkg: error processing package systemd (--configure): ...
0
votes
0answers
43 views

E: Encountered a section with no Package: header E: Problem with MergeList /var/lib/dpkg/status

I'm on ubuntu 16.04 64 bit unity, tried installing php7.3 because I need phpredit library and doesn't work with xampp, that version of php isn't in apt, tried installing it from a third party repo, ...
0
votes
0answers
53 views

Unable to get IP on my Ubuntu 19.04 virtual machine

I am trying to install a package textlive as mentioned here https://milq.github.io/install-latex-ubuntu-debian/ However when I do osboxes@osboxes:~$ sudo apt-get install texlive [sudo] password ...
0
votes
1answer
43 views

How to find the specific `*Release` apt state information file for a given package?

I need to programmatically gather the apt Origin and Suite information for a certain package, in order to configure unattended-upgrades. I can manually find the corresponding apt state information ...
0
votes
0answers
59 views

How to get perf fully working with all features?

I've installed the following packages: linux-tools-common, linux-tools-generic and linux-cloud-tools-generic I now have perf but it's a bit broken. 1 - sudo perf report --gtk GTK browser requested ...
0
votes
1answer
168 views

ubuntu 16: having trouble installing ffmpeg (latest version)

Ubuntu 16.04.6 LTS and trying to install ffmpeg. $ sudo apt install ffmpeg Reading package lists... Done Building dependency tree Reading state information... Done ffmpeg is already the newest ...
0
votes
0answers
49 views

What can I remove from a normal installation of Ubuntu 18.04? [duplicate]

I just did a normal installation of Ubuntu 18.04.3 LTS and would like to know if I really need all the apps installed by default and if I can remove most of them without breaking the system. Are there ...
0
votes
0answers
26 views

Can't uninstall language on ubuntu 18.04 lts

I was installed language pack,but now i want to uninstalled it. The problem is i can't uninstalled it the message goes like this: sudo apt-get remove language-pack-id [sudo] password for marcell: ...
0
votes
0answers
35 views

Create an executable application in Ubuntu with many dependencies?

We have coded an application with many dependencies. Right now, we can use a makefile to compile source code. What we want to do next is create an executable application (we don't want to release our ...
1
vote
1answer
32 views

What is the minimal set of packages required to transform a LaTeX file to a PDF?

I have a plain LaTeX file which I want to compile to a PDF. I see that people suggest texlive-full for this task. At the same time, it weights ridiculous amount of memory. $ apt-get install texlive-...
0
votes
0answers
53 views

Installing NVIDIA drivers appears to be inconsistent [duplicate]

Following the instructions here, I am attempting to install some specific NVIDIA drivers on Ubuntu 18.04. I am doing this as the first thing after a fresh installation of Ubuntu, such that there are ...
1
vote
0answers
95 views

Problem installing clang-7 on ubuntu 19.04

I am trying to install CARLA on ubuntu 19.04, but it requires clang-7 package. I tried to install clang-7 with sudo apt install clang-7 But I got the error: Reading package lists... Done Building ...
3
votes
2answers
82 views

Understanding differences between “apt install” and “dpkg -i” [duplicate]

I'm a beginner with Ubuntu, trying to understand how package management works, and I have a few questions. This has occurred whilst I have been trying to install CUDA on my machine, so I will use CUDA ...
1
vote
0answers
103 views

Installing distutils dependency for python3 on Ubuntu 18.04

I tried to install distutils and here's what i got this problem: The following packages have unmet dependencies: python3-distutils : Depends: python3 (>= 3.6.8-1~) but 3.6.7-1~18.04 is to be ...
0
votes
0answers
68 views

Error processing package sane-utils (--configure)

I'm trying to run the command "sudo apt upgrade" and I see this error which is not allowing me to install ubuntu-desktop on my CLI based server. Is there any way that I can fix this issue or please ...
0
votes
1answer
47 views

Can't install libdb4.8 and libdb4.8+++ on Ubuntu 19.04

Recently I reinstalled my system (Kubuntu 19.04) but I can't install those two libraries (I have the same system on my laptop and there's no issue there). The error message: Package libdb4.8-dev is ...
0
votes
1answer
95 views

Can not run updates on Bionic 18.04

So I had a problem with Xenial and thought it would be solved when I upgrade to Bionic but I still have the issue. After doing a fresh install of Bionic, I tried to update everything using the '...
-1
votes
1answer
33 views

What is meant by “new packages” in apt upgrade?

The documentation for apt upgrade says: upgrade is used to install available upgrades of all packages currently installed on the system from the sources configured via sources.list(5). New ...
3
votes
3answers
1k views

Attempting to remove a package complains about unmet dependencies

On Ubuntu 18.04, I am having some problems with my installation of CUDA, so I would like to uninstall CUDA and start from scratch. So, I tried the following: sudo apt remove cuda But this then ...
0
votes
1answer
105 views

How to repair broken package dependencies

I have a remote Ubuntu server. When I'm running apt install -f I'm getting this message: sudo apt install -f Reading package lists ... Done ...... The following packages were installed automatically ...
0
votes
0answers
226 views

sudo apt-get update is not working

I am using ubuntu 18.04 and when I try the apt-get update command I get: Hit:1 https://repo.skype.com/deb stable InRelease Hit:2 http://ppa.launchpad.net/jonathonf/mate-1.22/ubuntu bionic InRelease ...
0
votes
1answer
88 views

sudo apt-get upgrade returns an error [duplicate]

I am running Ubuntu 18.04 and every time I run sudo apt-get upgrade, I get this error: dpkg-deb: error: tar subprocess returned error exit status 1 dpkg: error processing archive /var/cache/apt/...
0
votes
0answers
51 views

I deleted tar and dpkg by mistake: Please Help

Due to some tutorial that I followed wrongly, I am receiving this error when I try sudo apt-get upgrade. Please help. dpkg: warning: 'tar' not found in PATH or not executable dpkg: error: 1 expected ...
0
votes
0answers
118 views

“failed to fetch” error while installing Apache2 on Ubuntu 18.04

I am trying to install Apache2 on the Ubuntu Container(based on this official Docker Image). The container runs on Ubuntu 18.04. On running apt install apache2, I get the following error. E: Failed ...
0
votes
1answer
22 views

List unmet dependencies

How to show unmet dependencies for some .deb package (e.g. other packages that are needed but not installed or too old) without installing it?
0
votes
1answer
63 views

Getting error in apt-get autoremove. How can I remove it?

I got the following error message when trying to run sudo apt-get autoremove : $ sudo apt-get autoremove Reading package lists... Done Building dependency tree Reading state information... ...
0
votes
0answers
25 views

Is there any significant benefit of using UMAKE if the user has time to install software from the deb package?

A lot of devs recommend umake to install IDE's over snap, flatpak, etc. But what if a user decides not to choose snap or flatpak and choose tar or deb package to install over umake, is that a dumb ...
1
vote
1answer
117 views

How can I resolve package dependency conflict?

When I enter the command: sudo apt install libstdc++6:i386 I get the output: The following packages have unmet dependencies: libstdc++6 : Breaks: libstdc++6:i386 (!= 8.2.0-1ubuntu2~18.04) but 8-...
0
votes
0answers
30 views

How to Install G++ Compiler The Correct way? [duplicate]

When I try to install it with the commands: sudo apt-get install g++ or sudo apt-get install build-essential It shows me an error: Reading package lists... Done Building dependency tree ...
1
vote
1answer
56 views

Dependencies are not installable

I'm trying to install splash 0.7.12 as instructed in the wiki, but keep getting this error: The following packages have unmet dependencies: splash-mapper : Depends: libgsl2 but it is not installable ...
0
votes
0answers
14 views

Determing Missing Compiler / Files

I am very new to Linux. My question is this : I have installed CodeBlocks IDE, and tried to compile a simple "Hello World" program to no avail. After researching and looking at the output errors in ...
0
votes
0answers
18 views

When I run the updater is says there is a package open [duplicate]

When I want to do an update I get a message: Unable to get exclusive lock This usually means that another package management application (like apt-get or aptitude) already running. Please close that ...
0
votes
0answers
112 views

How to connect to ubuntu repositories from ubuntu server 18.04.3 lts in Vbox

There was a problem connecting to the repositories with ubuntu. Both systems (host (Ubuntu 18.04.3 LTS)) and the virtual machine with the ubuntu-server 18.04.3 cannot connect to the repositories. ...
1
vote
1answer
57 views

Broken package can't be removed without installing it, which I can't do

I have a problem with my system. I want to get rid of some packages to free up some space, because I am running an Ubuntu chroot with crouton on a Chromebook with only 64GB of storage, almost all of ...
1
vote
1answer
60 views

How to fix broken kernel that was partially removed

So I'm a super noob with Ubuntu and I was running out of disk space in Ubuntu 18.04. In order to clean the system, I tried to remove old system kernels with: sudo apt-get remove linux-image-VERSION ...
1
vote
0answers
177 views

Apt/Package Errors after dist-upgrade

Ran apt-get dist-upgrade and continue to get the below error when attempting to run anything else. Included the current packages below as well. Any help is appreciated. # apt-get install -f Reading ...
0
votes
0answers
33 views

Can't use packages that installed using pip

Previously, I had not any issues with installing packages like speedtest-cli or youtube-dl using pip (pip3 install speetest-cli or pip3 install youtube-dl) then using them from the terminal (speedtest-...
0
votes
1answer
57 views

Is concurrent execution of “sudo apt-get install”, “sudo snap install”, and “pip install --user ” recommended?

To improve installation efficiency, I am thinking of conducting concurrent package installations when I have to use commands sudo apt-get install, sudo snap install and pip install --user in a script....
0
votes
0answers
19 views

how to fix snapd error?

Error code below: dpkg: error processing package snapd (--configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration Errors were encountered ...