Podcast #128: We chat with Kent C Dodds about why he loves React and discuss what life was like in the dark days before Git. Listen now.

Questions tagged [package-management]

Questions about the management of software packages, in particular the APT and dpkg systems.

Filter by
Sorted by
Tagged with
2
votes
2answers
416 views

Can't install MyPaint on 18.10 from usual repository (not flatpak or snap)

After I installed 18.10 (when it was beta) and started to install all software I got this problem with MyPaint. Today this problem still persists. Universe repository is enabled. I was able to install ...
0
votes
0answers
11 views

timedatectl: Failed to create bus connection: No such file or directory

The scenario: I'm trying to set timezone on a docker container based on Ubuntu 18.04 docker image. Just pull the image, updated, and installed systemd > apt-get -y update > apt-get -y install ...
0
votes
1answer
16 views

timedatectl: command not found

The scenario: I'm trying to set timezone on a docker container based on Ubuntu 18.04 docker image. Just pull the image and updated > apt-get -y update The error: When run > timedatectl I ...
0
votes
1answer
22 views

software-properties-gtk crashes on startup (19.10)

I am currently using Ubuntu 19.10 and trying to open 'additional drivers' results in the program crashing. When I start it from the terminal, I get the following traceback: philip@philip-hp-pavilion:/...
0
votes
0answers
21 views

Why some package are not installed

Im trying to make a docker image using ubuntu as base image so, Im running FROM ubuntu:latest ENV DEBIAN_FRONTEND noninteractive COPY root / RUN apt-get update \ && apt-get install -y ...
1
vote
0answers
24 views

Cannot install texlive-full, kpsewhich frozen on 18.04

I'm trying to install texlive-full on Ubuntu 18.04.3 LTS with this command: apt install texlive-full All required packages are downloaded. When it starts to setup the packages, it starts the ...
-1
votes
1answer
98 views

Fallo al obtener http://co.archive.ubuntu.com/ubuntu/dists/bionic-backports/InRelease

There's an error in http://co.archive.ubuntu.com/ubuntu/dists/bionic-backports/InRelease... wolfi3@Hp-G42:~$ sudo apt update [sudo] password for wolfi3: Hit:1 http://packages.elementary.io/...
0
votes
1answer
48 views

Having problem with package manager Ubuntu 18.04.3 LTS

When I am trying to install any new package, I am getting this: (Reading database ... 170573 files and directories currently installed.) Removing linux-image-4.15.0-29-generic (4.15.0-29.31) ... /etc/...
-1
votes
1answer
45 views

APT is not working at all: “E: The value 'jessie' is invalid for APT::Default-Release as such a release is not available in the sources”

I'm trying to do run the command sudo apt-get install ssh, but when I do I get this error. $ sudo apt-get install ssh Reading package lists... Done E: The value 'jessie' is invalid for APT::Default-...
0
votes
0answers
6 views

How to create a local repo using apt-mirror without a server

I know that this question has been repeated so many times before, but I'm at a loss of what to do with my mirrored repo. I've mirror archive.ubuntu using apt-mirror and now I want to point apt to the ...
0
votes
0answers
18 views

Uninstall package vs. Purge package [duplicate]

What is the difference between uninstalling and purging a package? As I understand it, purging a package also removes all the configuration data. Then, my question, why would I remove a package but ...
0
votes
0answers
11 views

Something about Packages

I do not have very good experience with Linux systems. But sometimes I need work with Ubuntu Bionic 18.04. Yesterday, I was trying download my data from connected server with ssh. But there was error. ...
-1
votes
0answers
18 views

How can I delete this package mysql-server-5.7

dpkg -s mysql-server-5.7 Package: mysql-server-5.7 Status: install ok half-configured Priority: optional Section: database Installed-Size: 46369 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@...
1
vote
0answers
34 views

I cannot remove mysql-server-5.7

I am trying to remove mysql with the following commands: sudo apt purge mysql-* sudo apt autoremove and got these errors: dpkg: error processing package mysql-server-5.7 (--remove): installed ...
3
votes
1answer
3k views

Error encountered when using dpkg to install packages (--configured)

I used sudo aptitude update and sudo aptitude upgrade to update the packages, and encountered an error when processing the package man-db (with --configure). A few days later, same error occured with ...
0
votes
0answers
21 views

Failure to update due to unmet dependencies [duplicate]

Attempting to update I am encountering unmet dependencies errors(below) Running sudo apt-get install -f leads me to a pipe error(second snippet). Is there something I'm Missing? `libglvnd-dev: ...
0
votes
0answers
19 views

What I'd this on my phone It says warning linker: [on hold]

uid=10243(u0_a243) gid=10243(u0_a243) groups=10243(u0_a243),3003(inet),9997(everybody),50243(all_a243) context=u:r:untrusted_app:s0:c512,c768 java.lang.SecurityException: Permission Denial: Do not ...
-1
votes
0answers
66 views

MPICH installed in /usr/bin - how do I follow these instructions to adjust PATH to run MPICH?

I have installed the Ubuntu 18.04 pre-compiled package for mpich 3.3~a2-4. It has placed mpichexe in /usr/bin, as expected with Ubuntu packages. So, according to MPICH.org Argonne User’s Guide (3.3....
0
votes
0answers
5 views

i'm trying to install odoo 12 on ubuntu 18.04 and i'm facing issue about npm so i want to remove node completley , but i'm facing errors

i'm facing issues about npm while installing odoo12 "The following packages have unmet dependencies: npm : Depends: nodejs but it is not going to be installed" so i'm trying to remove existing node ...
2
votes
1answer
6k views

Dependency issue on installing gstreamer on Ubuntu 18.04 [duplicate]

I recently upgraded to Ubuntu 18.04 and the DVD player stopped working. After some research I was trying to reinstall gstreamer but I ran into an issue that seems related to Ubuntu 18.04 and that is ...
0
votes
0answers
55 views

dpkg: dependency problems prevent configuration of libisccc160:amd64:

dpkg: dependency problems prevent configuration of libisccc160:amd64: libisccc160:amd64 depends on libisc169 (= 1:9.11.3+dfsg-1ubuntu1.10); however: Package libisc169:amd64 is not configured yet. ...
5
votes
5answers
5k views

Redmine 3.2.3-1 is half installed. Can neither be reinstalled nor removed

When I installed Redmine I had a problem in the middle of the database configuration. I think I ctrl C'ed in the middle of it because I tried to switch to Mysql after starting with sqlite3. Since then ...
1
vote
1answer
128 views

Software Update problem libplacebo18 on ubuntu 18.04

This has been since the last update message I can't install any other programs because of this error, please help. If you are using third party repositories then disable them, since they are a ...
0
votes
0answers
12 views

Can't install gtk-3-dev: unable to correct problems, you have held broken packages [duplicate]

I'm on Ubuntu 19.04 and have been trying to install libgtk-3-dev, but getting the following error: ~/Downloads/Software $ sudo apt install libgtk-3-dev Reading package lists... Done Building ...
0
votes
2answers
4k views

Unmet dependencies issue with Python

Running sudo dpkg --configure -a produces Errors were encountered while processing: python-pil python-imaging-tk python-imaging python-pil.imagetk python-setuptools and running sudo apt-get -u ...
1033
votes
24answers
3.3m views

Unable to lock the administration directory (/var/lib/dpkg/) is another process using it?

I get this error when trying to use apt-get: E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/) is ...
0
votes
3answers
2k views

Apt unmet dependencies while installing R on Ubuntu 16.04

I wanted to install the new R version so I did a purge by removing all r-*. And then I broke everything unfortunately. I try to reinstall R project by typing sudo apt install r-base r-base-core r-...
-1
votes
0answers
40 views

Not able to solve the issue of system updates : Ubuntu 16.04 [ A problem occurred when checking for updates ]

I have already tried this : sudo apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following ...
1
vote
2answers
160 views

DPKG error, conflict while installing packages

Keep trying to install things, but the console will spit out (apt --fix-broken install was when I tried to fix it): apt --fix-broken install Reading package lists... Done Building dependency tree ...
0
votes
0answers
50 views

Cannot install apache2 due to dependency issues

I am running Ubuntu 19.04. How do I install apache2-bin and apache2-utils? I thought sudo apt-get install apache2 would install everything I need. The following packages have unmet dependencies: ...
2
votes
0answers
326 views

Cannot install xorgxrdp due to dependency issues

I am following a video on xRDP from windows RDP and I needed to install xorgxrdp. When I try that I am told there are some dependency issues such as below: The following packages have unmet ...
1
vote
0answers
44 views

multiple errors when run apt-get update [duplicate]

When I run sudo apt-get update on Ubuntu 16.04 , I got the following Segmentation fault (core dumped) Reading package lists... Error! W: The repository 'https://repo.skype.com/deb stable Release' ...
0
votes
1answer
433 views

Installing java

When I am installing java I am getting this problem how can I resolve it? Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
0
votes
0answers
23 views

Why am I seeing PackageKit Daemon has crashed after update to Ubuntu

I installed updates to Ubuntu 18.04 with sudo apt-get update && sudo apt-get upgrade. Some of these updates required a restart. Upon restart, after GRUB, I should enter the corresponding ...
0
votes
1answer
1k views

dpkg: error: unable to create new file '/var/lib/dpkg/info/format-new': No such file or directory

When I try to sudo apt-get upgrade I get: Preconfiguring packages ... dpkg: error: unable to create new file '/var/lib/dpkg/info/format-new': No such file or directory E: Sub-process /usr/bin/dpkg ...
0
votes
2answers
3k views

Multiple dpkg postinst script and other errors while upgrading Ubuntu 18.04

This is the apt-get upgrade output: Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages have been kept ...
3
votes
2answers
55 views

Does apt-cache policy <package_name> require sudo?

Can't find any formal explanation to determine whether apt-cache policy <package_name> command requires sudo or not. Tested it in my machine (Ubuntu) with lots of packages and seems to work, ...
0
votes
1answer
3k views

Package 'openbsd-inetd' has no installation candidate

When I try to install openbsd-inetd, it shows root@amsys-G41MT-S2PT:/home/amsys# sudo apt-get install openbsd-inetd Reading package lists... Done Building dependency tree Reading state ...
0
votes
1answer
42 views

RabbitMQ - Packages have unmet dependencies [duplicate]

i am following this steps to install rabbitmq on ubuntu 16 echo "deb http://www.rabbitmq.com/debian/ testing main" | sudo tee /etc/apt/sources.list.d/rabbitmq.list > /dev/null wget https://www....
1
vote
2answers
307 views

Why apt package chromium-browser installs snap package instead?

When I do apt-get install chromium-browser it downloads some .deb file, and then installs a snap package: Selecting previously unselected package chromium-browser. (Reading database ... 227048 ...
0
votes
0answers
26 views

I tried installing google calendar, now I cannot use apt-get install, exit code 126 [closed]

So I was trying to install this thing and its dependencies (using apt-get and pip for the python stuff)(not sure if important) and I found out, that I couldn't install anything. Now when I try to ...
0
votes
0answers
16 views

Unable to uninstall freeradius

Firstly I install freeradius using this command : apt-get install freeradius but I don't know, maybe it didn't get installed properly because there is no such directory /etc/freeradius so I tried to ...
2
votes
2answers
3k views

Kolab groupware(Mail Server) fails to install because of dependency problems

I need some help. I'm trying to setup a kolab sever to be used by computer science students at my college, starting this fall. I had a bit of some trouble setting up ldap, bur after some experimenting ...
0
votes
0answers
53 views

Will anything happen to Ubuntu if I uninstall Python? [duplicate]

Will anything happen to Ubuntu if I uninstall Python from my Ubuntu machine? I want to run minimal software in the OS. OS installed: Ubuntu 16.04.6 LTS (GNU/Linux 4.4.0-131-generic x86_64) ...
2
votes
3answers
9k views

dpkg: error: cannot scan updates directory `/var/lib/dpkg/updates/'

I want to install a package in Ubuntu 14.04, but every time I run the ./configure command it gives me this error: E: Cannot get debconf version. Is debconf installed? debconf: apt-extracttemplates ...
0
votes
1answer
5k views

Package system is broken, multiple errors, dpkg cannot process libc6

This is what Update Manager pops up with: The following packages have unmet dependencies: libc6: Depends: libc-bin (= 2.15-0ubuntu10.4) but 2.15-0ubuntu10.4 is installed Depends: libgcc1 but ...
0
votes
1answer
3k views

Errors while processing: tomcat7

I get following errors when I try to install any software or reinstall tomcat7: Job for tomcat7.service failed because the control process exited with error code. See "systemctl status tomcat7....
9
votes
6answers
4k views

apt-get autoremove dangerous?

I was compiling a tool called Rejoystick so I installed a few packages and dependencies. But now I don't need it any more so I removed those packages. Running apt-get shows that I have some packages ...
22
votes
1answer
377 views

Are Ubuntu packages security audited?

I'm unsure what the current procedure for package security for Ubuntu is. When something ends up in the Ubuntu package repositories, are the package audited by a central, trusted team and if so what ...
0
votes
0answers
386 views

Problems installing software (dpkg error “error processing package openjdk-11-jre-headless:amd64” ) on Ubuntu 18.04

When trying to install the program TestDisk on my Ubuntu machine via the terminal, with the command sudo apt-get install testdisk, everything looked normal at first, but then started giving me a bunch ...