Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
Join us in building a kind, collaborative learning community via our updated Code of Conduct.

Questions tagged [package-management]

Questions about the management of software packages, in particular the APT and dpkg systems.

0
votes
0answers
17 views

apt update showing error in Ubuntu 18.04

When I am running sudo apt update the following errors are being displayed. $ sudo apt update [sudo] password for milan: apt: error while loading shared libraries: libapt-pkg.so.4.12: cannot ...
0
votes
0answers
6 views

Create snap of proprietary .deb plus ppa dependencies?

I have a proprietary program that runs on 16.04 with an additional ppa for qt5.6. It is the only app that holds me back from updating to 18.04, so my idea was to create a snap package including the ....
0
votes
0answers
11 views

repos.codelite.org errors appearing in sudo apt update, but codelite not installed

When running sudo apt update, I always get errors such as the following: W: GPG error: http://repos.codelite.org/wx3.1.0/ubuntu artful InRelease: The following signatures couldn't be verified ...
-3
votes
0answers
58 views

Upgrade Ubuntu from 16.04 to 18.04 causing unable to use gnome and other problems 08/14/2018 [on hold]

On 08/14/2018, my ubuntu recommended me to upgrade from 16.04 to 18.04. The upgrade went on horribly wrong. In the middle of the installation, it tells me it encounters failure and your ubuntu will ...
0
votes
0answers
9 views

apt-get wants an older GNUTLS version to be defined

Just upgraded to 18.04, and when I run sudo apt update, it complains: /usr/lib/x86_64-linux-gnu/gio/modules/libgiognutls.so: symbol gnutls_pkcs11_privkey_init version GNUTLS_3_4 not defined in file ...
1
vote
0answers
19 views

how to remove packages with unmet dependencies

I'm using Ubuntu 18.04. Some months ago I tried to install nvdia drivers, but I couldn't, the installation didn't complete properly, and apt-get get broken. Since I had to finish somework, I keep this ...
0
votes
0answers
16 views

Problems with installing ranger and acctually any other package

Im trying to install the ranger filemanager: scorewinner@fegserver:~$ ranger Command 'ranger' not found, but can be installed with: sudo apt install ranger But when i try to install it with apt ...
0
votes
0answers
25 views

Cannot sudo apt-get update and install postgresql? [duplicate]

I got an error when I tried to update sudo apt-get update as below: Err:1 http://apt.postgresql.org/pub/repos/apt xenial-pgdg InRelease Temporary failure resolving 'apt.postgresql.org' Err:2 http://...
0
votes
0answers
26 views

/usr/bin/pg no longer present in 18.04 util-linux package

I just upgraded from 16.04 to 18.04. The /usr/bin/pg command was present in 16.04, in the util-linux (2.27.1) package. /usr/bin/pg is not present in 18.04, and not in util-linux (2.31.1.0) package. ...
0
votes
0answers
7 views

Unable to locate package python3.4-venv [duplicate]

I have a fresh install of Ubuntu 18.04.1, and am trying to install python3-venv. I have tried all of the following: sudo apt install python3-venv sudo apt install python3.4-venv sudo apt-get install ...
0
votes
0answers
28 views

Each time I try to get Software it doesn't locate package [duplicate]

On my ubuntu server 18.4 im using sudo apt-get install links2 and this loads and it says Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate ...
0
votes
0answers
14 views

How to remove illegal apt sources [duplicate]

My system is Ubuntu 16.04.3 on an arm64 machine. I share this system with my colleagues. Now someone must do some change because when I execute sudo apt update, I always get the error as below: E: ...
1
vote
0answers
11 views

Audit when installed packages were last used

I am trying to audit package bloat in my Ubuntu container infrastructure which operates as follows: Base container links in all dependencies. This is done to ensure versions of dependencies are ...
0
votes
0answers
36 views

Python errors when try to install [on hold]

I have search a couple of days to solve some errors with python. Whatever I want to do in my terminal , I get these errors. Something should not be config right? pi@keuken:~ $ sudo dpkg --configure -...
0
votes
1answer
15 views

PHP Version Looks Wrong

Despite not installing php5.4, it seems to be the version. Now, Although I delete all php packages on the computer, it still looks the same(5.4). sudo apt-get purge 'php*' sudo apt-get purge php.* ...
0
votes
1answer
17 views

Major problem with libxcursor1:amd64 [duplicate]

I am running Ubuntu 16.04 and have a problem with libxcursor1:amd64 which is causing everything to run really slow and not allow packages to be updated. I have tried apt-get -f install to fix things ...
0
votes
1answer
50 views

Packages broken & apt does not work after aborted Ubuntu upgrade to 16.04 LTS (from 14)

I attempted to upgrade Ubuntu 14 to 16 LTS using sudo do-release-upgrade and everything is broken. The installation is not completed. The logs say it was aborted. When I use apt or apt-get the ...
2
votes
0answers
29 views

Standard package missing [duplicate]

I am trying to install httpie: » sudo apt update Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease Hit:2 http://archive.ubuntu.com/ubuntu bionic-security InRelease Hit:3 http://archive.ubuntu....
0
votes
0answers
44 views

How do I install gcc-5.4 along side gcc-5.5? (Neither of these packages exist)

I'm on 18.04, and need to compile some custom Tensorflow Ops. I need gcc-5.4 specifically because gcc-5.5 breaks things. However, as far as package naming goes, there is only officially "gcc-5". Is ...
1
vote
1answer
36 views

how to install Xscreensaver?

i've been trying to install this all morning, but i get this error. i don't know hoow to solve it... Im on ubuntu 18.04
2
votes
1answer
27 views

Is my offline local repository broken?

I have created a offline local repository with apt-mirror. I followed the instructions here: tecmint.com/setup-local-repositories-in-ubuntu. After I finished modifying /etc/apt/sources.list, I ran ...
1
vote
1answer
31 views

Where does apt store downloaded packages? [duplicate]

I know that apt-get ( as in sudo apt-get install vim) stores downloaded packages in /var/cache/apt/archives. However, when using apt (as in sudo apt install vim) instead, there are no packages stored ...
0
votes
0answers
20 views

Install app from the repository of a different version

Need mlterm 3.8.4-1 installed on a Lubuntu 16.04, which can only see version 3.5.0-1 of mlterm from the repository of Xenial Xerux. Is there any way to (say) target the repository of Bionic Beaver ...
0
votes
0answers
16 views

Dependency resolution problem in apt-get

Using Ubuntu 16.04 Listing available apache2 versions: root@ubuntu-xenial:~# apt-cache show apache2 | grep Version Version: 2.4.18-2ubuntu3.9 Version: 2.4.18-2ubuntu3.8 Version: 2.4.18-2ubuntu3 It ...
1
vote
1answer
35 views

Can't download xlock into Ubuntu 18.04

I have been trying to install xlock using the command sudo apt-get install xlock It outputs this instead of installing xlock: Reading package lists... Done Building dependency tree Reading ...
0
votes
0answers
18 views

game removal failure [on hold]

I'm running 17.10 and loaded a few Games for my grandchildren. When I tried to remove the program went through removal but didn't remove just came back to the removal launch screen. Never had an issue ...
1
vote
1answer
75 views

Upgrade to 18.04, now sudo apt-get upgrade produces loads of insserv errors as irqbalance is not configured

I've upgraded a virtual server (running on vmware) to 18.04 and now I get a lot of errors when I do sudo apt-get upgrade Ubuntu 18.04.1 LTS (GNU/Linux 4.15.0-29-generic x86_64) $ sudo apt-get ...
0
votes
0answers
39 views

18.04.1 Server keeps creating /var/lib/dpkg/lock and /var/cache/apt/archives/lock. What now?

I'm working with a fresh install of 18.04.1 from which I have removed certain packages that communicate asynchronously with other hosts, having pinned them, along with certain other packages, for non-...
0
votes
1answer
66 views

Failed to lock /var/cache/apt/archives/lock

I was trying to upgrade from Ubuntu 16.04 to Ubuntu 18.04 and ran into the following error: Failed to lock /var/cache/apt/archives/lock I searched google/askubuntu/ubuntu subreddits for any ...
1
vote
0answers
20 views

Can't update or remove ruby-net-telnet

Running Ubuntu 16.04. All other packages update fine but attempting to update or remove ruby-net-telnet returns errors Preparing to unpack .../ruby-net-telnet_0.1.1-2_all.deb ... Unpacking ruby-net-...
3
votes
0answers
99 views

Bionic Default Repositories do not have release file - sudo apt-get update not working [closed]

I am facing an issue with apt : sudo apt-get update won't successfully complete on my Ubuntu 18.04 Desktop. First I'd like to specify that the subject Xenial repository does not have a release file ...
0
votes
1answer
35 views

how to fix Snapd dpkg error?

when i make sudo apt-get update && sudo apt-get upgrade this early morning for my new kernel 4.4.0-131-generic. i get my snapd error. Setting up snapd (2.34.2~14.04) ... Failed to enable ...
1
vote
1answer
35 views

Solutions for risks when using external repository

This is a list of risks when using external repositories I found. Quality: Conflict between packages from external repositories and stable packages in system. Conflict between external repositories ...
2
votes
2answers
70 views

When *.pyc files (related to their deb-packages) are created and how to recreate them?

I have two Ubuntu 18.04.1 LTS systems: clean installation of Ubuntu 18.04.1 LTS upgraded from Ubuntu 16.04.5 LTS Note: All things in the both systems have been installed using APT (from deb-...
0
votes
0answers
13 views

How do I notify package maintainers that there's a new version of ghostscript that needs updating? [duplicate]

The current version of ghostscript in bionic is 9.22 but it has a major bug with rendering embedded fonts. This is fixed in 9.23. 9.22 is dated 2017-10-04 and 9.23 is dated 2018-03-21 so it's been ...
0
votes
0answers
30 views

How can I install both curl (depending on libcurl4) and mongodb (depending on libcurl3)?

On Lubuntu 18.04, I have installed mongodb, by following https://docs.mongodb.com/manual/tutorial/install-mongodb-on-ubuntu/#install-mongodb-community-edition sudo apt install -y mongodb-org mongodb-...
0
votes
0answers
36 views

Create offline repository with apt-mirror

I'm trying to create an offline repository for ubuntu version 16.04. I found instructions for this in multiple places, but much of it is dated, and none fully worked for me. Here is what I've done ...
1
vote
0answers
20 views

how to install conky manager package

I can't get download conky manager package... It's forbidden for me.. I tried to download and remove later but conky window can't remove... I can't remove this part from my screen by uninstalling
0
votes
0answers
20 views

Trying to Backup System with broken Package manager

I attempted to update Ubuntu from 14.04 to 16.06 and it doesn't look like it completed successfully. The problems I am facing now can be asked/answered in other posts but I want to back everything up ...
0
votes
1answer
56 views

E: Unable to locate package screen

I am aware that if one googles the error above, then he would get tons of results. However, after trying many of the proposed solutions, and after working on this error for about a week in full-time, ...
1
vote
2answers
46 views

Do package managers exist for AppImages?

Using APT it is possible to install applications and keep them up-to-date. APT is only available in Debian based systems. The same can be said about, for example, RPM for Red Hat. Because there are ...
0
votes
0answers
18 views

apt installation help - osmium-tool

I am trying to install osmium version 1.7.1 or 1.8 on my local machine but apt-get install wget osmium-tool -y installs a very old version of the package. Going through the webpage here it looks like ...
1
vote
1answer
32 views

VLC Unmet dependencies

I upgrade from LTS 16.04 to 18.04 from software updater VLC has been removed and now installing VLC giving the following errors The following packages have unmet dependencies: vlc : Depends: ...
0
votes
1answer
48 views

How to resolve broken packages after upgrading to Ubuntu 16.04

I recently upgraded from Ubuntu Server 14.04 to 16.04, the upgrade process was interrupted in the last step, after that I cannot use apt to install any software because of broken packages also the ...
0
votes
0answers
99 views

Upgrade gcc (4:7.3.0-3ubuntu2) to gcc-8 (8.2.0) in ubuntu 18.04

Has recently upgraded my ubuntu from 16.04 to 18.04.1 LTS. When trying to run vmware I am getting this message: gcc version 8.2.0 not found so I checked gcc v. and I found: (Ubuntu 7.3.0-16ubuntu3). I ...
0
votes
0answers
12 views

Grace Installation [duplicate]

I want to install grace plotting tool in Ubuntu 18.04.1. When I ran sudo apt-get install grace, I got the following error message. The following NEW packages will be installed: grace 0 to upgrade,...
3
votes
2answers
63 views

Ubuntu LTS stability

tl;dr: Does Ubuntu LTS update libraries to versions where API elements may be changed/removed? Due to Debian stable's lack of patching their kernels to support new hardware, I've run into problems ...
0
votes
1answer
62 views

dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)

On Ubuntu 18.04 I am getting this when I want to install the recommended Nvidia driver. sudo apt install nvidia-340 Reading package lists... Done Building dependency tree Reading state ...
1
vote
1answer
66 views

Zoneminder unmet dependencies

Im trying to install zoneminder on ubuntu 16.04 server and I get this unmet dependencies error. How can I correct this? root@tpadzm:/home/joey# apt-get install zoneminder Reading package lists... ...
2
votes
2answers
226 views

Package php7.2-mbstring unmet dependencies in Ubuntu 18.04

Try to install php-mbstring for mediawiki setup. already added after first attempt universe repository: Package php7.2-mbstring missing in Ubuntu 18.04 But gives me hard time Here details: ...