Questions tagged [opengl]

Questions about OpenGL, a library for rendering 2D and 3D graphics

Filter by
Sorted by
Tagged with
0
votes
0answers
20 views

How can I check my nvidia opengl library is working or not from terminal in ubuntu 16.04?

I installed nvidia in ubuntu 16.04, currently the os uses GPU graphcis (which I checked in system settings>details) However, I would like to confirm about nvidia opengl library is working or not? ...
0
votes
0answers
13 views

visualize 3d mesh: moderngl.create_standalone_context () error

I tried to visualize 3D mesh using the package moderngl, but i found a bug in the function moderngl.create_standalone_context () i can't resolve it. you can see more details in the attached image. if ...
1
vote
0answers
19 views

Problem with Installing Opengl

I entered sudo apt-get install freeglut3-dev it said enter sudo dpkg --configure -a When I did that in terminal it showed me
0
votes
1answer
109 views

Enabling OpenGL in Windows 10 Guest VM in QEMU

I'm trying to install Sketchup 2019 on a Windows 10 VM (Ubuntu 18.04, QEMU 3.1.0), however Sketchup requires OpenGL 3.1 or later in order to run. I had asked a similar question previously hoping by ...
0
votes
0answers
44 views

After installing mesa-20-0-06 from kisak's ppa, glxinfo still shows mesa-19.3.5 and OpenGL 2.1 instead of 3.x (lubuntu 18.04.4 LTS on i965 Laptop) [closed]

Well, I think the title already says it. What dependencies could still lack? Do I have to compile new drivers for other than i965 ? Because I already did, but it didn't help.
0
votes
0answers
36 views

How to force Ubuntu 18.04 to use openGL 3.2+ not openGL 3.1

I have already done this... "1. Open terminal either via Ctrl+Alt+T or by searching for ‘Terminal’ from software launcher. When it opens, run command: sudo add-apt-repository ppa:ubuntu-x-swat/...
1
vote
0answers
27 views

How can I open my compiled OpenGL application with a double click?

I have written a custom OpenGL application. I can launch it from terminal with ./basic_cube but when I double click on it from within a file browser, I get the following error: How can I launch this ...
0
votes
0answers
76 views

Wine issue with OpenGL

I am trying to run some windows applications with Wine. However I get the same error all the times. Initially I thought it was an error related to the specific application I was trying to run, but I ...
1
vote
1answer
104 views

Clutter Performance Issue with 965gm GPU

I am currently using Ubuntu 16.04 and when I look my system details my gpu is named as Intel® 965GM but if I install Ubuntu 20.04 it is named as Intel® 965GM (CL). System ui and google chrome is ...
0
votes
0answers
66 views

Pycharm project cannot load Radeon drivers

When I try to run a project (qudi) in pycharm, I get the following errors: libGL error: MESA-LOADER: failed to open radeonsi (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri) ...
0
votes
0answers
52 views

Software rendering is used instead of Nvidia GPU (1060) on Ubuntu 18.04

I have issues with Nvidia 1060 GTX not being used by the OS. This has started after a recent regular update. Os Ubuntu 18.04.4. I don't use any sort of VM. This is my desktop. I would really ...
0
votes
0answers
74 views

Do i Have OpenGL 3.3 or 3.1?

iam trying to run a program which requires OpenGl 3.3 (which is Blender) but it doesn't work. And When i Run glxinfo | grep 'version' i get the Following. server glx version string: 1.4 client glx ...
0
votes
0answers
85 views

is possible get VNC remote server working with KDE/plasma?

I'm trying to get running a multiuser remote desktop Quarantine Mode, every session running their own instances of kde. At this moment I have configured lightDM with the VNC server running. I can get ...
0
votes
0answers
8 views

Dota not working after Open gl

I recently installed OpenGL and glut for c++ and they are working fine. But when I play my Dota 2, I can't hear any voice and can't find matches(in the queue forever). Is it problem with open gl?
0
votes
0answers
41 views

Qt5.4: libQt5.4OpenGL.so.5.4.2 error adding symbols: File in wrong format

I am building a cpp based codebase (COLMAP: https://github.com/colmap/colmap) using cmake build system. When I run the make command, I get the following error: Qt/5.4/gcc/lib/libQt5OpenGL.so.5.4.2: ...
0
votes
0answers
45 views

Cairo can not find OpenGL ES 2.0 headers on Ubuntu 18.04

I am trying to compile Cairo 1.16.0, but it fails, giving me the following errors: checking for cairo's OpenGLESv2 surface backend feature... checking for glesv2... no checking GLES2/gl2.h ...
0
votes
1answer
20 views

Rendering of games is messed up when alt+tabbing back into them

I can alt+tab out of a game (any game) to go back to the gnome desktop, but whenever I tab back into the game, the result is bad: the game is rendered and all input works, but the rendering takes ...
0
votes
0answers
117 views

Problem(s) with Scilab and Ubuntu 18.04

I try to use Scilab 6.0.1 (standard repos version) under Xubuntu 18.04.4 (with Ubuntu studio packages). There seems to be a problem (or a combination of problems). First, this bug https://bugs....
1
vote
0answers
47 views

How to update Nvidia driver safely in Ubuntu?

Problem Background: I'm facing problem in rendering 3D objects that is using Pyrender. Pyrender needs OpenGL (EGL or Mesa), all the Graphics files (GL, GLE and GLX) should be in usr/lib/nvidia or usr/...
0
votes
0answers
60 views

nvidia-smi works, but glxinfo show OpenGL uses Intel graphics card; Ubuntu 18.04

I want to play a game using the discrete graphics on my notebook. I don't care about the Intel graphic card - I just want to use exclusively NVidia. $ nvidia-smi Mon Mar 23 20:40:58 2020 +-----...
0
votes
1answer
134 views

32 bits apps don't work with nvidia 440 drivers

Since I updated to nvidia 440 drivers when I run 32 bits apps (including the Steam GUI) I get the following error: libGL error: No matching fbConfigs or visuals found libGL error: failed to load ...
0
votes
0answers
99 views

System Error: libGL.so.1: cannot open shared object file: No such file or directory - ogre-meshviewer

Ogre 1.11.6 $ locate libGL.so /usr/lib/x86_64-linux-gnu/libGL.so /usr/lib/x86_64-linux-gnu/mesa/libGL.so /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1.2.0 $ ...
1
vote
0answers
412 views

Trying to use latest Mesa breaks OpenGL on amdgpu in Ubuntu 19.10

I'm having an issue upgrading to the latest Mesa drivers (anything >= 19.3) from any external repository, in this case oibaf. In the past I did not have any issues doing this, but a couple of months ...
0
votes
0answers
71 views

My laptop is using secondary Intel GPU instead of Nvidia

Well, basically this is very weird I have Kubuntu 19.10 with 5.3.0-40-generic Kernel first GPU - NVIDIA GeForce 920MX second GPU - Intel HD Graphics 520 When i'm trying to launch Nvidia X settings ...
0
votes
0answers
715 views

Ubuntu 18.04 Install Mesa 19.3 Drivers

I am trying to install Mesa Drivers 19.3 on my Ubuntu 18.04 Distro for my Radeon RX 580 graphics card. I did run the following commands: sudo add-apt-repository ppa:kisak/kisak-mesa sudo apt-get dist-...
2
votes
1answer
70 views

Any recent updates to OpenGL?

I do engineering work in VariCAD. It offers three display options per object: "Shaded", "Transparent", and "Wireframe". This has worked extremely well until recently. Now, when I start the program, ...
4
votes
1answer
240 views

How to get the MuPDF OpenGL viewer on Ubuntu 18.04?

TLDR How do I install mupdf-gl on Ubuntu 18.04 (preferably without building from source)? I have recently started using MuPDF. I tried installing it in a desktop machine with Ubuntu 18.04.3. However,...
0
votes
0answers
387 views

Understanding glxinfo error

My env is Ubuntu 18.04, headless server. lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.3 LTS Release: 18.04 Codename: bionic If I connect via ...
0
votes
0answers
310 views

OpenGL version under Lubuntu 18.04(3.3) is lower then on Windows(4.1)

I'm posting today about an odd occurrence I've run into. So I have a machine that was running Windows 7 and I switched it over Lubuntu 18.04LTS. I've updated to the latest(? Apparently not... maybe ...
0
votes
0answers
131 views

VLC causing libGL errors after update (using PPA nvidia drivers)

When I run vlc, either from snap or the system version, I see these errors: libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast Error: couldn't find RGB GLX ...
0
votes
0answers
123 views

Switch OpenGL loader to NVidia

TL;DR I am trying to compile OpenGL code on a machine with NVidia 4.18 graphics driver and CUDA 10.1 installed. It is currently not linking with OpenGL like -lGL on the command line. End TL;DR I ...
1
vote
1answer
62 views

Enable GL_INTEL_performance_query on Intel HD 500?

I am trying to use the OpenGL extension: GL_INTEL_performance_query to read the Intel performance counters from an integrated Intel GPU (HD 500). This extension is supported on my hardware and also ...
0
votes
1answer
610 views

glxinfo | grep OpenGL not showing nvidia

I just installed Ubuntu 19.10, ran sudo apt-get update && sudo apt-get upgrade, already have nvidia drivers installed, but I don't know why when I run glxinfo | grep OpenGL it doesn't show ...
0
votes
0answers
310 views

Ubuntu 18.04 / Nvidia GeForce GTS 450 / 4k howto?

Does anyone know how to run an Nvidia GeForce GTS 450 in 4k mode under Ubuntu 18.04? Since today I own a 4k monitor, but Ubuntu lets me only show 1920x1080 pixels. By the way: Installing different ...
0
votes
0answers
622 views

libGL.so: undefined reference to `glapi_tls_Current'?

I am a newbie trying to build a C++ project on Ubuntu 18.04, which I used to be able to build without any issues before updating from Ubuntu 16.04. My machine has an NVIDIA GPU running with NVIDIA ...
0
votes
1answer
53 views

I can not install openGLUT on ubuntu 16.04

I am trying to install openGLUT. I have downloaded it from https://sourceforge.net/projects/openglut/files/development/OpenGLUT-0.6.3/ . When I 'make' the configuration 'Nothing to be done for '...
1
vote
0answers
190 views

Which is the right OpenGL version

I am trying to run a software that needs at least an OpenGL shading language version of 1.4. It works fine with I use my laptops Nvidia card but crashes with the intel gpu. I am trying to debug why ...
1
vote
0answers
55 views

Java AWT BorderLayout() can crash libGLX_mesa.so.0 in Ubuntu Linux ver 18.04.1 - how to fix?

I have a large Java application that includes many commands such as new JPanel(new BorderLayout()) this.setLayout(new BorderLayout()); but not all of them seem to cause the crashing. I can prevent ...
0
votes
0answers
36 views

Switching back and forth between nouveau and NVIDIA video driver broke the link to OpenGL

I have tried the NVIDIA video driver but I have some problem with graphics. Unfortunately when I switch back to nouveau video driver compilers and/or linkers can't find the OpenGL libraries any more. ...
3
votes
0answers
530 views

Ubuntu18.04 steam libGL error: No matching fbConfigs or visuals found and libGL error: failed to load driver: swrast

Probably the same problem as Steam: libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast but none of the solution there works for me. This happens after I ...
0
votes
1answer
1k views

Which package to install to get header file glad.h?

I am trying to compile this example https://learnopengl.com/Getting-started/Hello-Window: #include <glad/glad.h> #include <GLFW/glfw3.h> // ... I have installed libglfw3-dev but I am ...
4
votes
1answer
67 views

Black window when launching Spotify

So the client was working without any problems. Next day, I turn on my computer this error : [1014/192432.737169:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : ...
0
votes
0answers
2k views

Update OpenGL version to 4.6 in Ubuntu 18.04

I have problem related my nvidia driver in Ubuntu 18.04. Actually the problem occurred in computer server and I remote the computer server by using X2Go. My Computer Server using Ubuntu 18.04 And ...
0
votes
1answer
416 views

Unable to run Blender on Ubuntu 19.10

I'm trying to run blender on Ubuntu 19.10, but I receive the following error: a graphics card and driver with support for opengl 3.3 or higher is required So I tried glxinfo | grep "OpenGL" and ...
0
votes
1answer
2k views

How to repair OpenGL on Ubuntu 19.10?

My system has been upgraded 18.04 > 18.10 > 19.04 > 19.10. This problem started with the upgrade to 19.10. AnyDesk won't run, gives this error: GdkGLExt-WARNING **: 08:49:56.379: Window system doesn'...
0
votes
1answer
429 views

AnyDesk won't run on Ubuntu 19.10 [duplicate]

AnyDesk was running great for me on Ubuntu 19.04. Then I upgraded to 19.10, now it won't start. I installed from the anydesk repository and have version 5.4.0. I've uninstalled & reinstalled ...
2
votes
0answers
59 views

OpenGL not working on an old laptop

So yesterday I decided to do a minimal install on my T30 (the Thinkpad, not the tank) that has Mobility Radeon 7500 graphics and everything was pretty smooth besides the fact that any packages that ...
0
votes
1answer
481 views

Can't update OpenGL on Ubuntu 16.04

My GTX TItan X should support OpenGL 4.5: https://www.geforce.com/hardware/desktop-gpus/geforce-gtx-titan-x/specifications However, I fail to upgrade OpenGL beyond version 1.4 glxinfo | grep "OpenGL ...
0
votes
0answers
26 views

“lock to launcher” caused problem

I am using ubuntu 16.06 since I tried "lock to launcher" for MATLAB, the screen of MATLAB has become see through/transparent, applying unlock did not work thank you for your help
3
votes
1answer
1k views

OpenGL/GLSL 4.5 on Ubuntu 19.04, Intel Integrated Graphics

I can't seem to get OpenGL 4.5 support on Ubuntu 19.04 with Intel Integrated Graphics. Completely new to working with OpenGL and I'm trying to run some existing code. When attempting to run the ...

1
2 3 4 5
11