Questions tagged [octave]

GNU Octave is a high-level interpreted language and software, primarily intended for numerical computations. Historically it has been solely run from the command-line (that is, through a terminal emulator) but since version 3.8.0 a graphical user interface (GUI) has been available as part of the software.

Filter by
Sorted by
Tagged with
1 vote
1 answer
32 views

Octave library error when reading in data (FSL PALM)

I am running FSL PALM via Octave (v.5.2.0) from Ubuntu 20.04. I installed Octave per these instructions. I am encountering this error from Octave, which I think it related to a package dependency (...
user avatar
2 votes
2 answers
244 views

How to create a wrapper script for the Flatpak version of Octave, to avoid the long command flatpak run org.octave.Octave?

In the apt version of octave, I can use the command octave script.m to execute the file script.m. Similarly flatpak run org.octave.Octave script.m works too. However, to avoid the long command flatpak ...
user avatar
1 vote
1 answer
39 views

What's the package name for using de2bi in octave?

I'm trying to usede2bi in Octave but it seems that the package isn't installed. To install it, I should use this command: pkg install -forge <package_name> I don't know the package name, ...
user avatar
0 votes
0 answers
107 views

Octave package install error due to libncurses5-dev

I've installed Octave on Ubuntu 21.04 but run into problems installing packages. After trying to install liboctave-dev, I get liboctave-dev depends on libncurses5-dev; however: Package libncurses5-...
user avatar
  • 1
2 votes
2 answers
2k views

Why are there so many OpenBLAS packages and which one would yield fastest results?

In Ubuntu 20.04, there are many packages for OpenBLAS. ~$ apt search openblas p libopenblas-base - Optimized BLAS (linear algebra) library (transitional) ...
user avatar
0 votes
0 answers
19 views

Package 'octave-octcdf' has no installation candidate (Ubuntu 18 LTS) [duplicate]

I need to install octave-octcdf package to work with Octave. I tried, sudo apt-get install -y octave-octcdf. But this receives an error as following; user@PowerEdge-R540:~/user/tools$ sudo apt-get ...
user avatar
  • 1
0 votes
0 answers
1k views

how to upgrade glx version from 1.2 to 1.3 or higher on WSL2 Ubuntu 20.04

I am now running octave for some plots, but it would always return an empty window. Octave is now running on WSL2 Ubuntu 20.04 with xming for image forwarding, and it returns the following warning ...
user avatar
  • 1
1 vote
1 answer
83 views

stable octave on MATE

I installed Octave on my RPi400 running 32-bit Ubuntu MATE for Raspberry Pi with the following commands, sudo apt-get update sudo apt-get install octave It installed fine the first time but flaked ...
user avatar
1 vote
1 answer
530 views

How to use Octave from repositories with OpenBLAS compiled on my computer?

It has been suggested that using Octave with OpenBLAS compiled in my own computer (rather than precompiled OpenBLAS from repositories) will make the computations faster. I installed GNU Octave (4.2.2) ...
user avatar
1 vote
1 answer
752 views

How to use GNU Octave with Intel MKL from Ubuntu repositories, for faster scientific computation?

Intel Math Kernel Library is a BLAS library, which is available in Ubuntu repositories from Ubuntu 19.10 onwards, and is reported to give much faster results. How to make GNU Octave use Intel MKL ...
user avatar
2 votes
1 answer
174 views

I am unable to close octave [duplicate]

I had a problem with installing Octave. Now I am unable to close it once it is opened. And I am unable to shutdown the computer. What path should I set, what /etc/environment should I set? I had used ...
user avatar
0 votes
0 answers
238 views

Problem using PulseAudio in a snap program

It appears that apparmor is preventing Gnu Octave from connecting to the Pulse audio pipe. How can I remove this restriction. dmesg output [10986.689501] audit: type=1400 audit(1590956219.198:4342): ...
user avatar
2 votes
1 answer
220 views

GNU Octave documentation failure

When starting GNU Octave, I get this error window Looking in /usr/share/octave/4.4.1/doc I found I did not have write access to the .qhc file there. I tried to give everyone write access to it, but ...
user avatar
0 votes
1 answer
767 views

Why can't I run this executable file (.exe) in Octave?

I have a source code written in Fortran 90: sourcecode.f90 It needs Lapack libraries for compilation so, I compile the source code with this command: gfortran -o executable.exe sourcecode.f90 -...
user avatar
  • 11
2 votes
1 answer
3k views

Fail to install control package to Octave (installed via snap)

I'm facing some difficulties installing packages in octave (5.2.0 via snap). I'm running ubuntu 19.10 The problem is: >> pkg install -forge control configure: error: in `/tmp/oct-bdXz48/...
user avatar
  • 135
0 votes
1 answer
2k views

/bin/sh: 1: Syntax error: Unterminated quoted string <builtin>: recipe for target 'wfdbinit.o' failed in WFDB octave toolbox installtion

I need to work by EEG signals and trying yo use WFDB from physionet site from this instruction, so based of its readme.MD file i tried to do: $ sudo apt-get install gcc libcurl4-openssl-dev perl ...
user avatar
-1 votes
1 answer
4k views

Octave error: 'dfs' undefined near line 1 column 1

how i could run SDF command in octave when i get this error: so i have seen this GitHub related project (octave-networks-toolbox) and into is there was SDF, so i tried to install it by this command: ...
user avatar
2 votes
0 answers
910 views

warning: LFLAGS is deprecated and will be removed in a future version of Octave, use LDFLAGS instead

Ubuntu 19.10 Octave 5.1 flatpak every time I install an application I get this error then the CPU usages reaches 100% pkg install control-3.2.0.tar.gz warning: LFLAGS is deprecated and will be ...
user avatar
0 votes
1 answer
638 views

How do I fix "undefined variable: void" error loading scilab BackDoor

I'm attempting to install sci cosim for Octave, and to do so I need to install scilab, and BackDoor, however, with BackDoor installed I get the following error upon starting scilab: atomsLoad: An ...
user avatar
1 vote
1 answer
837 views

Can't install octave forges with Ubuntu 19.04

Octave Forges fails to install octave from repositories on Ubuntu 19.04 using snap octave v5.1: pkg install -forge symbolic error: get_forge_pkg: could not read URL, please verify internet ...
user avatar
2 votes
1 answer
2k views

gpg key timed out error while installing GNU Octave on Ubuntu 18.04

I tried to install Octave using the following commands: sudo add-apt-repository ppa:octave/stable sudo apt update sudo apt-get install octave But after running the 1st command, I get the following ...
user avatar
3 votes
0 answers
100 views

Binding Octave Libraries

I am working with embed octave. While building the library, I encountered this error, can anyone suggest solution for this. /usr/local/lib/octave/5.1.0/oct/x86_64-pc-linux-gnu/PKG_ADD: /usr/local/...
user avatar
1 vote
1 answer
3k views

snap permissions for home directory for Octave

I installed the octave snap yesterday, but when I run octave, it does not have permissions to access my $HOME. How do I enable permissions? ctaggart@rustasia:~/octave-add$ octave octave: X11 DISPLAY ...
user avatar
0 votes
1 answer
1k views

Unable to install Octave in armhf - Error in loading `libopenblas.so.0`

I have installed Ubuntu 18.04 (using the armhf rootfs created by Canonical) in Termux in my mobile phone. While installing octave (sudo apt install octave) I am getting the following error. Setting up ...
user avatar
2 votes
0 answers
184 views

installing gslcblas on octave (installed via flatpak)

Installing gslcblas on octave is not a big challenge (see here). But how can I solve the same problem, when octave is installed via flatpak on Ubuntu 18.04? >> pkg install -forge gsl Gtk-...
user avatar
0 votes
1 answer
2k views

How to create a data file which can be opened by octave

I created two files FeaturesX.dat and PriceY.dat using the command: touch FeaturesX.dat and touch PriceY.dat but when I would try to open these files from octave using the command: load FeaturesX....
user avatar
  • 35
2 votes
0 answers
242 views

How to install GNU Octave on Ubuntu 18.10?

While trying to install it from Ubuntu Software Store it shows the error "unmet dependencies". I just upgraded from 18.04 LTS which had Octave installed and now I can't use it anymore.
user avatar
0 votes
1 answer
947 views

hist(), plot() in octave shows blank screen

Code used: x = 0.17860 0.85981 0.69683 0.56564 0.55712 0.68452 0.83126 0.11530 0.28621 0.75909 >>y y = 4.28759 1.07059 1.53263 7.99441 0.98204 3.45242 4....
user avatar
1 vote
1 answer
283 views

octave from ppa with packages not possible

I installed octave using ppa, but now all octave packages (e.g. optim) have broken dependencies. I proceeded in the following way: $ sudo add-apt-repository ppa:octave/stable $ sudo apt-get update $ ...
user avatar
  • 111
0 votes
1 answer
209 views

Installing Octave on Ubuntu Mate on Raspberry pi 3

I have Ubuntu Mate on a raspberry pi 3 and I'm trying to install Octave without success so far. I got (sorry if its not accurate, I translated from Spanish): $ sudo apt-get -y install octave octave ...
user avatar
2 votes
0 answers
215 views

Looking for location of tmp directory in flatpak

Looking for location of tmp directory in flatpak. I installed the Octave flatpak. When I go to access the tmp directory while in the Octave program the directory is not the same tmp directory if ...
user avatar
  • 1,805
2 votes
2 answers
276 views

How to use GNU Octave instead of Minitab

As a university student, we have to solve some problems and class activity using a Windows app called Minitab, while I don't use any other operating system except Linux. I installed GNU Octave and ...
user avatar
  • 311
1 vote
1 answer
2k views

gsl library: gslcblas library not found but installed

I have problems with installing the gsl package. Running Xubuntu 18.04, octave 4.4.1. Using -forge, the installation process stalls with the following message: pkg install -forge gsl configure: ...
user avatar
  • 111
1 vote
1 answer
2k views

Octave - Invalid ELF header - Ubuntu 18.04

TLDR; I want to run octave code in the terminal without any GUI but am facing a ELF header error. Full question; I am trying to run a basic octave script as can be seen here which is saved as a ...
user avatar
  • 13
2 votes
2 answers
699 views

Installing Octave Documentation on Ubuntu 16.04

I'd like to have on-disk documentation, as there are many times when I must be off the net. I have Ubuntu 16.04 and Octave 4.0.0. When I click the Documentation tab I get "The info file /usr/share/...
user avatar
  • 101
2 votes
0 answers
14k views

Error while loading shared libraries: libQt5Network.so.5:

I was installing GNU octave on my Ubuntu 18.04 (from the terminal). After installation octave wouldn't open when I tried to launch it using the desktop icon. So I tried launching from the terminal and ...
user avatar
  • 21
4 votes
2 answers
1k views

GNU Octave Command Window unreadable text

GNU Octave Command Window showing unreadable text. Ubuntu 16.04 LTS. GNU Octave 4.2.2. Intel® HD Graphics 520 (Skylake GT2). Octave was installed by means of the Terminal.
user avatar
6 votes
1 answer
2k views

Octave command window showing unreadable text [duplicate]

When I start Octave, on the command window I see this: However, after I run some commands, I can see they are in history and they do execute. I can see the text if I copy-paste it somewhere. How ...
user avatar
1 vote
1 answer
383 views

Errors in installing octave in ubuntu 16.10 [duplicate]

Whenever I run the command "sudo apt install octave" I keep getting this in my terminal window Err:1 http://in.archive.ubuntu.com/ubuntu yakkety/main amd64 libxml-libxml-perl amd64 2.0128+dfsg-1 ...
user avatar
1 vote
0 answers
153 views

error installing octave from source (qt4 unknown)

After I compile octave from source, I get the following error: GEN libgui/src/qrc-resource.cc Unknown option 'qt4'. Makefile:27266: recipe for target 'libgui/src/qrc-resource.cc' failed CXX ...
user avatar
3 votes
3 answers
882 views

Cannot install Octave (Dependency problem)

I've tried to install Octave in my Ubuntu 16.04 LTS 64bit using sudo apt-add-repository ppa:octave/stable sudo apt-get update sudo apt-get install octave and it generate a dependency problem the ...
user avatar
  • 141
2 votes
1 answer
99 views

Gnuplot and Octave giving scrollbar error

The following error is occurring in both Gnuplot and Octave at the newest installation: error: invalid string constant "murrine-scrollbar", expected valid string constant I have no idea how to ...
user avatar
0 votes
0 answers
928 views

Installing Octave 4.0.2 with apt-get

I am trying to install Octave 4.0.2 (specifically that version; I have reason to believe there is an incompatibility that affects software I want to run with and would like to install this version to ...
user avatar
  • 183
2 votes
1 answer
743 views

Fuzzy logic simulation software

I am trying to find the best fuzzy logic simulator for Ubuntu 16.04 LTS. In Windows, I have fuzzy logic working in MATLAB, but in Ubuntu, Octave doesn't seem to compile fuzzy logic code. Is there ...
user avatar
  • 21
0 votes
0 answers
497 views

Trouble in installing octave 4.0.1

I have tried installing octave 4.0.1 many times but it always shows errors whenever I run "make" command after "./configure" , but directory has 2 makefiles (Makefile.am, Makefile.in) Image showing ...
user avatar
  • 1
0 votes
1 answer
578 views

GNU Octave Installation Problem

I experienced compiling problems with a previous installation of octave. I uninstalled it and am trying a re-installation using: sudo apt-get install octave when I do this, I get the following error:...
user avatar
  • 1
18 votes
2 answers
20k views

Installing latest version of GNU Octave when I have already installed other version

I have installed Gnu Octave by using apt-get install octave. This installed version 4.0.3 on my machine. I want to install the latest available version. How can I: Uninstall the version I have? ...
user avatar
  • 497
0 votes
1 answer
645 views

Octave permissions on Ubuntu 16.04 after installing from PPA

I've installed octave on xenial using PPA: sudo apt-add-repository ppa:octave/stable sudo apt-get update sudo apt-get install octave after which I did not get root permissions, error being : ...
user avatar
11 votes
2 answers
17k views

How to install statistics package in Octave(4.0.0) in Ubuntu 16.04?

I have tried >> pkg install -forge statistics , but it showed error: the following dependencies were unsatisfied: statistics needs io >= 1.0.18 What should I do now?
user avatar
  • 431
3 votes
0 answers
22 views

Failed to install Octave. Error: you have held broken packages [duplicate]

Here is the error I got while trying to install octave: $ sudo add-apt-repository ppa:octave/stable $ sudo apt-get update $ sudo apt-get install octave The following packages have unmet dependencies: ...
user avatar