Questions tagged [numpy]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
28 views

Missing python module with different python versions (multiarry_umath)

I am using Ubuntu 18.4 on as Windows Linux Subsystem, which comes with python3.6.9 installed: python3 --version gives Python 3.6.9 as output. However, for my work I installed the ccp4 suite, which ...
1
vote
0answers
44 views

Installing Ananconda on Ubuntu 20.04, many erros

Disclaimer: I'm very very new to Linux. Background: I'm having issues installing Anaconda on my Ubuntu 20.04. I am running this off of my USB stick on a PC. I tried downloading the community pycharm ...
0
votes
1answer
218 views

no module named numpy error in python 3

i am using visual studio code for python3, and i installed pip and numpy on it. also changed path in command prompt. but it is still showing this error "ModuleNotFoundEror: no module named numpy&...
0
votes
0answers
27 views

Numpy module not found, but I have installed numpy [duplicate]

I am using Windows 10 and Ubuntu 20.04. I am trying to install some software (python-fsps) using sudo SPS_HOME=$SPS_HOME python3 setup.py install. However, this gives me the error ModuleNotFoundError: ...
1
vote
0answers
91 views

Ubuntu 18.04-Runtime error- Embedding python to C

I am working on a project which is related to object detection and ocr. I am using Ubuntu 18.04 and python 2.7, yolov3 for object detection and tesseract 5.0.0-alpha-692-g62ea for ocr. I have to embed ...
1
vote
1answer
6k views

I can't import numpy in Visual studo code

I've installed Numpy for python3, but when i import the package in Visual Studio Code i got this message error : Import Error: No module named numpy. I used pip3 install numpy to install it, the ...
2
votes
1answer
71 views

Vs code python, no module found

I'm trying to get vs studio working with python 3.7 and when I go to load numpy, it says "no module found". What's the best way to fix this?
0
votes
2answers
850 views

Unable to install numpy for python2

I used to have numpy working earlier. Not sure what happened, but now I get the import error: >>> import numpy Traceback (most recent call last): File "<stdin>", line 1, in <...
2
votes
0answers
241 views

Why isn't VS Code debugger working on python?

Everytime I try to import numpy, the VS Code debugger won't work, giving the output File "/usr/lib/python3/dist-packages/numpy/core/init.py", line 16, in < module>; from . import ...
1
vote
2answers
1k views

Installing Numpy using pip3 on Ubuntu - Error “Command failed with exit status 1”

I have installed pip3 on Ubuntu. But while using it to install numpy (using command 'pip3 install numpy') I am getting the following error - error: Command "x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -...
1
vote
2answers
4k views

numpy install error

Background Instructions indicate installing numpy in a python virtual environment (log below). The log indicates warning and errors: although the install process indicates 'Success', the warnings / ...
0
votes
2answers
624 views

How do I connect installed module to python shell?

I have downloaded 'numpy' by using pip install numpy and it says that my installation is successful. I have also installed python 3.7.3 on Windows, but everytime I try to import numpy on the python ...
1
vote
1answer
490 views

Fix dependencies pandas python3

Today I installed another package via pip3 install seaborn after doing so my pandas package seems to be broken and I have no idea how to fix it. I tried to uninstall and reinstall pandas, numpy and ...
1
vote
1answer
1k views

python 3.7 on Ubuntu 16.04

I have tried to install python 3.7 on my ubuntu 16.04 via this link. It is Installing it without any error and it returns : which python3.7 /usr/local/bin/python3.7 Also I have other python ...
0
votes
3answers
5k views

No module named numpy

I am trying to run Jupyter notebook from my Ubuntu subsystem in Windows 10. I've installed numpy, scipy, and pandas using the following commands: pip install scipy numpy pip install pandas When I ...
0
votes
2answers
4k views

Cannot import Numpy and Pandas

I have installed numpy and pandas using pip. After executing my python code it shows the following error: Traceback (most recent call last): File "demo.py", line 1, in <module> import ...
1
vote
1answer
822 views

How to access “python3.6/site-packages” directory?

So right now I am trying to import tflearn on a python script, but that returns the error AttributeError: type object 'numpy.ndarray' has no attribute '__array_function__' (Theres a huge error ...
1
vote
1answer
195 views

Problem with Python [duplicate]

i was trying to fix my GPU to use with Theano, i had a problem with the liblas.so but python worked good, but when i did sudo ldconfig /usr/local/cuda/lib64 (i got this from internet, bad idea, i ...
1
vote
0answers
182 views

Importing numpy fails with python-dbg but not python [duplicate]

I am trying to debug my Python program so I apt-get install python3.6-dbg. But when I run python3.6-dbg and I try to do import numpy I get: >>> import numpy Traceback (most recent call last):...
0
votes
2answers
8k views

How to install numpy and scipy for python 2.7.12, Ubuntu 16.04?

I tried to install numpy using: pip install numpy It worked, but I got a warning: warnings.warn(warning, RequestsDependencyWarning). Then I tried to install scipy with: python -m pip install --...
0
votes
2answers
1k views

How to install numpy for Python 3.6.5 explicitly [duplicate]

This is not a duplicate question, I want to install numpy for python 3.6.5. it works on 3.4 on the same machine but I need it for 3.6, I tried "pip3 install numpy" and "apt-get install python3-numpy", ...
0
votes
1answer
91 views

problem with two versions of python

I'm new to python and ubuntu. I installed two versions of python to be able to use them in jupyter .. but when i checked the version of numpy i got python import numpy numpy.__version__ and got &...
4
votes
2answers
5k views

PyPy3 fails installing numpy

Basically when I call pypy3 -m pip install numpy --user I get thrown this lovely mess: Traceback (most recent call last): File "/opt/pypy3/lib-python/3/runpy.py", line 193, in ...
1
vote
3answers
12k views

ImportError: cannot import name 'multiarray'

I installed Python3.6 as described here: sudo add-apt-repository ppa:jonathonf/python-3.6 sudo apt-get update sudo apt-get install python3.6 Then I installed numpy as follows: sudo apt-get install ...
0
votes
1answer
2k views

python numpy or scipy error

I want to work in python. When I import scipy or numpy it shows these errors: saikat@saikat:~/Downloads/Python-2.7.15$ python Python 2.7.14 |Anaconda, Inc.| (default, Dec 7 2017, 17:05:42) [GCC 7.2....
1
vote
1answer
4k views

Numpy installed only for python3.5, not for python3.6

I have both python3.5 and python3.6 in my computer. When I try to import python in numpy3.6, I get an error. When I try to install numpy through sudo pip3 install numpy, I get the message Requirement ...
0
votes
0answers
459 views

Ubuntu 16.04 : Can't seem to make numpy work in python 3.6.5 but it works fine in python 2.7.12

when I run import numypy in python 3 , the following appears : ModuleNotFoundError: No module named 'numpy' So you might say try pip3 install numpy But it is already installed which is confirmed when ...
0
votes
1answer
92 views

NVIDIA/DIGITS Run Time Error?

I have installed DIGITS on Ubuntu 16.04 regarding the NVIDIA/DIGITS. When I run ./digits-devserver output becomes: RuntimeError: module compiled against API version 0xc but this version of numpy ...
1
vote
1answer
1k views

How to remove this error while installing numpy on Ubuntu?

I am getting this exception while trying to install numpy. I have tried both by directly calling pip(command: pip install numpy) and through sudo as well. Please help resolve this: fareha@...
0
votes
0answers
517 views

How to install a package in the root directory using virtual environment?

I have created a virtual environment in the root directory and trying to install numpy using the command: pip install numpy It gives the following error: OSError: [Errno 13] Permission denied: If ...
0
votes
1answer
1k views

Numpy error : Error while running numpy.mean(num)(where num is an array) [closed]

I am new to data science and just installed numpy in the system. So, I stuck at a place when I run numpy.mean(num) function to calculate the mean of the array of numbers. So, can anybody suggest the ...
1
vote
1answer
7k views

How do I write a function in Python with a filename as an argument? [closed]

**EDIT: Sorry if I was unclear. Let me clarify: I'm trying to write a function that takes a filename and a number i as arguments, loads the file specified by the filename with numpy.loadtxt(), and ...
-1
votes
1answer
3k views

import error:module named numpy

I am getting import error: module named numpy. Does this mean i have to install numpy? I have downloaded the new version extracted it into home. I am not sure what else to do. I am using Ubuntu 16.04....
0
votes
1answer
883 views

Error installing scikitlearn

I am trying to install scikit learn using pip install -U scikit-learn But it doesn't get installed. I tried to install numpy and scipy at first but I could not install those either :(
0
votes
2answers
618 views

How to import numpy as standard user from server?

I installed python, numpy, scipy as super user in server and I can import them without any errors. However, standard users (who connect with ssh) can not import them. How to fix it so that standard ...
0
votes
1answer
8k views

fatal error: numpy/arrayobject.h: No such file or directory

Can you please help with this? mona@pascal:~/computer_vision/tf-faster-rcnn/lib$ sudo pip2 install numpy The directory '/home/mona/.cache/pip/http' or its parent directory is not owned by the current ...
2
votes
0answers
153 views

What is an appropriate infrastructure for Deep Learning? [closed]

I work on Kaggle's Galaxy Zoo competition with Keras/Tensorflow, but the huge amount of data (lot of images) sends my computer to limbo. Mine is a more or less ordinary PC (i5) with a generous 48GB of ...
0
votes
0answers
2k views

How to update a version of numpy [duplicate]

i have a ubuntu 14.04 , i want to update my version of numpy . How to do it ?
1
vote
1answer
13k views

ImportError: Missing required dependencies ['numpy', 'pytz'] when executing python3?

I have installed numpy and pytz packages through pip3 install <package name> But there shows the following import errors when executing the following df_demo.py code, I do not know why and ...
3
votes
1answer
2k views

Numpy broken in Ubuntu 16.04 LTS

I have installed the package python-numpy on Ubuntu 16.04 LTS. Unfortunately, the package is broken: >>> import numpy Traceback (most recent call last): File "<stdin>", line 1, in <...
3
votes
3answers
47k views

how to install numpy for python3

I need help with installing numpy to Ubuntu 16.04. after: $ pip3 install numpy come up always: PermissionError: [Errno 13] Permission denied: '/usr/local/lib/python3.5/dist-packages/numpy' What to ...
5
votes
1answer
706 views

Snapcraft Python2 building numpy with python-dev

just starting to get my hands dirty with snappy. I am trying to port a python project to a snappy app. The python code relies on numpy 1.5.1, which relies on python-dev being installed. My snapcraft ...
0
votes
1answer
619 views

Problem occured when install numpy for python3.4 on ubuntu [duplicate]

When I tried pip3 install numpy I got the error as SystemError: Cannot compile 'Python.h'. Perhaps you need to install python-dev|python-devel. Then I continue to install python-dev but got ...
10
votes
4answers
98k views

No module named 'numpy'

Actually I am shifting from Windows to Linux. Using pycharm on Windows I have a python 3 script that requires numpy and matplotlib to run, so I installed them on my Linux system using sudo apt-get ...
0
votes
1answer
322 views

Question about the eig() function in GNU Octave

In GNU Octave, does the eig() do the balancing of the matrix? I know the eig() in numpy does the balancing of the matrix.
0
votes
2answers
2k views

I cannot install python-numpy [duplicate]

I have Ubuntu 14.04 and I cannot install numpy. here is my attempt: ohad@ohad-Vostro-3300:~$ sudo apt-get install python-numpy [sudo] password for ohad: Reading package lists... Done Building ...
22
votes
3answers
111k views

How to update to the latest numpy and scipy on Ubuntu 14.04LTS

On my Ubuntu 14.04LTS, for python3, I have >>> import numpy >>> import scipy >>> numpy.__version__ '1.8.2' >>> scipy.__version__ '0.13.3' I want to update ...
1
vote
1answer
139 views

I am using ubuntu14.04. I have installed numpy in python3, but it is not in python2.7.

I have installed both python3-numpy as well as python-numpy from the App store. But then, numpy only works on python3. I want it to work on python2.7 also.
2
votes
0answers
1k views

Numpy/Scipy with Openblas

I've been trying to install Numpy/Scipy and allow them to both use Openblas. I've been following various guides but have been using this one of late. At the end of the guide, there are a couple of ...
5
votes
1answer
5k views

Problems installing Numpy in Virtualenv

I have numpy installed globally (I think via Django) but I'm trying to install it within a virtualenv. When I run pip install numpy (within my virtualenv), it gets stuck at Running setup.py install ...