Questions tagged [networking]

Managing and using network connectivity on a Ubuntu system

Filter by
Sorted by
Tagged with
386 votes
43 answers
1.7m views

Installing Broadcom Wireless Drivers

I'm having serious problems installing the Broadcom drivers for Ubuntu. It worked perfectly on my previous version, but now, it is impossible. What are the steps to install Broadcom wireless drivers ...
26 votes
5 answers
64k views

Installing Wi-Fi driver for Realtek Semiconductor RTL8723DE Device [10ec:d723]

How do I install Wi-Fi drivers for Realtek RTL8723DE device in Ubuntu 16.04? lspci -v | grep -i network 02:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d723
user avatar
24 votes
9 answers
73k views

Wi-Fi not working on Lenovo ThinkPad E570 (Realtek RTL8821CE)

We just bought a Lenovo ThinkPad E570 (which is supposed to have the Intel 8265 for wireless). This laptop was bought in part because it is certified to run Ubuntu and as such to me at least it would ...
user avatar
  • 8,518
82 votes
3 answers
205k views

How to share files through the local network?

I have a desktop (Ubuntu 13.04 & Win 7 Home Premium) and a Laptop (Ubuntu 12.04), both having WiFi adapters. I also have a WiFi router connected to internet which both my computers can access. I ...
user avatar
  • 1,215
32 votes
2 answers
124k views

How to install Broadcom wireless drivers offline?

I have installed Ubuntu alongside Windows 8.1. But the wifi is not working in Ubuntu (perhaps the drivers are not present), which worked fine in windows. Also I cant connect with Ethernet since my ...
user avatar
  • 623
25 votes
4 answers
21k views

Realtek RTL8723BE Wi-Fi incredibly weak

I have a HP 14-AN001NA laptop. It came with Windows 10 installed on which the Wi-Fi worked fine anywhere in the house. However I removed Windows 10 and installed Ubuntu 16.04 instead and since I ...
user avatar
63 votes
1 answer
118k views

Ubuntu GNOME 17.04: wi-fi not working -- mac address keeps changing?

My Panda USB wi-fi adapter works just fine on 16.10, but when I try to connect to my wi-fi router in 17.04, GNOME network manager reports "Connection failed." I did some tinkering, and noticed that my ...
user avatar
  • 2,205
42 votes
4 answers
147k views

Wifi problems with rtl8723be in Ubuntu 14.04

I have dual booted my Windows 8 laptop with Ubuntu 14.04. The wifi driver is Realtek rtl8723be. It didn't use to work but I updated the kernel to 3.18 and reinstalled the driver and that seemed to ...
user avatar
40 votes
3 answers
232k views

How to install Wi-Fi driver for Realtek RTL8821CE on Ubuntu 18.04? [duplicate]

I'm trying to install drivers for my Wifi on my HP All-in-one desktop. I've been told to show the output of the command "sudo lshw -C network" so here it is: *-network description: Ethernet interface ...
user avatar
  • 501
86 votes
7 answers
92k views

Last upgrade crashes network manager (no internet connection, no applet)

While upgrading today, something caused my wireless network manager to disappear. Not even connecting via wired connection. This error is being shown by files: **(nm-applet:2716): WARNING **: Could ...
user avatar
163 votes
12 answers
139k views

Wifi doesn't work after suspend after 16.04 upgrade

This particular version of the "doesn't work after suspend" came after upgrading to 16.04. It seems that the upgrade includes a Wicd applet (added to Metacity Classic Gnome task bar alongside regular ...
user avatar
  • 2,075
155 votes
6 answers
48k views

Best way to cache apt downloads on a LAN?

I have multiple Ubuntu machines at home and a pretty slow internet connection, and sometimes multiple machines need to be updated at once (especially during new Ubuntu releases.) Is there a way where ...
user avatar
  • 2,013
80 votes
5 answers
91k views

Wireless networking not working after resume in Ubuntu 14.04

[Update]: The same problem exists in Kubuntu and is solved in the same manner. [Solved]: By applying the following command nmcli nm I got the following: Before suspend RUNNING STATE ...
user avatar
26 votes
5 answers
69k views

Can't get RTL8125B working on 20.04

So I did a fresh install of Ubuntu 20.04 on a computer with the new RTL8125B Realtek network card and I cannot get the network to work. I was very suprised since this is supposed to be the new feature ...
user avatar
70 votes
1 answer
176k views

How do I setup an Icecast server for broadcasting audio in my network?

Broadcasting the output of the soundcard as an internet radio stream is a reliable way to stream audio in a network. This can nicely be used to e.g. transmit audio in a wireless LAN to another ...
user avatar
  • 137k
44 votes
6 answers
94k views

How do I change / spoof my MAC address and easily switch between multiple ones?

My router can do port-forwarding based on MAC addresses. That is, a specific MAC will get a specific IP, for which I can configure a set of ports to be forwarded. In order to easily change that set of ...
user avatar
51 votes
5 answers
116k views

Ethernet device not managed

I am using Ubuntu 16.10 and recently I have not been able to connect to internet using Ethernet. The network manager shows device not managed. The WiFi network is working fine. I've tried the ...
user avatar
  • 672
123 votes
9 answers
398k views

16.04 LTS wifi connection issues with Realtek RTL8723BE adapter

I discovered several issues with wifi connection after installing 16.04 LTS. First, wifi doesn't reconnect normally after sleep or hibernation. Sometimes the network icon turns into a "up and down ...
user avatar
  • 2,594
66 votes
4 answers
337k views

Changing Network Interfaces name Ubuntu 16.04

I tried to change network interfaces name on this new Ubuntu 16.04 LTS version but doesn't have the /etc/udev/rules.d/70-persistent-net.rules. So, I tried to use /lib/udev/write_net_rules but it not ...
user avatar
8 votes
1 answer
20k views

Ubuntu 14.04 Wireless not working: no network interface. Atheros [168c:003e] device

I just installed Ubuntu 14.04.3 LTS after installing windows 10 in my new VN7-571G and the wireless is not working. It never had: even during the installation it was not recognized. I run a script to ...
user avatar
  • 255
296 votes
18 answers
1.8m views

How to restart the networking service?

I tried to use sudo service networking restart and sudo /etc/init.d/network restart but they both crash the window manager and I can no longer use my keyboard for input into X. when I use the /...
user avatar
  • 4,362
24 votes
2 answers
54k views

How to set a domain to ip address?

You can reach this IP address 2.186.116.46 (if my computer is online). I want to assign a domain to it so I wonder how is that possible when I have no DNS? I do own my domain which is ".com". My IP is ...
user avatar
22 votes
5 answers
181k views

Drivers for Broadcom BCM43142 on Ubuntu 14.04 (Trusty Tahr)

I am not able to install drivers for my Wi-Fi + Bluetooth card (Broadcom BCM43142). What I have done till now: I have tried using the drivers at this website. I tried following the instructions ...
user avatar
  • 551
12 votes
1 answer
11k views

Intel Wifi 6 AX210 - WiFi not working after Update

After the latest updates (Terminal: sudo apt update & upgrade) my WiFi suddenly didn't work anymore. I did a fresh installation including all applications necessary for me and again did not work ...
user avatar
  • 123
134 votes
3 answers
206k views

Why is my network interface named enp0s25 instead of eth0?

A lot of my scripts stopped working after installing Ubuntu 15.10 and I have trouble remembering this new name as I was used to ethx and wlanx for years. Is there a reason for this change? Do I have ...
user avatar
  • 5,231
48 votes
3 answers
182k views

How to transfer files between Ubuntu and Windows?

I wanna transfer some files from this PC with Ubuntu to a PC with Windows 7 I don't care how to do it (ftp, samba or whatever) I wanna know the steps, I searched a lot but I can't find anything that ...
user avatar
  • 505
39 votes
5 answers
162k views

Ubuntu 14.04 Server - WiFi WPA2 Personal

I just installed Ubuntu 14.04 Server and cannot get wifi configured correctly to work with WPA2 personal and could use some help. There was a simple wizard during install where I selected my SSID ...
user avatar
  • 493
35 votes
7 answers
206k views

How to set static IP address?

I have configured network adapter of guest Ubuntu to work in a bridged mode so I could ssh to it from the host machine. The problem is that the guest Ubuntu ip address keep changing. Even though ...
user avatar
  • 495
13 votes
10 answers
54k views

Wireless Network in Virtualbox

I just installed my first Ubuntu Server (12.04) instance and immediately ran into the following problems: Running apt-get install or update fails (see below) Running ifconfig produces peculiar IP ...
user avatar
  • 1,745
272 votes
6 answers
197k views

How do I find out which process is eating up my bandwidth?

I think I'm being the victim of a bug here. Sometimes while I'm working (I still don't know why), my network traffic goes up to 200 KB/s and stays that way, even tough I'm not doing anything internet-...
user avatar
  • 9,516
68 votes
7 answers
191k views

How to connect to WPA2/PEAP/MSCHAPv2 enterprise wifi networks that don't use a CA_Certificate, like Eduroam

My university uses WPA2 Enterprise encryption for students to login their wireless. In NetworkManager I have keyed in everything that they needed Security : WPA & WPA2 Enterprise Authentication :...
user avatar
  • 1,064
83 votes
9 answers
131k views

Ubuntu 20.04 Network Performance Extremely Slow

I just upgraded from Ubuntu 18.04 to 20.04 on one of the Dell XPS 13 machines, and the network performance is abhorrent. Internet speed is very fast from a google speed test (>300Mb/s for both upload ...
user avatar
  • 1,659
57 votes
6 answers
151k views

Network interface name changes after update to 15.10 - udev changes

I updated a virtual machine running Ubuntu server 15.04 to the just released new stable 15.10. There were no apparent problems, but after reboot the machine lost its network connection. lspci showed ...
user avatar
  • 1,664
22 votes
6 answers
67k views

Unable to get wifi adapter working - clean 19.04 install - network unclaimed

My wifi card is an Intel® Wireless-AX200 (802.11/a/b/g/n/ac/ax), Bluetooth® 5, and bluetooth is working. I've tried following various guides, however these drivers are apparently yet to make it into ...
user avatar
  • 425
11 votes
3 answers
35k views

Connect two computers with SSH in a home LAN

I have two ubuntu computer shared the same wifi and desire to reach another from one's terminal. First create an user on the second computer named "Second" and hostname "Algorithms" Then tried to ...
user avatar
774 votes
22 answers
1.6m views

Command for determining my public IP?

If I check with google, I can see my public IP. Is there something on the Ubuntu command-line which will yield me the same answer?
user avatar
  • 8,179
80 votes
7 answers
98k views

How can you monitor total internet data usage across reboots?

Some broadband providers impose a monthly download limit, charging extra if you go over. It is also quite easy to exceed some of the lower limits just by installing/updating packages and 'normal' ...
user avatar
  • 35.9k
58 votes
8 answers
492k views

How to set static routes in Ubuntu Server?

I have used Ubuntu since Ubuntu 8.10; today I'm working with Ubuntu 12.04 Server. I am having difficulty keeping static routes on booting. I would usually put the route commands /sbin/route add -...
user avatar
31 votes
4 answers
47k views

14.04 - Network manager stopped working

When I started my laptop, there was no network service, and also no network icon in the top bar. It gives an error when I start OS like "Sorry, Ubuntu 14.04 experienced an internal error". When I ...
user avatar
  • 775
27 votes
3 answers
93k views

How to install TP-LINK Archer T4U driver?

I bought the wireless adapter to use with a computer without internet access but I can't figure out how to install it with just a USB with the driver on it. I've read a few articles on how to install ...
user avatar
  • 273
12 votes
2 answers
17k views

TP-LINK TL-WN823N Unable to connect to network

I have purchased a TP-LINK TL-WN823N (EU) V2.0 device, which is a USB device that should work as a Network Interface Card, allowing me to connect my computer to wireless networks. Unfortunately, I am ...
user avatar
  • 123
1 vote
4 answers
5k views

Ubuntu 20.04 Wifi Keeps Dropping

I recently moved and set up my system with a new wifi router. Since then, my Ubuntu randomly loses wifi every 5-10 minutes. I have to turn off the wifi setting on my computer and turn it back on to ...
user avatar
13 votes
4 answers
24k views

Wireless disabled by hardware switch on an Asus X550V

I'm using Ubuntu 13.04 and I have ASUS X550V laptop. This is my rfkill list: 0: asus-wlan: Wireless LAN Soft blocked: no Hard blocked: no 1: asus-bluetooth: Bluetooth Soft blocked: no ...
user avatar
2 votes
1 answer
1k views

Creating additional Virtual Host Ubuntu Server

I have currently one website running perfectly on my LAMP server (Ubuntu Server 16.04.3). I now would like to add another one to the server. So i first went to the /etc/apache2/sites-available file ...
user avatar
56 votes
8 answers
266k views

Can't view Wifi networks after upgrading to Ubuntu 16.04

I can't view any wifi networks after upgrading to Ubuntu 16.04 from 14.04. This issue also occurred when trying to upgrade to Ubuntu 15.10. This is what my network window looks like: I have Broadcom ...
user avatar
35 votes
6 answers
92k views

How do I keep my Wifi from dropping out?

I have a System76 Gazelle, gapz8, running Ubuntu 14.04. My wifi keeps dropping out at random intervals. I have a new router, so I don't believe that's the issue, but I am in an apartment building, so ...
user avatar
  • 1,071
29 votes
2 answers
127k views

How do I install drivers for the Atheros AR8161 Ethernet controller?

I have installed Ubuntu 12.04-64 bit on my Lenovo IdeaPad laptop, and the wired Ethernet (LAN) connection doesn't work. Running the lspci -vv | grep Atheros command from the terminal shows me I have ...
user avatar
60 votes
9 answers
539k views

How do I set a static IP in Ubuntu?

I am a new with Linux, having years experience with Windows servers/desktops and am having issues setting a static IP. I am using a method used for previous versions of Ubuntu, which doesn't seem to ...
user avatar
  • 703
4 votes
2 answers
9k views

how to setup ubuntu that fstab runs after network is connected?

right now I have setup /etc/fstab like this: //192.168.5.167/H /mnt/ssd cifs credentials=/root/.smbreds,noauto,x- systemd.automount 0 0 I want to set it up like first network should be connected ...
user avatar
70 votes
7 answers
184k views

Ubuntu 18.04: switch back to /etc/network/interfaces

Starting sometime around Ubuntu 18.04, the Ubuntu devs stopped using the classic /etc/init.d/networking and /etc/network/interfaces method of configuring the network and switched to some thing called ...
user avatar
  • 994

1
2 3 4 5
48