Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [metasploit]

The tag has no usage guidance.

0
votes
0answers
12 views

Why i cant search on metasploit

when i search something " msf > search ms17-020 [!] Module database cache not built yet, using slow search msf > " this will happen how to solve this?
1
vote
1answer
174 views

How can i get metasploit for 18.04

Just got Ubuntu mini 18.04 and im planning on making it specially designed for hacking & pentesting, ive got the basics such as nmap and some custom scripts but im wondering how to get the god of ...
4
votes
1answer
2k views

How to update ruby version to 2.5.1?

When I tried opening metasploit by msfconsole It showed an error rbenv: version `2.5.1' is not installed (set by /opt/metasploit-framework/.ruby-version) I tried rbenv install rbx-2.5.1 its ...
0
votes
2answers
194 views

Problem installing armitage

When installing armitage, after downloading and extracting, I wrote: sudo sh -c "echo java -jar /opt/armitage/armitage.jar \$\* > /opt/armitage/armitage" And to that I got: sh: 1: cannot create /...
0
votes
0answers
350 views

Armitage error, could not connect to database

The following error messages appear while starting ARMITAGE: i cant found a database.yml file i really need it. hre how to fix this: try setting MSF-DATABASE-CONFIG to file that exists did you use ...
0
votes
0answers
211 views

Not able to start msfconsole after installing Metasploit

vikram@vikram-Inspiron-N5010:~$ msfconsole /opt/metasploit-framework/lib/rex/logging/sinks/flatfile.rb:21:in `initialize': Permission denied @ rb_sysopen - /home/vikram/.msf4/logs/framework.log (Errno:...
1
vote
2answers
334 views

run programs from select menu [duplicate]

I've created a simple bash script to create a select menu which look like this : 1) Run nmap 2) Wireshark 3) metasploit framework 4) Exit now I want to run these programs as per menu selection. I am ...
0
votes
1answer
576 views

Metasploit wont launch

I recently downloaded Metasploit and tried to run it by typing msfconsole but I get this: ** Welcome to Metasploit Framework Initial Setup ** Please answer a few questions to get started. Would ...
-4
votes
1answer
48 views

Use different address after every 20 requests

I'm using Ubuntu 16.04 to run a pentest on a client's website using metasploit's HTTP scanner module. After 20 requests, the server I'm testing against blocks my IP and prevents me from being able to ...
-1
votes
1answer
99 views

Cannot open Metasploit [duplicate]

I installed Metasploit on 12.04 and it is ready to use, but I don't know how to run it. I have tried to execute this file: metasploit-latest-linux-installer.run and it starts to boot up then it says: ...
0
votes
0answers
33 views

Remove the console [duplicate]

I installed Metasploit, but now I want to remove this console for some reasons. Could anyone be able to tell me how to remove this console?
2
votes
1answer
603 views

How to choose to install all apps at once in katoolin/Kali linux repositories interface?

How can I install all the Kali linux tools at once? This is what I have. View the categories of available software in katoolin interface Can I just press 0 for everything to be installed at once, ...
0
votes
1answer
243 views

Metasploit installation — Syntax error

I was installing Metasploit using the script invocation for quick installation and as I pasted the script in the terminal the error ./msfinstall: line 1:syntax error near unexpected token 'newline' ./...
6
votes
2answers
64k views

How to install Metasploit and Armitage

I want to install metasploit and armitage on my ubuntu 16.04 LTS laptop running kernel 4.6 I've read blogs and posts on how to install it but the problem is is that they are outdated. The packages ...
0
votes
1answer
401 views

Permission denied when using bundler commands

I am pretty much completely new to Metasploit so I may just be having a problem that anyone who is experienced could fix but I hadn't seen any fixes online anywhere. I am running msfvenom -p android/...
2
votes
0answers
273 views

Is it possible to install metasploit on Ubuntu touch

I know that it is possible to install Metasploit on iPhones and somehow on Android mobile devices, today I installed ubuntu emulator and try ubuntu touch directly from my computer and I have a ...
2
votes
1answer
4k views

Armitage won't start: parse error

I installed Armitage along with Metasploit and Postgresql but Armitage is not connecting. Starting Postgresql works fine sudo service postgresql start * Starting PostgreSQL 9.3 database server ...
2
votes
1answer
1k views

metasploit problems

I've searched the whole internet for an answer and still haven't found one, I decided to uninstall metasploit i typed in the following $ cd /opt opt$ ls google lol sublime_text tor-browser-en ...
0
votes
1answer
3k views

Issue with Metasploit/Armitage install on Ubuntu

I installed Metasploit via this tutorial. I am able to run msfconsole and it works fine. However, I can't do service metasploit start (metasploit.service doesn't exist), and there is no file for ...
1
vote
0answers
2k views

Problems Installing Metasploit Framework on Ubuntu

I have encountered 3 problems while following this guide to installing Metasploit Framework on Ubuntu and Debian: 1) After installing proper version of ruby, there is a command given for installing ...
1
vote
0answers
29 views

Need to remove Metasploit from my Ubuntu 12.10 system [duplicate]

Tonight I installed Metasploit in my Ubuntu 12.10 it did not work properly, so I removed it by executing the following command in terminal sudo rm -r /opt/metasploit Now when i try to re-install it,...
2
votes
3answers
10k views

Uninstall Metasploit problem

I had serious problems with Metasploit since I installed it, so I want to uninstall it I did try /opt/metasploit-4.5.0/uninstall but it doesn't work it shows a yes and no .. I choose yes then wait ...