Questions tagged [mesa]

Mesa is a software library for 3D computer graphics that provides a generic Khronos-compliant OpenGL implementation for rendering three-dimensional graphics on multiple platforms.

Filter by
Sorted by
Tagged with
1
vote
1answer
43 views

Chrome stop working after upgrade to Ubuntu 20.04

Last night I've upgraded to Ubuntu 20.04 and now Chrome won't start. 10:20:00 /opt/google/chrome$ ./chrome MESA-LOADER: failed to retrieve device information MESA-LOADER: failed to open i915 (search ...
0
votes
0answers
41 views

Ubuntu 20.04 - Some MESA drivers are not updating when using apt upgrade

I've been using Oibaf PPA and keeping the MESA drivers up to date. However for the past few days the following are not updating and are held back - - libegl-mesa0/focal 20.2~git2006191930.8f11cc~...
0
votes
0answers
19 views

current OpenGL, GPU, Wayland, etc. dev packages on Focal Fossa

Wondering if anyone is up to date on package information for working with OpenGL/mesa/SDL/DRI/GPU tools/Intel graphics/Vulkan/Wayland/LLVM-specific stuff,and anything else that might be interesting
0
votes
0answers
25 views

How to know if the Intel Iris Gallium3D controller is working?

again here asking questions. First of all thank you all for any help. How to know if the Intel Iris Gallium3D controller is working? As I have read from MESA 20.0 it comes active by default, but is ...
0
votes
0answers
57 views

How to force Ubuntu 18.04 to use openGL 3.2+ not openGL 3.1

I have already done this... "1. Open terminal either via Ctrl+Alt+T or by searching for ‘Terminal’ from software launcher. When it opens, run command: sudo add-apt-repository ppa:ubuntu-x-swat/...
0
votes
0answers
84 views

Pycharm project cannot load Radeon drivers

When I try to run a project (qudi) in pycharm, I get the following errors: libGL error: MESA-LOADER: failed to open radeonsi (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri) ...
0
votes
0answers
52 views

Cairo can not find OpenGL ES 2.0 headers on Ubuntu 18.04

I am trying to compile Cairo 1.16.0, but it fails, giving me the following errors: checking for cairo's OpenGLESv2 surface backend feature... checking for glesv2... no checking GLES2/gl2.h ...
1
vote
0answers
664 views

Trying to use latest Mesa breaks OpenGL on amdgpu in Ubuntu 19.10

I'm having an issue upgrading to the latest Mesa drivers (anything >= 19.3) from any external repository, in this case oibaf. In the past I did not have any issues doing this, but a couple of months ...
0
votes
0answers
175 views

Problem with 32 bit libs on ubuntu 18.04.4

The general problem with a program for ip-camera iVMS-4200. It worked until I remove all 32 bit packages from system(Ubuntu 64 bit 18.04.4). After removing 32 packages iVMS-4200 had broken. Now I ...
0
votes
0answers
1k views

Ubuntu 18.04 Install Mesa 19.3 Drivers

I am trying to install Mesa Drivers 19.3 on my Ubuntu 18.04 Distro for my Radeon RX 580 graphics card. I did run the following commands: sudo add-apt-repository ppa:kisak/kisak-mesa sudo apt-get dist-...
0
votes
0answers
33 views

Can you wipe a botched kernel update and start again?

My Kubuntu installation has gone wrong. More specifically it is version 18.4 LTS on a computer with AMD Ryzen processor with Vega (Raven) Graphics. To get the graphics to work properly and stop ...
0
votes
1answer
126 views

Ubuntu 18.04: Cinnamon is currently running without video hardware acceleration

I recently updated some packages, and I'm getting an error on reboot saying the hardware acceleration has been disabled, and the package manager doesn't work any more. The error messages keep ...
0
votes
0answers
108 views

Help with Ubuntu Graphics Drivers

Graphics drivers on Ubuntu have always eluded me. I'm trying to verify my Mesa drivers, but upon running glxinfo |grep "OpenGL version", I get OpenGL version string: 4.6.13572 Compatibility Profile ...
0
votes
1answer
107 views

Flathub packages are freezing system after upgrade to 19.10

Since I upgraded to 19.10 my system is freezing when starting Flatpak progs, like Foliate or Visual Studio Code. Can only hard shutdown. Syslog shows error messages in Kernel amdgpu. It seems this ...
1
vote
0answers
55 views

Java AWT BorderLayout() can crash libGLX_mesa.so.0 in Ubuntu Linux ver 18.04.1 - how to fix?

I have a large Java application that includes many commands such as new JPanel(new BorderLayout()) this.setLayout(new BorderLayout()); but not all of them seem to cause the crashing. I can prevent ...
0
votes
0answers
147 views

Installing Mesa from older Ubuntu release

The current stable release of Mesa packaged with Ubuntu 19.10 (eoan) has a nasty memory leak on AMD GPUs that affects me severely. The leak is also present in latest development builds, but is ...
1
vote
0answers
113 views

Kmscube on Ubuntu 16.04

I am trying to run kmscube on Ubuntu 16.04. I have built it with meson and ninja, but I see this error when I am trying to run it: i965_dri.so does not support the 0xffffffff PCI ID. Using display ...
0
votes
0answers
22 views

Why the Graphics Card name is not the same on two platforms?

I am using Ubuntu 16.04.6. I use a software to show which version of OpenGL can launch. On the Windows 7, it shows I can use OpenGL 3.1. But on Ubuntu, it shows I only can use OpenGL 3.0. Is ...
2
votes
1answer
780 views

How to uninstall AMD drivers and install mesa? - 18.04.3 LTS

I just installed the amdgpu-pro drivers from AMD's official website. But now some apps are not working that well and I heard that Mesa drivers were superior. How do I uninstall these drivers and ...
2
votes
2answers
5k views

How do I use my RX 5700 with Ubuntu 19.04?

I have an Ryzen 3700x and the RX 5700. There appears to be no hardware acceleration, and I seem to be using software-rendering for everything. I have recently uninstalled the proprietary AMDGPU pro ...
1
vote
0answers
412 views

Intel Whiskey Lake OpenGL 4?

I have a Whiskey Lake processor. How can I get a mesa version that supports OpenGL 4 on this arch? I've followed the instructions here, but I still get: OpenGL vendor string: Intel Open Source ...
0
votes
0answers
170 views

GPU-Passthrough from scratch / Shared GPU w/ Looking-Glass library

I have installed an ubuntu 18.04.2 on a new system. My hardware specs are as following: 2 x xeon 2670v1 128gb ddr3 ecc sapphire radeon r9 380 samsung evo 750 256gb My objective is to run a Windows ...
0
votes
0answers
452 views

AMD GPU crashing when playing game

I have a problem on my Ubuntu 18.04 machine. I recently upgraded my GPU to a RX 580 from a GTX 960, but now it seems to crash every time I've played a game for a bit. This time interval isn't ...
0
votes
1answer
2k views

How to: Mesa on ubuntu 19.04

I am on ubuntu 19.04 codename disco dingo. When I type this : glxinfo | grep "OpenGL version" I get this OpenGL version string: 4.6.0 NVIDIA 418.56 same with binary driver : $ glxinfo | grep "...
5
votes
2answers
2k views

Weird screen flicker/tearing while using 75hz on AMD GPU

I hope it's not making much difference that I'm posting my question here even if I'm using Pop!_OS. The problem also occurs on a Manjaro live usb. I'm using a Ryzen 1500x CPU, 16GB of RAM, MSI ...
9
votes
1answer
2k views

how to address apt-upgrade problem involving libglx-mesa0 and Nvidia driver

I have an Nvidia 1070 system with Ubuntu 18.04, Nvidia driver 396.37, CUDA 9.0, and then TensorFlow and Keras running on it. Having run sudo apt update, when I run sudo apt upgrade, I get the ...
1
vote
0answers
306 views

How can I install Mesa drivers from source?

I followed this guide but my driver version isn't changed. I compiled the Mesa 19.0.0 drivers without any issues but glxinfo -B output says I still have old drivers. Btw, I have the latest Meson and ...
1
vote
1answer
927 views

Dependencies missing while building Mesa3d

Meson was used,missing dependencies are as follows: Found pkg-config: /usr/bin/pkg-config (0.29.1) Dependency vdpau found: NO Dependency xvmc found: NO Dependency libomxil-bellagio found: NO ...
0
votes
2answers
432 views

Doesn't SteamPlay/Proton under AMDGPU-PRO work?

I'm new in LinuxGaming, switched from Win10 to Ubuntu 18.04 few weeks ago. Now i found out how to use SteamPlay and Proton and i really like the idea! But my problem is, that i can't start Games ...
4
votes
1answer
628 views

Ubuntu 18.04 -> 18.10 doesn't boot

After an upgrade from 18.04 to 18.10, my ubuntu does not boot and just losing the signal after the grub. I cat login with "nomodeset" but then the resolution is lower and can't be changed. Here are ...
0
votes
0answers
350 views

Severe Lag/Stuttering on New Versions (18.10-19.04) with Vega 64

I'm writing this because I'm having some pretty severe issues with my system that I had originally dismissed as a card issue (patching the firmware at one point actually mitigated the issue I'm having)...
1
vote
1answer
896 views

Radeon VII GPU Not Working

I'm having trouble getting a Radeon VII GPU working correctly in Ubuntu. I read that it requires a recent kernel and mesa version. I've installed the latest kernel (5 RC 6) and the latest mesa open ...
0
votes
1answer
319 views

can i use Mesa 18.1.1 as intel graphic driver and nvidia 415.25 graphic driver for nvidia 940mx and switch them using sudo prime-select?

My laptop has hybrid graphics with ubuntu 18.10 and both Intel HD620 and Nvidia 940mx. when I switch Nvidia graphics it works with zero lag, but Intel graphic lags, so I installed mesa 18.1.1 for ...
0
votes
1answer
711 views

Ryen Raven Ridge 2400G Problems on Ubuntu 16.04

First off, I am a new Linux user and I am still learning how everything works etc... I have been having problems running Linux on my Dell Inspiron 5575 with the Raven Ridge Ryzen 5 2400G. Random ...
1
vote
2answers
4k views

Reinstall MESA driver

I'm new here and will be thankful if you help me in this case. I dunno why, but somehow I did upgrade video driver and now I want to restore the original one for current system. Is this safe and is it ...
4
votes
2answers
11k views

Ubuntu 18.04.1 LTS R9 390X amdgpu guide / testing summary

I cannot get amdgpu to load as driver. Instead it always loads radeon. Setup: Ubuntu 18.04.1 LTS i7-5830k 2x R9 390X
0
votes
0answers
486 views

Is 18.04.1 compatible with my Gemini Lake laptop?

I'm getting a Lenovo V130-15IGM 81HL002VGE with a N5000 Gemini Lake SoC. I'm inclined to go with LTS but does 18.04.1 come with a new enough version of MESA? Also do you think I should go with 18.10 ...
1
vote
0answers
207 views

How to compile Mesa with debug symbols?

I want to modify Mesa's source code and build it with debugging symbols enabled. I downloaded and built the sources with these commands: sudo apt build-dep libgl1-mesa-dev apt source libgl1-mesa-dev ...
0
votes
0answers
1k views

mesa-vulkan-drivers not working on Ubuntu 18.04 ? vulkan-smoketest fails

I am on Ubuntu 18.04 with an Intel CPU (8700k Coffee Lake) and a GTX 650 graphics card. I have the nvidia propretary drivers 390.87 installed for the GTX 650, and vulkan-smoketest succeeds (see the ...
-2
votes
1answer
151 views

SketchUp WebGL application hangs in the Ubuntu-based OS's 16.04, 18.04, which running on the hardware, but works in the same OS's in the Virtualbox

I am trying to use this app on the Ubuntu 18.04: https://app.sketchup.com/app, but have a problem. When the model is bigger than the screen and is moving behind the upper border, the SketchUp hangs. ...
0
votes
0answers
23 views

How to force the use of AMD R7 265 in Notebook with Ubuntu 18.04 LTS that uses two video cards controlled only by software? [duplicate]

I would like to run my R7-265 video card in my ubuntu 18.04 LTS. The problem is that you do not provide support since ubuntu 14.04 LTS later. (the screen below) And I'd like to use my video card. How ...
0
votes
1answer
3k views

OpenGL not rendering in Ubuntu 18.04

I was practicing OpenGL by making small demos, the demos were running well but after I switched to Ubuntu 18.04, the objects are not rendering any more. The program compiles with no errors but I get ...
1
vote
1answer
1k views

Upgrade mesa-utils Ubuntu 18.04

I love Linux so I tend to play games on Linux. So I install steam on ubuntu 18.04 The game I tried to play needs OpenGL 3.1 see here So, I did some search on the internet and I found this After ...
3
votes
0answers
2k views

glxinfo Error: couldn't get an RGB, Double-buffered visual

I have a Ubuntu 16.04 server with 3 Quadro P5000. I downloaded LINUX X64 (AMD64/EM64T) DISPLAY DRIVER with version number 390.77 I installed several mesa packages $ apt list --installed | grep mesa ...
2
votes
1answer
1k views

Vulkan video backend on Intel graphics card/mesa driver on Ubuntu 16.04

I saw in Dolphin emulator that Vulkan was a video backend option, like OpenGL, I use an Intel graphics card with Mesa driver that came with my Ubuntu install. How do I check my Vulkan version, and ...
3
votes
2answers
3k views

How to install Mesa from source?

How to install Mesa from source code in Ubuntu 18.04? I downloaded mesa-18.1.3.tar.xz from here ftp://ftp.freedesktop.org/pub/mesa/ then extracted it, then in the directory with the sources did the ...
0
votes
0answers
174 views

Installing Mesa 17.3.9

I just upgraded my graphics driver to the latest Mesa 18.1.1 and need to revert to the stable 17.3.9 version. Could anyone please help me with the terminal command lines? I am currently using Ubuntu ...
0
votes
0answers
38 views

libwaffle-1.so.o: cannot open shared object file: No such file or directory

I have Ubuntu 16.04 OS and am trying to perform tests on piglit. I have a Fermi GPU (GE4 GTX 480). This is the error I receive. Could you please guide? https://drive.google.com/open?id=...
1
vote
0answers
779 views

steam: missing libGL.so.1 and libdrm.so.2

I am attempting to install steam from the ubuntu repos on Xubuntu 17.10, and am running into a dependecy issue. Steam requires these two 32bit libraries: The following packages have unmet ...
2
votes
0answers
535 views

xdriinfo says Screen 0: not direct rendering capable

When I give xdriinfo command to check the driver associated with my laptop screen, I'm getting the following response although I have Intel HD Graphics 5500 Screen 0: not direct rendering capable. ...