Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [mdadm]

a utility to administrate Linux Software RAID devices

0
votes
0answers
20 views

mdadm - setting faulty device doesn't result in new mail in the root mailbox

If I understand correctly, mdadm is supposed to mail root when something fails because it has MAILADDR root in mdadm.conf But sudo mdadm --manage /dev/md0 --set-faulty /dev/sdb1 and then sudo ...
0
votes
1answer
29 views

Ubuntu MDADM raid drive failure?

I have an QNAP running Ubuntu and the drives in an MD software-raid, but after a reboot, the server went to emergency mode (which I recovered from by removing the raid from fstab). (The front LED's ...
0
votes
0answers
13 views

Ubuntu installation in raid 5 array

We have created raid 5 through hardware controller in the server. and installed the Ubuntu OS in the array. it gets installed successfully , but the server doesn't boot next time after the restart ...
1
vote
1answer
46 views

Cannot mount drive under ubuntu server 18.04

I have upgraded my home server from ubuntu 12.04 to 18.04. The system holds 2 disks of 2.0TB in Raid 1. When I try to mount them on the 18.04 I get the following error. mount -t ntfs /dev/md126 /mnt/...
0
votes
1answer
36 views

mdadm.conf file needed? How to create and where?

I'm running ubuntu mate 18.04. My system is on an nvme. I had a 4TB HD with all my back ups along with my plex media. I got a second identical HD for Christmas and used it to create a raid1 array ...
2
votes
1answer
107 views

server installation with intentionally incomplete raid1

I'm upgrading a current 16.04 server to 18.04. The / and /boot partitions are mirrored (simple mdadm). To avoid the risk of a failed installation, I broke (--fail then --remove) the mirror and am ...
0
votes
1answer
39 views

Unable to mount partition from NAS RAID array to recover data

I have one disk of a 2 disk raid1 array that failed in the raid device. The manufacturer and subsequent investigation indicates it is formatted as a linux disk. fdisk -l displays Device ...
0
votes
0answers
17 views

RAID6 Array MDADM Assemble Force Not Working Out of date?

Hope someone can help me, I think I know what next step to take, but I don't want to lose any data! Somehow I got into a situation where the RAID6 went inactive, following some Googlefoo I stopped it ...
0
votes
0answers
50 views

Clonezilla (Bionic Beaver) not seeing Intel RST RAID0 (even as individual disks)

I'll admit I'm kind of an idiot when it comes to Linux, and I've spent the last three days trying to migrate from a single disk to two disks in RAID 0 using my BIOS' Intel RST RAID solution. I've ...
0
votes
2answers
156 views

Dual booting with Fake Raid 0 (intel rst)

I have working windows 10 on this fake raid 0. Windows shows raid as a Intel Raid 0 Volume I want to install ubunt (tried other flavours of linux but no luck too) and ubunt doesn't see my fake raid. ...
1
vote
0answers
38 views

Mirrored Volume of Windows to Ubuntu RAID 1

I am dual booting Windows 10 and Ubuntu 18.10. The D:\ Drive has a mirrored volume on another hard disk. I am trying to use mdadm to setup similiar mirroring on Ubuntu so that, regardless which OS I ...
0
votes
1answer
40 views

mdadm automatically removes drive from array

I've successfully configured a raid 1 array with mdadm. Both drives have a raid partition and an uefi partition with GRUB installed. When I execute "cat /proc/mdstat", I have a working array with 2x ...
0
votes
0answers
15 views

RAID5 with differently sized drives?

I have a mdadm RAID5 across 6 1TB disks. One of the drives failed recently so I replaced it with a 2TB disk. Is there any way to make the RAID larger so it can use some of the extra space on the new ...
0
votes
0answers
12 views

Problem moving RAID 1+0 to new MB with fresh installation

I had a perfect functioning 4 1TB disks mdadm with ubuntu 16.04 LTS: sdb1 & sdc1 RAID1 (md0) and sdb1 & sdc1 RAID1 (md1) md0 and md1 in RAID0: 2TB RAID 1+0 But I had to change MB ...
1
vote
0answers
17 views

Moving a RAID5 from Windows 10 to Ubuntu 18.04

I've converted a Windows 10 box over to Ubuntu 18.04 . I've been using a Mobius 5-Bay external enclosure set to RAID5 for a few years and am now attempting to mount and use it in Ubuntu. After looking ...
0
votes
0answers
115 views

Ubuntu Server 18.04.1 Initial mdadm Setup

I need some help with setting up a basic RAID 1 using the new 18.04.1 server installer. There's a lot of outdated stuff out there, all referencing version 16.04 and earlier, a lot that show setting up ...
0
votes
0answers
21 views

What happened with the “mdadm doesn't start array with external bitmap” bug?

My system seem to be affected by this bug: https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/803737 The symptoms are exactly the same. The bug is marked as fixed in Debian and Confirmed/Unassigned ...
0
votes
1answer
17 views

MDADM fresh install disk failure

I'm having a unique mdadm issue. I have an 8 disk raid5. (storage, not boot disk). I sold the computer, so I put a fresh install of ubuntu on it. In that time, one of the drives died. So there ...
0
votes
0answers
102 views

Can't find RAID array after HW upgrade Ubuntu 18.04

I had a RAID1 configuration set up using this RAID guide (DigitalOcean) on my home server. It was working great until I upgraded the motherboard and cpu. The disks used in the array both have ...
0
votes
0answers
63 views

After upgrading to 18.04 from 16.04 my software RAID1 array cannot be assembled by mdadm

I had been using two 4TB hard disks /dev/sdb and /dev/sdc in a software RAID1 array and after upgrading to 18.04 (from 16.04) it seems that I cannot assemble the array (mdadm --assemble cannot read ...
0
votes
1answer
27 views

mdadm array doesn't assemble on boot

Following this guide https://www.digitalocean.com/community/tutorials/how-to-create-raid-arrays-with-mdadm-on-ubuntu-18-04 on creating a Raid5 array on Ubuntu server 18.04. The array creates fine ...
0
votes
0answers
48 views

Recent instructions for mdadm RAID-1 and LUKS setup on UEFI systems

I have been trying to find a recent document on installing Ubuntu (18.04 preferred) using mdadm RAID-1 mirrors and LUKS underneath mdadm. The main point of using LUKS under the mdadm layer is that ...
1
vote
0answers
259 views

Speed of software RAID 0 with 4 SSD drives is strange

Situation: I have a server working on Ubuntu Server 16.04. I created software RAID 0 array that contains 4 SSD disks. When I checked the speed of the RAID array on my server I was confused. I was ...
0
votes
2answers
121 views

BCache + MDADM running extremely slow

I have 3x 14TB toshiba drives mdadm-ed (/dev/md0) raid 5'd together that are setup as a bcache. I have a 256GB fast SSD as the front of the bache. write-back is enabled on bcache. After a few days, ...
0
votes
0answers
14 views

Raid 1 created subpartition automaticallly

I have been making software raid1 with 2 2T hdd. Each hdd has two partition of /dev/sda1(18G),sda2(1.8T) and /dev/sdc1(18G),sdc2(1.8T) I used command mdadm --create /dev/md0 --level=raid1 --raid-...
0
votes
0answers
68 views

How can I recover a raid 5 single disk or entire array?

I have three disks that where part of an array on a debian box that will no longer boot. Im have installed them in a ubuntu 18.04 box and am attempting to mount them but get the error "can't read ...
0
votes
0answers
162 views

Migrating RAID to Ubuntu 18.04

I have a RAID 1 array with two disks, running on Ubuntu 14.04. I am planning on installing Ubuntu 18.04 onto the system partition (sda1), and once the new OS is installed, i need to reassemble or ...
0
votes
0answers
8 views

looking for a utility that can check/fix an ARRAY (mdadm) that throws an “Invalid Argument” error when attempting to assemble

I have a HDD with a partition that had(has?) a valid ARRAY on it. Before altering the partition size I could assemble this ARRAY (RAID1=clean,degraded) and access the data. I needed to shrink the size ...
1
vote
1answer
87 views

Upgrade instructions if using software mirroring from 16.04 LTS to 18.04 LTS

I'm on Ubuntu 16.04.5 LTS ... I think I'd like to jump to 18.04, but I'm not sure what (if anything) I need to do with my mdadm array(s) I have two RAID 10 devices... one is a 35 GB swap (md0) and the ...
0
votes
2answers
255 views

How can I configure postfix to send emails via gmail (2FA problems)?

I have a new Ubuntu 18.04 system and want to have mdadm, smartd, et al. to send warning emails through my gmail account. I have followed the guides in How can I configure Postfix to send all email ...
1
vote
0answers
75 views

Fix damaged GPT on mdadm software RAID array

I have a RAID array setup with two member disks sda and sdb. I am using mdadm along with Intel RSTe (for OS compatibility purposes). I have the following errors. sgdisk -v /dev/md126 Warning! Disk ...
1
vote
0answers
33 views

RAID5 (md0) isn't mounting (Ubuntu server 16.04)

Background: I'm not a total newbie, but Linux is not my thing. Current hardware is an old Atom box running 16.04 (It's just a file server). It has a small system disk and 3 larger disks running in ...
1
vote
0answers
218 views

Mount a linux_raid_member (level 1)

Original topic: https://unix.stackexchange.com/questions/78804/how-to-mount-a-disk-from-destroyed-raid-system I did it by the "hard way": (first if its possible clone this disk before you do ...
1
vote
1answer
46 views

Old Raid1 working on new Ubuntu Server install?

I recently did a fresh install of Ubuntu Server 18.04 over my old 16.04 install. I had a Raid1 config in my old setup, which I administered through mdadm. It seems as if my Raid1 config is still ...
0
votes
0answers
28 views

Moving /home while also specifying mdadm (/etc/md0) in fstab?

I believe I'm supposed to ask a new question, as the previous one was incorrectly marked as a duplicate. I'm new and not sure how to justify it's unique context. I've added this below. This is in ...
1
vote
0answers
48 views

Not able to create file system, mount or delete for my RAID

This is my first time building my own RAID and I think something is messed up and I have no idea what to do next. I have looked all over the interwebs and have not found any solutions that help. I ...
1
vote
0answers
397 views

RAID inactive and new md127 was somehow added as raid disk

I'm currently trying to get our RAID working again after the server crashed. The setup is: one RAID with 2 hard drives and a second one with 7 hard drives. But apparently after I tried to start it ...
0
votes
0answers
33 views

RAID0 will not assemble on boot, not able to assemble manually

our lab's RAID0 array has seemingly stopped working. The system knows there are drives there, but I haven't been able to assemble them no matter what I try googling around in these forums. I've ...
0
votes
0answers
33 views

Why won't mdadm add a disk to an array when it says nothing is wrong with it?

My raid setup is booting into a degraded state. In dmesg I see an error that the disk does not contain a v1.2 metadata super block. But mdadm --examine says that it does. Two questions really: How ...
1
vote
1answer
778 views

unable to use RAID disk during ubuntu 18.04 server installation (curtin installer)

I create a RAID 5 Volume with 5 Hard Disks by Hardware RAID, and intend to install ubuntu-server 18.04 by USB. First I encounter MODSIGN: Couldn't get UEFI db list, unable to open /dev/sda after few ...
0
votes
0answers
142 views

Following upgrade from 16 to 18 boot erroneously requires mdadm initialization

I've recently upgraded the packages found in 16.04 to 18.04 via updating apt/sources.list as explained for example here. This process failed several times because of conflicting dependencies for ...
0
votes
0answers
11 views

Attempting reassembly of broken Raid1 array, added 1st drive, mounted, shows 2016 files only?

So, I resolved a booting-to-Busy Box (initramfs) issue with FSCK /dev/sda, but on successfully rebooting, found my 5TB RAID1 array on /dev/md0 (2 drives) was INACTIVE. No apparent reason as nothing ...
0
votes
1answer
731 views

“mdadm: Duplicate MD device names in conf file where found."

Problem: When I boot my Ubuntu 16.04 (Server) box. I'm dropped to a Busybox V1.22.1 (initramfs) prompt I receive a message “mdadm: Duplicate MD device names in conf file where found.” Good to know ...
0
votes
1answer
1k views

Ubuntu 18.04 server and RAID - fakeRAID or hardware or mdadm

I'm unclear what my best option is to install Ubuntu 18.04 server onto a new machine. I initially thought I'd be able to set up a RAID 1 mirror on my 2 SSDs in the UEFI menu and use that. Following ...
0
votes
1answer
866 views

Ubuntu Server 18.04 Intel RAID (RST) can't detect the RAID

I've created RAID10 in BIOS (Intel RST). In 16.04 everything was OK. And in 18.04 I can't see my raid at all. I choose: Active MDADM containers (Intel/DDF RAID) => "yes" Activate Serial ATA RAID ...
0
votes
0answers
17 views

mdadm create speed has decreased massively, faulty drive? Will it speed up again?

I'm trying to set up an array in RAID 5 with 5 4TB HDDs, I'm using mdadm and to begin with things seemed fine, here is the first progress report. Personalities : [raid6] [raid5] [raid4] md0 : active ...
0
votes
1answer
22 views

Dismissing a RAID1

I've a task in mind that sounds simple, but I'm not sure it would be possible to complete. I'm dismissing a server, on which I've all partitions (boot partition and others!) mirrored as RAID1 through ...
2
votes
0answers
80 views

Can't create LVM on RAID1

I have issue creating LVM on RAID1. I have formatted two HDDs for Linux RAID Disk /dev/sdg: 9.1 TiB, 10000831348736 bytes, 19532873728 sectors Units: sectors of 1 * 512 = 512 bytes Sector size (...
2
votes
1answer
63 views

Adding Disk to Degraded RAID1 Array

I am trying to add a disk (sdc1) to a degraded RAID1 array (md126), but I don't know how to proceed. Any help will be appreciated because I don't want to lose any of the data on the drive. Output isn'...
0
votes
0answers
23 views

Ubuntu Server MDADM Raid 6 Is lost on reboot

I am setting up my first software RAID for a Plex Server. I was able to create the array, set up samba file share and transfer data to and fro. But every time I reboot the system I lose the array. ...