Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [matplotlib]

matplotlib is a plotting library for the Python programming language

0
votes
0answers
26 views

Matplotlib output messed up in Kubuntu 18

I run the same Python3 code on several computers for plotting data. On one of them, I have got Ubuntu 16.04, the others are Kubuntu 18.04 and 18.10. In Kubuntu, the plot is completely messed up, the ...
1
vote
0answers
24 views

How to get matplotlib.pyplot to work on ubuntu?

I'm using Ubuntu to run and compile python. When I tried to import matplotlib.pyplot it said it wasn't found. So I installed matplotlib using pip install matplotlib it said it installed but now I am ...
0
votes
0answers
425 views

Installing Basemap with Python3.6 on Ubuntu 18.04

I have been trying to get Basemap up and running for the past couple of hours. Following this tutorial I run: conda install basemap in my venv on Pycharm. Installation goes as planned and I get a ...
0
votes
1answer
770 views

graph created by matplotlib.plot.show closed automatically after the python script finished through command line [closed]

I want to plot a graph and keep it even if the script finished. But it failed after I tried many times. After script finished executing, the graph created by the show() method will be closed ...
0
votes
0answers
264 views

Can't run Basemap

I installed Basemap using conda install basemap and also I run conda install basemap-data-hires But I'm still getting the same error ModuleNotFoundError: No module named 'mpl_toolkits.basemap' I ...
0
votes
1answer
750 views

matplotlib error : MatplotlibDeprecationWarning

from matplotlib import pyplot as plt /home/rishabh/.local/lib/python2.7/site-packages/matplotlib/colors.py:680: MatplotlibDeprecationWarning: The is_string_like function was deprecated in version ...
2
votes
2answers
3k views

Python matplotlib - ImportError: No module named functools_lru_cache

I have installed matplotlib for Python using pip which was completed without error. Yet I get this error when I try to import it: import matplotlib Traceback (most recent call last): File "<...
4
votes
2answers
3k views

What is a good, default backend for matplotlib

I've decided to setup a custom matplotlibrc, and thus I need to pick a backend for matplotlib. What is the best one in terms of not needing to install other additional packages? I tend to use ...
1
vote
0answers
117 views

Build matplotlib dependencies for both python2 and python3

I would like to have various virtual environments in my computer, some of them running python 2.7 and others with python3, and some of them must have full matplotlib support, which is achieved with --...
1
vote
2answers
2k views

Problem in installing matplotlib ubuntu 16.04

I have to install python package "matplotlib" in Python 2.7; Ubuntu 16.04 After inserting: pip install matplotlib I get the following error messagge: open here error picture I tried this solution: ...
2
votes
1answer
19k views

How to fix install error “Could not find a version that satisfies the requirement pyplot”?

I am trying to install pyplot as follows: x@y:~$ sudo -H pip3 install pyplot Collecting pyplot Could not find a version that satisfies the requirement pyplot (from versions: ) No matching ...
0
votes
1answer
157 views

installation issue with matplotlib

The following happens whenever I try to install matplotlib vijay@vijay-Inspiron-1545:~$ python -mpip install matplotlib Collecting matplotlib Exception: Traceback (most recent call last): File "/...
-1
votes
1answer
1k views

matplotlib.pyplot is not working!

I'm using Jupyter Notebook, and matplotlib.pyplot is not working. I'm using Python 2.7 in Ubuntu 14.04.
1
vote
1answer
1k views

Kernel dead in jupyter notebook, matplotlib seems not to work

I recently updated my anaconda package with $conda update conda and then $conda update anaconda After that update my matplotlib is not working anymore and every time I try to run Jupyter notebook and ...
1
vote
1answer
732 views

17.04: using matplotlib with GTK-based backend?

On a new 17.04 Ubuntu system, with python and python-matplotlib, I wanted to plot using the Matplotlib GTKAgg or GTKCairo backends. This works nicely in 16.04, but is broken in 17.04, as a result of ...
-1
votes
1answer
365 views

apt-get not recognizing newest version of python-matplotlib

I'm trying to update matplotlib from an old to the newest version 2.0.2. Through apt-get I am told matplotlib is already the newest version "1.5.1" Do I have to update the repository or something ...
1
vote
1answer
497 views

Deleting .ICEauthority file

I had some problems with matplotlib (Python). Someone had suggested deleting .ICEauthority file. I did it and my problem with Python is solved. Is that going to cause any side-effects on my system?
1
vote
1answer
546 views

How can I install a pdf font?

I am trying to save a matplotlib plot as a pdf page as shown in this example. Everything is fine until tex fonts are used. That is, I can display plots that use tex fonts, but not save them as a pdf. ...
0
votes
1answer
620 views

Unable to run python code because of Cycler dependency of Matplotlib

I have a small python program that calls on matplotlib. It seems that this library is dependent on "Cycler" which is giving me this error: Traceback (most recent call last): File "main.py", line 1,...
0
votes
0answers
43 views

Matplotlib won't import [duplicate]

I tried to download matplotlib using sudo apt-get install matplotlib, per their website, and that failed, since it won't import and I have literally no idea where it installed. I know that it must ...
1
vote
1answer
10k views

Plot simple functions like sine of x with IPython

My teacher plotted some functions with Jupyter Notebook or IPython. I have installed Jupyter Notebook and have the home screen, but how can I plot a function? I have already tried: plot sin(x) but I ...
1
vote
1answer
460 views

16.04LTS breaks matplotlib in interactive mode

Consider the following python code import matplotlib.pyplot as plt import time plt.ion() plt.figure() plt.scatter(1,2) plt.draw() while True: time.sleep(1) I try this on a fresh install of ...
0
votes
0answers
554 views

python3 module import and installation

I'm trying to install matplotlib. This is what I get when I use python3 in terminal. However, in my python file, it still shows that I do not have matplotlib module. :( Why is this? python3 >>&...
2
votes
0answers
227 views

Plotting with Octave and Matplotlib Broken on Ubuntu 16.04

I'm having a problem using plot commands using python-matplotlib and Octave ever since I installed Octave. Prior to installing Octave v4.0.2, I was able to plot with Matplotlib v. 1.5.1 just fine. ...
3
votes
1answer
8k views

Unable to install matplotlib using pip in Ubuntu 16.04

In Ubuntu 16.04 I am able to install almost every python package and library using pip except for matplotlib. I use this command to install matplotlib pip install matplotlib This gives the error: ...
2
votes
1answer
4k views

When trying to import Matplotlib.pyplot, get “UnicodeDecodeError”

When trying to run a Python script starting with import numpy as np import matplotlib.pyplot as plt I'm getting the following error message: /usr/lib/python2.7/dist-packages/matplotlib/font_manager....
4
votes
1answer
4k views

How to ensure matplotlib in a Python 3 virtualenv uses the TkAgg backend?

I am using Ubuntu 16.04 with Python 3. Using APT to install python3-matplotlib and then printing the matplotlib backend gives TKAgg, which is expected because Ubuntu has 16.04 has python3-tk installed....
2
votes
1answer
1k views

How do I install matplotlib dependencies?

How can I easily install all the non-Python dependencies I require before I can pip install matplotlib?
2
votes
2answers
4k views

Segmentation fault (core dumped) using matplotlib on Ubuntu Mate 16.04

I recently installed on my machine (an old imac) Ubuntu Mate 16.04. When I try to run a python script from terminal I get the error: Segmentation fault (core dumped) The same script works perfectly ...
6
votes
3answers
57k views

No module named 'numpy'

Actually I am shifting from Windows to Linux. Using pycharm on Windows I have a python 3 script that requires numpy and matplotlib to run, so I installed them on my Linux system using sudo apt-get ...
3
votes
1answer
9k views

How to install Python Matplotlib 1.5.1 on Ubuntu?

I want to install matplotlib 1.5.1 for python 3.4 on Ubuntu 14.04. But, when I type in the terminal sudo apt-get install python3-matplotlib, I just get matplotlib 1.3.1. I have tried to use pip to ...
2
votes
1answer
380 views

Error Getting Dependencies for Matplotlib

I am trying to install the python package matplotlib from source. I cannot install the package from the repository using sudo apt-get install python-matplotlib because I need to be able to install the ...
4
votes
3answers
5k views

matplotlib not working in Pycharm 4.5.3

I'm trying to run a simple code in Pycharm Community Edition 4.5.3 to display a graph with some points using matplotlib import matplotlib.pyplot as plt plt.plot([5,4,4,4,6,6,7,7,8,8,9,10,10,10,10,11,...
3
votes
0answers
4k views

Really installing PyQt4/5 for python 3.4 on trusty

I am using Python 3 on my ubuntu 14.04.2 (trusty), along with Python 2. I am trying to run ipython --pylab, but with Python 3, this fails (works well with Python 2). It fails since it needs QT4/5 or ...
1
vote
2answers
12k views

Python 2.7 matplotlib provides error?

import numpy as np import matplotlib.pyplot as plt provides the error Traceback (most recent call last): File "/home/xx/PycharmProjects/Udemy/Array_Processing.py", line 2, in <module> ...
2
votes
0answers
446 views

Installing python libs under Lubuntu 14.10 getting Errors

Hey there I need to install some python packages on my Laptop for work(university). The command they gave us is sudo apt-get install python3 python3-pip python3-pyqt4 python3-tk and pip3 install --...
1
vote
1answer
3k views

How to install numpy, scipy, and other packages from source for Python3 in Ubuntu 14.04.2 LTS

I just recently installed Ubuntu 14.04.2 LTS alongside Windows-7 (64-bit). I wanted to install the latest versions of numpy, scipy, matplotlib, and other packages for Python3. I saw the we can use ...
4
votes
1answer
4k views

Plotting with Matplotlib in Python 3 pylab: Tkinter and Qt FontManager errors

I'm trying to use pylab (i.e., $ ipython3 --pylab) in Python 3 on Ubuntu 14.04. I'm running into the same error regardless of whether I use the Tkinter or Qt4 backends. AttributeError: 'FontManager' ...
1
vote
0answers
607 views

matplotlib xkcd with utf-8 label

In python3 / matplotlib, I'd like a plot with a label: plt.plot(np.sin(np.linspace(1,10)), label='fête') plt.legend(loc='upper left') plt.show() Works great. Now let's try with xkcd mode: plt.xkcd()...
3
votes
1answer
980 views

Ubuntu 14.04 upgrade causes matplotlib error

Since upgrading to 14.04 any python code I run that uses matplotlib returns an error. Here is what my ipython console returns In [1]: import matplotlib.pyplot as plt ----------------------------------...
7
votes
1answer
1k views

Backend for python3 module matplotlib

I'm trying to use python3 to plot graphs. The only back-end for matplotlib that seems to work is tkAgg (Tkinter), however this looks like it has been designed in the Stone Age. So I was trying to ...
2
votes
1answer
4k views

How to install an earlier version of matplotlib?

I have matplotlib 1.3.1 installed on my computer. However I have to run some code that runs with matplotlib 1.1.1 but not with 1.3.1. Therefore I should remove this version and installed 1.1.1. How ...
2
votes
1answer
708 views

Problem embedding a pylab Figure in a Gtk application using quickly

I am currently trying to build a simple app that includes some pylab figures. I just started to use quickly and I am concerned about some import issues. That is, none of the matplotlib backends will ...
1
vote
3answers
31k views

matplotlib Error: No module named matplotlib even though it is installed

I have been through the process of installing matplotlib on my Ubuntu 12.04 computer. However, when I try to run a test program, I get the following error: Traceback (most recent call last): File "...
7
votes
2answers
3k views

Most up to date Ipython and Matplotlib in Ubuntu 13.10

I've recently updated my Ubuntu to the 13.10 version. To my surprise, Ipython and Matplotlib are available only in versions prior to those I had in my previous 12.04 LTS install. When with the 12.04, ...