Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [maas]

Metal as a Service – MAAS – lets you treat physical servers like virtual machines in the cloud. Rather than having to manage each server individually, MAAS turns your bare metal into an elastic cloud-like resource.

4
votes
0answers
362 views

How do I create custom RHEL image for Ubuntu MAAS?

I'd like to create custom image to deploy RHEL by Ubuntu MAAS, but it seems maas-image-builder is deprecated and it doesn't support to build RHEL image. Does anyone have idea to build custom image ...
4
votes
0answers
130 views

Need some help - installing multi-node OPenstack with Juju and Maas

I am trying to install multi-node OPenstack using Juju and Mass. Juju initializes 4 nodes and they all come up clean but get stuck at relations - attached picture for reference. Thanks in advance ...
4
votes
0answers
337 views

Using HTTPS with MAAS web interface login redirects to HTTP

I need to use HTTPS for login into MAAS web interface. But when I goto https:// ip-of-maas /MAAS/, it redirects you to http:// ip-of-maas /MAAS/accounts/login/?next=%2FMAAS%2F which makes HTTPS ...
3
votes
0answers
82 views

Errors creating OpenStack deployment with Autopilot

I'm following the guide, I correctly reached step 6. Now when I perform (from MAAS node, ubuntu user): ubuntu@maas-server:~$ /snap/bin/conjure-up --bootstrap-to juju the procedure stops with the ...
3
votes
0answers
70 views

Computer Clustering

I know this question has been asked earlier but am not able to get a simple step by step answer. What I need is : Create a seemless Cluster where I would Use 1 Laptop as Main PC where I can work on ...
3
votes
0answers
208 views

crm status failing to work after adding remote node

My setup: 1. Ubuntu 14.04.4 LTS 2. Kilo Release (2015.1.3) 3. pacemaker: 1.1.10+git20130802-1ubuntu2.3 4. pacemaker-cli-utils: 1.1.10+git20130802-1ubuntu2.3 5. corosync: 2.3.3-1ubuntu2 6. libcorosync-...
3
votes
0answers
108 views

Cannot Deploy Charms from Charm Store

Ran into a strange problem, on juju 1.24.2-utopic-amd64 and 1.7.0+bzr3299-0ubuntu1~utopic, when trying to deploy a charm to a node, e.g. juju deploy --config ./kilo.yaml nova-compute nova-compute-01 -...
3
votes
0answers
302 views

Wordpress deployed with JUJU using LXC fail

When I deploy the wordpress and mysql charms with juju on my maas controller like so: juju deploy --to lxc:0 wordpress juju deploy --to lxc:0 mysql juju add-relation wordpress:db mysql:db --debug ...
3
votes
0answers
346 views

Canonical openstack deployment, an issue with JuJU

I'm deploying canonical openstack in my lab environment on following topology: -------------- MAAS + DHCP VM -------------- |-Switch-| |_ Server 1 |_ Server 2 |_ Server ...
3
votes
0answers
299 views

Adding network to machine deployed by Juju

I have a small OpenStack cluster deployed with Juju/MAAS. How can I add an extra network to one of the already deployed machines? Because the cluster is operational I would like to avoid redeploying ...
3
votes
0answers
813 views

JUJU Error “ERROR failed to bootstrap environment: waited for 10m0s without being able to connect: ”

Having a bit of a struggle with bootstrapping Juju using juju-quickstart -i With two separate ubuntu clusters, we are having the same exact error (displayed below). I've confirmed I can SSH to ...
3
votes
0answers
728 views

Juju bootstrap node can't access Ubuntu archives via MAAS

I am trying to install MAAS and Juju on VirtualBox. The network configuration of VirtualBox is set to NAT Network. Everything is just fine. I am able to PXE boot. But when I start juju bootstrap, ...
3
votes
0answers
229 views

Maas out of sync with lshw

I created a maas tag with $ maas-cli maas tags new name='5-disks' comment='A machine that has at least 5 hard disks' definition='count(//node[starts-with(@id,"disk") and @class="disk"]) >= 5' But ...
2
votes
0answers
149 views

MAAS Users and LDAP integration

I have 20+ users on my staff (which is constantly fluctuating) and it is a little inconvenient to constantly add/delete accounts in multiple places. Will MAAS eventually support LDAP so I only have to ...
2
votes
0answers
125 views

deployment fails with juju and Maas

I am trying to bootstrap a VM machine in order to deploy Openstack cloud and it hangs as below: maasadmin@FGSUSSUMAAS01:~$ juju bootstrap stagingmaas Creating Juju controller "stagingmaas" on ...
2
votes
0answers
454 views

juju bootstrap hangs forever at “Attempting to connect to 10.X.X.X:22”

I am installing openstack Autopilot as per the below URL https://www.ubuntu.com/download/cloud/autopilot After executing the conjure-up --bootstrap-to this command juju bootstrap hangs at "...
2
votes
0answers
514 views

Trying to use MAAS 2.1.3 to deploy Centos 7

"Ubuntu MAAS 2.1.3" has several Ubuntu and Centos versions supported out of the box. Our environment has a target version of Centos 7 for general deployment in the lab. Ubuntu MAAS is working great ...
2
votes
0answers
36 views

Document Update Required about the Openstack Autopilot Installation

I am installing autopilot openstack referring to the guideline on the offical cloud website: The current issue is that we stucked at the juju bootstrap when excute "sudo openstack-install" at Step 6 "...
2
votes
0answers
742 views

grub-install : error: unable to identify a filesystem in hostdisk//dev/sdb error seen in MAAS UI console while deploying a node

I have configured a MAAS setup(version 1.9.4) for VM's. For one of the nodes I have attached 32GB disk (/dev/sdb). I am trying to deploy a juju charm which makes use of this storage ie /dev/sdb. When ...
2
votes
0answers
193 views

juju bootstap command goes from 'preparing…' to 'destroying..' (instance started … but not deployed)

I'm trying to setup a MAAS, JUJU based openstack cloud, and can't seem to get the juju controller installed. The bootstrap command seems to succeed on to the 'Preparing for Juju GUI 2.1.10 release ...
2
votes
0answers
538 views

MaaS fails commisioning node

After having setup MaaS (DHCP configured), I am able to PXE boot a node but get a lot of warnings like "Temporary failure to resolve proxy" with Xenial after it reaches its login screen. Then it shuts ...
2
votes
0answers
244 views

Apple Mac Pro as part of a MaaS Cluster?

Has anyone tried putting a Apple Mac Pro in a MaaS cluster. Basically we have a internal cluster for development builds, continuous integration, automated testing etc. We need to support Linux, ...
2
votes
0answers
102 views

Does services like Trove, Ceilometer et cetera come with Ubuntu Openstack Autopilot?

1. Since there is limited information(yes) about the current and updated status of ubuntu openstack autopilot on your website, i will like to find out if all services of openstack will come with ...
2
votes
0answers
406 views

How to deploy ramdisk image on to disk less nodes using MAAS?

I am using MAAS version 1.7.6 with ubuntu 14.04. Currently MAAS can deploy ubuntu/centos images on to the nodes by installing into local disk. I want to deploy my disk less nodes with ramdisk image. ...
2
votes
0answers
31 views

Ceph cannot reformat because disk is mounted

I am using MaaS 1.8, trying to use the juju-deployer with juju-deployer -c config.yaml -d vivid-kilo -e envName Here is my config. http://pastebin.com/TsvdnSKA Here is the error output: http://...
2
votes
0answers
190 views

MAAS detected disks de1GB and Landscape detects nodes but with checklists(X)

My problem is that MAAS, with hard drives does not recognize your storage capacity, and continue with the installation checklist landscape in brand teams recognize but with a red X. equipment ...
2
votes
0answers
512 views

Landscape Openstack-installer fails during juju bootstrap

I've got my MAAS and behind my server I've got my 5 nodes all are ready to use (status ready in MAAS) First I used MAAS and JUJU without Landscape and it works perfectly fine. Juju bootstrap OK. Use ...
2
votes
0answers
61 views

Bringing up interfaces on ceph nodes

I have machines under MAAS with 4 interfaces. I want to configure my ceph nodes to use two networks that are not the pxe boot network. MAAS doesn't "up" all of the interfaces when a machine is ...
2
votes
0answers
571 views

Juju incomplete Neutron installation

We have installed Openstack on distributed nodes using Juju + MAAS. Everything looks good, but Neutron cli is unresponsive. user@controller:~$ nova list +----+------+--------+------------+------------...
2
votes
0answers
121 views

Strange behaviour observed on Ubuntu MAAS Juju server

Sorry for the wall of text. I have observed some pretty strange behaviour in Juju and our Ubuntu MAAS OpenStack over the last couple of weeks, seemingly totally out of the blue (I was out of the ...
2
votes
0answers
183 views

Does there exist a way within the context of MAAS to specify which disk shows up as sda when provisioning nodes with multiple disks?

I am looking for a method by which I can specify the disk elected to be sda on enlisted MAAS nodes with multiple disks when they undergo commissioning, OR a method to specify which disk of those found ...
2
votes
0answers
808 views

openstack-install Can't import Boot Images

Trying openstack-install, http://www.ubuntu.com/download/cloud/install-ubuntu-openstack, on a Trusty server - hoping to get Openstack Juno going - but having problems with importing images. Install ...
2
votes
0answers
875 views

Nova get-password returns empty string

I have a multi-host MaaS, Juju Openstack deployment. Each charm on different host, multiple nova-compute units (nodes). And Im using Quantum charm for networking. When I attempt to retrieve the admin ...
2
votes
0answers
2k views

Maas cannot power control virsh node

Maas is not able to power-control vm-nodes. If i try to commission a declared vm node with the power settings: Power address: qemu+ssh://ubuntu@192.168.25.14/system Power id: vm1 the node does not ...
2
votes
0answers
93 views

Deploy ubuntu with MAAS fails

I have a problem with the Ubuntu deploying with MAAS. I'm trying to install Ubuntu on a KVM virtual machine. The boot with pxe works, I see the login prompt during the deploying, the server connect ...
2
votes
0answers
1k views

Ubuntu MAAS DHCP working DNS Not working

I setup Ubuntu 14.04 MAAS on one server. I setup interface to manage DHCP and DNS via the Cluster interface. DHCP is working. But, DNS is not! When I try to add another node, it is doing PXE boot, ...
2
votes
0answers
2k views

With MAAS set to manage DNS on a subnet on a private IP range, why do only some nodes have DNS entries?

I'm trying to set up OpenStack on MAAS, using trusty. I have a network between these machines all bridged/switched together. I have set up MAAS at 192.168.7.200, I have a Juju client machine at 192....
2
votes
0answers
817 views

ubuntu 14.04 maas doesn't auto detect ipmi

I have recently upgraded from ubuntu 12.04 to 14.04. When I pxe boot the nodes I get the message that the node has no power type set so I can't commission it. I have tried manually setting the IPMI ...
2
votes
0answers
448 views

Proper MaaS configuration

Working with Ubuntu Server 12.04 maas installation, and I am having trouble making sense of the official documentation: Docs I might be missing something, but I can't find any documentation on what ...
2
votes
0answers
578 views

MaaS dhcp cannot be detected at node installation

I am installing a MaaS Ubuntu 12.04 by ISO with virtualbox as the host machine. I have a problem on the cluster management during the process of adding the node. The node cannot detect the dhcp ...
2
votes
0answers
228 views

Infiniband + Maas?

I'm looking at setting up an HPC based on Mellanox Infiniband rather than Ethernet. Because I have many nodes to manage, I was looking at trying something new, like MAAS. I know Infiniband cards ...
2
votes
0answers
2k views

MAAS with external DHCP TFTP time out

I'm trying to get MAAS up and running, and I've installed the control node without maas-dhcp or maas-dns since I already have another DHCP server. I've set up the next-server attribute in my DHCP ...
1
vote
0answers
46 views

Series “Bionic” is not supported by charm, supported series are: Xenial,Trusty,Yakkety

I am trying to deploy Openstack using juju and also deploy bundle.yaml on Ubuntu 18.04. It fails with the error cannot deploy bundle: series "bionic" not supported by charm, supported series are: ...
1
vote
0answers
15 views

Does stable release of MAAS on Ubuntu 18.04.1 support Cavium ThunderX2 (ARM-based) server?

On my setup, MAAS server can power on/off the appliance. Commissioning failed. Machine summary shows CPU/Memory/Storage unknown. Looked inside a wireshark trace, communication between MAAS server and ...
1
vote
0answers
32 views

MAAS server won't recongnize nodes

I'm a newbie on researching and deploy MAAS Server with Juju and Openstack. I installed Ubuntu Server 16.04 on VMWare Workstation with 2 NIC: 1 of them is external network with Bridge Mode with IP ...
1
vote
0answers
30 views

LVM and dm_crypt with MAAS mounting issue

I'm trying to have MAAS/Curtin encrypt a single drive on deployment and so far I'm hitting some roadblocks when implementing encryption using the dm_crypt module from curtin. I can have curtin setup ...
1
vote
0answers
96 views

Network Error MAAS

I can not get MAAS to deploy a node. I can power the node off and on. I get the error below. Error:Node failed to be deployed, because of the following error: {"network": ["Node has no address family ...
1
vote
0answers
63 views

Problem enlisting node with MAAS : ipmitools has “no installation candidate”

I'm doing a project for my school where I have to set up MAAS and enlist different nodes. Sadly, when enlisting the node, the cloud-init does something similar to an "apt update" once the login ...
1
vote
0answers
240 views

Getting an initial error after maas setup

Getting error: ubuntu xenial is configured as the commissioning release but it is unavailable in the configured streams This is a brand new one to me as I have set up maas many times, so it must be ...
1
vote
0answers
121 views

conjure up error while installation cannot retrieve charm

I am deploying ubuntu openstack. in conjure-up after initialization and deployment of nodes Os, conjure up crashes with this error: cannot retrieve charm "cs:openstack-dashboard-252": cannot get ...