Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [maas]

Metal as a Service – MAAS – lets you treat physical servers like virtual machines in the cloud. Rather than having to manage each server individually, MAAS turns your bare metal into an elastic cloud-like resource.

0
votes
1answer
881 views

How do you add a machine to MAAS with IPMI power using CLI

I want to add a new machine to MAAS for commissioning and deployment using the MAAS CLI. What is the MAAS CLI command to add a new machine that supports IPMI power parameters?
0
votes
1answer
770 views

conjure-up stuck Attempting to connect to the bootstrapped node

conjure-up --bootstrap-to command was issued. It did bootstrap and maas did install ubuntu and the host is up and running. However, the conjure-up is hung at: user@maas:~/.cache/conjure-up/landscape$...
1
vote
1answer
152 views

Configuring maas-region-controller

When trying to install MAAS in a virtual machine, the following is displayed on the target's screen after running sudo apt-get install maas. The virtual machine is built by vagrant. Is there has any ...
0
votes
0answers
88 views

Xenial-maas container not running

I have installed a xenial-maas container using this doc Last step gave an error - something about br0 gert@cpru1:~$ sudo lxc list +-------------+---------+-----------------------+--------------------...
0
votes
1answer
133 views

MAAS is unable to detect subnets

I have created fresh maas setup with version 2.2.1-6078-g2a6d9. It's unable to detect subnets. Errors from maas.log: Jul 17 07:08:44 pranita_maas maas.dhcp.probe: [error] Can't initiate DHCP probe; ...
0
votes
1answer
553 views

MAAS IPMI power password

I'm trying to run ipmipower -D LAN_2_0 -h 192.168.13.135 -u maas -p xxx --cycle --on-if-off command to verify why my MAAS node is failing to deploy an OS, but need to know the maas ipmi power password....
0
votes
1answer
640 views

What are possible causes for error PXE-E99 during MAAS machine commissioning

When trying to commission a node in MAAS, the following is displayed on the target's screen after boot: Booting from PXE Device 1: Integrated NIC 1 Port 1 Partition 1 >>Start PXE over IPv4. ...
0
votes
1answer
493 views

can I delete virbr0 and virbr0-nic created by MAAS?

When installing MAAS, it creates virbr0 and virbr0-nic and an associated fabric and subnet (e.g. 192.168.whatever). What's the purpose of these? Can these be deleted from the OS (e.g. ip link del) ...
0
votes
1answer
437 views

MAAS server network configuration

Scenario: MAAS Server: 10.1.1.100/24 [VLAN1] Physical Server IPMI (Dell iDRACs): 10.1.2.0/24 [VLAN2] Physical Server OS Management Network: 10.2.3.0/24 [VLAN3] I believe IPMI is from MAAS > iDRACs ...
0
votes
1answer
278 views

add machines and devices to MAAS with CLI

I would like to pre-populate MAAS with new machines for future OS deployments. For example, I have 10 servers, each with a quad port nic. I know the MAC addresses (40) that belong to the servers (10)...
0
votes
1answer
585 views

Launch OpenStack Autopilot: Stuck “waiting for machine” while attempting to conjure-up Landscape

I need help with conjuring-up Landscape. This is step six in the Installation instructions. MAAS has been installed(master node), and we have 9 other machines commissioned and ready for use. ...
0
votes
1answer
56 views

Connect mongodb across 2 ubuntu 14 servers

I have a node app install in 10.10.xx.xx1 and a mongod server running in 10.10.xx.xx2. Both servers are running on a same network. I am trying to connect the node app to the mongo server from the ...
1
vote
2answers
2k views

stack.sh script to install OpenStack fails with error “can't find systemd-python” on Ubuntu 16

I am trying to install openstack in ubuntu 16. I am following this tutorial: OpenStack install on Ubuntu 16.04 server - DevStack I am executing these commands and the stack.sh script: k@ubuntu:~$ ...
2
votes
2answers
218 views

Different clock time on Maas server and its nodes

After I deployed Maas and Canonical Distribution of Openstack on a virtual environment (VMware ESXi), I found out that Maas server has a correct clock time while the nodes used for Openstack have ...
0
votes
1answer
581 views

conjure-up - connection attempt for failed: ssh: - help

i have a problem with conjure-up installation ... Every time I get stuck at Attempting to connect "IP":22 ... I have a test environment now with 3 same servers (Intel SR1500) ... I have very ...
1
vote
0answers
303 views

How to add custom power type to MAAS 2.1.x to use PC power control using raspberry pi

I have built raspberry pi with Piface to control my physical pcs, I have server with Ubuntu 16.04 and installed MAAS 2.1.5 on it. There was old post, how to build pc power control using ubuntu 14.x ...
1
vote
0answers
169 views

“sudo conjure-up --bootstrap-to juju” command is not working

This is my first time, i am trying to install openstack on ubuntu, using vms. I have a private network for PXE boot only managed by maas vm and have other vms as nodes. One vm which i want to setup ...
2
votes
0answers
454 views

juju bootstrap hangs forever at “Attempting to connect to 10.X.X.X:22”

I am installing openstack Autopilot as per the below URL https://www.ubuntu.com/download/cloud/autopilot After executing the conjure-up --bootstrap-to this command juju bootstrap hangs at "...
1
vote
1answer
117 views

Conjure-Up Landscape failure

I am current following this guide to test out Ubuntu's Autopilot setup. The section of deploying Landscape is not working on my end, and am wondering if anyone can provide assistance. I have a ...
2
votes
1answer
187 views

Landscape Autopilot - Accessing inner Juju Environment

I'm trying to access the inner juju environment by doing the following from the MAAS server First up - juju status from the 'outer' environment production@maas:~$ juju status Model ...
1
vote
0answers
63 views

Maas deployment failes while commissioning works

I installed MAAS in our testing environment to try out OpenStack Autopilot. Everything worked fine but when I try to deploy a node it ends up in "deployment failed - timeout after 40min". When I take ...
1
vote
1answer
242 views

Juju 2.X using MAAS, juju status hangs after juju controller reboot

After deploying an Openstack cloud using juju/MaaS, I rebooted the controller by mistake. When it came back up, juju commands were hanging. I know I could delete .local/share/juju/ .cache/juju/ And ...
0
votes
1answer
105 views

Node enlisting fails when using ssl on MaaS

Trying to get ssl working with MaaS (MAAS Version 2.1.5+bzr5596-0ubuntu1 (16.04.1)). I'm working with a certificate I've signed by an internal CA. I've enabled ssl in apache and the web ui is all set. ...
0
votes
0answers
82 views

Live Migration with JuJu

I have a juju setup and I'm using a manual cloud that mixes physical and virtual machines(VirtualBox). In my scenario, I have 7 services that are related and works perfectly. Now, everything is OK ...
3
votes
0answers
82 views

Errors creating OpenStack deployment with Autopilot

I'm following the guide, I correctly reached step 6. Now when I perform (from MAAS node, ubuntu user): ubuntu@maas-server:~$ /snap/bin/conjure-up --bootstrap-to juju the procedure stops with the ...
3
votes
0answers
70 views

Computer Clustering

I know this question has been asked earlier but am not able to get a simple step by step answer. What I need is : Create a seemless Cluster where I would Use 1 Laptop as Main PC where I can work on ...
0
votes
0answers
194 views

MAAS installation failing at database migrations (Rendering model states)

I'm trying to install MAAS on Ubuntu Xenial (16.04) per instructions at https://docs.ubuntu.com/maas/2.1/en/installconfig-package-install. I am running it as a Vagrant box using image ubuntu/xenial64. ...
0
votes
0answers
54 views

How to recover deleted machines from MAAS

I was deleting a test machine from maas (nodes -> machines) and accidentally delete several other machines. They were rediscovered several minutes later but now are in the devices (nodes -> devices) ...
0
votes
0answers
106 views

MAAS - Internal server error by selecting “Settings” tab

When I click on Settings on MAAS Web UI, I encountering the message Internal server error. I can't figure out why I'm encountering this message ONLY by clicking on settings tab, and to be honest I ...
0
votes
0answers
244 views

MAAS - Access to node

MAAS Region controller (regionA.maas) is running up, synched with one Rack Controller (rackA.maas), who has actually one node (nodeA02.maas) with address: 192.168.1.38:2225. Had a first automatic ...
0
votes
1answer
212 views

Python3 MAAS API

Once again I'm trying to figure out how to query MAAS with python ... I have the following in the config file ... # /etc/maasinv/maasinv.ini [maas] apikey = FbT9S6S9B3U7y38HKZ:NotRealNunyaNunya:...
0
votes
1answer
178 views

[Ubuntu endless recursive Synch Image load

MAAS Region Controller is well connected with Rack Controller but since now never synched. Was checking the error log in Rack Controller showing me following: May 19 03:26:45 rackA maas.networks....
1
vote
0answers
42 views

Install MAAS on productive system

I'm running 16.04 LTS with 3 VMs. Got some other servers I might Cluster together with MAAS. Is it possible to install on the Master productive machine the MAAS and cluster the different servers ...
2
votes
0answers
513 views

Trying to use MAAS 2.1.3 to deploy Centos 7

"Ubuntu MAAS 2.1.3" has several Ubuntu and Centos versions supported out of the box. Our environment has a target version of Centos 7 for general deployment in the lab. Ubuntu MAAS is working great ...
1
vote
0answers
33 views

MAAS deployment without formatting secondary disks

I manage a cluster of computers used for scientific computing using MAAS 2.1. Each node has a 500GB SDD that holds the OS and serves as scratch space for computation. Additionally, each node has a ...
0
votes
0answers
184 views

How to run “juju add-machine” for a linux machine other than ubuntu?

I have a windriver linux machine and want to run juju add-machine ssh:<user>@<machineIPaddress> from a another machine. ssh to that machine works. After running juju add-machine ssh<...
2
votes
1answer
151 views

Do we need internet access to all the servers while bootstraping with conjure-up?

I am trying to follow the steps that are provided to setup openstack with ubuntu maas juju autopilot. I am stuck at one step where I am running conjure-up --bootstrap-to <hostname>. This ...
0
votes
1answer
397 views

Unable to deploy a node in MAAS 2.1.3 in Ubuntu 16.04 LTS

In previous MAAS versions I successfully deploy a few machines and everything worked fine, but after I updated MAAS to 2.1.3 version using the solution from: https://www.ubuntu.com/download/cloud/...
1
vote
1answer
46 views

Landscape - Inavlid login credentials. Please try again

I just conjured up Landscape, following the instructions there and when I try to login in the webmin, this error appears: Invalid login credentials. Please try again. Isn't it supposed to be the ...
1
vote
0answers
473 views

Unable to see device on MaaS

I tried to PXE boot an Intel NUC using a MaaS server and got the following message: cloud-init[1498]: Can not apply stage final, no datasource found! Likely bad things to come! After this message ...
11
votes
1answer
16k views

Should I add HWE kernel to the Ubuntu server manual installation (not from a hosting provider)?

Manually installing Ubuntu server (not from a hosting provider) -- should I add a HWE kernel? From the moment I mount the ISO in my VirtualBox and starting the installation process, I am asked for 4 ...
1
vote
1answer
272 views

MaaS 2.2rc2 - DHCP Relay help

Our MaaS KVM VM is setup on a server with an IP of 10.62.7.140 (10.62.7.129/26), we have DHCP helpers enabled on switches and forwarding traffic from our iLO network - 10.62.0.0/22. I have created a ...
0
votes
1answer
312 views

Ubuntu OpenStack Autopilot Juju Bootstrap no progress

I'm trying to deploy an Ubuntu Openstack Setup with Autopilot. Following the official instructions (https://www.ubuntu.com/download/cloud/autopilot), I've setup a MAAS Server and made PXE Booting ...
1
vote
1answer
158 views

MAAS Apache2 Webserver configuration

TL;DR Please paste content of /usr/share/maas/maas-http.conf I screwed up configuring my maas-http.conf and now I don't reach the webserver. I tried to install letsencrypt certificates for https but ...
0
votes
0answers
510 views

Openstack Deployment on MAAS2.0

This is my first go at containers, so please bear with me. I tried to deploy openstack using MAAS2.0. I setup the required machines ( 4 nodes + Juju Controller) and I followed the instructions on ...
0
votes
1answer
155 views

autopilot does not work

I tried to install OpenStack Autopilot according to the instructions from here, everything went well until the point 6. Launch OpenStack Autopilot. Snap install conjure-up --classic OK Conjure-up --...
1
vote
0answers
63 views

How to export configuration of maas (Metal as a service)

For a few days, I have performed some tests of automatic tool deployment of Canonical: Maas. I think it's very promising. But how can I save my configuration? And, if I have one save, how can I import ...
1
vote
0answers
156 views

MAAS: How to login to deployed node via terminal NOT via ssh

after deploying my nodes, I need to access several of them to debug their networking configuration. Since this is obviousely broken, ssh is not available and I need to login at the server directly. ...
3
votes
1answer
77 views

Is it possible to encrypt with Maas?

Can Mass install servers on luks encrypted lvm? Using mandos to boot encrypted volume Many thanks David
0
votes
2answers
301 views

How to update grub after installing Ubuntu 14.04 through MAAS with Global Kernel Parameters?

I have installed Ubuntu 14.04 LTS with kernel version 4.4.0-71-generic via MAAS with the Global Kernel Parameter setting as "quiet splash". I proceeded to disconnect the system from PXE boot and ...