Questions tagged [linux-headers]

Linux source header files, their use, installation, location, etc.

Filter by
Sorted by
Tagged with
0 votes
0 answers
9 views

Proper way to set up or change a mongodb cummunity server in ubuntu 20.04?

when i enter a sctipt wget - https://www.mongodb.org/static/pgp/server-5.0.asc sudo apt-key add - when it is generate warning apt-key is deprecated. manage keyring files in trusted.gpg.d instead (see ...
user avatar
0 votes
0 answers
24 views

How to sign a deb package?

I have created a deb package using rpmbuild and alien command, now I want to sign that .deb package. So, I am wondering how I can sign a deb package in ubuntu. Can anyone please guide me on this?
user avatar
1 vote
1 answer
1k views

Install VMWare Player on Ubuntu 22.04 (kernel 5.17)

I'm running Ubuntu (Mate) 22.04 with a kernel upgraded to 5.17.4 (I have very new hardware). After downloading and running the .bundle-file from VM-Ware, the vmmon and vmnet modules failed to install. ...
user avatar
0 votes
1 answer
55 views

Unable to update Ubuntu on VM

This is a screenshot of the 404 Not Found error messages I'm getting when trying to update Ubuntu 22.04 on a virtual machine:
user avatar
0 votes
1 answer
143 views

Trying to install linux headers 2204

Trying to install linux headers for Ubuntu 2204 Desktop (uname -r = 5.13.0-40-generic) and I get: sudo apt install linux-headers-$(uname -r) Reading package lists... Done Building dependency tree... ...
user avatar
0 votes
0 answers
42 views

Building linux-tools deb produces empty binary packages

I'm trying to build the linux-tools-generic package on Ubuntu Impish (i.e. 21.10). I am trying to follow the guides I can find (e.g. this one), so the workflow looks something like this: Set up by ...
user avatar
0 votes
0 answers
78 views

headers in ubuntu20, for nvidia 470 , for quadro T500

This is a very similar problem to this one: nvidia-smi not working with quadro T500 but for a specific setup. I have a brand new Lenovo Thinkpad P15s and want to install the nvidia drivers and cuda ...
user avatar
  • 1
0 votes
0 answers
22 views

linux headers reinstall error [duplicate]

Hi I have recently started getting the following error: apt_pkg.Error: E:The package linux-headers-4.19.0-041900 needs to be reinstalled, but I can't find an archive for it. I have tried to follow ...
user avatar
0 votes
0 answers
44 views

what is this symbol on the boot screen ubuntu 20.04?

Every time i turn on the pc this symbol appears, before the lenovo logo and the ubuntu symbol appeared.
user avatar
2 votes
1 answer
312 views

nvidia-340 driver on Ubuntu 20.04 getting error

I try to solve these links but had no luck nvidia-340 driver on Ubuntu 20.04 https://phoenixnap.com/kb/install-nvidia-drivers-ubuntu
user avatar
0 votes
0 answers
38 views

Kernel problems, how to set up ubuntu from boot stick

I am absolutely new to Ubuntu and I do not understand what the current problem is. I have installed Ubuntu 18.04 and after the installation wifi and bluetooth would not work. Because of this I tried a ...
user avatar
  • 1
1 vote
0 answers
76 views

Missing Header files in newer kernel

I am trying to install a source package on a fresh install of 20.04 running kernel 5.13.0-28-generic. The package requires <config/modversions.h>. This package installed with no problems on 5....
user avatar
0 votes
1 answer
87 views

mspdebug can't find libmsp430.so, but it is on my computer

I am running mspdebug with tilib driver, but mspdebug says: tilib: can't find libmsp430.so: libmsp430.so: cannot open shared object file: No such file or directory I have done a search and libmsp430 ...
user avatar
6 votes
2 answers
4k views

How do I install kernel 5.15.7=> on Ubuntu 21.10 Impish Indri?

I'm using Ubuntu 21.10 impish indri. For some specific hardware support, I'm advised to upgrade to kernel 5.16 (mainline). I tried manually installing the .deb files and installing them using dpkg -i. ...
user avatar
  • 4,964
0 votes
1 answer
636 views

How to downgrade to Linux kernel 4.15.x on ubuntu?

I'm using ubuntu 18.04 which runs on linux kernel 5.4.0. And i wish to install and use Linux kernel 4.15.x cause that works better on my system. Can anyone please guide me how to do that.
user avatar
2 votes
1 answer
594 views

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver -- kernel headers for 5.16.2

I'm trying setup my Lenovo Legion 5 Pro w/ Ubuntu 20.04.3 LTS machine so that I can use my GPU (Nvidia Geforce RTX 3070 8GB) for machine learning, for example with PyTorch. However, even after re-...
user avatar
  • 123
0 votes
0 answers
66 views

cannot create directory : Read-only file system [duplicate]

In my Linux system suddenly this msg start appearing "cannot create directory: Read-only file system" Now I am not able to create any directory or not able to download anything. What should ...
user avatar
0 votes
0 answers
30 views

Reading file from Unzipped Folder - Linux

what i'm trying to do is reading files from 4 different Unzipped folders until now with no success, i wrote that script: for file; do local file_type=$( file -i "$file" ) case "$...
user avatar
0 votes
1 answer
127 views

How long can $DISPLAY environment variable value be?

What is the maximum length that $DISPLAY environment variable value can take? I understand that it is - hostname:displaynumber.screennumber So will it be => max($DISPLAY) = max(hostname) + max (...
user avatar
0 votes
1 answer
372 views

Problem getting the right linux headers to run VirtualBox/Vagrant

I am on Ubuntu: lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 20.04.3 LTS Release: 20.04 Codename: focal Kernel version: uname -r 5.13.0-23-generic ...
user avatar
  • 1
-1 votes
1 answer
37 views

Embedded studio

I used to program embedded microcontrollers with keil uvision software on windows but recently I switched to ubuntu operating system and still don't know how to program microcontrollers (cortex -m3 ...
user avatar
0 votes
1 answer
35 views

How use specific commands

I'm trying to install VMware. But because of some difficulties, I followed a tutorial which lists some commands to resolve my problems. I see this commands: $ sudo apt update && sudo apt ...
user avatar
0 votes
1 answer
179 views

Static ip address issue

I gave a static IP address using following command network: version : 2 renderer: networkd ethernets: enp0s3: dhcp4 : false addresses : 192.168.3.244/24 ...
user avatar
1 vote
1 answer
434 views

Headers in ubuntu 20.04

I am trying to install the Linux headers like this: apt install linux-headers-$(uname -r) gcc make acpid dkms libglvnd-core-dev libglvnd0 libglvnd-dev dracut However, I have this error: Package '...
user avatar
1 vote
0 answers
72 views

"The package linux-headers-5.11.0-37 needs to be reinstalled, but I can't find an archive for it."

I recently tried to install an upgrade but I keep getting the following error: The package linux-headers-5.11.0-37 needs to be reinstalled, but I can't find an archive for it." How do I fix this?
user avatar
0 votes
1 answer
236 views

Difference between packages libxml2-dev and libxml2

I have simple C++ application that uses libxml2 library. For this purpose I need to install it. But which package I need to install: sudo apt-get install libxml2 System still complains regarding ...
user avatar
  • 3,877
0 votes
0 answers
128 views

Ubuntu 18.04 Kernel update to 5.13

I am trying to update kernel in Ubuntu 18.04 to 5.13 for having my wifi working? Currently I am seeing that "No WIFI Adapter Found" in settings so I think I would need Mediatek 7961 driver. ...
user avatar
0 votes
1 answer
774 views

Post update errors with linux-image-5.4.0-80-generic

Today I did my regular ubuntu update sudo apt update && sudo apt dist-upgrade and have been getting the following error Reading package lists... Done Building dependency tree Reading ...
user avatar
0 votes
0 answers
116 views

I can't seem to install Vmware. I tried other solutions with no success. Im using Ubuntu 20.04.3 LTS

I am trying to install the Vmware software in my system but the kernels it requires vmmon and vmmnet is not getting installed. I tried multiple things like installing build-essential & linux-...
user avatar
0 votes
0 answers
129 views

How to install the missing header sys/sockio.h?

I use Ubuntu 20.04 and want wo build a C program. But the sys/sockio.h header files is missing. Which package do I have to install? The command locate -b '\sockio.h' returns nothing.
user avatar
  • 123
1 vote
1 answer
579 views

ocfs partition creation failure

I am trying to create a cluster file system shared by two devices. I am seeing the following error: mkfs.ocfs2 successful mount.ocfs2: Cluster name is invalid while trying to join the group Stopping ...
user avatar
0 votes
1 answer
277 views

modify specific columns based on another column by using awk and gsub

I have a file (file1) with millions of rows and columns. An example of data are: "col1","col2","col3","col4","col5","col6" "AAA",0,...
user avatar
  • 3
-1 votes
1 answer
974 views

What is difference between ubuntu 18 and 20? [closed]

I hope to know what is difference between ubuntu 18 and 20. If you can help me, please post your answer. Thanks.
user avatar
0 votes
0 answers
74 views

Unable to use/find gettimeofday in Ubuntu kernel

I am using Ubuntu 20.10 with kernel source 5.8.0-59.66 I need to get the current time of day (from the epoch) within the kernel. Using either RHEL 7.9 or CENTOS 7 I have relied on the gettimeofday() ...
user avatar
  • 1
6 votes
1 answer
11k views

Ubuntu 20.04 and kernel 5.13.0-051300-generic: how to install the headers and libc6

I recently upgraded the kernel to version 5.13.0-051300-generic on my Tuxedo laptop equipped with Ubuntu 20.04. I am now trying to install the headers linux-headers-5.13.0-051300-generic_5.13.0-051300....
user avatar
0 votes
0 answers
127 views

Linux headers for kernel 5.4.20

I have an old ODROID U3 board running Ubuntu 20.04 with kernel 5.4.20. I want to setup a wireguard VPN server on it, but it turns out that wireguard needs linux headers for this kernel. The uname -r ...
user avatar
  • 179
0 votes
0 answers
4k views

installing linux-headers-standard on Ubuntu 20.04 / WSL2

When I use VBoxManage to create a vm I'm told I need to have linux-headers-generic installed. So I try sudo apt-get install linux-headers-standard and get this message: Reading package lists... Done ...
user avatar
  • 191
0 votes
1 answer
54 views

apt-getupdate/upgrade success yet GUI software updater keeps nagging. Normal?

New to Ubuntu 20.04 uname -r 5.8.0-55-generic lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 20.04.2 LTS Release: 20.04 Codename: focal After running ...
user avatar
1 vote
1 answer
420 views

linux-headers-5.4.0-56 generic

Is there any solution for this "Error: E:The package linux-headers-5.4.0-56-generic needs to be reinstalled, but I can't find an archive for it." I can't do anything...just whatever I do or ...
user avatar
1 vote
1 answer
2k views

Uninstall IntelliJ idea from Ubuntu

I have deleted all files of IntelliJ-idea community edition from my laptop, and when I search on terminal for delete, it shows not installed, but on my laptop it is available, help me to delete the ...
user avatar
  • 13
0 votes
1 answer
78 views

How to include a generic library when calling the headers

this code gives me error #include <linux/mman.h> no such file or diretory while this works #include </usr/include/linux/mman.h> how do i change in order so i can use the first option?
user avatar
0 votes
0 answers
623 views

Can not install kernel headers. Has no installation candidate

I have just upgraded to Ubuntu 20.10 After that I decided to upgrade to latest kernel as well. But now there is some mismatch between my kernel version and headers. This image shows that I am using ...
user avatar
0 votes
1 answer
1k views

assert.h no such file or directory (Ubuntu 20.04 arm64)

I tried to solve this problem by installing the various libraries but still nothing. Advice? I checked the include path: parallels@ubuntu-linux-20-04-desktop:~$ locate /assert.h | grep assert.h$ /...
user avatar
0 votes
1 answer
148 views

How can I get the Last-modified header on a https website?

I'm trying to trigger a last-modified response from a https website, but all I get is 301 Moved Permanently The above only works on websites with http and I can't figure out why it won't work for ...
user avatar
0 votes
1 answer
508 views

Does Ubuntu 16.04 server supports kernel version 5.4?

Is there any recommended kernel version to use for ubuntu 16.04 server? Does it supports latest kernel version 5.4? will it cause any issue?
user avatar
0 votes
1 answer
165 views

What is GKEOP kernel image?

Just looking through possible linux kernels, I fall on linux-image-gkeop listed using Synaptic Package Manager.. never seen.
user avatar
0 votes
0 answers
250 views

Installing Device Drivers for TP-Link TL-WN725N Wireless Adaptor

I have purchased a TP-Link TL-WN725N wireless adapter and require to install its device driver to get it working. After perusing the product information sheet, I see that my current version of the ...
user avatar
  • 121
0 votes
1 answer
713 views

Camera devices suddenly disappeared on ubuntu 20.04

I am using Ubuntu 20.04 on Asus Tuf. I have a very weird problem with the camera devices. When I restart the computer, both the integrated webcam and the external webcam are working perfectly and I ...
user avatar
0 votes
0 answers
438 views

Is it OK to delete obsolete linux-hwe-5.4-headers files on usr --> src?

Over the last six months, linux-hwe-5.4-headers-5-4-0-xx haven't been deleted from usr-->src directory. Earlier from the current versions, v42 to v62 are still available. Will there be any problem ...
user avatar
  • 384
0 votes
1 answer
237 views

/usr/src full with header files, purge and autoremove not helping

I have the issue with my /usr/src folder getting filled up with header files, and I didn't find a way to remove them. It is causing my disk very close to be totally out of free space: # df -h ...
user avatar
  • 173