Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [libraries]

General tag pertaining to application libraries

2
votes
2answers
60 views

ldd started to show me “not a dynamic executable”

I am a bit confused because I don't understand why it happens: The last changes on the system that I remember were installed g++5 for the old porject (removed already) apt autoclean removed ...
1
vote
1answer
26 views

gsl library: gslcblas library not found but installed

I have problems with installing the gsl package. Running Xubuntu 18.04, octave 4.4.1. Using -forge, the installation process stalls with the following message: pkg install -forge gsl configure: ...
0
votes
0answers
18 views

Install hdf5 1.8.16 (Xenial) on Bionic (18.04)

I have an application that was compiled with HDF under ubuntu 16.04, i.e. hdf5 1.8.16 but need to run it on Ubuntu 18.04 meaning hdf5 1.10. I tried to create symlinks in /usr/lib/x86_64-linux-gnu ...
0
votes
1answer
58 views

ubuntu does not boot after installing anaconda and pyinstaller

What happened. After restarting, the system does not boot. It freezes at the Ubuntu logo and the dots. What I did just before that. I installed anaconda and then I installed Pyinstaller. When running ...
0
votes
0answers
43 views

How to install requested libs: GLIB, libavcodec and libavformat?

I've got an application from InteractiveBrokers, which sometimes gives me this: So I searched for those libs in synaptic, but in the screenshots below you can see that they all seem to be installed. ...
0
votes
1answer
44 views

What is libgtk-x11-2.0.so library?

I am trying to migrate my code from gtk2 to gtk3 . So instead of the library libgtk-x11-2.so which library i should use in gtk3. And What is the use of libgtk-x11-2.0.so ? is this library is a gtk2 ...
0
votes
0answers
65 views

How do I install libg2c.so.0 in Ubuntu 18.04 64 bit

I tried to install libg2c.so.0 through the following command which did not work for me sudo apt-get install libg2c0 I am running Ubuntu 18.04-64 bit machine. It would great if somebody can help me ...
1
vote
1answer
115 views

“No such file or directory error” with libcrypto.so.1.0.0 in spite of installing libssl

When trying to run a game, I got the error message `/home/relax/.config/itch/apps/white/Whitev2/White: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No ...
0
votes
0answers
85 views

No module named pandas

I cannot import pandas libraries despite been installed import pandas as pd Traceback (most recent call last): File "", line 1, in ImportError: No module named ...
0
votes
0answers
48 views

“Error while loading shared libraries” on Ubuntu 18.04.1 LTS

I want to run daophot in my system which has been installed using scisoft8. But i am getting error as daophot: error while loading shared libraries: libcfitsio.so.1: cannot open shared object file: ...
1
vote
1answer
89 views

Undefined reference to udev_new

I am currently trying to test a c++ code I wrote on Qt, and I downloaded libudev and it keeps giving a lot of "undefined reference to". I followed almost all of the posts of upgrading libudev, sudo ...
-5
votes
1answer
43 views

What is the point of LTS releases if they contain outdated packages? [duplicate]

As the title says. What's the point of the LTS if I have to update anyway at least every 2 years because the packages aren't updated to new versions and hence quickly contain non-supported versions?
1
vote
2answers
78 views

On Ubuntu 16.04, pip is installing libraries to python 2.7

I'm new to Ubuntu and I'm trying to learn python. I use pyCharm IDE and python 3.5 but now when I'm trying to install libraries using the sudo pip command they are installing to python 2.7, so when I'...
1
vote
0answers
24 views

Why does the music in the game “Oh, Deer!” work in 16.04 but not 18.04?

So, I got an indie game (Oh, Deer!) from Humble Store and while using Lubuntu 16.04, its music worked flawlessly. However, when I installed 18.04, game refused to launch unless I installed libmad0 ...
0
votes
1answer
94 views

Numerous libxxxx… libraries missing when trying to launch applications

I just freshly installed Ubuntu 18.04 but some things went wrong in the process and now I seem to be missing some libraries. I often can not launch programs after I installed them due to "error while ...
1
vote
1answer
163 views

What is the library to be installed for `jasper.h` header file?

I am trying to build Opencv on Ubuntu 18.04. When I run make I get the error: grfmt_jpeg2000.cpp:59:10: fatal error: jasper/jasper.h: No such file or directory #include <jasper/jasper.h> ...
0
votes
0answers
32 views

enforce libtool to link with libdl.so

I am building a shared lib on Ubuntu 18.04.1 that has to be linked explicitly with libdl.so. All is good when using a non-libtool makefile - -ldl is supplied to the linker and the produced binary ...
0
votes
0answers
52 views

Error “ELF file OS ABI invalid” with the incorrect libstdc++.so.6

Using Anaconda (a scientific distribution of Python environment), I installed one package in my Linux system. However, when I started to call the related function, the error occurs: ncks: error ...
0
votes
0answers
12 views

Absent libraries between Ubuntu 16.04 and 14.04 [duplicate]

I am using an Ubuntu 16.04 LTS system for my data processing. This specific data processing was traditionally done on an Ubuntu 14.04 system. Due to library differences between the 14.04 and 16.04 ...
2
votes
0answers
98 views

Which MPI library are packages linked against? Open MPI?

Some packages in the Ubuntu repositories provide pre-compiled binaries of shared libraries (*.so). For example, the package fftw2 provides the FFTW library (version 2), including the MPI-related ...
0
votes
2answers
233 views

How to update libeigen3 to version >= 3.3 on 16.04 xenial?

Issue: I have libeigen3 from the official repo installed: $ sudo apt-get install libeigen3-dev [sudo] password for nicolas: Reading package lists... Done Building dependency tree Reading ...
0
votes
1answer
21 views

Questions about building new version of OpenJPEG on Ubuntu pc

Is it worth updating to a new version from 2.0.1 in the first place? Should I delete the 2.0.1 build to install the new one? How is the GitHub versions of the project, like if I wanted to install 2....
0
votes
0answers
55 views

Where to get libwx_gtk2u_richtext-2.8.so.0?

I'm missing libwx_gtk2u_richtext-2.8.so.0 in my system and I need it to run xorg-edit, flawlessly dig in mouse settings and maybe, finally, fix my old problem. I'm on Ubuntu 18.04 using XFce. I cannot ...
1
vote
0answers
140 views

Some Qt apps (dropbox, megasync) stopped working

Just recently some of the apps I had to backup files stopped working and I do not know why. For example, at trying to start nautilus-dropbox or megasync I get errors related to the Qt library. See the ...
1
vote
0answers
1k views

Error while loading shared libraries: libQt5Network.so.5:

I was installing GNU octave on my Ubuntu 18.04 (from the terminal). After installation octave wouldn't open when I tried to launch it using the desktop icon. So I tried launching from the terminal and ...
0
votes
0answers
261 views

Clean install 18.04 over partial install 18.04

Is it possible to perform a clean install 18.04 over a partial upgrade 18.04. The problem is after 16.04 upgrade to 18.04, the system presents too many problems in running apps, this has forced me to ...
3
votes
3answers
1k views

How to have both libcurl3 and libcurl4 installed at same time?

My favorite web brower depends on libcurl3 (Opera 36.0) But many apps depends on libcurl4 including PlayOnLinux or Steam client. It will be nice to have PlayOnLinux or Steam installed but I'm not ...
0
votes
1answer
380 views

Boost.Numpy installed from source but is not working

I am on Ubuntu 14.04 and I have libboost-all-dev installed (Boost 1.54) and I need to install the Boost.NumPy library. I know that NumPy comes with Boost 1.64+ but I need to stick with 1.54 for now, ...
1
vote
1answer
227 views

Error 'libudunits2.a not found' when installing ggraph, Additional Error : object ‘scale_type’ is not exported by 'namespace:ggplot2'

I ran into these two errors 'libudunits2.a not found' and Error : object ‘scale_type’ is not exported by 'namespace:ggplot2' on Ubuntu 17.10 during an install of ggraph in Rstudio via install....
1
vote
0answers
34 views

Ubuntus (lib)ATLAS packages are only multi-threaded

Before I file a bug, I would like to ask if anybody can confirm that the (lib)ATLAS packages (libatlas3-base) in Ubuntu (not limited to 16.04) are multi-threaded only? And, that there is no way to ...
1
vote
1answer
82 views

when installing idevicerestore i get errors saying i`m missing libraries

i`ve been trying to install Idevicerestore on my Ubuntu 16.4 and i keep getting errors of missing libraries, and it's frustrating trying to install them one by one. this is what comes up after running ...
1
vote
1answer
680 views

Is it possible to install static libraries from apt in 18.04 x86_64?

I'm trying to build a project that depends on binary distributed static libraries. The linker complains it cannot find ini_config functions, among others: config_params.c:(.text+0x16f): undefined ...
0
votes
1answer
243 views

when trying to instal wickRme on 18.04 I get the following error

sudo gdebi WickrMe_4.44.04-01_amd64.deb ... This package is uninstallable Dependency is not satisfiable: libicu55 Then I tried searching for a match apt-cache search libicu but on install attempt ...
1
vote
1answer
176 views

mupen64plus not working; failed to find core library

Using Ubuntu 16.04LTS on an HP Beats 15 Notebook with 8 Gigs of RAM and an A10 AMD processor. I've never had this problem before while using mupen64plus on other computers with less RAM and less ...
0
votes
0answers
195 views

Cannot link EGL

I have installed the latest NVIDIA drivers and tried to link EGL library, but somehow it does not work. g++ -o hello hello.cpp -lEGL hello.cpp:2:23: fatal error: EGL/egl.h: No such file or directory ...
1
vote
1answer
131 views

How to connect ICU library with gcc in the Ubuntu 16.04?

I have downloaded the icu4c-61_1-Ubuntu16.04-x64.tgz from the http://site.icu-project.org/download/61#TOC-ICU4C-Download site. I do not see any installation instruction there. In my NetBeans C/C++ '...
1
vote
0answers
78 views

Finding and fixing expected location of libraries

glxgears ran by a normal user cannot find libGL.so.1: $ ldd /usr/bin/glxgears linux-vdso.so.1 => (0x00007ffce3176000) libGL.so.1 => not found libm.so.6 => /lib/x86_64-linux-gnu/...
0
votes
2answers
115 views

Installing library with foreign architecture

I have been trying to install libc6-i386 on ubuntu 16.04 using: and the command line gave the following error: sudo apt-get install libx11-6:i386 It seems that it cannot detect packages from other ...
0
votes
0answers
106 views

libfreetype6 errors are every where!

when I run any type of apt-related command there is no way which I don't see an error related to libfreetype6, like this: nima@cesar:~$ sudo apt-get install phpmyadmin php-mbstring php-gettext ...
3
votes
2answers
2k views

Packet Tracer Segmentation Fault Ubuntu 18.04

I have installed Cisco Packet Tracer 7.1.1 on Ubuntu 18.04. Every time I launch the application it closes and give me a message Segmentation fault (core dumped). Using the gdb, I went to the ...
3
votes
1answer
119 views

Ubuntu wine drop-down menus issue

Environment: Ubuntu 18.04 kernel 4.15 Crossover 17.5.0-1 Wine 2.8 There is an issue when selecting any drop-down menu in wine applications. Drop-down menus doesn't to be appear. The issue ...
0
votes
0answers
113 views

g++ libraries under Windows Subsystem for Linux (WSL)

How can I know where and what exactly are the g++ libraries in my WSL (Ubuntu 16.04)? Would the libraries be influenced by those under Windows?
3
votes
1answer
601 views

GParted can't work

I installed Gparted with sudo apt install gparted and sudo apt install -f. When I typed sudo gparted, it tells me: Unit -.mount does not exist, proceeding anyway. /usr/sbin/gpartedbin: error while ...
2
votes
0answers
301 views

How to fix this GTK library installation error?

I'm trying to install GTK library in ubuntu 16.04 LTS but I'm getting error saying E: Unable to correct problems, you have held broken packages. nikhil@nikhil-desktop:~$ sudo apt-get install libgtk-3-...
0
votes
1answer
53 views

How does this program statically link to a .so in a non-default path

A program I am using can only be installed with a custom installer (IDA Freeware Demo). I have installed it in my home dir, it all works fine. Now I noticed when checking the program with ldd: it ...
-3
votes
1answer
233 views

Problems with libraries for programs [GParted, Krita]

GParted or Krita do not start. If you run them through the terminal, you get an error about the libraries. Unit -.mount does not exist, proceeding anyway. /usr/sbin/gpartedbin: error while ...
1
vote
0answers
310 views

Where to get libpulse-mainloop-glib >= 0.9.19?

I'm trying to compile Xfce Pulse Audio Plugin. But have problem with ./configure: checking for libpulse-mainloop-glib >= 0.9.19... not found *** The required package libpulse-mainloop-glib was not ...
0
votes
1answer
217 views

What's causing this ClamAV error?

I'm using ClamAV within a script to scan a selection of directories. The command used is clamscan -ri "$dir". Recently I've encountered the following error message: LibClamAV Warning: SWF: declared ...
0
votes
0answers
125 views

make fails boost ; openssl

I'm trying to build project with Casablanca cpprestsdk. Step 4 - make fails with a very long log error, although it is clear to see it is caused by openssl or boost. /usr/include/boost/asio/ssl/...
1
vote
2answers
1k views

18.04 - can't run grub-customizer

I'm on a fresh install of Ubuntu 18.04 and I installed grub-customizer. But when I try to launch it, I get the following output: user@ubuntu:~$ grub-customizer grub-customizer: error while loading ...