Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [libpng]

The tag has no usage guidance.

1
vote
1answer
55 views

Lubuntu boots into Terminal. Xorg cant connect to Zlib

My Lubuntu 18.04 boots strait into the terminal. When I try to start the GUI with startx I get the following error message: xauth: timeout in locking authority file /home/jonathan/.Xauthority xauth: ...
0
votes
2answers
128 views

Can't install libpng12 due to usrmerge. Can't run PacketTracer without it [duplicate]

I need libpng12 because of PacketTracer. Is there a workaround without installing it? Is it safe to remove usrmerge? dpkg: regarding libpng12-0_1.2.50-2+deb8u3_amd64.deb containing libpng12-0:amd64: ...
1
vote
0answers
326 views

Can't run .run files(libpng error)

When I use the command +chmod +x appname.run and then ./appname.run I get the following message, but nothing more happens: libpng warning: Application jmp_buf size changed Segmentation fault (...
1
vote
1answer
110 views

Relocation error libqt5 and libpng16

I have recently upgraded from 16.04 to 18.04 While trying to start qjack I get this error qjackctl: relocation error: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: symbol png_set_option version PNG16_0 ...
0
votes
1answer
1k views

Failure to install libpng-dev in ubuntu 18.04

I am not able to install libpng-dev in Ubuntu 18.04, getting the following error: libpng-dev : Depends: libpng16-16 (= 1.6.34-1) but 1.6.34-1ubuntu0.18.04.1 is to be installed ...
0
votes
1answer
1k views

zlib_1.2.9 not found required by /usr/lib/x86_64-linux-gnu/libpng16.so.16

After downloading zlib-1.2.9 on Ubuntu 18.04 I have these problems opening one of my softwares (Schrodinger suites). ImportError: /opt/schrodinger2017-1/mmshare-v3.7/lib/Linux-x86_64/libz.so.1: ...
0
votes
1answer
879 views

How to remove or reinstall libpng in ubuntu 16.04?

I installed this libpng package for installing wps office. libpng12-0_1.2.50-2+deb8u3_amd64 From then I am having problem upgrading. command 'sudo apt-get upgrade' gives me this problem. Reading ...
9
votes
4answers
14k views

Libpng12 needed for 17.10

Blackmagic Design's Resolve video editor, V14.0.1, requires libpng12. Unfortunately, only libpng16 is provided with the new 17.10 release. Is there a way to revert to libpng12 under 17.10? If so, ...
0
votes
1answer
947 views

Not able to install Vim (Depends: vim-common (= 2:7.4.1689-3ubuntu1.2) but 2:7.4.1689-3ubuntu1 is to be installed)

I am trying to install Vim. I got the following error $ sudo apt-get install vim Reading package lists... Done Building dependency tree Reading state information... Done You might want to run ...
0
votes
0answers
75 views

Unable to install either libpng12-0 and wps on Ubuntu 17.04 [duplicate]

I was trying to install wps on Ubuntu 17.04, but it would not install. I looked at the previous questions, and I found out a solution was to install the PNG package before installing wps. I therefore ...
0
votes
0answers
382 views

ffmpeg: error while loading shared libraries: libpng15.so.15

ffmpeg is required for clipbucket we have installed ffmpeg on server it do exist on path /usr/bin/ but when type ffmpeg -version it gives strange error ffmpeg: error while loading shared libraries: ...
2
votes
1answer
2k views

E: Package 'libpng12-0' has no installation candidate (Ubuntu 17.04) [duplicate]

When I run: sudo apt-get install libpng12-0, I get this error message: Reading package lists... Done Building dependency tree Reading state information... Done Package libpng12-0 is not ...
0
votes
1answer
1k views

libpng-dev is installed; program doesn't link

I want to compile farbfeld program suite. I run make. Error: cc -s -lpng -o png2ff png2ff.o util.o png2ff.o: In function `main': png2ff.c:(.text.startup+0x58): undefined reference to `...
0
votes
2answers
5k views

Stata 14 fails to start on Ubuntu 16.10/17.04/17.10, with “libpng12.so.0” error. How do I install libpng12?

The proprietary software Stata version 14 works fine on LTS 16.04, but I made the mistake of upgrading Ubuntu to 16.10 without thinking about the possibility that proprietary software (Stata is my ...
0
votes
1answer
501 views

Packages have unmet dependencies (1ubuntu1 vs 1ubuntu1k1)?

While installing dependency packages I ran into this problem: The following packages have unmet dependencies: libpng12-dev : Depends: libpng12-0 (= 1.2.54-1ubuntu1) but 1.2.54-1ubuntu1k1 is to be ...
2
votes
1answer
721 views

Unmet dependencies libpng++-dev

I try to (re)install libpng++-dev, but i got this error message: [...] The following packages have unmet dependencies: libpng++-dev : Depends: libpng-dev E: Unable to correct problems, you have ...
0
votes
0answers
108 views

Why does apt-cache policy claim libpng-dev doesn't exist?

When I run apt-cache policy libpng-dev I get output that says: libpng-dev: Installed: (none) Candidate: (none) Version table: Why? Isn't this command supposed to show you what version(s) are ...
1
vote
1answer
2k views

Wrong library version used (libpng)

I installed a long time ago the libpng12-dev package with the apt-get command. It installed libpng-1.2.54. But now I have a project that require the libpng-1.6.16 version. Since it's not available ...
24
votes
2answers
78k views

E: Package 'libpng12-0' has no installation candidate [ubuntu 16.10 Gnome]

I tried to install WPS Office on my laptop (ubuntu 16.10 Gnome, 64 bit) with Gdebi installer but it said Dependency is not satisfiable: libpng12-0 Then I tried to open this library as follows ...
0
votes
1answer
2k views

How to check if libpng and png++ is installed

How do I check if png++ and libpng is installed in ubuntu ? I am trying to compile this code http://ttic.uchicago.edu/~dmcallester/SPS/index.html and the readme says I require libpng and png++ I have ...
0
votes
1answer
342 views

how to run program using png library

I installed libpng and zlib and want to run this program using png.h. I have Code::Blocks and I'm completely new in IT. I don't know why it doesn't run. I get the following: undefined reference to ...
0
votes
1answer
3k views

Cannot install libpng*?

(this blocks the installation of the R package 'png') When I do: sudo apt-get install libpng* I get: Reading package lists... Done Building dependency tree Reading state information... Done ...