Questions tagged [julia-lang]

Julia is a high-level, high-performance dynamic programming language for technical computing, with syntax that is familiar to users of other technical computing environments.

Filter by
Sorted by
Tagged with
0 votes
0 answers
247 views

Run Julia from Terminal

I have just installed Julia 1.7.2 in my notebook (I have Ubutnu 20.04). The folder containing Julia is in Downloads. I can run julia by runing $ ./Downloads/julia-1.7.2/bin/julia That is, looking the ...
  • 11
0 votes
1 answer
166 views

Random pieces of text pasted in code files

Quite often, when I'm writing small programs in e.g. MATLAb or Atom/Juno (on Ubuntu 20.04), I get errors because a a certain variable is not recognized. Upon taking a closer look, the origin seems to ...
  • 101
1 vote
1 answer
71 views

How should I run my Julia code using libjulia-openblas64 package on Ubuntu 20.10?

I have Ubuntu 20.10 installed. Also I have simple program written in Julia language: using LinearAlgebra println(LinearAlgebra.BLAS.vendor()) M = 500; c = [ sin(a + b.^2) for a in 1:M, b in 1:M] t0 = ...
  • 91.9k
6 votes
1 answer
7k views

Why does my symlink to /usr/local/bin not work?

I installed Julia locally by unpacking it into a folder. Then I tried to add the executable to /usr/local/bin since I don't want to modify the $PATH. sudo ln -s bin/julia-1.5.3/bin/julia /usr/local/...
  • 861
0 votes
0 answers
343 views

Issue setting symbolic link for Julia Lang

I am running Ubuntu 18.04.3 LTS. I guess my question is a general question about symbolic links with a specific set up. However, I am new to Ubuntu and maybe I am wrong and my issue lies somewhere ...
1 vote
0 answers
3k views

"Could not resolve host: github.com" when trying to get Julia packages

I'm sorry if I'm noob on computer science but I am with a few problems when trying to download packages for Julia language. I have installed the version 0.6 on a Ubuntu 16.04.3 and I can reach into ...
1 vote
1 answer
606 views

Missing libraries when trying to run a julia program [duplicate]

So I am new to Linux and I was trying to run a Julia program using julia transport.jl However when enter that in terminal I get the following ERROR: LoadError: LoadError: LoadError: LoadError: ...
  • 111
10 votes
2 answers
8k views

Problems installing Julia language

I'm following instructions from here (see Ubuntu section). It says me to do sudo add-apt-repository ppa:staticfloat/juliareleases sudo add-apt-repository ppa:staticfloat/julia-deps sudo apt-get ...
  • 201
5 votes
1 answer
6k views

How to add a new language definition for syntax highlighting in Gedit?

I've attempted to create a new .lang file for getting Gedit to recognize the Julia programming language. I have read the tutorial, the reference document and the wiki page Gedit/NewLanguage, and I ...
  • 2,148