Questions tagged [jre]

The Java Runtime Environment.

Filter by
Sorted by
Tagged with
0
votes
0answers
82 views

Ubuntu 19 Java JAR (Java 8) GUI blank screen

I'm trying to launch a JAR file which requires Java 8 (not higher/lower). When I install Java 8 and I launch the application it opens a window but the content of the window is just blank. I've tried ...
0
votes
1answer
34 views

Work on a Java Project in Ubuntu

I am a beginner so I apologize if you're gonna read a silly question. I want to work on a Java Project. It's a project available on GitHub: https://github.com/particleincell/Starfish. The problem ...
0
votes
0answers
29 views

Clone a Repository and use it in Eclipse IDE

I am not an expert in the field and I am new to the world of programming so maybe you could find this question quite banal. I would need to work with this open-source code written in Java: How ...
0
votes
0answers
166 views

Run Java program in Ubuntu using jre [duplicate]

I created a Java program. This program has a .jar extension and it's running with Java jre runtime. All the dialog I use it in Windows operating system. I want to run a .jar program in ubuntu. How can ...
2
votes
0answers
743 views

package javax.jnlp not in java.desktop ubuntu

Anybody solve this error? I'm trying to run a Java application on Ubuntu, and I got this error: $ javaws http://192.168.1.211:7777/forms/frmservlet/config=mmcs selected jre: /usr/lib/jvm/default-java ...
0
votes
1answer
90 views

Install NetBeans 8.01 in Ubuntu 18.04 - JRE not found

I have downloaded the netbeans-8.0.1-cpp-linux.sh now I'm trying to install it. I've authorized the execution. chmod u+x netbeans-8.0.1-cpp-linux.sh Now I'm trying to: sudo ./netbeans-8.0.1-cpp-...
5
votes
3answers
7k views

Update to latest version of java after ppa is discontinued

I have been trying to install the latest version of java-8. However, I found out that the PPA ppa:webupd8team/java has been discontinued due to changes in the java licence. How should I update my ...
4
votes
1answer
6k views

How to install Java 8 on Ubuntu 19.04 [duplicate]

I upgraded my system to the latest Ubuntu. However, it seems that it's shipped with java 11. I removed it because I need Java 8. However, it seems that Java 8 won't install on my system and I was ...
0
votes
0answers
404 views

Install old Java8 version

I've installed Java 1.8.0_201, but i need the 8.161 version to run a software. I try with Synaptic but i can't downgrade java. I try do download the .tar file from this website but i don't know how ...
0
votes
1answer
2k views

How to install java 32bit version

I need a java jre 32bit version, how can I install it in my Ubuntu Server 18.10? I could only install the 64bit version of jvm.
0
votes
0answers
224 views

Issue with compiling/running a java program in xterm (python default)

I'm trying to run a java program using xterm. I've installed jre1.8.0_191 in /usr/java, but when I run javac HelloWorld.java. (The java file I created) I get a /usr/bin/python3: bad interpreter: No ...
3
votes
3answers
1k views

JVM without JRE [closed]

Why can't the Java Virtual Machine run without the Java Runtime Environment? What is the purpose of the Java Virtual Machine, and what is the purpose of the Java Runtime Environment? What are both ...
45
votes
12answers
16k views

Android Studio update issue with jre/bin/java

While updating Android Studio I got the following error. The patch was downloaded and extracted, but there was some conflict with jre/bin/java Access denied. The error message is shown in the below ...
0
votes
1answer
7k views

JAVAFX_HOME path on ubuntu

So my problem is openjfx and using it on Scala-sbt project. The actual problem is JAVAFX_HOME path. First of all I have java version 10.0.2 installed on my computer and openjfx (which I take as JavaFX)...
0
votes
0answers
32 views

How can I reinstall oracle-java-installer? [duplicate]

I tried to set Java 10 as default JRE but it deleted other ones, but when I closed it then it everything that tries to download now doesn't work that uses Java code. This comes when I try to download ...
1
vote
2answers
728 views

Why wont JRE run my .Jar file [duplicate]

Before you mark this as the same thing as the others, You need to know I have done this before hundreds of times with no problem, I just reinstalled Ubuntu 18.04 2 days ago, and I was trying something ...
0
votes
1answer
509 views

How to change IntelliJ IDEA's JRE

I have a problem with launching IntelliJ IDEA on Lubuntu 18.04. While researching this issue I stubled upon this post, which describes the similar problem. People there advise to use IDEA's bundled ...
2
votes
2answers
10k views

eclipse: class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Since the update yesterday (yes, the linux update), eclipse denies me to run even the most simple helloworld: has been compiled by a more recent version of the Java Runtime (class file version 53.0), ...
0
votes
0answers
815 views

Cant find jre folder after installing jdk-10.0.1 [duplicate]

Following the link to install jdk https://www3.ntu.edu.sg/home/ehchua/programming/howto/JDK_Howto.html#zz-3. , I was unable to find the jre folder under jdk-10.0.1. "image of the line giving me the ...
0
votes
1answer
3k views

Dbeaver with SDKMAN JRE JDK location

I'm trying to configure Dbeaver with a custom location of my Java installation as I have it installed via SDKMAN. To do that, I have added the vm parameter to the dbearver.ini file, so now when ...
0
votes
1answer
618 views

Default Java not detected by Maven as installed

I have an Ubuntu installation with Oracle JDK 1.8.0_141 that was installed using this guide. tar file was extracted to /opt/jdk and below commands used to set java as default. update-alternatives --...
0
votes
1answer
3k views

No java command after installing JDK [duplicate]

I have downloaded and installed JDK 9 with NetBeans. NetBeans runs fine and I build test application that also runs fine from IDE. But if I run java command in terminal I have error 'java' can not ...
0
votes
1answer
2k views

/usr/sbin/update-info-dir: 1: /etc/environment: JAVA_HOME: not found

I'm trying to install nginx. By Running : apt-get install nginx it fails throwing a strange error saying that there is no JAVA_HOME Lokking to my /etc/environment file , it looks like this : ...
2
votes
1answer
2k views

java crashed with SIGABRT in WTFCrash()

on a newly installed Ubuntu 16.04, I was receiving Ubuntu 16.04 has experienced an internal error. there is a bug issue reported about OpenJDK with this error, therefore I completely removed Java ...
0
votes
1answer
545 views

How to remove JDK and keep JRE in ubuntu 16.04

I've installed JDK-8 on my VPS with the command: sudo apt-get install openjdk-8-jdk But I just realized I don't really need JDK and JRE is enough for me since I develope my projects on my laptop in ...
0
votes
2answers
464 views

Java Plugin crashes on the latest kernel [closed]

I know java npapi plugin is discontinued both by firefox and chrome, but I really need java to work. So, installed Mozilla Build of Firefox, and kept it on a earlier version (51.0.1). Java has been ...
0
votes
0answers
124 views

Deploy exe file into ubuntu or linux environment

I finished my java program development and converted it into exe file which I would like to execute in Ubuntu or Linux environment(Please advise if exe file is not suitable since my program don't have ...
1
vote
1answer
3k views

Intellij can't find JDK/SDK

Here are my environment variables for Java: $ echo JAVA_HOME JAVA_HOME $ echo $JAVA_HOME /usr/lib/jvm/java-8-openjdk-amd64 $ echo $JRE_HOME /usr/lib/jvm/java-8-openjdk-amd64/jre/bin When I click ...
0
votes
0answers
165 views

while installing jre1.8.0_131 returned error exit status 127 and errors were encounted while processing: install-info

i'm using ubuntu 16.04. i m totally new to linux. i tried to install jre1.8.0_131, and i exported the path, copied the files as tutorial said. and then when i use sudo apt upgrade, an error occurs: 0 ...
1
vote
0answers
548 views

Issue in run the sqldeveloper in terminal

I am facing the issue during run the sqldevleoper in the terminal, for that installed JDK 1.8 in my machine even though it showing like. Please refer the below error and share your solution to that. ...
2
votes
3answers
16k views

“JRE Libraries are missing or not compatible” error message

When trying to install SPSS (a statistical analysis package) using sudo ./SPSS_23.0_LNX.bin I get the following: Preparing to install... Extracting the JRE from the installer archive... Unpacking ...
1
vote
3answers
1k views

JRE not installed/Java is disabled on Ubuntu 14 but works on another distro

I need to run some js from a webpage, but when it tries to load I got the error of the subject topic. I'm running ubuntu 14, FF 50xx, and latest version of java. But, that part of the page that came ...
0
votes
1answer
2k views

Cannot install openjdk-8-jre on 16.04 LTS at Myanmar

When I type sudo apt install openjdk-8-jre , it shows as below and didn't install. Reading package lists... Done Building dependency tree Reading state information... Done You might want to ...
0
votes
1answer
1k views

path to javaldx not found (error on libdbus-glib-1.so.2) but JRE is available

trying to run 32 bit dbg build LibreOffice on 64 bits Ubuntu... $ LibreOfficeDev_5.3.0.0.alpha0_Linux_x86_archive/program/soffice javaldx: Could not find a Java Runtime Environment! Warning: failed ...
1
vote
0answers
161 views

Getting JRE error when trying to Uninstall OpManager

Hey I'm kinda new to Ubuntu so forgive the basic nature of the doubt. I'm getting the following error when I try to uninstall OpManager by running uninstaller.bin. This application requires a Java ...
0
votes
2answers
1k views

Setup a modern java for Android Studio

I have troubles setting up java 1.8 for Android Studio. Gradle Sync says: Error:Buildtools 24.0.1 requires Java 1.8 or above. Current JDK version is 1.7. Here what I've got, with the help and ...
-1
votes
2answers
524 views

How do I repair apt-get install after mixed install with rpm?

I'm running Ubuntu 16.04.1 LTS Desktop, but I followed the instructions for installing Oracle Java Runtime for the rpm packaged manager. https://docs.oracle.com/javase/8/docs/technotes/guides/install/...
2
votes
3answers
1k views

Which java to install? [duplicate]

Application use java. When run script, it returns ./browser.sh ./browser.sh: 7: ./browser.sh: java: not found I check java version: java -v The program 'java' can be found in the following packages:...
1
vote
2answers
23k views

Java / Minecraft “Error: Could not find or load main class –Xms1024M”

I am not a Linux pro nor a Java pro, but I am setting up a Minecraft server on Ubuntu 16.04. System has 8GB RAM. I followed all the directions for setting up the server (which is very simple) but ...
2
votes
3answers
261 views

Azureus runs fine on latest java but its dependency check asks for dated version of JRE. How to tell Ubuntu to stop naggin me for “unmet dependency”?

So I force installed Vuze (and its dependency Azureus) via apt-get, and it is working fine on default-jre. Even though the default-jre works as a dependency for Azureus (at least for my use-case ...
0
votes
1answer
1k views

Which JRE should I install for macros in Libre Office for Xenial

I have a clean Ubuntu 16.04 install, and opening Libre Office, it said it requires a JRE installed before I can run or write macros. I want to write VBA macros. Running apt search jre shows many ...
0
votes
1answer
1k views

Installing of jdk and jre 1.8 in Ubuntu 14.04

I tried with all the types possible of installing Java for example: sudo add-apt-repository ppa:webupd8team/java -y sudo apt-get update sudo apt-get install oracle-java8-installer Even I deleted the ...
0
votes
2answers
48 views

Executing file with other application through terminal

Is there any way for me to execute a .jar file with JRE through the command line. I'm having an issue with the file and I wanna see if I can get any information as to what the error is. When I try to ...
2
votes
1answer
537 views

Gephi crashes while loading the sample file

I was trying to install gephi for some network analysis. Initially there was problem with the Java Runtime Environment that is installed. I removed the Open JRE and installed the Oracle JRE 8u77. Even ...
0
votes
1answer
212 views

jre and jdk installation

I got following error while installing the open jdk from ubuntu 14.04. how do i solve this ? You might want to run 'apt-get -f install' to correct these: The following packages have unmet ...
0
votes
1answer
5k views

How to install JRE on ubuntu 15.10?

I have Java version 1.7.0_91 installed in my Ubuntu PC. I installed it using the command sudo apt-get install default-jdk so, I think only JDK is installed but not the JRE. So what can I do to ...
1
vote
0answers
47 views

JRE reinstallation error - Cannot install or upgrade any package

This error occurs everytime I try to install or check for updates. I simply cannot do anything. E:The package jre1.8.0-66 needs to be reinstalled, but I can't find an archive for it.
2
votes
0answers
248 views

Is there anything wrong with java-package?

There is a question about How can I install Sun/Oracle's proprietary Java JDK 6/7/8 or JRE? There are 23 answers at the moment, most of them are either explaining how to do it manually (unpack, move ...
7
votes
1answer
8k views

how can i upgrade only jre from 7 to jre 8 on ubuntu 1404

I currently have the jre 7 and need to upgrade to 8 on ubuntu 1404. I need only JRE upgraded to 8 for demo purpose. Could you please guide me on this? java version "1.7.0_79" OpenJDK Runtime ...
1
vote
2answers
5k views

Java Runtime Environment 1.4.2 Installation

I´ve got HP Proliant dl380 g3 and I can´t use few things from the "iLO(integrated lights-out)" because this tool needs the Java Runtime Environment 1.4.2 to run in my browser HP does not support ...