People who code: we want your input. Take the Survey

Questions tagged [icedtea]

IcedTea is build environment for OpenJDK. It also adds functionality to OpenJDK, including a powerful web plugin.

Filter by
Sorted by
Tagged with
0
votes
0answers
20 views

Password field is disabled in Icedtea

Password Field is disabled when I start my "jnlp" program using IcedTea. How to enable password field so I can login?
0
votes
0answers
59 views

package sun.applet not in java.desktop

I am on Ubuntu 20.04. I have Iced Tea installed and I am using latest OracleJDK. Whenever I try to run any .jnlp file, it shows: package sun.applet not in java.desktop Also, I am not getting any Java ...
0
votes
0answers
37 views

IcedTea javaws file execution error

I have a .jnlp file that works on my windows machine, however with Ubuntu after running the below command javaws {file.name} IcedTea loads the file until an error message arises. class java.io....
3
votes
1answer
5k views

Run JNLP (Java Network Launching Protocol) file on Ubuntu 20.04

I am new to Ubuntu 20.04 (or say any version). I recently upgraded my PC from Ubuntu 18.04 to Ubuntu 20.04. While in Ubuntu 18.04 I was able to login to my company from file *.jnlp. Required Java ...
1
vote
0answers
662 views

Failed to open Cisco WebEx meeting using Java Web Start

To enter a college class I need to execute a JNPL file using the command line (because audio doesn't work from Chrome or Firefox): user@computer:~$ sudo javaws '/home/user/Downloads/CiscoWebExServlet' ...
0
votes
0answers
83 views

javaws command brings yellow screen

I am trying to use javaws to access console of a supermicro server. This one does not have iKVM/HTML5 feature so I will have to use jnlp file. I installed javaws using apt install icedtea-netx And ...
0
votes
1answer
68 views

How to get sound with KGS go server with 16.04 or higher?

Before 16.04 we can get sound using the client cgoban-h.jar and openjdk-6 (and pulseaudio). But no more openjdk 6 for 16.04. The only sound working actually is the bell at the start of a game. :/ ...
0
votes
1answer
299 views

Java not running in latest Firefox

Java is not working or showing up in Firefox 71, though I have Icedtea installed: sudo apt-get install icedtea-plugin icedtea-plugin is already the newest version (1.6.2-3ubuntu1). 0 upgraded, 0 ...
1
vote
0answers
3k views

How to make IcedTea use OpenJDK instead of (no longer installed) Oracle Java?

I had some issues with an .jnlp file using OpenJDK so I installed Oracle Java. It didn't work either, so I uninstalled it (the config folder is still there though). Now, if I want to open something ...
-2
votes
1answer
8k views

Java web application (jnlp) doesn't work

I want to open a java web application (Mirth Connect) on my Ubuntu machine. So following the tips on this page I installed icedtea: sudo apt-get install icedtea-netx and then executed the jnlp file ...
2
votes
0answers
722 views

Running Java Applet on Ubuntu in 16.04

I'm trying to run Java applet on ubuntu 16.04 chrome and firefox browsers. After googling online I see suggestions to install 'icedtea'. Even after that I'm still not able to run java applet as i ...
0
votes
0answers
48 views

i am having issues with an outdated version of iced-tea and have tried doin f install and no luck

Errors were encountered while processing: /var/cache/apt/archives/icedtea-netx_1.5.3-0ubuntu0.14.04.1_amd64.deb Error in function: dpkg: error processing package icedtea-netx:i386 (--configure): ...
0
votes
1answer
820 views

CheckPoint VPN on Ubuntu without IcedTea plugin

I was using firefox with IcedTea plugin to connect to my company CheckPoint VPN, because with snx I never succeeded to connect and don't know how to configure other vpn clients. Now, starting from ...
2
votes
1answer
13k views

Getting java plugin into firefox [duplicate]

I want the java plugin to work in Firefox and so I want to be clear on something. It appears that the default JRE (OpenJDK) that one gets from doing sudo apt install default-jre will not work, and ...
1
vote
0answers
2k views

How can I install the icedtea 7 plugin on 16.04?

I have just installed Ubuntu 16.04, and need to run a Java 7 applet in Firefox, so I installed OpenJDK 7 following the instructions here. Now when I test my java version this is what I get: % java -...
2
votes
0answers
616 views

Java doesn't work (IcedTea )

I installed IcedTea Plugin on Ubuntu 14.04 LTS using Firefox. I receive this error message: Problem initializing runtime environment. Changing the SecurityManager is not allowed. I am not very ...
0
votes
1answer
79 views

one JVM only — how?

I had to install the Oracle JDK to get Netbeans to launch (forgot about umake). Now that I have the official JVM, I want to remove each and every other JVM -- all the OpenJDK stuff, including IcedTea,...
5
votes
0answers
2k views

OpenJDK, IcedTea security settings

I am a beginner Linux user. From my knowledge the system uses OpenJDK and IcedTea only when I connect to a SAP IDES server through SAP GUI JAVA adding a string in it to connect to that server. I use ...
4
votes
1answer
19k views

libnpjp2.so - java plugin missing in openjdk-8-jdk:i386

I am using ubuntu 14.10 and i installed jdk8 via apt-get install openjdk-8-jdk:i386. Using update-alternatives, I have made java 8 as the default one. Now, when i checked java on firefox using this ...
0
votes
1answer
151 views

Error in downloading IcedTea web Start

I executed the command: sudo apt-get install icedtea-netx ...and this error was displayed: Error in downloading IcedTea web Start.. A screenshot of the terminal session: Please Help!
1
vote
1answer
420 views

Cgoban3 for offline use

The software Cgoban3 client is a program to play the game of Go online on the KGS server: http://www.gokgs.com/index.jsp In order to download the Cgoban3 client one first has to get the file cgoban....
1
vote
0answers
13 views

Java not working on Ubuntu 15.04 [duplicate]

When i double click on a .jar file, it opens the archive manager. I have made it executable. I have tried getting Java 6,7 and 8 from the Software center. If i right click on the file and choose to ...
0
votes
2answers
166 views

JavaScript for Firefox 35 and later

Is there anything current or installing a Java and JavaScript for the new Firefox? I recently upgraded Firefox. Now websites I need are not working. There is old information about IcedTea Java plug-in ...
0
votes
1answer
4k views

Firefox Java plugin (icedtea) is installed, what prevents it from being loaded?

After upgrading my Ubuntu installation (now running 14.04 LTS) my java plugin for firefox ceased to work. It does not report an error or anything it just tells me that I need to install a plugin to ...
0
votes
1answer
3k views

How to update IcedTea plugin for latest java

Verifying Java Version A newer version of Java is available Your Java version: Version 7 Update 65 Newer Version 8 Update 25 How do I update IcedTea plugin for latest java?
0
votes
1answer
953 views

IcedTea Doesn't Run Properly in Firefox

I have Java 7 installed for Ubuntu 12.04 and I have IcedTea installed in Firefox (33.0). Some Java plugins are not working correctly. For example: starting from the IcedTea-Web-Tests (see the IcedTea ...
8
votes
4answers
18k views

Unable to install icedtea plugin on Utopic Unicorn 14.10

Trying to install icedtea-7-plugin on 14.10 x64 gives an error. apt-get install icedtea-7-plugin . . . Selecting previously unselected package icedtea-netx:amd64. . . . Processing triggers for man-...
3
votes
0answers
644 views

How to use Firefox AppArmor profile with IcedTea Java plugin on Ubuntu 14.04?

Whenever I set up Ubuntu on a new system, I active the default AppArmor profile for Firefox via sudo aa-enforce /etc/apparmor.d/usr.bin.firefox Doing this on Ubuntu 14.04, however, makes Java ...
2
votes
1answer
258 views

Problem in launchimg TopCoder Arena

I have a IcedTea plugin for TopCoder Arena. I used it till a week back. But today when I am trying to launch the arena, it is showing this error Fatal: Initialization Error: Could not initialize ...
3
votes
0answers
579 views

Unable to start topcoder arena in Ubuntu 14.04

When I want to clear cache using javaws - viewer these error comes. I am trying to launch my topcoder arena. Picked up JAVA_TOOL_OPTIONS: -javaagent:/usr/share/java/jayatanaag.jar Exception in ...
5
votes
1answer
21k views

Where is the IcedTea Control Panel?

I want to disable the sandbox banner on Java Webstart applications, and the official documentation hints at a control panel, but I am unable to find it.
1
vote
4answers
7k views

Java is not working in any browser

I'm using Ubuntu 14.04 , and I've used the 12th edition and 13th and it was always the same problem for me, java is NOT working on any of my browser : all applets aren't functional, I can't login to ...
15
votes
3answers
62k views

IcedTea plugin for OpenJDK 8

I updated from OpenJDK 7 to 8. I uninstalled 7, which uninstalled the IcedTea plugin as well. I tried to reinstall IcedTea with sudo apt-get install icedtea-7-plugin But it doesn't work. When I ...
0
votes
1answer
489 views

Installing IcedTeaPlugin for Chrome

I am trying to get the java plugin to work on chrome but have failed so far. I made symbolic links for the two files : IcedTeaPlugin.so and libjavaplugin.so I made the links in the file section /opt/...
1
vote
2answers
3k views

Ubuntu 14.04 - icedtea-6-plugin:i386 : Depends: icedtea-netx:i386 (= 1.5-1ubuntu1)

First of all, I'm a noob on ubuntu. I needed to run a Java application and installed latest version. After that, tried to run .jar file, it worked, but when I try to run the installed files, they give ...
5
votes
2answers
5k views

Iced Tea plugin keeps asking for permission to run Java applets

Every time the browser wants to load a Java applet a dialog asking me for permission to run the java applet appears. No matter if I check the option "remember this option" or not, the dialog appears, ...
3
votes
0answers
3k views

icedtea-web 1.5 needs confirmation to run trusted applet

I've got ubuntu 14.04 64 bit. I'm using firefox 29 and icedtea as java. "About:plugin" in firefox: IcedTea-Web Plugin (using IcedTea-Web 1.5 (1.5-1ubuntu1)) Now I've setup firefox to ask to activate ...
4
votes
1answer
8k views

Error running Java web application with OpenJDK Java7 runtime in Ubuntu 14.04

I have fresh Ubuntu 14.04 install on my HP Pavilion g6 laptop. I have installed OpenJDK and IcedTea plugin in order to run Java applications as explained here. But when I am going to chess.com ...
2
votes
1answer
3k views

Java applets crashing in 14.04 and 14.10

PhET simulations (java applets) crash in 14.04 (and in 14.10 [update]) after execution. Icedtea starts loading the app and gets to 100%. Then it crashes. I get an error message to use the console to ...
24
votes
1answer
48k views

java plugin in Chromium

Icedtea-7-plugin installed but it does not appears in the list in about:plugins in Chromium. Not able to execute java applets. Tried installing Icedtea-7-plugin but in vain. Using openjdk7 in 14.04
2
votes
2answers
5k views

Cannot launch .jnlp file in precise pangolin

I'm trying to install Matlab but I can't open the download_agent installed from mathworks. It's an jnlp file, but if I use open with -> IcedTea in nautilus nothing happens, and when I try javaws ...
0
votes
1answer
248 views

Problems running java websites

I'm having problems with openjdk7 and icedtea7. In one computer, which works with ubuntu 13.10, I have installed openjdk7 and icedtea7. In the other computer, which works with ubuntu 12.04 and is an ...
2
votes
1answer
74 views

Are there any reliable sources with more frequent jdk icedtea package releases?

I use the canonical repository for retrieving updates from the jdk icedtea, but it seems that it is lagging a lot behind what is supposed to be the latest stable version as per the icedtea website (...
2
votes
1answer
2k views

Mozilla plugin not found to install icedtea

I couldn't configure icedtea web plugin because the ./configure commands fails due to an such an error: Package requirements (mozilla-plugin) were not met: No package 'mozilla-plugin' found Consider ...
1
vote
1answer
3k views

IcedTea plugin not working in Midori web browser

I have Lubuntu 13.04, and I use the Midori WebBrowser. I initially had a problem with the plugins, but later on, I could activate Flash and Java. I use the IcedTea browser plugin to view Java content. ...
6
votes
3answers
16k views

icedtea-7-plugin non-functional in Ubuntu 13.04

I installed(sudo apt-get install) icedtea-7-plugin (and all its dependencies) and have closed firefox and reopened it; and the plugin still does not appear in http//about:plugins Is there a fix for ...
3
votes
1answer
2k views

How to run topcoder arena applet using proxy in Ubuntu 12.10?

I was trying to run topcoder arena applet using proxy. I install latest JDK and iced-tea. When I try to run using: javaws ContestAppletProd.jnlp I'm getting: File cannot be launched because ...
2
votes
1answer
2k views

OpenJDK not working in Ubuntu 12.10 on Firefox

This is a problem I've been facing for quite some time now : installing Java. I have installed the following packages using Synaptic icedtea-netx openjdk-7-jre A few others got installed along with ...
2
votes
2answers
15k views

How to remove openjdk-7?

I want to uninstall java 7 and install the version 6 (as some of programs I would like to use are incompatible with 7). I tried : $ sudo apt-get remove openjdk-7-jre [sudo] password for USER: ...
-2
votes
1answer
623 views

IcedTea java was blocked because it is out of date [closed]

IcedTea is not working and whenever I click "update" it just takes me to a wiki page about IcedTea. I am new to ubuntu and Linux in general so this is very frustrating for me. I need to get this fixed ...