Questions tagged [held-packages]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
2
votes
0answers
201 views

mariadb-server : Depends: mariadb-server-10.3 (>= 1:10.3.25-0ubuntu0.20.04.1) but it is not going to be installed

Recognizing that this is basically a FAQ: nicholas@mordor:~$ nicholas@mordor:~$ sudo apt --fix-broken install Reading package lists... Done Building dependency tree Reading state information......
0
votes
0answers
49 views

Held Broken Packages

Some things i try to install give me a "held broken packages error", eg. MyCroft (and quite a few others) I have tried the usual: apt-get update, upgrade, dist-upgrade, autoremove & -f ...
0
votes
1answer
393 views

Ubuntu 18.04. Unable to install libx11-dev. Unable to correct problems, you have held broken packages [duplicate]

So I'm trying to compile Aseprite, and I'm unable to install a package I need in this process: libx11-dev. Here is the output for "sudo apt install libx11-dev" sudo apt install libx11-dev Reading ...
0
votes
0answers
70 views

Error when installing Wine on Ubuntu 18.04.4 LTS

When I am installing Wine on Ubuntu 18.04.4 LTS, I get the following error: The following packages have unmet dependencies: winehq-stable : Depends: wine-stable (= 5.0.0~xenial) E: Unable to ...
0
votes
0answers
31 views

Code blocks not loading “The following packages have unmet dependencies ”

Codeblocks installation I tried this but it didn't work. I'm new on Ubuntu, can you help?
0
votes
0answers
85 views

apt-get does not proceed with package installation if one package is held

I have put a hold on one of the packages via apt-mark hold cmake but when installing some dependencies for some software, the software's automatic package update script is trying to update lots of ...
8
votes
3answers
6k views

libsensors5 or libsensors-config upgrade problem

After upgrading my Ubuntu from 18.10 to 19.04 some packages were held back but I didn't really care since I thought the issues will be resolved in a few weeks when dependencies will be upgradeable to ...
0
votes
1answer
5k views

why libpython3.6 is not installing?

sudo apt-get install libpython3.6 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
0
votes
0answers
23 views

The following packages have been kept back unable to upgrade [duplicate]

$ sudo apt-get dist-upgrade ubuntu 18.04.1 Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages ...
1
vote
0answers
624 views

Ubuntu 16.04 LTS - another “held broken packages” issue

Was trying to install "unity-tweak-tool" and get: $ sudo apt-get install unity-tweak-tool Reading package lists... Done Building dependency tree Reading state information... Done Some packages ...
3
votes
1answer
1k views

The following packages have been kept back [duplicate]

Here is a long list of packages that have been kept back: The following packages have been kept back: aptdaemon fcitx-frontend-qt5 gir1.2-packagekitglib-1.0 kde-style-breeze kde-style-breeze-...
3
votes
1answer
3k views

Can't install MySQL 5.6 on Ubuntu 16.10 [duplicate]

I was following this instruction https://askubuntu.com/a/765458/490870 duke@ostrov:~$ sudo apt install mysql-server-5.6 [sudo] password for duke: Reading package lists... Done Building dependency ...
5
votes
1answer
586 views

Blacklist only one specific version of a package for upgrades

Let's say we have a package mypackage that is available in different versions from different sources. I do not want to disable any of these sources though. However, the currently latest version of ...
3
votes
3answers
6k views

Issues with Unity Tweak Tool on Ubuntu 16.04

I recently installed 16.04 on my desktop, and one of the first things I did was install the Unity Tweak Tool (via the Ubuntu Software app store). It was working fine for a while. Later, after making ...
1
vote
1answer
3k views

Problem with installing php on Ubuntu 16.04

Entering this into the terminal: sudo apt-get install php7.0 php-pear libapache2-mod-php7.0 php7.0-mysql gives me this output: it@it-Latitude-E6410:~$ sudo apt-get install php7.0 php-pear ...
2
votes
0answers
110 views

Hide hold back package from being listed in software updater and apt

I'm running 16.04 but downgraded the gedit package from 3.18.3 back to version 3.10.4 because of the new ugly and badly usable design, following this great answer by @Videonauth. His script installs ...
1
vote
1answer
284 views

couchdb : Depends: couchdb-bin (>= 1.6.1-0ubuntu4) broken packages

I encountered a problem trying to install couchdb on my Ubuntu 14.10 (GNU/Linux 3.10.23-xxxx-std-ipv6-64 x86_64) server. When I run apt-get install couchdb, I've got the following mistakes : The ...
0
votes
1answer
193 views

Firefox stuck on old version and problems with held packages

I did a clean installation of Ubuntu 14.04.2 two months ago and I noticed recently that firefox was stuck at version 36. I uninstalled it and then the system showed version 35 as the latest. The same ...
6
votes
1answer
29k views

The following packages have been kept back [duplicate]

I have already tried all the usual fixes to this .. no luck so far sudo apt-get dist-upgrade Reading package lists... Done Building dependency tree Reading state information... Done ...
0
votes
1answer
222 views

Why do dist-upgrade and upgrade give different held packages?

sudo apt-get upgrade gives: Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages have been kept back: ...
1
vote
1answer
209 views

Can't install a bunch of packages starting with lib and ending in :i386[not actually a duplicate] [duplicate]

This is definitely NOT a duplicate. The "possible duplicate" I even said I tried in the original question. As for anything else, well, 16 comments and 1 answer that didn't work. It's clearly not a ...
2
votes
0answers
6k views

Ubuntu 12.04 LTS server - build-essential install not possible [duplicate]

Have found this question multiple times on the forum, but none of the answers were serious enough. So the problem with ubuntu 12.04. LTS server is that after a fresh install you can not install build-...
0
votes
1answer
115 views

You have held packages error when trying to install e17

I received the following error when trying to apt-get install e17 (enlightenment window manager): curios:~$ sudo apt-get install e17 Reading package lists... Done Building dependency tree ...
1
vote
1answer
5k views

Unable to re-install compizconfig-settings-manager

While attempting to fix a problem with compiz settings manager, I got an idea from someone to purge compiz - sudo apt-get purge compiz. The compiz core packages are still intact however, the gui ...
3
votes
1answer
510 views

Update unresolvable problem

When I am try to update my system , I am getting the following error: Could not initialise the package information An unresolvable problem occurred while initialising the package information. ...