Questions tagged [hardware-acceleration]

The use of computer hardware to perform some functions faster than is possible in software running on the general-purpose CPU.

Filter by
Sorted by
Tagged with
0 votes
0 answers
173 views

libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)

I encounter this error everywhere since I upgrade to ubuntu 22.04 on wayland. But is this related? Here is the error libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name =...
0 votes
1 answer
12 views

Video playing: Skipped frame when on battery

When I'm playing a video on battery (either youtube (example), or local VLC ), there is noticeable stutter/skipped frame only when I'm battery powered. I guess there is some kind of power optimisation ...
  • 123
0 votes
0 answers
103 views

Chromium has graphics glitches when hardware acceleration is enabled

I have issues with my chromium when i activate Hardware acceleration. So looks my chrome://gpu when i enable hardware acceleration. And all other windows and tabs of Chromium. I need to disable ...
  • 696
0 votes
1 answer
67 views

nvidia GPU suddently not used anymore at all

Somehow my NVIDIA GPU is not being used at all anymore (just for displaying the screen). Take a look at this picture: There are a lot of options missing. Also, take a look at this: Usually 600MBit ...
  • 175
0 votes
0 answers
90 views

chrome Video Acceleration is not working on wayland

I am trying to enable video acceleration in chrome My chrome://gpu output says that hardware acceleration is enabled but when I play video on youtube, the hardware acceleration is disabled CPU: Info:...
  • 1
0 votes
0 answers
54 views

how to ssh into your vmware and make hardware acceleration possible

How to ssh into your VMWare workstation 16 player I want a step-by-step guide to it. Also how to enable hardware acceleration
  • 11
1 vote
0 answers
2k views

High cpu usage on youtube

When playing videos on youtube the cpu increases up to 100% while in everyday use it stays around 15%. In windows when playing videos on youtube the cpu usage is between 20 and 30% I think it's a ...
0 votes
1 answer
2k views

AMDGPU VA-API fails on firefox due to libLLVM-13.so

I'm using Ubuntu 20.04 LTS x11, the kernel version is 5.13.0-39-generic #44~20.04.1-Ubuntu. I installed firefox and turned VA-API on, but I notice error outputs like libva info: VA-API version 1.8.0 ...
  • 1
0 votes
0 answers
47 views

UHD600 can't play video

Ubuntu 21.10, UHD 600 (system recognizes as UHD 605) The problem: can't play movies in default preproducer nor in vlc, it only plays audio. Firefox (even with VA-API enabled) can't play a 720px video ...
1 vote
0 answers
291 views

Hw acceleration lost after upgrade to 21.10

After upgrading to Ubuntu 21.10 I lost the hw acceleration. Now if I try to play a H264 video using vlc I get: $ vlc myvideo-h264.mkv VLC media player 3.0.16 Vetinari (revision 3.0.13-8-g41878ff4f2) [...
  • 405
1 vote
2 answers
3k views

Chrome in Ubuntu 21.10 only achieves video acceleration with VP9, not with H.264, resulting in higher CPU usage

I'm checking with the developers tools, and with VP9 on youtube, I get Vpx decode, but with H264, I get FFMpeg only. I'm launching with the flags: --ignore-gpu-blocklist --use-gl=desktop --enable-...
  • 59
2 votes
1 answer
442 views

Chromium Video-Call: Blurred background -> CPU fan

If I use the "blurred background" feature in a video call in Chromium, then the CPU fan gets very loud. I have quite new Lenovo Laptop. Maybe Chromium can't use the hardware acceleration. ...
  • 2,322
0 votes
0 answers
179 views

How To Fix Error: "Check your video drivers. Your system is currently running without video hardware acceleration."

I am running Ubuntu 20.04 Server (Intel Pentium G3240, XEON E3-1200 integrated GPU) with Cinnamon desktop (ver. 4.4.8). When I login I get the message above in a popup window. The system is running ...
2 votes
0 answers
116 views

Graphics problems after upgrade from 21.04 to 21.10 [Intel 1075H UHD] [duplicate]

tl;dr [solved] render problems (e.g. in keepassxc) only appear when use_composite in XFCE4 is disabled (see new bug report) black screen in Firefox still appears. Workarounds: start Firefox with --...
  • 121
0 votes
0 answers
2k views

How to enable 3D acceleration on Windows VM in virtual machine manager

I have tried setting Type to Spice server and opengl on in display Spice and in Video Virtio setting the model to Virtio and 3D acceleration on, but that made the Windows VM unusable because of the ...
  • 1
0 votes
0 answers
721 views

run parsec on ubuntu 20.04 + nvidia hardware acceleration

I am interested in using parsec as a remote desktop. According to the internet it has very good results. I am using ubuntu 20.04 and have a nvidia rtx 3070 ti graphics card I installed parsec from the ...
  • 187
2 votes
0 answers
1k views

Google Meet extremely slow likely due to Hardware Acceleration

Every time I enable Hardware Acceleration in order to have visual effects on Google Meet the entire browser (Firefox, Chrome, and Brave) is so slow it's impossible to use. I've tried installing the ...
  • 384
1 vote
1 answer
1k views

Enabling hardware acceleration in Firefox

I'm using Ubuntu 20.04.3 on AMD Ryzen 3 5300U with Renoir graphics, running Firefox 93 x64 on X11. I followed the guide on ArchWiki, but even though MOZ_LOG_="PlatformDecoderModule:5" ...
  • 1,232
7 votes
0 answers
4k views

Hardware acceleration chrome+youtube?

I am having an issue watching hd (720 or 1080) videos on Ubuntu 21.04 fresh install. I get really high cpu usage (50% on all cores) which is pretty high for a 720p vid. I tried watching the same video ...
  • 235
0 votes
1 answer
1k views

Can't get nouveau to work with VA_API for video acceleration on firefox? Only can get CPU drivers to work with firefox

Edit2: Sorry, running Ubuntu 20.04.3 LTS, and HWE stack. I get the same error with the GA Stack. _ I've been trying to get nouveau to work so that I can use my Nvidia P500 for hardware acceleration ...
3 votes
0 answers
356 views

How to disable graphics hardware accelerations in 20.04?

For troubleshooting purposes, how do I completely disable graphics hardware accelerations in Ubuntu 20.04 (Focal Fossa)? The related Graphics settings don't seem to be available in the Settings app ...
  • 273
0 votes
1 answer
95 views

ubuntu freeze do i need more ram?

I am currently running a dual boot setup for ubuntu 18.04 and windows 10. While building some code on ubuntu(along with several internet tabs opened), my computer will freeze and lag to the point i ...
  • 11
1 vote
1 answer
86 views

Ubuntu Server HWE Kernel future releases

I’m running a Media Server on a Ubuntu Server LTS 20.04 with HWE kernel 5.8 (latest). The thing is that my cpu is an intel 11th gen, and the integrated GPU is being detected/claimed by Ubuntu only ...
2 votes
1 answer
510 views

Linux: Browsers has no hardware acceleration Nvidia 840M

My laptop has a nvidia 840m geforce card. I'm trying to get hardware acceleration working for youtube on the browser. As the cpu heats up. After spending much time going through forums and guides. I ...
0 votes
1 answer
5k views

How to (force) use Nvidia graphics with OpenShot?

I'm on Ubuntu 20.04 . Yesterday I slightly edited a video in OpenShot, but video exporting was too slow, like it will take forever to finish! So now I want to use my Nvidia GeForce GTX 1050Ti, but I ...
  • 128
0 votes
0 answers
1k views

Hardware Acceleration Doesn't work on Chromium

I've been trying to set up hardware acceleration using the chromium dev branch + this guide: https://www.linuxuprising.com/2018/08/how-to-enable-hardware-accelerated.html I've also enabled hardware ...
3 votes
2 answers
3k views

How to get chromium with vaapi on ubuntu 20.10?

is there any way to get chromium with vaapi on ubuntu 20.10?? I've tried snap version from candidate/vaapi channel and it does not work now but it worked about a month or so ago. gpu: intel hd 620
  • 61
2 votes
0 answers
499 views

How to view hardware video encoder/decoder utilization on AMD GPUs?

For a long time I've used the tool psensor to view the utilization of the hardware video encoding/decoding block on my Nvidia GPUs, but recently I've been curious about how to perform a similar task ...
0 votes
0 answers
368 views

xserver-xorg-hwe-18.04 broke hardware acceleration

I have been struggling to get my hybrid graphics (i915, amdgpu) to properly work in Ubuntu 18.04. A few months ago, I installed the drivers from ppa:oibaf/graphics-drivers. While the Intel drivers ...
4 votes
1 answer
4k views

prebuilt ffmpeg packages with QSV support for ubuntu

Suprisingly i couldn't find any ppa with prebuilt ffmpeg packages to add QSV (intel quicksync video) support. Are there any, around? And isn't QSV added by default because it would rely on ...
  • 223
0 votes
0 answers
2k views

How to enable VA-API in VLC in Ubuntu 16.04

I have Ubuntu 16.04. I can't enable VA-API in VLC (the VA-API output is not present among the one I can choose, only VDPAU, OpenGL GLX, X11, XCB, framebuffer, etc.). I have an Intel i5-4200M CPU, ...
0 votes
0 answers
242 views

How to speed up my new 'supposedly' high powered computer

Does anyone have some tips for ways I can optimize/improve the speed of my computer? Just bought a new one, intended for neuroimaging analysis, and i installed ubuntu. I know there's some features of ...
  • 95
2 votes
1 answer
19k views

How to use hardware encoding in ffmpeg (h264_omx) on Raspberry Pi 4 running Ubuntu

I'm nearly finished migrating my RPi4 4GB to Ubuntu 19.10 with Gnome - it is running better than I thought it would. I've got one remaining hurdle for the moment: using the h264_omx hardware encoder ...
1 vote
0 answers
1k views

vainfo fail in Ubuntu 16.04

I am using i5-8500 with intel UHD-630 graphics. Already I installed next packages. sudo apt-get install i965-va-driver vainfo But vainfo prints this message. sky@sky:~$ vainfo libva info: VA-API ...
1 vote
2 answers
2k views

Hardware Virtualisation problem in ubuntu while using virtualbox

So i am using Ubuntu 19.10 and recently installed virtualbox on my pc but there is a problem to use virtualbox. As you can see in the above screenshot, there are some invalid settings. (System ...
  • 85
1 vote
1 answer
3k views

HW acceleration in KVM VM?

I have setup a Ubuntu 19.04 virtual machine (guest) on my Kubuntu 18.04 LTS. Everything is working fine, but how do I enable HW-acceleration for video on the guest? vainfo gives this error: libva ...
  • 5,221
4 votes
3 answers
3k views

Hardware decoding on 18.04 with nvidia

I can not get hardware decoding for HEVC 10 bit files and VP9 (YouTube) through web browsers to work. Tried a bunch of online "solutions" with no luck. I have a nVidia GTX 1050 (2GB), running Kubuntu ...
  • 41
3 votes
1 answer
10k views

Enabling hardware acceleration for windows 10 VM in qemu 2.11 on 18.04

I have a a machine with specs per below where one of my VM's is windows 10 in which I'm trying to run sketchup 2019, which requires hardware acceleration to be turned on, so I'm trying to figure out ...
  • 121
4 votes
1 answer
10k views

ffmpeg h264_nvenc, "No NVENC capable devices found"

I'm trying to get hardware encoding working on ffmpeg. I'm using Ubuntu 18.04 with its default kernel (4.15.0-50.54), ffmpeg package (3.4.6-0ubuntu0.18.04.1) and Nvidia drivers (390.116-0ubuntu0.18....
  • 393
0 votes
0 answers
31 views

Screen froze and display garbled after booting Ubuntu and other distros

My pc is freezing and screen flickering when I boot Ubuntu or any other distro. Today I successfully installed Android x86 with the option "no hardware acceleration" so my question is there a option ...
0 votes
0 answers
109 views

YouTube video is stucked for few seconds if I have enabled the layers.acceleration.force-enabled in Firefox

If I have enabled layers.acceleration.force-enabled, the YouTube video usually get stucked for few seconds while the audio is playing fine, it never happend when I was in Manjaro, this problem is ...
  • 1,554
1 vote
1 answer
257 views

Facebook game & hardware acceleration

I cannot make Facebook's "Gardenscapes" game work on my fresh installation with Firefox. When I start it, it asks me to enable Hardware Acceleration. When the flash popup shows up, "Enable Hardware ...
  • 11
1 vote
0 answers
3k views

Fresh Ubuntu 18.04 install: only llvmpipe, neither Intel nor Nvidia GPU is used despite of config efforts

TLDR version: Once you have a fresh install of Ubuntu 18.04 (and has updated all the existing software on the system immediately after install) and your laptop run llvmpipe for grahics, what is the ...
  • 121
2 votes
1 answer
6k views

How to enable integrated GPU (with QSV) on Coffee Lake CPU in Ubuntu 18.x

I am so far unable to get Plex/ffmpeg to recognize the integrated GPU in my Core i7-8700 CPU. From my research it appears this is a common issue related to Coffee Lake CPUs, not just this specific ...
1 vote
0 answers
4k views

How to use a hardware device for HW-accelerated encoding with `ffmpeg` `snap`?

Using the ffmpeg package 18.04 from apt I can encode a video hardware-accelerated in HEVC on Kaby Lake: ffmpeg -vaapi_device /dev/dri/renderD128 -i input.mkv -vf 'format=nv12,hwupload' -c:v ...
  • 5,221
5 votes
1 answer
28k views

3D acceleration not working in VirtualBox

My laptop has an 8th Generation Intel Core i5 8250U processor, with an Nvidia GeForce MX150 GPU, 8GB RAM and a 1TB hard drive. I have installed Ubuntu 16.04 64-bit as a guest OS on Windows 10 64-bit ...
0 votes
1 answer
122 views

Virtual Box installed from the repos does not seem to be able to run with 3d acceleration

I'm running with Kubuntu 18.04 as host, on a machine with a Intel HD chip. Virtual Box is installed from the repos and guest is Kubuntu 17.10. If I do not enable hw acceleration, everything works ...
0 votes
1 answer
1k views

Ubuntu 18.04 intel 2d acceleration broken?

I upgraded from 17.10 where I had a custom driver from this PPA installed, because otherwise I couldn't get multihead support working on my intel graphics (i7-8700). I removed the drivers from the ...
3 votes
3 answers
7k views

Ubuntu 18.04 Virtual box : 3D acceleration activated, does not work

So I install a brand new ubuntu 18.04 in virtual box. I installed both host extensions and guest additions. My host system in a windows 10. I activated the 3D acceleration in my VM settings. when I ...
  • 181
3 votes
1 answer
1k views

High cpu usage when scrolling or moving windows Gnome in 18.04

I have an AMD a10-7850k apu in my computer and I also have an RX550 GPU. I have the RX550 GPU set up to be passed to a windows kvm for games and that works fine. But On my APU using the radeon driver ...
  • 116