Last call to make your voice heard! Our 2022 Developer Survey closes in less than a week. Take survey.

Questions tagged [gstreamer]

For questions related with the GStreamer multimedia framework. GStreamer allows a programmer to create a variety of media-handling components, including simple audio playback, audio and video playback, recording, streaming and editing.

Filter by
Sorted by
Tagged with
0 votes
0 answers
15 views

Unable to install gstreamer packages in Ubuntu 18.04.5 LTS [duplicate]

I see some of the gstreamer packages in ubuntu packages like the one https://packages.ubuntu.com/bionic/gstreamer1.0-rtsp. But when I run apt-get install gstreamer1.0-rtsp its not installing and ...
user avatar
1 vote
0 answers
24 views

How can I resolve multi-arch conflict (liborc-0.4-dev)?

When trying to install the package liborc-0.4-dev together with liborc-0.4-dev:arm64 on Ubuntu 18.04, I get a conflict: The following packages have unmet dependencies: liborc-0.4-dev : Conflicts: ...
user avatar
1 vote
0 answers
87 views

Hw acceleration lost after upgrade to 21.10

After upgrading to Ubuntu 21.10 I lost the hw acceleration. Now if I try to play a H264 video using vlc I get: $ vlc myvideo-h264.mkv VLC media player 3.0.16 Vetinari (revision 3.0.13-8-g41878ff4f2) [...
user avatar
  • 315
0 votes
0 answers
294 views

How can I install Nvidia Gstreamer plugins (nvenc, nvdec) on Ubuntu 20.04

I do like to accelerate GStreamer by making use of my GPU card, I have seen this tutorial, but it seems to be outdated! Nvidia Video Codec SDK doesn't have include folder to copy anymore, moreover I ...
user avatar
  • 205
0 votes
0 answers
108 views

Why is ffmpeg and vlc able run RTSP stream but gstreamer is unable to?

When executing this command (gst-launch-1.0 rtspsrc location=rtsp://--- --gst-debug=3) I get this output: Image Not sure how to make sense of this because my RTSP stream is sending via TCP. Also, this ...
user avatar
0 votes
0 answers
13 views

Where does xplayer store current position in a video

This started out as idle curiosity, and now I'm starting to get obsessive. When I close xplayer halfway through watching a video, then re-open the same video, it starts from where I was up to. I'm ...
user avatar
4 votes
0 answers
164 views

How to add additional .m4a plugin to gstreamer1.0-plugins-*?

In the app. called Audio Recorder, I can't record in .m4a format. The app says, "Please install additional plugins(from gstreamer1.0-plugins-* package) to support the m4a format" How do I ...
user avatar
  • 1,556
1 vote
1 answer
278 views

Is it possible to upgrade Gstreamer and libx264 on Ubuntu 18.04?

Ubuntu 18.04 has 1.14 Gstreamer installed and libx264-152. Is it possible to upgrade it to 1.16 or 1.18 as well as some dependent libraries like: libx264-155 and libx265? Whether some PPA exists or ...
user avatar
2 votes
1 answer
768 views

How to handle gstreamer missing codecs

I experience the issue of missing codecs for popular video containers like mp4 and avi both when using gstreamer on the command line as well as when trying to run sample playbin code (details per each ...
user avatar
  • 2,134
0 votes
0 answers
66 views

Rygel Media Server - files lists by metadata not file name

A new install of Ubuntu Hippo, restored the media files to "Videos" and made that a shared folder. I was able to see and play these files on my network-conected TV when I was running 20.4 ...
user avatar
  • 19
0 votes
0 answers
161 views

trying to install every gstreamer but stuck with Conflicts 1.18.4-1 is to be installed

CONTEXT I want to install everything gstreamer.. MY OS : Ubuntu 21.04 WHAT I TRY apt install *gstream* -y ERROR I GET The following packages have unmet dependencies: gstreamer1.0-python3-dbg-plugin-...
user avatar
  • 101
0 votes
1 answer
250 views

Missing GStreamer plugins h264parse, and avdec_eac3

I attempted to install LabVIEW Community into a Crossover 64 bit Windows 10 bottle. At first there were many errors that indicated missing libraries. I installed them, and these errors no longer ...
user avatar
  • 81
0 votes
1 answer
187 views

Dummy output issue after installing Gstreamer and ALSA plugins in Ubuntu 20.04

I had installed Gstreamer and ALSA plugins to work on some experiments. Steps followed for the installation of the plugin: https://tsn.readthedocs.io/avb.html#plugins-installation However, after the ...
user avatar
1 vote
0 answers
1k views

How to use GStreamer to play an mp4 video?

I want to use GStreamer on ubuntu 21.04. Here is what I have attempted: user@host:~$ gst-launch-1.0 -v playbin uri=file:///home/user/thisVideo.mp4 Setting pipeline to PAUSED ... Pipeline is PREROLLING ...
user avatar
  • 215
1 vote
1 answer
1k views

gnome-control-center: symbol lookup error: /lib/x86_64-linux-gnu/libgstvideo-1.0.so.0: undefined symbol: gst_aggregator_simple_get_next_time

A few days back I was trying to build wxWidgets-3.15 library on Ubuntu 21.04 with multiple flags enabled. I've had some issues with the build so I made a ticket on that on stackoverflow. Unfortunately,...
user avatar
0 votes
0 answers
608 views

Ubuntu 18.04 with gstreamer dev version 1.19

The default version of gstreamer is 1.14 , what i need to do is to use the gstreamer 1.19. What i have tried : apt purge gstreamer issue : this will remove gdm3 the default display manager Cloned ...
user avatar
0 votes
0 answers
29 views

rtpulpfecenc & rtpulpfecdec missing fron gstreamer1.0-plugins-good

I am in trouble running streams with fec using rtpulpfecenc and rtpulpfecdec. They are missing from folder and other good-plugins are there, s0 running gst-inspect on these is useless. I have run ...
user avatar
4 votes
1 answer
3k views

Is GStreamer available for Ubuntu 21.04, and if it is, then how to install it?

My first attempt to install GStreamer on Ubuntu 21.04 looks like this: user@localhost:~$ sudo apt install gstreamer Reading package lists... Done Building dependency tree... Done Reading state ...
user avatar
  • 215
2 votes
0 answers
527 views

20.10 => 21.04 update broke Gstreamer's plugins? (RTSP streams over VLC won't work, while i.e. mplayer plays them OK)

After updating to 21.04 (hirsute), my VLC broke as for the RTSP stream playback functionality. I suspect this to be related to my gstreamer plug-ins breaking down during the install. Running the RTSP ...
user avatar
3 votes
1 answer
687 views

gstreamer faac in Ubuntu 20.04

Does anyone know how to install the faac plugin for gstreamer on Ubuntu 20.04 I have run $ sudo apt install gstreamer1.0* which installed plugins-good, -base, -bad and -ugly. I am getting $gst-...
user avatar
0 votes
1 answer
3k views

Receiving and sending udp stream with one gst-launch-1.0 (gstreamer) command

On an Ubuntu 18.04 laptop, I can receive a stream with the following gst-launch-1.0 commands: The stream source (from a test brd that generates a test pattern): $ gst-launch-1.0 -e videotestsrc ! ...
user avatar
1 vote
0 answers
144 views

Sound issue of LDOCE5 viewer (written in Python3 using Gstreamer)

I have installed LDOCE5 viewer on Ubuntu 20.04 as described here. In summary: Install some dependencies: sudo apt-get install git make python pyqt5-dev-tools python3-pyqt5 \ python3-pyqt5.qtwebkit ...
user avatar
  • 365
1 vote
1 answer
533 views

GStreamer 1.19 error: gst/sdp/sdp.h: No such file or directory

Ubuntu 18.04 $ gst-inspect-1.0 --gst-version GStreamer Core Library version 1.19.0.1 My helloworld program has these includes: #include <gst/gst.h> #include <glib.h> #include <gst/sdp/...
user avatar
1 vote
2 answers
732 views

Unable to apt install armhf packages with unmet dependencies [duplicate]

I am trying to setup an multi arch environment to cross compile armhf board. The steps I followed is quite simple. Install ubuntu-18.04.1-desktop-amd64 on VirtualBox. sudo dpkg --add-architecture ...
user avatar
  • 111
0 votes
2 answers
646 views

symbol lookup error: a conceptual questioning

Since I installed ubuntu on my laptop, I have a problem with gstreamer, which affects many programs using it, totem, kdenlive, even gnome-control-center, and prevents them from working. The error ...
user avatar
  • 3
2 votes
2 answers
499 views

Build gnash on ubuntu 20.04

To play some old flash animations I need a flash player for ubuntu 20.04. I was used to use Gnash, but this is no longer shipped with ubuntu. So I tried to compile it by myself, i.e. cloned the git ...
user avatar
  • 163
2 votes
0 answers
284 views

C270 webcam keeps freezing in both cheese and teams

I've bought a Logitech webcam c270 for my online course, for some reason the university uses Teams. Both Teams and the C270 are compatible in my ubuntu 20.04. The webcam works pretty well until it ...
user avatar
1 vote
1 answer
1k views

v4l2loopback device not working with gstreamer

I'm on Ubuntu 20.4.1. I followed the instructions on https://github.com/umlaeute/v4l2loopback e.g. sudo modprobe v4l2loopback to set up a loopback device which I then can also find under ls /dev/video*...
user avatar
  • 23
1 vote
0 answers
266 views

Cpaturing a window using ximagesrc gives black borders around the image

I was trying to capture a single window using ximagesrc. Encoding it to png and saving it gives black bordes around the image. This was the command i used. gst-launch-1.0 ximagesrc remote=1 num-...
user avatar
0 votes
0 answers
488 views

Opus encoder with channels=8 and mpegtsmux is not working

Pipeline: gst-launch-1.0 v4l2src device=/dev/video0 io-mode=4 num-buffers=3600 ! video/x-raw, width=3840, height=2160, format=NV12, framerate=60/1 ! omxh265enc gop-mode=basic gop-length=60 b-frames=0 ...
user avatar
  • 1
0 votes
0 answers
222 views

Update Gstreamer to latest version

I get this message in logs, how to update to latest version. Gst version 1.17.0.1 is installed but Pitivi requires at least version 1.17.90
user avatar
1 vote
0 answers
1k views

How to install gstreamer 1.16 on ubuntu, which already have gstreamer 1.14

Is there ant way I can upgrade to gstreamer 1.16 from 1.14 or The way I know is: download .deb file and dpkg --install .deb But doing this have other dependency...like libc6 need to >=2.29 . . Any ...
user avatar
2 votes
1 answer
1k views

GNOME Sushi preview not working for video files

I have GNOME-sushi installed on Ubuntu 20.04 LTS. Initially when I selected a video and pressed spacebar, the following error occurred. After installing the gstreamer1.0-plugins-bad and gstreamer1.0-...
user avatar
  • 2,165
3 votes
0 answers
723 views

Handbrake preview video "Missing GStreamer plugin"

I have a fresh install of Ubuntu 20.04 and chose to install non-free codecs upon installation. But apparently I'm still missing some codecs. When I want to preview a file in handbrake, I get these ...
user avatar
  • 1,113
1 vote
0 answers
772 views

Ubuntu 20.04 - RTP Sound horrible with PulseAudio

just upgraded some of my computers to Ubuntu 20.04, also tried with fresh install, in all case the pulseaudio rtp receive module is giving me very poor sound. Did some testing with vlc as a client to ...
user avatar
  • 11
0 votes
1 answer
908 views

PyQt5 QtMultimedia shows black screen on playing H.264 video

We are using a tool based on PyQt5 for some video processing. Since a few days some users complain, that the tool shows only a black screen instead of a video. Sound is still working. We were able to ...
user avatar
  • 31
2 votes
1 answer
4k views

Which package contains gstreamer-properties?

Simple question: $ gstreamer-properties gstreamer-properties: command not found What package do I need to install? I've already tried: $ sudo apt-get install libgstreamer1.0-0 gstreamer1.0-plugins-...
user avatar
  • 121
1 vote
0 answers
1k views

gstreamer: windows webcam to ubuntu 18.04 streaming not possible

I want to stream OS agnostic w/ gstreamer: PC1: Windows webcam PC2: Ubuntu box I even cannot display my webcam on PC1 and get this error: C:\Users\gerri\Desktop>gst-launch-1.0 ksvideosrc device-...
user avatar
  • 273
0 votes
1 answer
7k views

Gstreamer error: XDG_RUNTIME_DIR not set in the environment

I am using Ubuntu 18.04 LTS on the Windows 10 PC with Windows Subsystem for Linux turned on so that I can run Linux on the PC. I tried to use Gstreamer-1.0 then. When running the line: gst-launch-1.0 ...
user avatar
1 vote
0 answers
198 views

gnome subtitles "could not play the file"

I'm running Ubuntu 18.04.3 with Gnome-subtitles 1.6 installed via PPA as follows sudo add-apt-repository ppa:pedrocastro/ppa sudo apt-get update sudo apt-get install gnome-subtitles because they ...
user avatar
3 votes
0 answers
3k views

Gstreamer stuck at setting pipeline to paused

I am currently trying to run gstreamer on ubuntu but there are some errors I face. When I try to run a simple pipeline, like the video test pipeline gst-launch-1.0 videotestsrc ! autovideosink it ...
user avatar
0 votes
0 answers
1k views

GStreamer won't show video

I'm using a Lenovo Thinkpad P1. I installed Ubuntu 18.04 but had problems with stability and supporting an external monitor so I upgraded to 19.04. This seems to work well but now I'm trying to use ...
user avatar
  • 346
6 votes
3 answers
4k views

Which codecs does Totem require for H.264 playback in a fresh install of 19.04?

I have a fresh install of Ubuntu 19.04 and I am unable to play a MP4 video in Totem. Following the suggestion to install the necessary decoder was unsuccessful. Which codecs must I install to play ...
user avatar
  • 12.6k
0 votes
1 answer
746 views

Trouble with gstreamer, video playing with qt 5.10 application on Ubuntu

New laptop, installed Ubuntu 16.04, everything was fine. Now I'm trying to play video with my qt app. Sadly, I get an error when doing it - for avi files this is what I get: (myApp:2322): GStreamer-...
user avatar
  • 61
2 votes
1 answer
2k views

How do I get pbutils on Ubuntu 18.04 and 19.04, a required dependency of gstreamer?

I have the following build error: meson.build:49:0: ERROR: Dependency "gstreamer-pbutils-1.0" not found I want to meet needed dependencies. the previous one was: meson.build:48:0: ERROR: ...
user avatar
  • 2,714
6 votes
1 answer
2k views

What is the development package for "gstreamer-player-1.0"

According to valadoc, a package called gstreamer-player-1 exists. However, I can't find a corresponding package in the ubuntu package search.
user avatar
0 votes
1 answer
135 views

Transcription software playback issues

I need to transcribe some audio recordings. Audacity replays the WAV files perfectly, yet when I try to use dedicated software (Parlatype or gTranscribe) the playback jumps and stutters in places. ...
user avatar
  • 71
0 votes
0 answers
228 views

G Streamer pipeline not working properly

I've try the Below pipeline for Youtube Live straming... gst-launch-1.0 v4l2src device=/dev/video0 ! 'video/x-raw,width=1280,height=720,framerate=30/1' ! x264enc ! flvmux ! rtmpsink location="<...
user avatar
  • 71
0 votes
1 answer
4k views

Error when compiling gst-rtsp-server example

I'm currently trying to setup a Ubuntu server to redistribute a rtsp feed coming from an ip camera. I saw that the gst-rtsp-server library of gstreamer could help me with this issue. I installed the ...
user avatar
  • 245
0 votes
1 answer
552 views

since ugrade to 18.04, gstreamer requires a missing library: libiconv

My installation of gstreamer has been broken since I upgraded to 18.04:$ gst-launch-1.0 gst-launch-1.0: error while loading shared libraries: libiconv.so.2: cannot open shared object file: No such ...
user avatar
  • 1

1
2 3 4 5