Skip to main content

Questions tagged [gobject]

GLib Object System library provides object-oriented framework for C programming language with bindings in other languages, and is used extensively with Gtk applications. Questions related to software development using Gtk or to the library itself should use this tag. DO NOT USE FOR REPORTING BUGS.

Filter by
Sorted by
Tagged with
2 votes
0 answers
106 views

syslog very large, full of "Object St.DrawingArea has been already disposed error

I found my root partition quickly (lets say daily, even hourly) full. took a look at the syslog and it was 18GB in size. took a look inside and it was full of two errors, one related to a specific ...
Masoud Borbor's user avatar
2 votes
1 answer
11k views

PyGObject, venv and Ubuntu 20.10: ImportError: libffi.so.7: cannot open shared object file: No such file or directory

After updating from Ubuntu 20.04 to Ubuntu 20.10 I am not able to run PyGObject applications on a Python Virtual Environment. I can reproduce the issue following these simple steps: sudo apt-get ...
Roberto Leinardi's user avatar
4 votes
1 answer
2k views

Differences in GLib, Gtk+, GObject, Atk, GIO [closed]

What are the differences or relations of these libraries/terms in GNOME development?
Lakindu Akash's user avatar
2 votes
2 answers
2k views

When *.pyc files (related to their deb-packages) are created and how to recreate them?

I have two Ubuntu 18.04.1 LTS systems: clean installation of Ubuntu 18.04.1 LTS upgraded from Ubuntu 16.04.5 LTS Note: All things in the both systems have been installed using APT (from deb-...
N0rbert's user avatar
  • 101k
0 votes
0 answers
683 views

Nautilus : python extension package compatibility issue (Ubuntu 14.04)?

I tried to install several python nautilus extensions (i.e. nautilus-columns, nautilus-open-as-root,... ) without any success. Installation goes fine, but nothing shows up in nautilus. Of course, ...
Thierry's user avatar
  • 911
1 vote
0 answers
1k views

Python Gobject broken Help?

I don't know what broke it, but my python Gobject library is missing something ... When I try to run most tools like gnome-tweak-tool which require GTK, I get an error saying : Traceback (most ...
Xqua's user avatar
  • 99
5 votes
1 answer
3k views

system-config-printer broken after update to 14.04

After I upgraded to Ubuntu 14.04 the dialog system-config-printer in gnome runs into problems when called from the command line: sudo system-config-printer Traceback (most recent call last): File "/...
alodi's user avatar
  • 205
8 votes
1 answer
8k views

I cant configure rhythmbox as gobject-introspection 1 is not installed

Previously I advised someone on how to upgrade to Rhythmbox to version 2.99.1 here. However they couldn't upgrade due to gobject-introspection-1.0 not being installed. I couldn't help them. Now, ...
Simon's user avatar
  • 4,813
0 votes
1 answer
1k views

Can I change the file icon with Gio? [duplicate]

Possible Duplicate: How can I change the folder icon? I'm using python. I want change a file icon with Gio from a python app. I found a lot of deprecated documentation and I'm not sure how I can ...
Costales's user avatar
  • 2,278
2 votes
1 answer
992 views

GObject (GTK3) TreeView: how can I activate row programmatically?

I've got a working TreeView with a ListStore as its model and selection set to SINGLE. How do I emit a signal to activate a specific row? I'm using PyGI. (Sorry if this is basic; it's not in the ...
monotasker's user avatar
  • 3,675
0 votes
2 answers
969 views

Compiling Pyqt4 program

I am trying to package a program I wrote (using Pyqt4) into a single executable for linux. I tried using Pyinstaller however it has problems with importing Gio (for settings) from gi.repository ...
user654628's user avatar
12 votes
1 answer
4k views

What does "Introspection" mean, and how is it related to GObject Introspection?

What does introspection mean exactly? How is it useful for a programmer? Can somebody please explain in layman terms?
Nishant George Agrwal's user avatar