Questions tagged [gnutls]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
3
votes
0answers
26 views

Black window when launching Spotify

So the client was working without any problems. Next day, I turn on my computer this error : [1014/192432.737169:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : ...
1
vote
1answer
45 views

lynx: relocation error

Trying to run cron jobs with lynx fails. I get this error: lynx: relocation error: /usr/lib/x86_64-linux-gnu/libgnutls.so.30: symbol _idn2_punycode_decode version IDN2_0.0.0 not defined in file ...
1
vote
0answers
231 views

why I cannot install libgnutls30-dev?

if I try to install gnutls-dev it will install the libgnutls28, but in the system I do have libgnutls30. How can I install the dev files for gnutls30? Note, selecting 'libgnutls28-dev' instead of '...
0
votes
1answer
430 views

Occasional gnutls handshake error

I'm trying to download the AOSP from Google using repo sync. Occasionally, I receive an error similar to the following: fatal: unable to access 'https://android.googlesource.com/platform/system/bt/': ...
1
vote
1answer
169 views

Missing df --direct option?

during configuration (after install) of Oracle XE 18c on my 16.04, I noticed this message generated by the shell script: /bin/df: unrecognized option '--direct' 'Try '/bin/df --help' for more ...
0
votes
0answers
226 views

Generating a CSR using Certtools in Ubuntu 18.04

I've generated many CSR's using OpenSSL. It's easy and straight forward. However, GnuTLS is the new and updated replacement for SSL on Ubuntu according to some sources but the interrogation during ...
2
votes
1answer
294 views

Cannot run FileZilla on Ubuntu 18.10

Got this message today (Ubuntu 18.10) trying to run FileZilla 3.33.0. ****GnuTLS error -50 in gnutls_priority_set_direct: The request is invalid. Error: Failed to initialize TLS. Error: Could not ...
0
votes
0answers
510 views

wget cannot access a site on local network, returning this error: A TLS fatal alert has been received

I want to periodically download the index page of a monitoring web service, running on our local network (172...*:) that is using a self signed certification for SSL. I'm using these switches: $ ...
2
votes
4answers
863 views

ubuntu 18.10 - filezilla GnuTLS

Filezilla version 3.33.0 using GnuTLS 3.6.4 suddenly and constantly throws an error GnuTLS-error -50 after trying to initialise TLS. No connection works.
5
votes
1answer
9k views

Ubuntu 16.04 openssl s_client write:errno=104

I'm getting the following error when trying to connect to github.com, google.com, dropbox.com via https, but stackoverflow.com, askubuntu.com and the majority of https websites work. Relevant details:...
5
votes
1answer
2k views

apt-get wants an older GNUTLS version to be defined

Just upgraded to 18.04, and when I run sudo apt update, it complains: /usr/lib/x86_64-linux-gnu/gio/modules/libgiognutls.so: symbol gnutls_pkcs11_privkey_init version GNUTLS_3_4 not defined in file ...
0
votes
1answer
3k views

“libgnutls-dev has no installation candidate” error while installing Ubuntu as a DC in a Windows server domain

I am trying to install Ubuntu (the latest) as a AD-Server in a test Windows server domain. I am following this tutorial but it is somewhat old. When arriving at minute 14, I am lost. I need to ...
6
votes
1answer
13k views

16.04 - curl: (35) gnutls_handshake() failed: Error in the pull function

When trying to connect to a HTTPS websites, I get this error curl: (35) gnutls_handshake() failed: Error in the pull function.. In detail: curl -vvv "https://example.tld" * Rebuilt URL to: https://...
0
votes
1answer
651 views

Create, sign and deploy certificates in Ubuntu 14 system using certtool

I'm trying to learn about certificate generation, signing and what it takes to become a CA. I am developing a HTTP proxy, which will be a middle proxy between browser and actual web server, and it ...
0
votes
0answers
1k views

Installing Samba from Source and Receiving Gnutls Error

OK, after beating my head against the wall for a day I need help trying to figure out what's going on here: Using in-tree heimdal kerberos defines Checking for program krb5-config.heimdal ...
3
votes
1answer
5k views

GnuTLS: TLS connection was non-properly terminated - error after upgrading to ubuntu 16.04

I am using ubuntu server 16.04. I just upgraded this morning. This command which is part of the redmine upgrade generates a GnuTLS error. I have searched for solutions online but have found none. ...
0
votes
0answers
614 views

broken curl on ubuntu… OR… gnutls_srp_allocate_client_credentials, version GNUTLS_3_4 not defined

I just installed ubuntu (xenial) on a box and discovered that my newly-installed git is crippled: $ git clone https://github.com/FortAwesome/Font-Awesome.git Cloning into 'Font-Awesome'... git-remote-...
2
votes
0answers
425 views

How do libgnutls version numbers work?

I'm running Ubuntu 14.04.5 LTS and it appears there are two libgnutls packages available: libgnutls26 and libgnutls28. According to apt-cache show, these are versions 2.12.23 and 3.2.11, respectively....