Questions tagged [glibc]

glibc is the GNU C Library, which provides many common and important functions for programs. Almost every program in Ubuntu directly or indirectly depends on this, and will completely fail to run without it. Besides the kernel, glibc is probably the most essential part of the system; even the init daemon requires it. In Ubuntu, glibc is provided by the libc6 package.

Filter by
Sorted by
Tagged with
0
votes
0answers
20 views

Visual Studio Code 1.51.1 not launching on Ubuntu 20.10 (ERROR: GLIBC_2.29' not found)

VSCODE VER: 1.51.1 This shows up with code --verbose: /usr/lib/x86_64-linux-gnu/gvfs/libgvfscommon.so: undefined symbol: g_task_set_name Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/...
0
votes
0answers
22 views

Why free() coredumps on one but not the other?

I have this very simple source code used as a test program: #include <stdio.h> #include <stdlib.h> int main() { FILE *fp; fp = fopen("file.txt", "w"); ...
1
vote
0answers
46 views

downgrade libc6 to 2.23-0ubuntu11.2

I'm running ubuntu16, and last week I installed https://ubuntu.pkgs.org/20.04/ubuntu-universe-amd64/clang-10_10.0.0-4ubuntu1_amd64.deb.html from ubuntu20 package repository(by simply add ubuntu20 ...
0
votes
0answers
38 views

Terminal no longer works (at all)

I think I've really done on on myself now. So, I've been trying to run steam on Lubuntu and upon startup it reports that I'm missing libc.so.6, so specifically I went to the debian package website, ...
0
votes
1answer
43 views

Operation not permitted

Got trouble with starting one app. Introduction I have Ubuntu-20.04-amd64 with core 5.x on my VDS. I have needed to install other core with some patch. But patch was available for 4.9.158 core version....
0
votes
0answers
64 views

libcrypto.so: undefined reference to `fcntl@GLIBC_2.28'

Am performing ARM cross compilation on x86 and i have a tool chain like below : SET(CMAKE_SYSTEM_NAME Linux) include(CMakeForceCompiler) SET(CMAKE_C_COMPILER arm-linux-gnueabihf-gcc) SET(...
0
votes
0answers
31 views

how to fix blender not opening on ubuntu 20.04

Recently on my dual core processor, which has dual boot of windows 8 and Ubuntu 20.04, windows opens blender 2.81 with OPENGL32, but it is laggish. So I installed Ubuntu and when I try to open blender ...
0
votes
1answer
65 views

Compile glibc 2.3 with linuxthreads

I'm trying to compile glibc 2.3 (https://ftp.gnu.org/gnu/glibc/glibc-2.3.tar.gz) with the addon linuxthreads (https://ftp.gnu.org/gnu/glibc/glibc-linuxthreads-2.3.tar.gz) under ubuntu 18.04. The ...
1
vote
1answer
31 views

Why do “ping undefinedhost” and “curl undefinedhost” (e.g. libc “gethostbyname”) ping / contect to the local host instead of failing?

I have an old Ubuntu 16.04 (LTS) installation and today noticed, that ping and curl are being told (by libc, I assume), that the IP of any unknown host is the same as the IP of the local host (e.g. &...
1
vote
1answer
319 views

libc6-dev header files missing on Ubuntu 20.04

byteswap-16.h contains a macro used in many programmes. On Ubuntu 18.04 this file was part of the libc6-dev package and installed to /usr/include/x86_64-linux-gnu/bits. With 20.04 this file is no ...
1
vote
0answers
3k views

Version `GLIBC_2.28' not found

I'm trying to install PyTorch on ARMv7(32-bit) architecture but PyTorch doesn’t have official ARMv7 builds so i tried this unofficial build. It installed successfully but when I import torch I get ...
0
votes
1answer
207 views

4kvideodownloader launcher doesn't start

About 6 months ago 4kvideodownloader just stopped working. When I try to start the app it shows up on the launcher for 5 seconds and it looks like it's about to open, but it disappears without having ...
1
vote
1answer
80 views

How to install glmnet on R 3.2.3

i need to install glmnet package for my R, but it said it doesn't support the version i installed (3.2.3). I have tried to install R 3.6. the problem i am facing is that to install R 3.6, i need ...
0
votes
0answers
177 views

Prefer AAAA (IPv6) DNS lookups before A (IPv4) lookups

I want AAAA requests first as required by https://tools.ietf.org/html/rfc8305#section-3 Both queries SHOULD be made as soon after each other as possible, with the AAAA query made first but I ...
0
votes
0answers
41 views

videoforlinux libv4l installed even if a dependency is not met

Working with Ubuntu 16.04 LTS. Requirements of libv2l-0 Investigating the problems highlighted in skypeforlinux recognises external webcam but gives black screen I looked into the requirements of ...
0
votes
0answers
15 views

How to find the linker that is compatible with a given libc?

I'm having a binary which has to be run with another libc rather than the default libc on my machine. I have tried LD_PRELOAD=/path/to/libc /path/to/binary but it gives error as I dont have a ...
1
vote
0answers
2k views

GLIBC_2.27 not found when launching applications through Nautilus

I have VSCode installed and never experienced this issue before, but now after I installed some web camera utilities and video conversion I seemed unable to launch VSCode from Nautilus. What works: ...
1
vote
0answers
5k views

/lib/aarch64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by ./domoticz)

For my homeautomation I need GLIBC_2.28 or higher. My os is: pi@odroidn2:~$ cat /etc/os-release NAME="Ubuntu" VERSION="18.04.4 LTS (Bionic Beaver)" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 18.04....
0
votes
0answers
65 views

/usr/bin/dpkg: relocation error: /usr/bin/dpkg: symbol xstat version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference

I tried to install a software that required to run this command: sudo apt-get update Once I run it I received this error: /usr/bin/dpkg: relocation error: /usr/bin/dpkg: symbol xstat version ...
1
vote
0answers
125 views

Receive error “version `GLIBCXX_3.4.23' not found” while trying to reactivate Matlab License

I am trying to reactivate my license for Matlab and I am getting stuck because I cannot click on a link. Here is the link that I cannot click on: When I do try to click on the link, I get this error ...
0
votes
0answers
980 views

Libc Version Error

I used ubuntu 18.04 and I tried to do update libc package from 2.27 to 2.29, turn out its a bad idea and I get an error message every time I try sudo apt-get upgrade The error message : Reading ...
3
votes
0answers
13k views

GLIBC_2.27 not found Ubuntu 16.04

One of the software I want to run needs GLIBC_2.27, and all I see is this error on the console: /lib/x86_64-linux-gnu/libm.so.6: version 'GLIBC_2.27" not found When I run this command ldd --version ...
1
vote
3answers
501 views

How to re-insall libc6 after remove?

I removed libc6 manually (i.e. by sudo apt remove libc6 command) on my Ubuntu 18.04 system and after reboot, there is just grub command prompt: GNU GRUB version 2.02 Minimal BASH_like line editing ...
0
votes
2answers
478 views

Install libpng version 1.6 for Ubuntu 19?

How to install libpng for Ubuntu 19 so that I would be able to open Packet Tracer 7.2.1?
2
votes
1answer
1k views

error: ld-2.27.so in swift on Ubuntu 18.04

I installed swift on my ubuntu 18.04 and when i start i get this error. but the code works fine when i'm writing them, I search some solution to fix this error but the thing is that i will remove the ...
3
votes
1answer
6k views

version `GLIBCXX_3.4.26' not found even though libstdc++.so.6 recent enough

I realize there are many questions like this, but the difference from the others is that my libstdc++.so.6 actually does appear to be up to date enough (see below for the strings it exports). This is ...
1
vote
0answers
438 views

gdb error for keepassx/keepassxc: “Cannot find user-level thread for LWP” “generic error”

I tried to run gdb on keepassxc, but encountered an unfamiliar error: $ gdb /usr/bin/keepassxc GNU gdb (Ubuntu 8.1-0ubuntu3) 8.1.0.20180409-git Copyright (C) 2018 Free Software Foundation, Inc. ...
0
votes
1answer
733 views

./a.out fails to load

I am trying to execute a C program via gcc compiler on ubuntu 18.04 In a folder named 'gsl', I have extracted the gsl.tar file. This is also the folder where I save all my ' '.c programs written in ...
5
votes
0answers
4k views

`GLIBC_2.28' not found in Ubuntu 16.04/14.04 in Travis

I have been using a binary to test in Travis, but it's been compiled with a new version of GLIBC apparently and now I get this all the time: perl6: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2....
0
votes
2answers
3k views

How to fix broken glibc packages

I am using Ubuntu 18.04 and I tried to upgrade libc6 from version 2.27 to 2.29 but I ended up breaking package system. I cannot fix because when I try to use fix commands, it always shows tons of ...
2
votes
0answers
6k views

'GLIBC_2.25' not found on Ubuntu

Getting following error while compiling the visit (visualization tool) pawar@pawar:/usr/local/visit/bin$ ./visit ./../current/linux-x86_64/bin/python: /lib/x86_64-linux-gnu/libc.so.6: version `...
2
votes
1answer
756 views

dpkg: error processing package glibc (--configure)

I am using Ubuntu 18.04.2 LTS and, recently, every time I try to sudo apt-get upgrade the following occurs: Reading package lists... Done Building dependency tree Reading state information... ...
0
votes
0answers
2k views

Ubuntu 18.04 Fresh Install Apparent Absence of glibc

I have just installed ubuntu 18.04. I have run: apt update && apt upgrade I have downloaded llvm from llvm releases When I run: clang file.c -o file Where 'file.c' contains: #include &...
0
votes
0answers
179 views

how i install glibc 2.19 without terminal (manually and already compiled files)

How do I get the files of glibc 2.19 to copy and paste in the relevant folders, for specifically execute blender 2.79b? I can't compile, make install or anything related to terminal installation, so ...
1
vote
1answer
1k views

sys/ustat.h file not found

I'm trying to build a modified version of the LLVM compiler as used in the Pepper-project I'm using this script to install it, however it fails with this error: /pequin/compiler/buffetfsm/llvm/...
3
votes
0answers
2k views

How can I get glibc as a static library?

I want to compile a program and statically link it to glibc, so it can run on other Linux distributions without the user having to do any special configuration. I tried using CFLAGS="-static -static-...
4
votes
2answers
12k views

Compilation of m4 1.4.10 to 1.4.18 fails due to “Please port gnulib freadahead.c to your platform!” on Ubuntu 18.10

The building of tarball releases of GNU m4 1.4.10 to 1.4.18 (didn't test all hotfix versions, but I assume the error is consistent among this range) with ./configure && make -j1 and git git ...
1
vote
2answers
1k views

How to install requested libs: GLIB, libavcodec and libavformat?

I've got an application from InteractiveBrokers, which sometimes gives me this: So I searched for those libs in synaptic, but in the screenshots below you can see that they all seem to be installed. ...
3
votes
1answer
369 views

Systemd error after upgrading from 18.04 to 18.10

After upgrading from 18.04 to 18.10 i got the following error: systemd[1]: segfault at ffffffffffffffc0 ip 00007fe716b80184 sp 00007ffcc7f9cf88 error 5 in libc-2.28.so[7fe716af5000+171000] I reboot ...
0
votes
0answers
681 views

sudo apt-get dist-upgrade giving errors, unable to open Ubuntu

I'm trying to do sudo apt-get dist-upgrade for upgrades all of the packages on the Linux system (14.04). In the middle, it gave an error and I ran sudo apt-get install -f, the PC got rebooted and went ...
4
votes
0answers
14k views

What is the recommended way to install glibc 2.27 on Ubuntu 16.04? [duplicate]

I tried the following command, but it seems that the package was not found. $ sudo apt-get install libc-bin=2.27-3ubuntu1 Reading package lists... Done Building dependency tree Reading state ...
1
vote
1answer
7k views

/lib/libc.so.6: version `GLIBC_2.14' not found on a ubtuntu machine

I have an internet-less ubuntu server (amd64) which is accessed via ssh. To install a package i installed "libc6-udeb_2.13-38+deb7u10_amd64.udeb" which messed up everything. Now i get this error ...
1
vote
1answer
214 views

In context of Docker images, which Ubuntu image version fixes the CVE-2018-10000 issue with Glibc?

We are trying to address a security issue with Ubuntu 17.10 image (ubuntu:17.10) which uses glibc version 2.26. This has a security vulnerability CVE-2018-10000 that is related to integer overflow. ...
0
votes
1answer
2k views

Undefined reference to symbol acos@@GLIBC_2.2.5 while compiling xpdf

I get the following error while compiling xpdf using make. I've tried using the command: LIBS=-l make but it doesn't work. I know the problem is that the c compiler cannot recognise the math code in ...
1
vote
0answers
541 views

How to build a source package glibc-source for arm architecture on x86 machine

I am building a glibc-source for arm architecture but I am getting the following issue. I have run the following commands: apt-get source glibc-source sudo apt-get build-dep glibc-source Changed ...
1
vote
0answers
6k views

Downgrade glibc on ubuntu 18.04

Ubuntu 18.04 comes with glibc 2.27. This breaks some tools I'm currently using for a project. Is there any way for me to downgrade glibc in 18.04 to 2.26? apt-cache shows that only version 2.27 is ...
8
votes
3answers
9k views

How can I fix a missing/renamed libc.so.6?

The reason that I need to somehow become root without typing sudo is because error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory I used ...
8
votes
1answer
13k views

'GLIBC_2.25' not found on Ubuntu (Windows Subsystem for Linux)

I have following error on Ubuntu 16.04 (Windows Subsystem for Linux) /lib/x86_64-linux-gnu/libc.so.6: version 'GLIBC_2.25' not found I've already tried: apt-get update apt-get install libc6 It ...
2
votes
0answers
67 views

how do I get a list of syscall numbers from my ubuntu distribution?

This question may be a little clean and green. I'm looking to retrieve a list of syscall numbers like in this post.
2
votes
1answer
10k views

GLIBC => 2.5 Ubuntu 16.04

I'm running Ubuntu 16.04 LTS in a server environment, and a piece of backup software says it needs "On Linux, glibc 2.5 or higher is required." I've run ldd --version and get ldd (Ubuntu GLIBC 2.23-...