Questions tagged [glib]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
58 views

Boot hangs on “Initialize hardware monitoring sensors”

My Ubuntu 19.04 installation does not boot up anymore. It hangs on the message "Initialize hardware monitoring sensors": I can log in however on terminal (eg TTY5) Output of journalctl: One red ...
0
votes
1answer
244 views

E: Version '2.48.2-0ubuntu4.1' for 'libglib2.0-0' was not found

I am doing mlperf. ///// update 2 ///// main page: https://mlperf.org/ github and testing steps: https://github.com/mlperf/training/tree/master/object_detection Just follow the README.md, until ...
5
votes
1answer
840 views

How to configure a `dconf` key globally across all user accounts

I want to set the 'automount' key, for the ‘media-handling’ schema, to ‘false’, for all users on a single desktop machine. I can do this individually, i.e. one user at a time, by using gsettings ...
20
votes
1answer
7k views

Cinnamon session crashing login from greeter

I wanted to change my desktop environment (DE) to cinnamon because it was way faster on my test computer. I ran the command: apt-get install cinnamon-desktop-environment Rebooted. Changed the DE ...
0
votes
0answers
283 views

How to update libglib without updating everything?

I am asking this because I was downloading midori browser for lubuntu 14.04.5 (without ppa) and a dependency error occurred. libglib2.0-0 (>= 2.41.1). Package Installer package: midori status:Error ...
2
votes
0answers
690 views

GTK3 compilation won't find right GLib-2.0, which I actually compiled. What am I missing?

The last days I struggled with libraries (GLib2.52.2 & GTK3.22.15), while I tried to compile them on Ubuntu 16.04 LTS (fresh installation). The GLib2.52.2 just compiled without errors after ...
6
votes
1answer
5k views

Ubuntu 16.04 GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications

i keep getting this error. I am not sure how to get rid of it. I am using NVIDIA drivers 381.22 does that cause this problem? i tried everything from here: My dconf/gsettings installation is broken. ...
0
votes
1answer
775 views

Compile gcc 3.2 on Ubuntu 16.04 (under compiler gcc 5.4.0)

I am on Ubuntu 16.04 and with gcc-5.4.0 already installed. I am trying to build the gcc-3.2 compiler according to this tutorial as I need it to compile glib-1.2.10, to build gtk-1.2.10, to run phoebe-...
2
votes
1answer
340 views

“Play it slowly” error (GLib.Error , gconfaudiosink) [not solved]

I recently moved Ubuntu 16.04 from an HDD to SSD. // latest update: uninstalled, rebooted, reintalled the software. Problem still there. // Since then, "Play it slowly" doesn't work, a dialog window ...
0
votes
1answer
779 views

There's no choice to create a Python2.7 notebook in Jupyter

My Jupyter notebook doesn't have a choice for creating a Python notebook. Can you please why could the reason be and how to fix it? I expect to see something like the following: But this is what I ...
1
vote
0answers
44 views

Why am I getting GLib errors when I launch Firefox? [duplicate]

I am new to Linux and have been poking around a lot in Terminal. I launched Firefox from the command line and noticed that I began getting the below. It still opens and seems to run as it should. I ...
0
votes
2answers
2k views

Ubuntu-software crashes

Just ran a regular software update, nothing abnormal. Prompted me to reboot, so I did, and once logged in the program ubuntu-software "crashed" (window opened briefly, then disappeared). Rebooted a ...
1
vote
1answer
2k views

*could not find libmount* when cross-compiling glib-2.5

I'm trying to cross-compile for my embedded target but libmount/libmount.h could not be found: (... compile process) checking for LIBMOUNT... no checking libmount/libmount.h usability... no checking ...
0
votes
1answer
4k views

Ubuntu14.04 install glib-2.50.0

I'm trying to install glib-2.50.0 on Ubuntu 14.04. When I ran ./configure in terminal. It came out with configure: error: *** Could not find libmount How to solve it?
0
votes
0answers
450 views

libglib2.0-dev package has unmet dependencies

i'm trying to install libglib2.0-dev (dependency for gstreamer1.0-dev) into 64-bit Ubuntu-16.04 but unsuccessful, with the following error message: The following packages have unmet dependencies: ...
0
votes
0answers
2k views

fatal error: glib.h: No such file or directory" even though I have libglib2.0-dev installed

I have recently switched from openSuse to Ubuntu, and I'm having trouble compiling a project of mine (https://github.com/laleksic/URMulator) which worked flawlessly on openSuse. Running make, I get ...
1
vote
1answer
512 views

Ubuntu 16.04 LTS upgrade broke some dependencies

I just upgraded my laptop from 14.04 LTS to 16.04 LTS and it appears to have broken several dependencies. I noticed two broken python packages, but after poking around, it appears like the issues may ...
58
votes
3answers
33k views

Nautilus not opening up, showing GLib error

When I launch nautilus from terminal the following error is printed and nautilus doesn't open up. (nautilus:25179): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->...
7
votes
1answer
536 views

Another (unsolvable) “old glib” problem

Im sure veterans know the drill (as this question seems to have been asked a billion times), but I am getting this error while installing a piece of software ( ./configure )from source: *** 'pkg-...
1
vote
1answer
2k views

Nautilus not working since 16.04 install [closed]

So after I installed 16.04 Ubuntu update, I tried to open my home folder, but it didn't work. I tried running nautilus in terminal and it thrown this: user@user-desktop:~$ nautilus (nautilus:13623): ...
2
votes
1answer
2k views

GLib-GObject-WARNING when closing gvim

I set my computer up new with Ubuntu 16.04 today. I already installed vim-gnome. While working with it, everything is fine. But when I close gvim I get this message in the terminal: (gvim:5834): ...
2
votes
0answers
356 views

How to solve old GLIB error while installing “pygobject” using jhbuild

I am trying to install pygobject using jhbuild. And I am getting this error: configure: error: Package requirements (glib-2.0 >= 2.48.0) were not met: Requested 'glib-2.0 >= 2.48.0' but version ...
3
votes
0answers
83 views

Proprietary driver utility won't load

I have a xenial with kde5. When I go to proprietary drivers' utility in system settings I see only the flash message about collecting data about my system, but the list of drivers' list never loads. ...
2
votes
1answer
363 views

glib-2.48.0 configure syntax code error

I should probably post this in the glib forums but I want to try here first. I want to update the required dependencies for GTK+. When I start the process with glib-2.48.0 I find that there is no ...
1
vote
1answer
729 views

gconf override glib schema error - “can not parse as value of type 'd'”

I'm trying to override the gconf settings for text-scaling-factor and scaling-factor on my system, following the method mentioned here. So I created a file at /usr/share/glib-2.0/schemas/30-retina-...
0
votes
1answer
1k views

unity --version > ImportError: No module named glib

When I execute the command unity --version as shown below, I am getting an error. The Version is Ubuntu 15.10 alex@xc1706:~$ unity --version Traceback (most recent call last): File "/usr/bin/...
4
votes
3answers
11k views

“ImportError: No module named glib” when running ScreenFetch

When opening terminal I get the follow 4 lines before ScreenFetch runs: [[ ! ]] Traceback (most recent call last): [[ ! ]] File "/usr/bin/unity", line 21, in <module> [[ ! ]] import glib [...
12
votes
4answers
18k views

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages

I've been trying to install the CoreBird Twitter application and have had horrible luck with getting it to compile and then I came across a deb (from here) and tried to install it that way. However, ...
0
votes
1answer
1k views

Key “enable-interactive-search” not found

Nautilus doesn't open. Here is terminal output: ** (nautilus:7905): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not ...
0
votes
1answer
212 views

Does 'g_thread_join' delete 'gpointer data'?

From the reference manual: "g_thread_join() consumes the reference to the passed-in thread . This will usually cause the GThread struct and associated resources to be freed." Does 'g_thread_join' ...
2
votes
1answer
913 views

Can't compile tiny C code which uses librsvg

I am almost complete noob in linux world and I use Ubuntu 14.04 LTS with gnome-session-fallback (compiz) under VirtualBox on Windows 8.1 machine. My goal is to use this library: https://github.com/...
0
votes
1answer
1k views

`make` does not work on `dbus-glib-0.104`

My system is Ubuntu 14.10, I used make on other packages minutes before this, so in general it is working. My aim is to install xfce4-windowck-plugin-0.2.4 for which I am trying to manually solve the ...
1
vote
0answers
827 views

glib-2.0 removed, need them back

I earlier installed glib-2.42 which was needed as a dependency for a program. But some softwares(sublime text) stopped working and were showing error related to glib. So i downgraded the version to 2....
0
votes
1answer
61 views

System functionality lost after my compilation of glib 2.0 and Gstreamer

It seems that my Ubuntu 14.4 LTS lost lots of functionality after my compilation of glib 2.0 and the latest Gstreamer. Multimedia, IME, auto-mount and many other functionality have lost since then. ...
0
votes
1answer
183 views

How can i downgrade a package installed from source?

i installed glib2.42 from source but that's creating a problem for me. So i tried to downgrade it running make uninstall and installed glib2.28 afterwards. But now when i try to build a software using ...
7
votes
1answer
23k views

glib.h make error. fatal error: glib.h: No such file or directory

for solution i searched on the Internet. i added the output of the command pkg-config --cflags glib-2.0 that is -I/usr/include/glib-2.0 -I/usr/lib/i386-linux-gnu/glib-2.0/include to the make file like ...
0
votes
1answer
168 views

14.04 server glib critcal: source id x

Console keeps giving me this error glib critcal: source id x was not found when attempting to remove it I don't know why it gives me this. If someone could give me some log to give ill post it? ...
9
votes
3answers
6k views

GLib-CRITICAL console-kit-daemon

A fresh install of 14.04 with KDE installed yields the following error: [...] Jan 8 13:58:19 linuxtest4 console-kit-daemon[1969]: GLib-CRITICAL: Source ID 20 was not found when attempting to remove ...
0
votes
1answer
122 views

Whenever I open firefox from terminal there is an error [duplicate]

Currently using 14.04 and whenever I open firefox from terminal this error message comes (of course it does open firefox and it works fine) (process:7949): GLib-CRITICAL **: g_slice_set_config: ...
7
votes
3answers
14k views

Unable to restart Nautilus (required by Dropbox)

Every time I log in Dropbox opens up the screen informing me that Nautilus needs to be restarted. Clicking the restart button does nothing though. If I enter terminal and run nautilus -q it returns ...
0
votes
1answer
580 views

gfortran compiling GILDAS fails with undefined references to libgio

I'm trying to compile the software package GILDAS (http://www.iram.fr/IRAMFR/GILDAS/) from source on 14.04, and am getting stuck on the make checks, with an error which seems to be an issue either ...
5
votes
2answers
16k views

How to solve old GLIB error

I am in the process of installing GTK+ but it needs various pre-requisites. These are glib - 2.0 >= 2.35.3 atk - >= 2.7.5 Pango- >= 1.32.4 gdk-pixbuf-2.0 >= 2.27.1 Now I upgraded my glib-2....
1
vote
1answer
1k views

Glib error when trying to open Firefox and Thunderbird

I read the other similar problems but either there are no answers or the problem is not the same as mine. Suddenly, without any reason, my Firefox and Thunderbird just stopped working. I click on the ...
0
votes
1answer
354 views

What's the matter with my GTK here?

Every time I run a gtk program such nautilus, synaptic, those kind of appears again and again but those programs can still run: (gnome-terminal:589): GLib-GObject-WARNING **: Two different plugins ...
34
votes
4answers
24k views

Gvim GLib-GObject-WARNING in ubuntu 13.10

I upgraded from ubuntu 13.04 to ubuntu 13.10 this afternoon. And when I try starting vim form the terminal after the upgrade, I get these warnings (gvim:4054): GLib-GObject-WARNING **: Attempt to ...
4
votes
2answers
8k views

Installing glib gives “You must have either have gettext support”

I'm trying to install glib-2.37.6 (also same problem with glib-2.32.1) and getting this error during configuration: You must have either have gettext support in your C library, or use the GNU ...
2
votes
1answer
1k views

winegstreamer broken with >=glib-2.32.0, how to check the glib version in ubuntu?

I am a novice to Ubuntu and don't know which keyword should be put in Google. I wine a game but the game couldn't play a video. Someone tell me that you may come across the bug in wine, but I'm not ...
4
votes
2answers
5k views

Thunderbird won't start

Restarted my computer, and noticed that Thunderbird which is set to auto-start did not start. So I clicked on the icon on the taskbar, the box highlighted the icon, the cursor spun around for a minute ...
3
votes
2answers
10k views

Komodo Edit: GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

when i try to run Komodo Edit 8.0 from terminal, it returns me this error: (process:9508): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed how can i fix this? note: ...
0
votes
1answer
2k views

GEdit not working for some users

I am using GEdit 3.8.2 on Ubuntu 13.04 Raring Ringtail with GNOME 3.8. I have two user accounts on my computer. When I launch GEdit in my account, I get a window that is blank, and am not able to ...