Questions tagged [gem]

RubyGems is a package manager for the Ruby programming language. Ruby packages, known as gems, are managed via the 'gem' command-line tool. This tag is for all questions related to managing the Ruby packaging system: gem installation, updates, removal, troubleshooting, etc.

Filter by
Sorted by
Tagged with
0 votes
0 answers
39 views

How do I install v8@3.15 on ubuntu?

I am new to Linux and I am trying to setup a ruby on rails app from work. Now, the Gemfile wants to install therubyracer. Upon running bundle install, it fails: Fetching therubyracer 0.12.3 Installing ...
user avatar
3 votes
1 answer
53 views

Installing gem5

I am trying to install gem5 using the below documentation: https://www.gem5.org/documentation/learning_gem5/part1/building/ But in the documentation, the below commands does not work: python3 'which ...
user avatar
1 vote
0 answers
318 views

ERROR: Failed to build gem native extension "mysql" on wsl2 with ubuntu 20.04

I have tried to install gem install mysql on wsl2 but I got the error. Building native extensions. This could take a while... ERROR: Error installing mysql: ERROR: Failed to build gem native ...
user avatar
  • 111
1 vote
0 answers
2k views

Redmine: Bundler could not find compatible versions for gem “actionpack”

I'm trying to configure plugin in redmine after getting a github link of the plugin it's installed successfully and these command running smoothly as: sudo gem update sudo gem install bundler sudo ...
user avatar
1 vote
1 answer
288 views

Could not find rake-0.9.2 in any of the sources - Ubuntu 16.04

I am trying to install snorby, but I get this this error: Could not find rake-0.9.2 in any of the sources I tried to: Delete Gemfile.lock bundle install --no-deployment bundle install rake bundle ...
user avatar
1 vote
0 answers
686 views

Problem installing a ruby gem on Ubuntu 16.04

I have a problem installing a Rubygem pdfbeads on my Ubuntu 16.04 and wonder if anyone could help. I never used or ran ruby before, but I needed this gem as it is required within a DJVU-to-PDF file ...
user avatar
3 votes
1 answer
1k views

Problem with accessing an installed ruby gem package from a shell script under Ubuntu 16.04

I used snap to install the latest version of ruby under Ubuntu 16.04 $ sudo snap install ruby --classic $ which ruby /snap/bin/ruby $ ruby -v ruby 2.7.0p0 (2019-12-25 revision 647ee6f091) [x86_64-...
user avatar
5 votes
1 answer
4k views

Can't install RMagick 4.0.0. Can't find ImageMagick with pkg-config on Ubuntu 16.04

Trying to install pdfbeads on Ubuntu LTS 16.04 with the command $ gem install pdfbeads I'm getting the error message "ERROR: Can't install RMagick 4.0.0. Can't find ImageMagick with pkg-config" Below ...
user avatar
1 vote
0 answers
104 views

How to analyze output in gem5 simulation

How can we check the data sharing and parallelism for a benchmark in gem5 simulator. I have run for 4 cores with 4 threads with 2 level cache where size of L1=4MB and L2=4MB respectively. I was told ...
user avatar
  • 21
1 vote
0 answers
72 views

How can I manage all my Ruby gems as Ubuntu packages?

Whenever I have to install Ruby software on our Ubuntu based webserver, I run into a new gem package manager problem that I never saw with Ubuntu packages. By now I really hate it, and got the idea ...
user avatar
  • 5,509
0 votes
1 answer
139 views

Uninstalling old xenial Ruby gems after bionic upgrade

When I upgraded to Bionic, Ruby was upgraded from its default Xenial version 2.3 to its default Bionic version 2.5. That means that Ruby gem-provided programs that I installed via gem install no ...
user avatar
  • 162
2 votes
1 answer
469 views

Why Vagrant fails after OS upgrade?

Multiple packages upgraded like gem, ruby and its plugins. Now when I run vagrant up I get: Vagrant failed to initialize at a very early stage: The plugins failed to initialize correctly. This may ...
user avatar
  • 993
0 votes
2 answers
2k views

gem install failure

I am trying to install an instagram-crawler by using the gem command: gem install instagram-crawler But I am receiving the following error: Building native extensions. This could take a while... ...
user avatar
0 votes
1 answer
2k views

Failed to build gem native extension - Mastodon

I'm trying to install Mastodon (joinmastodon.org) on a Ubuntu 16.04 server. Firs I get this rbenv: version `2.5.3' is not installed (set by /home/mastodon/live/.ruby-version) I installed the 2.5.3 ...
user avatar
  • 143
0 votes
0 answers
565 views

colorls not available on some terminal emulators?

running into a weird issue that I have absolutely no idea how to troubleshoot (and didn't find anything useful on google) so figured I could ask for some guidance. I have colorls installed and ...
user avatar
  • 155
3 votes
1 answer
711 views

Is ruby a pre-requisite to install gem?

I need to install gem on my Ubuntu 16.04 in order to install Travis CI CLI. Is it necessary to install ruby before installing gem? I literally have no idea about ruby and gem.
user avatar
  • 891
1 vote
1 answer
233 views

How can I fix these errors when trying to run a ruby-based project on NetBeans 6.9.1?

I am trying to run a ruby-based project on NetBeans 6.9.1 but nothing happens and Mongrel shows an error message. ruby -v => 1.8.7 rails -v => 2.3.8 gem -v => 1.5.0 Error message: /var/...
user avatar
  • 11
2 votes
1 answer
5k views

Error while trying to install zsteg

While trying to install zsteg on Ubuntu Server (Linux 4.8.0-49-generic x86_64) I encounter the following error: $ sudo gem install zsteg Building native extensions. This could take a while... ERROR: ...
user avatar
  • 133
14 votes
3 answers
19k views

Error: Failed to build gem native extension when trying to download Rubocop

when I try "sudo gem install rubocop", I get... Building native extensions. This could take a while... ERROR: Error installing rubocop: ERROR: Failed to build gem native extension. ...
user avatar
0 votes
1 answer
3k views

The program 'gem' is currently not installed, but I installed it with \curl -L https://get.rvm.io | bash -s stable --ruby

I'm running Ubuntu 16.04, and trying to set up my environment for Ruby on Rails 5 using this guide: http://railsapps.github.io/installrubyonrails-ubuntu.html. As far as I can tell, the program 'gem' ...
user avatar
0 votes
2 answers
3k views

Error occurred while installing bundle

Following error occurred while trying to configure githubpage from my local machine: Error Displayed: An error occurred while installing ffi (1.9.14), and Bundler cannot continue. Make sure that `...
user avatar
  • 6,600
2 votes
1 answer
2k views

Failing to install ruby gems required by vagrant plugin install vagrant-proxyconf

I have an Ubuntu 16.04 machine behind a proxy. From this machine I am able to use the proxy as expected using the http_proxy and https_proxy environment variables. However, when a new vagrant box is ...
user avatar
6 votes
1 answer
8k views

Can't install json 1.8.1

I'm trying to install json gem using ruby 2.2.3 (I've tried with other oversions), and I always get the same error: Fetching: json-1.8.1.gem (100%) Building native extensions. This could take a ...
user avatar
0 votes
1 answer
598 views

Just installed Ubuntu/Ruby, cant create rails project

so I've just started using Ubuntu a few days ago, started trying to get an IDE working for Ruby on Rails developement, downloaded/installed everything from scratch. I found out the first version of ...
user avatar
3 votes
1 answer
364 views

Unable to install Github-Pages with gem?

I've been trying to install github-pages using gem. I have Ruby v. 2.1.2: ✦ ruby -v ruby 2.1.2p95 (2014-05-08 revision 45877) [x86_64-linux] I installed Ruby using RVM and I've set 2.1.2 as my ...
user avatar
  • 31
0 votes
1 answer
1k views

Ubuntu 14.04 LTS:error parsing `Gemfile`: Undefined local variable or method `urce' for Gemfile. Bundler cannot continue

I'm new to Web App Development beginning with Ruby On Rails. To get started I followed this. I'm in the final steps where it asks to create a Database (I'm using mysql) by running rake db:create but ...
user avatar
  • 135
1 vote
1 answer
506 views

could not get gem5 running

kept having this message on my command console "scons: *** No SConstruct file found. File "/usr/local/lib/scons-2.4.1/SCons/Script/Main.py", line 923, in _main" when i type this command scons build/...
user avatar
  • 11
1 vote
1 answer
2k views

Gem Debugger won't install with bundle install

I have installed ruby on rails using rvm. I am using 2.2.0 ruby and 4.2.0 Rails. I tried running bundle install on an older project that I developed on a former pc but I get : Gem::Ext::BuildError: ...
user avatar
3 votes
1 answer
5k views

can't bundle install json gem in ubuntu

I have installed ruby on rails using rvm . I am trying to bundle install an older project that I had on a former pc but I get the following error when I run the bundle install command: Installing ...
user avatar
0 votes
1 answer
1k views

gem install bundler error [closed]

I am newbie here. When I tried to install gem install bundler, it gave me ERROR: Could not find a valid gem 'bundler' (>= 0) in any repository ERROR: While executing gem ... (Gem::RemoteFetcher::...
user avatar
1 vote
0 answers
3k views

Problems Installing Metasploit Framework on Ubuntu

I have encountered 3 problems while following this guide to installing Metasploit Framework on Ubuntu and Debian: 1) After installing proper version of ruby, there is a command given for installing ...
user avatar
4 votes
1 answer
1k views

Why did lolcat stop working after installing rvm?

After recently doing something that involved installing rvm, this error occurs when I try using lolcat. /home/max/.rvm/rubies/ruby- 2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:...
user avatar
  • 51
0 votes
1 answer
620 views

I cant install Spree gem

Please help me to solve this problem. I have ubuntu 14.04. A new version of ruby. roman@Salomon:~/shopcart$ spree install --auto-accept gemfile spree gemfile spree_gateway gemfile ...
user avatar
  • 1
1 vote
1 answer
3k views

Why can't I install bcrypt?

I've a problem: when I try to install some Gem with the command "bundle install", I recive this output: Gem::Ext::BuildError: ERROR: Failed to build gem native extension. /usr/bin/ruby2.1 -r ./...
user avatar
1 vote
1 answer
863 views

Bundle install fatal error

I am migrating my project over to a new machine and I am having trouble running bundle install on the machine I am trying to use. When I run: bundle install I get this error: Unfortunately, a ...
user avatar
  • 173
0 votes
1 answer
663 views

gem install eventmachine fails, using rvm

Ubuntu 13.10 64bit, ruby 2.1.1 rvm 1.25.24 gem 2.2.2 from log file: compiling pipe.cpp ...
user avatar
  • 125
1 vote
2 answers
2k views

Ruby - no such file to load [gems]

This is error: [ERROR] no such file to load -- readline [TIP] Try to run 'gem install readline' or 'gem install --user-install readline'. If you still get an error, Please see README file or https://...
user avatar
2 votes
1 answer
4k views

puppet rspec no such file to load -- rspec-puppet (LoadError)

I have no prior experience at all of ruby. I am not interested in ruby (and so have no knowledge of rails etc) as such but am using puppet to manage a group of servers. I have written some modules ...
user avatar
  • 123
1 vote
1 answer
233 views

Gsl ruby gem on Ubuntu Saucy (13.10)

I'm trying to install the gsl gem on Ubuntu Saucy I installed the relevant gsl packages with sudo apt-get install gsl-bin libgsl0-dev But then installing the gem fails In file included from /usr/...
user avatar
3 votes
2 answers
2k views

Unable to Install Guard

I've seen Guard and it's usefulness in web development and would like to install it. Naturally, I expected to be able to use sudo gem install guard to do so (yes, it is a Ruby Gem). However the ...
user avatar
  • 1,955
0 votes
1 answer
2k views

why sudo gem install fails but gem install succeeds?

I simply do sudo gem install sqlite3 and have response: sudo: gem: command not found Then I do gem install sqlite3 and it works. Where is the problem with sudo ?
user avatar
0 votes
1 answer
936 views

gssapi requires Ruby version >= 1.9.1. on gem install

I'm trying to install knife-cloudstack plugin using gem install on Ubuntu 12.04 with chef-client configured and got error as said in title. >gem install knife-cloudstack ERROR: Error installing ...
user avatar
  • 101
2 votes
2 answers
687 views

pdfbeads will only output a single page

Following the instructions from this page I take a djvu document, check it for any sign of corruption by opening it in djvulibre and it checks out fine. Copy it to my testing folder and rename it ...
user avatar
1 vote
1 answer
872 views

error: alternative gem can't be master: it is a slave of ruby

I am struggling to get ruby up and running, and i get this message in many installations update-alternatives: error: alternative gem can't be master: it is a slave of ruby The full message: ...
user avatar
1 vote
1 answer
2k views

can't rake, missing gem but it's available

I'm trying to rake but I keep getting this As you can see, i18n (0.6.4) is installed and alive, so what's going on? what am I missing? I have tried to uninstall and install again, all went well but ...
user avatar
61 votes
7 answers
147k views

Determine which version of a gem is installed?

Is there a way via CLI to determine which version number of a gem is installed on my machine? Similar to yolk -l for python? I'm trying to see if I have the latest version of compass / sass / zurb ...
user avatar
  • 10.1k
3 votes
2 answers
2k views

Installing Jekyll with gem

I'm using Ubuntu 12.04. I am trying to install Jekyll through gem with sudo gem install jekyll but I get this error at some point of the installation: ERROR: While generating documentation for ...
user avatar
3 votes
0 answers
3k views

Failed to install a ruby gem, eventmachine

I tried to run a script that return this error messaged: Could not find gem 'eventmachine (= 0.12.10) ruby' in the gems available on this machine. Run `bundle install` to install missing gems. ...
user avatar
  • 7,755
1 vote
1 answer
15k views

Could not find a valid gem 'rails' (>= 0) in any repository

I am trying to install rails using the following command: sudo gem install rails and get the following error: ERROR: Could not find a valid gem 'rails' (>= 0) in any repository ERROR: Possible ...
user avatar
  • 2,017
0 votes
1 answer
43 views

Can I submit a ruby gem I'm working on for ubuntu app showdown?

I've been working on a ruby project, can I submit this for app showdown? Basically its a sinatra app, runs a site on localhost, which plays songs in browser
user avatar
  • 350