As of May 31, 2023, we have updated our Code of Conduct.

Questions tagged [flatpak]

Flatpak is a packaging format for distributing sandboxed applications on GNU/Linux distributions. Use this tag for all questions related to creating, distributing and running Flatpaks.

Filter by
Sorted by
Tagged with
-2 votes
0 answers
45 views

Miracast on Ubuntu, Wifi-Direct or dongle?

I am new to using linux, and don't expect an answer to this with certainty, but just whether it is likely to work, because I'm not sure if I understand the basic concepts correctly. Someone familiar ...
minusatwelfth's user avatar
1 vote
0 answers
27 views

How do I run flatpak apps on discrete GPU by default?

I want some flatpak apps to run on my discrete Nvidia GPU by default. I can always right-click on the app and launch via discrete graphics but that's tedious. I followed these steps but it did not ...
Pss's user avatar
  • 131
-1 votes
0 answers
32 views

How to Execute Flatpak Command Using systemd at Suspend? [closed]

I've created the following script, named it pre-sleep, and saved it to /lib/systemd/system-sleep: #!/bin/sh case "$1" in pre) /home/XXXXX/OpenRGBCommand.sh ;; esac ...
UnrulyCarrot's user avatar
0 votes
0 answers
32 views

How to run the the latest cli version of Monero?

How would I install v18 of the cli monero wallet? nicholas@mordor:~$ nicholas@mordor:~$ sudo apt install monero Reading package lists... Done Building dependency tree... Done Reading state ...
Nicholas Saunders's user avatar
0 votes
0 answers
21 views

Where would Monero node or blockchain data be stored?

I'm trying find particularly large files to free up some working space. This is in the context of scanning the Monero blockchain for recovering a wallet. Operating on the assumption that Monero has ...
Nicholas Saunders's user avatar
0 votes
0 answers
72 views

How can I install jmeter 5.5 in ubuntu 22.04 LTS(GNOME 42.5, windowing system->wayland)

I tried installing .zip binary of jmeter from it's official website, but kept showing error. It doesn't install successfully. After then, I tried installing it from flatpak, but couldn't find the bin ...
Ривадж Ропахэти's user avatar
-1 votes
0 answers
85 views

Ubuntu 23.04 - Flatpak GTK Theme problem

All flatpak apps I installed use GTK3 theme instead of GTK4/Libadwaita theme after I updated to Ubuntu 23.04 from 22.10, and they don't respect the system theme (always use light theme, even though I ...
HannorSmith's user avatar
0 votes
1 answer
55 views

Is there an equivalent snap command to the Flatpak's `permission-show` and `permission-set`?

I am asking, because I have to handle a permission problem with a Firefox webextension and the sandboxed Firefox in Ubuntu 22.04. (See https://github.com/mi-g/vdhcoapp/issues/139) The solution turns ...
cyfex's user avatar
  • 59
1 vote
0 answers
21 views

Flatpak downloads more than originally intended

In the lines number 1, 6, 7, 8 Flatpak downloaded less than initially intended, which is understandable: some parts of the bundle were already present on my system. But why did it download more than ...
sigil's user avatar
  • 479
2 votes
1 answer
294 views

Inconsistent dark theme for GTK apps on 23.04

I have encountered the following issue with using Flatpak apps on Ubuntu 23.04. Basically, some (parts of) programs will pick up the dark mode I have selected in the settings, while others will not. ...
Gregory Khvatsky's user avatar
0 votes
2 answers
122 views

What are the pros and cons of having both snap and flatpak on enabled on Ubuntu? Would you recommend it? [closed]

What are the pros and cons of having both snap and flatpak on enabled on ubuntu? Would you recommend it? I'm currently running ubuntu version 22.10 and plan to upgrade to 23.04 in a few weeks.
Daniel's user avatar
  • 1
0 votes
0 answers
38 views

Unable to update PyCharm due to some conflicts in Ubuntu 22.04

I'm unable to update PyCharm from 2022.something to 2023. It's a bit hard for me to uninstall and reinstall it. I'm using Flatpak PyCharm community edition not the snap one.
Mostafa Ahmed AbdulRazik's user avatar
0 votes
0 answers
118 views

Gamepad mapping in Hurrican game

I tried to install the old but fantastic Hurrican game (developed by Poke 53280) on Kubuntu 22.04 via flatpak (https://holarse.de/wiki/hurrican). The game seems to run fine but I'm unable to configure ...
Silicomancer's user avatar
0 votes
0 answers
55 views

How to check if the are app's dependencies on platform (feedesktop, gnome, kde) from Flathub in order to remove them safely?

The place taken by flathub/flatpak repo (/var/lib/flatpak/repo) is insane, this issue is known. I already uninstalled applications unused or replaced by snap repo equivalent when they exist. ...
AvyWam's user avatar
  • 141
1 vote
1 answer
197 views

how to find wether an app is a snap or a flatpak or a native app "in terminal"?

I have installed both flatpak and snap versions of several apps (I sometimes even have appimage and deb file of some other apps installed too) to find which one works better for me. Now I want to ...
Masoud Borbor's user avatar
1 vote
1 answer
90 views

flatpak program - add to path such that terminal knows the program

I can usually fire op blender via the terminal by executing blender. This worked out of the box, when using snap. However, the version in snap was very old so I found a newer version in flatpak. ...
nammerkage's user avatar
0 votes
0 answers
58 views

Password protection on flatpak apps

I found a bash script to password protect one of my flatpak apps but it doesn't seem to work, please tell me where I got it wrong script-> #!/bin/bash read -s -p "Enter password: " ...
Krrish Dhaneja's user avatar
0 votes
1 answer
363 views

SSL connect error when to try add flathub repo

I'm trying to add the flatpak repository with this command: sudo flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo But I'm getting this error: error: Can't load ...
mehdi mansouri's user avatar
1 vote
1 answer
77 views

How can I give Android Studio update permissions?

I installed Android Studio using flatpak. But now I cannot update it because of write permissions. How can I give write permissions to it? I know about Flatseal but don't know what to turn off or on.
Aditya Datta's user avatar
1 vote
1 answer
87 views

I installed OBS from using .flatpakref but don't know where it is installed

I downloaded the OBS Studio .flatpakref from the official website's flathub link. I was able to run the .flatpakref and get everything installed fine, but I can't find where it downloaded, so I can't ...
IronGapple's user avatar
0 votes
0 answers
318 views

Evince complains about missing --filesystem=xdg-run/gvfsd privileges, how can I add those privileges

On 22.04, when using evince on the command line to add text annotations to a PDF and then save it, evince complains The peer-to-peer connection failed: Error while getting peer-to-peer dbus connection:...
Harald's user avatar
  • 1,022
0 votes
0 answers
27 views

flatpak software updates broken

Gnome Software can't carry out updates I have the proprietary Nvidia driver installed See the attached picture
Adriano Peluso's user avatar
0 votes
1 answer
790 views

Gestures flatpak app cannot read configuration file. says "please check permissions"

I recently installed the "Gestures" app from flathub and when I launch it, it says "cannot read the configuration file, please check permissions". How can I run this program ...
ReZa ET's user avatar
0 votes
0 answers
131 views

Failing to update NVIDIA drivers with flatpak

I am using Ubuntu 22.04 LTS. I want to update my flatpak drivers, and it requires NVIDIA driver (org.freedesktop.Platform.GL.nvidia-515-86-01). Unfortunately, NVIDIA doesn't allow my IP to download ...
Amir Sardar-Abadi's user avatar
2 votes
1 answer
337 views

How to match flatpak themes with GNOME dark theme?

I'm a beginner with Linux and I think I messed up the command lines when I tried to match flatpak apps with ubuntu's dark theme because not only it didn't work but now flatpak apps look ugly (a bit as ...
Louise's user avatar
  • 31
0 votes
0 answers
95 views

Obsidian unable to access folder on another partition - "Failed to open. No permission to access folder" error

I've created a common NTFS partition on the NVME disk so that I can put my coding, obisidian notes & other common files to be accessible both from Windows & Ubuntu. Partition is mounted on &...
claws's user avatar
  • 121
2 votes
2 answers
8k views

How to install Obsidian 1.0.3 on Ubuntu 22.04?

I am currently referring to the Obsidian note taking app. (see www.obsidian.md). The Obsidian AppImage did not work for me. Ubuntu Software Center just could not open it. Same goes for the Snap or ...
iguanahay's user avatar
0 votes
0 answers
337 views

Flatpak: Can't check signature: public key not found

I am using Ubuntu 22.04.1 LTS. I installed flatpak from official documentation of flatpak. Now I am trying to install bottles by using this command: flatpak install flathub com.usebottles.bottles and ...
Hammad Zafar Bawara's user avatar
1 vote
0 answers
37 views

Unable to sync .var folder

NextCloud desktop client doesn't sync ~/.var folder properly. It only syncs one folder which is: ~/.var/app/com.nextcloud.desktopclient.nextcloud ! I tried to restart sync process but it didn't ...
mbnoimi's user avatar
  • 184
0 votes
0 answers
144 views

I have a DNS error: "Error resolving “10.20.205.124 ”: Name or service not known "

I have Ubuntu 22.04 installed, and I wanted to use GNOME's online account manager but I have received this weird message: After a bit of research ,I figured out it may have something to do with DNS /...
iamnytik's user avatar
0 votes
2 answers
93 views

What is the "apt" equivalent of the zypper search command? Im trying to search for a specific pkg without having to scroll through every pkg

So before when I was using openSUSE, the one thing I liked about zypper was the simple zypper search [keyword] command that made it so easy to find a installed app. But for apt, I have yet to find one ...
Via80HD's user avatar
0 votes
2 answers
201 views

How to update Thunderbird from package version 9x (.deb, apt) to latest 10x as snapcraft (or flatpak) version, best way? 20.04 to 22.04

Currently running Ubuntu 20.04 LTS with Thunderbird v91.11 installed from Debian packages, but soon switching over to 22.04 LTS, what is the best way to update Thunderbird to the most recent version ...
w-sky's user avatar
  • 1,147
-1 votes
1 answer
489 views

Help cleaning Ubuntu 22.04 with flatpak

Hi these days im cleaning my ubuntu 22.04 system, that has been upgraded from 20.04, which was upgraded from 18.04 which cames from 16.04 … Just to clean as much as i can, and to learn new things. My ...
Eduardo Gutierrez's user avatar
0 votes
0 answers
100 views

Is it possible to download a binary artifact from Flathub for a build?

I'm pretty new to the whole Flatpak/Flathub environment, essentially I'd like to know if it's possible to download from a Flathub build a single binary file that can be used for offline install or ...
Gruber's user avatar
  • 109
0 votes
0 answers
175 views

Icon missing in tasks witcher and window, (but not in app launcher nor Task Manager)

For several but not all apps (installed with flatpak), there are icons missing in the task switcher and the application window itself. Yet these icons are available in the application launcher and on ...
Coo's user avatar
  • 161
0 votes
2 answers
195 views

Kdenlive not showing preview in "clip monitor" on Ubuntu 22.04

I just installed Kdenlive's Flatpak (version 22.04.3) following the instructions from the official website. It is not the first time I use Kdenlive. However, when I import the project, the clip ...
rmetra's user avatar
  • 75
0 votes
0 answers
233 views

Stuck with how to get flatpak installed on 21.04 [duplicate]

I have Ubuntu 21.04. It came with SNAP. Seems that has been left behind and how things work on flatpak. I have some version of Handbrake installed but it is probably old, so I want to update it. I ...
Recently Updated Ubuntu user's user avatar
1 vote
0 answers
94 views

Okular (Snap & Flatpak) problem with inverse search

I am on Ubuntu 20.04, and the Okular versions available to me seem to be the following: apt: 20.04.0 snap: 20.12.3 flatpak: 22.04.03 I would like a version > 20.12, because that allows me to ...
pglpm's user avatar
  • 149
0 votes
1 answer
713 views

How do I get rid of these leftover flatpak files?

I wanted to try out Tauon Music Box, so I installed the flatpak version, didn't quite like it so I removed it with the following: flatpak uninstall com.github.taiko2k.tauonmb but when I search for it ...
Uncle Woods's user avatar
0 votes
0 answers
52 views

How to keep screensaver from coming on in sandboxed programs?

I have the screensaver set to come on after 15 minutes of idle. When I'm using a native program, there's no problem, and the screensaver doesn't come on when I'm watching a video or playing a game. ...
BoyAmIThirsty's user avatar
0 votes
1 answer
214 views

What action do I need to take, if any, regarding these Flatpak errors?

I am using Ubuntu 20.04 and just ran a Flatpak update (vers 1.12.7). There were two errors. The first one (re: Freedesktop SDK 19.08 runtime) has shown up randomly lately, but the second one is new. ...
EHJ's user avatar
  • 69
1 vote
2 answers
464 views

How can I change the name or icon of an installed application?

I have two MPV media players installed of different versions. One is via apt and another via flatpak. I need them both for different purposes. But they have exactly same name and icon. So, whenever I ...
Vin Raghav's user avatar
2 votes
1 answer
3k views

Can not find executable path of flatpak apps

App installed using apt package manager starts running when I type the app name in terminal like firefox. [Using Kubuntu 22.04] which firefox This command will show the path of firefox in my system. ...
Shezan's user avatar
  • 355
0 votes
0 answers
156 views

How to best install Cisco WebEX?

After manually installing the WebEX client from Cisco to Ubuntu as: sudo apt-get install ./Webex.deb Surely there's a better way to use or find the Cisco video conferencing client?
Nicholas Saunders's user avatar
0 votes
0 answers
43 views

Okular's "open containing folder" results in "Malformed URL"

When I try Open Containing Folder from the File-menu of Okular, I get the following error: Here /home/jonas is the folder containg the PDF. Any idea what is going wrong here? I use Xubuntu 20.04, and ...
red_trumpet's user avatar
  • 1,719
4 votes
1 answer
3k views

Update flatpak from the command line?

What is a command line equivalent to sudo apt-get update or sudo snap refresh for flatpak?
les_h's user avatar
  • 242
4 votes
0 answers
333 views

How to remove apt browsers and use Flatpak browser

Similar to this question Why does removing Firefox install another browser? when I try to remove Firefox installed via apt, apt tries to install Chromium as an alternative as I have dependencies that ...
db579's user avatar
  • 454
2 votes
1 answer
800 views

Why was the Breeze theme installed as a flatpak in my system?

The Breeze theme is a standard theme installed on Kubuntu 20.04.2. Why was a flatpak version of the theme installed in my system? I want to use flatpaks as little as possible. Is there a .deb version ...
Joepie Es's user avatar
  • 1,410
0 votes
1 answer
855 views

Flatpak doesen't install on kubuntu 22.04 [duplicate]

When I try to install flatpak I get this error Reading package lists... Done Building dependency tree... Done Reading state information... Done Package flatpak is not available, but is referred to by ...
SuperVidak64's user avatar
0 votes
0 answers
184 views

Ubuntu Updater icon says 3 updates, but can't find any

Muon finds no updates. sudo apt-get dist-upgrade finds no updates. sudo apt-get install -f doesn't do anything. The Ubuntu Updater icon says there are 3 updates, but when it searches for them, it ...
Joe's user avatar
  • 1,834

1
2 3 4 5