Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [dpkg]

The Debian package management utility that performs lower level tasks in software installation and removal.

0
votes
2answers
49 views

ubuntu unable to resolve host

I'm working on ubuntu 14.04. I cant login to my pc as a root user.I tried different ways and i cant still the issue. If i give sudo command the response is like > ubuntu@ubuntu72:~$ sudo su sudo: ...
2
votes
0answers
40 views

How to remove and reinstall Vorbis codec?

Soundconverter crashes everytime I convert my flac files to Ogg Vorbis. I am getting the following error in terminal. The following packages have unmet dependencies: libvorbis0a : Breaks: libvorbis0a:...
1
vote
2answers
1k views

kernel package linux-headers-4.18.5-041805-generic is not supported

I update my kernel from 4.15 to 4.18.5 and then after my VirtualBox shows folowning errors Kernel driver not installed (rc=-1908) The VirtualBox Linux kernel driver (vboxdrv) is either not loaded ...
0
votes
0answers
16 views

Can't install anything because of this “The following packages have unmet dependencies. ”

Yesterday i tried to update vorbis codec using this: How to update Vorbis codec? and now i am getting this following error everytime i install anything from terminal. The following packages have ...
0
votes
0answers
15 views

Errors were found while processing keyboard-configuration [duplicate]

I am using Ubuntu 18.0 and, whenever I wish to install a package, or get an update, I receive the error message: Errors were found while processing keyboard-configuration console-setup-linux console-...
0
votes
0answers
89 views

Sub-process /usr/bin/dpkg returned an error code(1). Trying to upgrade

When I try to install any anything, I am facing the below error. Do you want to continue? [Y/n] y Setting up linux-image-4.13.5-041305-generic (4.13.5-041305.201710050600) ... Running depmod. update-...
1
vote
1answer
102 views

I have two different versions of VLC, how to remove?

After I upgraded to 18.04 I removed unused apps, old packages and other cruft through the Software store and through the terminal. I found that VLC did not match yaru/communitheme I'm using so I tried ...
1
vote
0answers
37 views

What is the difference between 'sudo apt autoremove' and 'sudo apt-get autoremove'? [duplicate]

I thought apt is just a new software which works exactly like apt-get. I always used them interchangeably. But it seems they are different, at least in the autoremove function. I ran sudo apt ...
0
votes
0answers
37 views

Ubuntu 16.04 update-initramfs hangs generating /boot/initrd.img4.13.0-31-generic [duplicate]

I was trying to update Ubuntu 16.04 but I can't run apt-get. I get: dpkg was interupted, you must run sudo dpkg --configure -a But when I run sudo dpkg --configure -a it hangs at: update-initramfs: ...
1
vote
1answer
75 views

Resolve Firefox dpkg error when reinstalling

I wanted to delete Firefox without much experience with Linux. I wanted Chrome to be my default browser, but it doesn't show up on Settings, so I searched with the file explorer 'firefox' and deleted ...
0
votes
0answers
19 views

Cannot seem to install Ruby - what am I doing wrong? [duplicate]

$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.04.2 LTS Release: 14.04 Codename: trusty I'm trying to install Ruby; here's what I see: $ sudo ...
0
votes
1answer
229 views

Installing mysql Error: dpkg ' Sub-process /usr/bin/dpkg returned an error code (1)

When I run sudo apt-get install mysql-server; I get Reading package lists... Done Building dependency tree Reading state information... Done The following NEW packages will be installed: ...
-3
votes
1answer
201 views

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) in using ubunutu 16.04 Docker container [duplicate]

root@01f1d013bd74: /opt/intel/computer_vision_sdk_2018.3.343/deployment_tools/inference_engine/samples# sudo apt-get install cmake E: Could not get lock /var/lib/dpkg/lock - open (11: Resource ...
1
vote
1answer
172 views

Ubuntu 18.04 and Rainlendar 2 install problem

I can't install Rainlendar 2 on my Ubuntu 18.04, I found this solution for 16.04 (Unable To Install Rainlendar2 For Ubuntu 16.04 LTS (32 & 64 Bit)), followed it, seems to work, but after install, ...
0
votes
0answers
584 views

Installing Flat Remix theme on Ubuntu 18.04 LTS

Recently, I upgraded from 16.04 LTS to 18.04 LTS. Although I like the default theme but I am also interested in trying out other themes available on the web. One of them being Flat-Remix-Gnome. I ...
0
votes
0answers
48 views

Is it safe to delete linux header file manually?

I recently have inode full issue on a production server. What I have done are: Sort folders according to how many files they have by: sudo find / -xdev -printf '%h\n' | sort | uniq -c | sort -k 1 -n ...
0
votes
0answers
12 views

Unpacking process of ubuntu 18.04 interrupted

I Was unpacking ubuntu 18.04 in my desktop laptop computer after succesfully downloading all the packages using terminal but the process was interrupted by power shortage. Now ubuntu 18.04 cannot go ...
-1
votes
2answers
147 views

Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported. Ubuntu 16.04.5 [closed]

$ sudo apt-get install Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: ...
1
vote
1answer
520 views

dpkg: error processing package install-info

I tried installing imagemagick package by sudo apt-get install imagemagick I'm getting the following error now, how to fix it. $ sudo apt-get install imagemagick Reading package lists... Done ...
0
votes
1answer
13 views

Disable 'recommends' from within package control file

I'm packaging an internal app for our company's repo which has libvips42 as a dependancy. This package recommends nip2, which in turn recommends iceweasel. This has the undesired side-effect of ...
0
votes
0answers
21 views

teamviewer not working [duplicate]

sudo dpkg -i teamviewer_11.0.57095_i386.deb dpkg: error processing archive teamviewer_11.0.57095_i386.deb (--install): cannot access archive: No such file or directory Errors were encountered while ...
0
votes
0answers
41 views

I can't update Lubuntu, dpkg issues!

I can not update my Lubuntu 18.04 LTS because of the below issue. I appreciate your help! debconf: DbDriver "config": Error setting up format object 822: Bareword "n" not allowed while "strict subs" ...
2
votes
1answer
1k views

ModuleNotFoundError: No module named 'apt_pkg' error

I run below command on ubuntu 16.4 : sudo add-apt-repository ppa:noobslab/apps of below question: How to install PlayOnLinux on Ubuntu 16.04 and get below error: Traceback (most recent call last):...
4
votes
1answer
65 views

How can I make dpkg-buildpackage stop after running configure?

Introduction I have a source package (downloaded with apt source ...) which I'd like to explore using rtags in a code editor. The standard way of doing this is to dry-run the makefile produced by the ...
0
votes
0answers
15 views

Ubuntu 16.04 dpkg is broken

I'm having issues with some kernel-upgrade that failed, and it prevents me from doing anything with apt or dpkg, like installing or configuring packages. I looks like removing the old kernels worked, ...
0
votes
1answer
33 views

gir1.2-gdkpixbuf-2.0:amd64 missing

I get this error and I am not able to remove install or reinstall anything: dpkg: warning: files list file for package 'libgnome-keyring-common' missing; assuming package has no files currently ...
0
votes
0answers
33 views

sudo dpkg --configure -a in a Bash file

I have created a bash file to install various packages on the system. I use this script to create a development environment on fresh Ubuntu installation. But sometimes things don't go as expected and ...
0
votes
0answers
190 views

dpkg error code (1) with Removing linux-image-4.15.0-29-generic

'$ sudo apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done The following packages will be REMOVED: linux-image-4.15.0-29-generic 0 upgraded, ...
0
votes
0answers
11 views

How to prevent packages from overwriting configuration files? [duplicate]

I noticed that during upgrades (mostly Ubuntu version upgrades, but I guess that doesn't matter), configuration files are checked whether they differ from the version which is going to be installed by ...
0
votes
0answers
28 views

Ignore Dependency APT

Python package PIL in apt was renamed from python-imaging to python-pil So I tried installing it like this: apt install python-pil dpkg --ignore-depends=python-imaging -i pyload.deb However now ...
6
votes
1answer
195 views

Package gnome-shell-common has been held back but when trying to update it I get this

When doing sudo apt upgrade it says 'gnome-shell-common has been held back'. When I do sudo apt dist-upgrade it doesn't show gnome-shell-common, and sudo apt install gnome-shell-common says it will ...
1
vote
1answer
147 views

Upgrade: solve dependency on previous release package

I just upgraded from 14.04 to 16.04. This wasn't easy, probably because I had a lot of tweaks on my machine (updated packages not installed from "official" sources). It wouldn't boot, I thought at ...
0
votes
0answers
522 views

Installing Minecraft on a 32-bit Xubuntu 18.04 LTS installation

Thanks in advance to anybody who is able to shine some light on this issue of mine. I have recently Xubuntu 18.04 LTS on my Dell Optiplex 755, and I've been having difficulty installing the Minecraft ...
0
votes
0answers
20 views

Unable to install any app from ubuntu software [duplicate]

The error it shows is: E:dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. What can I do to fix this?
0
votes
0answers
21 views

Why does “dpkg --configure” not support “--frontend” switch?

While scripting an unattended installation of packages, I had to run dpkg --configure -a which in turn configures keyboard-configuration package. I wanted to preseed debconf database with cat debconf....
0
votes
2answers
54 views

Failed to install Cloudera-manager-agent

I was installing cloudera manager in my machine running Ubuntu 16.04 LTS xenial OS. when I type sudo apt-get install cloudera-manager-agent I got following on my command line root@chinni:/home/...
0
votes
2answers
24 views

apt install crashed because of full hdd and dpkg --reconfigure does not work anymore (because of full hdd)

The title says it... Is there any way of removing programs without needing tu reconfigure before? I don't know how to fix this issue. Is there a lockfile or so that i can delete? I already tried to ...
1
vote
0answers
351 views

My Ubuntu 18.04 has dpkg gdm3 error

Every time I try to use command: sudo apt-get dist-upgrade on my Ubuntu 18.04, it pops out the error like this: Will not try to make an initrd. Setting up linux-modules-extra-4.15.0-32-generic (4....
0
votes
0answers
16 views

dpkg and inter-dependencies

I am attempting to create a virtual machine for my application using an ubuntu xenial base. this application requires many packages. The problem is that I'm often in the situation where I don't have ...
0
votes
0answers
59 views

dpkg: error: duplicate file trigger interest for filename `/usr/lib/gio/modules' and package `libglib2.0-0'

I can't install any software after I gave my ubuntu 14.04 LTS PC to my girlfriend for a while. When I try to upgrade anything it says dpkg: error: duplicate file trigger interest for filename /usr/...
2
votes
1answer
351 views

cannot remove badly installed packages [duplicate]

Cannot install anything, cannot remove anything. Please help. This is not a duplicate. First of all that is a completely different problem. Second, I tried the solution (command line one) and ...
0
votes
1answer
311 views

Broken python dependencies after trying to re-install

I had several installations of python on my ubuntu 18.04 system and tried to uninstall all necessary ones and just properly reinstall python3.6 So i deleted all folders that were listed under whereis ...
0
votes
1answer
18 views

Major problem with libxcursor1:amd64 [duplicate]

I am running Ubuntu 16.04 and have a problem with libxcursor1:amd64 which is causing everything to run really slow and not allow packages to be updated. I have tried apt-get -f install to fix things ...
0
votes
0answers
26 views

While installing Android Studio on Ubuntu 18.04 LTS, I am facing an error like this

dell@dell-Latitude-3440:~$ sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386 lib32z1 lib32bz2-1.0 *Removed the ask password* Reading package lists... Done Building dependency tree ...
1
vote
1answer
173 views

ubuntu 18.04 issues with digikam

I have just upgraded to 18.04 and am trying to install upgrades and or new programd via the terminal. I get the following message digikam-private-libs : Depends: libkf5sane5 (>= 4.3.4) but it is ...
0
votes
0answers
111 views

18.04.1 Server keeps creating /var/lib/dpkg/lock and /var/cache/apt/archives/lock. What now?

I'm working with a fresh install of 18.04.1 from which I have removed certain packages that communicate asynchronously with other hosts, having pinned them, along with certain other packages, for non-...
1
vote
0answers
60 views

Can't update or remove ruby-net-telnet

Running Ubuntu 16.04. All other packages update fine but attempting to update or remove ruby-net-telnet returns errors Preparing to unpack .../ruby-net-telnet_0.1.1-2_all.deb ... Unpacking ruby-net-...
0
votes
1answer
163 views

how to fix Snapd dpkg error?

when i make sudo apt-get update && sudo apt-get upgrade this early morning for my new kernel 4.4.0-131-generic. i get my snapd error. Setting up snapd (2.34.2~14.04) ... Failed to enable ...
0
votes
0answers
38 views

Cant upgrade to 18.04 due to less free space on / [duplicate]

I am trying to upgrade from 16.04 to 18.04. But getting an error that, there is not enough space on disk '/'. I have removed the old kernels with dpkg purge command, also have cleared cache using ...
0
votes
0answers
30 views

Remove unmet dependency openssl package

I have unknowingly installed i386 openssl packages in Ubuntu 14.0. Since the installation didn't go through successfully, I am not able to install any other packages. How can I remove those unmet ...