Questions tagged [dotnet]

Questions relating to the .NET framework, its open source implementation *mono* and the relevant programming languages.

Filter by
Sorted by
Tagged with
0 votes
1 answer
102 views

How do I fix my broken .NET 6 installation?

I have .NET 6 and .NET 7 on my Ubuntu system. When I try to execute a test in Rider it says dotnet 6 isn't installed. But it is. If I run dotnet --list-runtimes it shows only .NET 7. Console output: ...
  • 101
0 votes
0 answers
53 views

What is proper way to upgrade .NET Core on Ubuntu Server 22.04

I'm using this script to install .NET 7 on Ubuntu Server 22.04, these servers will be used in production curl -sSL https://dot.net/v1/dotnet-install.sh | bash /dev/stdin --version latest --runtime ...
  • 101
0 votes
1 answer
138 views

Installed dotnet6 package with Jammy but the Windows application is still asking for Mono

I am trying to run SDRPlay2RSS.exe with wine. This is a piece of software based on the .NET framework, belonging to radiotelescope software for the Radio Jove project. I first tried installing wine ...
  • 1
1 vote
1 answer
37 views

Running a command line .net application on boot, as a user, without needing login

I have a dotnet console application that when executed will run a loop and await a keypress. On certain keypresses it will perform an action (via api calls etc..) I have a raspberry pi running ubuntu ...
0 votes
0 answers
56 views

Rider not recognizing dotnet

A few days ago, my dotnet just stopped working. I purged and reintstalled it but after that, rider stopped recognizing it and only lists .Net Framework versions from mono. I tried the version from the ...
  • 1
0 votes
0 answers
436 views

How to fix `GLIBCXX_3.4.30' not found in Ubuntu 22.04

Trying to compile dotnet code on ubuntu and get this error: Failed to load /usr/lib/dotnet/dotnet6-6.0.109/host/fxr/6.0.9/libhostfxr.so, error: /home/ubuntu/anaconda3/lib/libstdc++.so.6: version `...
  • 1
0 votes
1 answer
73 views

Reconciling apt and snap installations of dotnet

Having two installations of .NET: $ lsb_release -d Description: Ubuntu 22.04.1 LTS $ which dotnet /usr/bin/dotnet $ which dotnet-sdk.dotnet /snap/bin/dotnet-sdk.dotnet The two installations seem ...
  • 232
2 votes
2 answers
4k views

How can I install dotnet Core 3.1 runtime on Ubuntu 22.04?

I have two Ubuntu 22.04 systems with Dotnet 6.0. The one that has been continuously upgraded from older versions of Ubuntu runs my Dotnet Core 3.1 app without any trouble -- because it still has the ...
  • 1,011
1 vote
1 answer
4k views

The command could not be loaded, possibly because: * You intended to execute a .NET application:

I am using dotnet6 in my ubuntu 22.04 version. Right now when I run dotnet --version, I am getting the below error. jyothish@jyothish-Lenovo-G570:~$ dotnet --version The command could not be loaded, ...
1 vote
1 answer
615 views

installing dotnet6 on ubuntu 22.04 WSL2 - installed but not showing in sdk-list

I am slowly transitioning to use ubuntu / linux WSL2 as primary for development - instead of windows, but there are still a lot of things I don't understand and have to look up, I am guessing this is ...
  • 453
9 votes
3 answers
5k views

Why don't any of these methods work for installing .Net Core SDK & runtime on 22.04 (Jammy Jellyfish)?

I went to the following official Microsoft link to install .NET Core 6.x (SDK & runtime) and they would not work. Basically, it tells you to : wget https://packages.microsoft.com/config/ubuntu/22....
  • 1,570
1 vote
1 answer
3k views

Run systemd service with sudo rights

I have a Raspberry PI (Ubuntu 20.04) that is running a Web UI with a button to turn on a relay (communicate with the Raspberry PI from the Web UI) so in order to do that, I need to run it with sudo ...
  • 131
0 votes
1 answer
64 views

Failed to run Terminal app by .desktop file

I have following desktop file entries. [Desktop Entry] Version=1.0 Name=TestClient.desktop GenericName=Test Comment=Test Exec=/usr/share/TestClient/TestClientService Path=/usr/share/TestClient Icon=/...
1 vote
0 answers
2k views

Ubuntu 20.04 Redirect HTTP to HTTPS

Raspberry PI running Ubuntu 20.04 hosting a dotnet 6 (core) web application. DotNet by default listens to port 5000 (HTTP) and port 5001 (HTTPS). I can get http://mydomain to work but I CANNOT get ...
  • 131
0 votes
1 answer
2k views

Ubuntu Failed to bind to address http://127.0.0.1:5000

Deploying an aspnetcore 6 web app to Ubuntu 20.04. Here is an article of what I am doing https://docs.microsoft.com/en-us/aspnet/core/host-and-deploy/linux-apache?view=aspnetcore-6.0#publish-and-copy-...
  • 131
0 votes
0 answers
635 views

How can I debug a .NET Core 5.0 console application in Rider?

I have installed .NET Core 5.0 via Snap: sudo snap install --classic dotnet-sdk --channel=5.0/stable sudo snap alias dotnet-sdk.dotnet dotnet JetBrains Rider (also installed through Snap) can detect ...
0 votes
0 answers
149 views

This site can’t be reached

I am on Ubuntu hosting a .NET 6 web app. If I go to the directory where the publish files are stored and run command dotnet webapp.dll, then I will get something like the output below (Then if I go to ...
  • 131
0 votes
1 answer
344 views

Installing .NET SDK on Ubuntu produces no executable dotnet file

Installing .NET SDK on Ubuntu 20.04 with the commands listed in the Install .NET on Ubuntu docs: wget https://packages.microsoft.com/config/ubuntu/20.04/packages-microsoft-prod.deb -O packages-...
  • 101
0 votes
1 answer
132 views

What dependencies need to be installed to make dotnet build and restore works on Ubuntu 20.04 system

I am planning to create build and release pipeline using Ubuntu azure agent. Dotnet Build and Restore commands are failing. My project is from a dotnet core 3.1 version. Please let me know the minimum ...
  • 101
2 votes
1 answer
2k views

How can I install two versions of .NET for Rider?

I have installed both Rider and dotnet-sdk with Snap, so that I can debug .NET projects. However, I now need to work on an older solution that runs on an older version of .NET. How can I install ...
0 votes
0 answers
1k views

NuGet `dotnet restore` doesn't work on Ubuntu 20.04 (Linux Mint 21) due to errors in the certificate chain

When I try to make a simple Unit Test project with the following command (inside a project folder called test): dotnet new xunit It fails and this is the output I get: /usr/share/dotnet/sdk/5.0.301/...
user avatar
2 votes
1 answer
125 views

Unattended upgrades for dotnet not working

I am trying to configre unattended-upgrades for microsoft dotnet on ubuntu 20.04.2. I added the origin and section to allowed-origins in my unattended-upgrades config: Unattended-Upgrade::Allowed-...
1 vote
1 answer
2k views

Running dotnet run command throws error Couldn't find a valid ICU package installed on the system

I was using .net core 3.1 on Ubuntu 20.04 for a while but now after a system update the skd does not seem to recognize the installed libicu. I am currently on dotnet 3.1.407. dotnet run Error ...
  • 121
0 votes
1 answer
2k views

Getting .NET Core SDK not located error when I open a script in VS Code in Unity3D. All solutions on Google only work for Windows and not Ubuntu 20.04

The .NET Core SDK cannot be located. .NET Core debugging will not be enabled. Make sure the .NET Core SDK is installed and is on the path. This is what the popup screen looks like in VSCode That's ...
0 votes
1 answer
6k views

Remove .Net from Ubuntu 20.04 completely

I was trying debugging options in Visual Studio Code for C#. But there's a message at the bottom right every time I open VB Code, which says, The .NET Core SDK cannot be located. .NET Core debugging ...
8 votes
4 answers
14k views

dotnet-sdk-5.0 not found on Ubuntu 20.04.2 LTS

I'm currently using the net core 3.1 and want to upgrade it to 5.0. I tried following this guide from Install the .NET SDK or the .NET Runtime on Ubuntu wget https://packages.microsoft.com/config/...
  • 203
1 vote
1 answer
882 views

i want to update from .net framework 4.0 to 4.5 or older (winetricks)

maybe this is so dumb lol but yeah I didn't know I needed dotnet45, I try to install it and it starts the net framework setup and shows me if I want to repair or uninstall the .net framework if I ...
0 votes
1 answer
1k views

dotnet 5.0 Microsoft.WindowsDesktop.App on ubuntu

Am running Ubuntu Budgie 20.04 and regularly run .Net apps (that I built) through CrossOver (20.0.4) / Wine. I just built a small WinForms utility in .Net 5.0 and tried to run it in CrossOver. A ...
  • 986
-1 votes
1 answer
160 views

How to configure the PowerShell prompt on Ubuntu?

How do I configure the PowerShell profile so that the prompt is changed? nicholas@mordor:~/.config$ nicholas@mordor:~/.config$ ls -alh total 108K drwxr-xr-x 23 nicholas nicholas 4.0K Feb 4 19:50 . ...
1 vote
2 answers
318 views

Having trouble installing .NET 5 on ubuntu server 20.04

I had previously installed .NET products on multiple ubuntu servers just fine but just one particular server can't connect to microsoft servers apparently. user@sv:~$ wget https://packages.microsoft....
  • 111
6 votes
3 answers
10k views

How to update .NET SDK to latest version?

Currently have the .net sdk 3.1.404 installed. There is a newer version out Download .NET Core 3.1 SDK 3.1.405. I am trying to figure out how to upgrade this on my machine. Part of my problem is ...
  • 165
0 votes
1 answer
565 views

dotnet452 conflicts with dotnet46

I have to run a windows msi installer application that demands .NET Framework 4.5.2 to be installed in the system. Now in my system few versions of .NET framework are already installed namely 4.6, 3.5 ...
user avatar
0 votes
1 answer
1k views

dot net sdk 5.0 on ubuntu

I've found and used this : https://github.com/dotnet/core/blob/master/release-notes/5.0/preview/5.0.0-rc.2-install-instructions.md to no avail. I can't get a install of .net sdk 5.0 on ubuntu I try ...
  • 2,928
0 votes
1 answer
397 views

Run dotnet core on Ubuntu 20.4

I just shifted to ubuntu and I am trying to run dotnet core 3.1 project on Ubuntu. I successfully installed dotnet core sdk. But when i go to the folder in a separate mounted disk and run command ...
0 votes
2 answers
351 views

Install latest version of dotnet-sdk by script

I am writing an installer script and need to install dotnet-sdk. I want to install the latest version which is 3.1 or in future 3.2 or whatever. Now I found that there are 2 versions in apt-get: user@...
0 votes
1 answer
500 views

Install location for a multi file .NET core app in Ubuntu

I have a compiled .NET core app which I am planning to run in three major OSs. When I am trying to test my build in GitBash on Windows 10, once I build the app I get a lot of files along with the ...
11 votes
4 answers
14k views

How to install Monodevelop in 20.04 and get it to build something?

I am trying to setup a development machine using 20.04 and am having problems with the Monodevelop environment. Whenever I create a solution and project it seems that it cannot find the proper build ...
  • 241
2 votes
1 answer
1k views

How to set environment variables from within powershell?

How do I make foo an environment variable accessible through printenv on bash? PS /home/thufir/powershell/helloPSTwitterAPI> PS /home/thufir/powershell/helloPSTwitterAPI> $env:foo = 'x' * 333 +...
  • 4,413
2 votes
1 answer
251 views

New tab in gnome-terminal closes on pressing Ctrl+C

I'm writing a bash script that runs few microservices at once. gnome-terminal --tab -t 'test' -- sh -c "cd Services/Api; dotnet run --no-build; bash"; The command works fine but when I press Ctrl+C ...
  • 21
1 vote
0 answers
172 views

How can I fix this VS Code / .NET Core SDK issue?

When starting VSCode (Visual Studio Code) I'm receiving the following error: When I search for my installed version in Terminal: computer@computeruser-wild-cpu:~$ dotnet --version 3.1.100 Do I need ...
  • 151
2 votes
1 answer
13k views

Problem with wine

I want to play osu! on ubuntu and wanted to instal dotnet but then came this error message: This package (dotnet20) does not work on a 64-bit installation. You must use a prefix made with WINEARCH=...
0 votes
1 answer
113 views

How can I run a command if all processes of a certain name crash?

I’m running a dotnet application on a VPS running Ubuntu, and the application has to be running continuously 24/7. When I start up the application, I use “nohup dotnet (name).dll”, and in HTOP those ...
3 votes
0 answers
1k views

dotnet Core 3 runtime snap not found in Ubuntu Core

I have a .Net Core 3 console app published for linux-x64. I want to run it on Ubuntu Core 18. I have installed the dotnet-runtime-30 Snap and aliased it like on this question. When run the binary ...
6 votes
1 answer
12k views

How to develop for Android with Xamarin?

I want to develop applications for Android in C#. On Windows I tried Xamarin Studio and I was very happy with it. Is there a way to use Xamarin on Ubuntu? I noticed there are Xamarin.Android binaries ...
  • 389
2 votes
1 answer
107 views

Server crash randomly

My Ubuntu Xenial (and also another Bionic Beaver one) server keeps crashing on random intervals. Sometimes twice a day and sometimes after 2 weeks and after months even! I contacted my server hosting ...
  • 123
19 votes
1 answer
21k views

`dotnet` command not found after installing using snap

I've install .NET Core on my Ubuntu 18.04 using sudo snap install dotnet-sdk --classic, but after the install process complete, the dotnet command still not working. Here is my console log: long@...
  • 375
2 votes
0 answers
991 views

Cannot install dotnet-sdk due to unmet dependencies

I followed the instructions given Here to install dotnet-sdk-2.2. On running the last command, I get the following error: $ sudo apt-get install dotnet-sdk-2.2 Reading package lists... Done ...
  • 33
2 votes
1 answer
1k views

Curl & libcurl3 held back, possibly by .net core

When I try to upgrade my packages, I receive a message that curl and libcurl3 have been kept back. I did not do this myself. Referring to "The following packages have been kept back:" Why ...
  • 193
1 vote
0 answers
36 views

Firefox Webdriver NuGet dependency for Linux machine

I need a Firefox Webdriver which can work on a Linux machine and right now the one that exists in the Nuget repository works only on Windows and I would like to know if there is a way to get one that ...
1 vote
4 answers
4k views

Cannot install .NET Core on Ubuntu Bionic Beaver

I'm currently trying to install .NET Core on Ubuntu 18.04 following these instructions. But I always get the following message: me@mine-Ubuntu:~$ sudo apt-get install -y dotnet-sdk-2.1.200 [sudo] ...
  • 13