Questions tagged [dependencies]

Use this tag when asking about managing and resolving dependencies. In Ubuntu most applications have dependencies, programs that they depend on to run correctly. This means that installing a package sometimes requires other packages to be installed, and removing packages will cause others to be removed by APT to prevent them from breaking.

Filter by
Sorted by
Tagged with
-1 votes
0 answers
16 views

How to install packages like libglu1-mesa in a server without sudo

I'm using GPU server provided by my school, and I don't have the root privilege. But running the code needs to install some packages like libglu1-mesa. They are not python packages so I cannot simply ...
iorioinu's user avatar
-2 votes
0 answers
21 views

dependencies issues for packages debhelper & dh-autoreconf for Ubuntu 20.04.6 LTS

Having issues installing two packages on an Ubuntu 20.04.6 LTS server. They both have dependencies on each other so neither of them will install: debhelper "sudo dpkg -i debhelper_12....
grichardson26's user avatar
-1 votes
0 answers
30 views

virtualbox isnot installed in my ubuntu 22.04 system [duplicate]

virtualbox is not installed in my Ubuntu 22.04 system The following packages have unmet dependencies. virtualbox : Depends: python3 (< 3.9) but 3.10.6-1~22.04 is to be installed ...
Hacker bee's user avatar
0 votes
0 answers
37 views

Unmet dependencies after Ubuntu 20.04 -> 22.0.4 upgrade

I have recently upgraded to Ubuntu 22.04LTS. After the upgrade, however, I have problems with apt-get upgrade, since many upgrades are kept back. Here is the full list: base-files cpp language-pack-...
mattiav27's user avatar
  • 875
0 votes
0 answers
25 views

How to package and deploy a DEB without any assumptions about dependencies installed on the target machine

I am creating a DEB package for installation by external systems. At this early stage of development the DEB package consists of custom-developed Python wheels. These wheels depend on: System binary ...
Olumide's user avatar
  • 569
0 votes
0 answers
47 views

Wine & PHP-gd conflict over libgd3

I initially had wine installed on my Ubuntu 22.04 through sudo apt install wine I then tried to install PHP 8.2 along with a set of its extensions by running sudo apt-get install -y php8.2-cli php8.2-...
Mohammed Alkhodary's user avatar
-4 votes
0 answers
42 views

Can't enter desktop environment [duplicate]

$ sudo apt-get install gnome-control-center Reading package lists... Done Building dependency tree... Done Reading state information... Done Some packages could not be installed. This may ...
Rinku Sahu's user avatar
-1 votes
0 answers
22 views

An error occurred, please run package manager from right click menu or apt-get to see what is wrong [duplicate]

Every time I start my laptop I get this error message. An error occurred, please run package manager from the right-click menu or apt-get to see what is wrong. The error message was: Error: Marking ...
sina panahi's user avatar
0 votes
1 answer
47 views

Help repairing broken Python base on Linux with Miniedit-WiFi setup

I previously uninstalled Python3.12 (on which I had ran Miniedit-WiFi tool) and left the default Python3.11; however the following console-log error keeps popping out whenever I run a Python script on ...
Kayemba Luwaga's user avatar
1 vote
1 answer
160 views

Nvidia driver update from 525 display ports no longer working with GTX 2070

Problem: After attempting to update my nvidia driver, I got stuck in a constant black screen on reboot. I was able to get back to my desktop but now my display port connections / dual monitors do not ...
Kyle Watts's user avatar
0 votes
1 answer
244 views

Unmet dependencies and broken packages error while I tried to upgrade Ubuntu 22.04 [duplicate]

sudo apt upgrade showing following error You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: libc-bin : Depends: libc6 (< ...
THORN HILL's user avatar
0 votes
1 answer
103 views

QGIS not installing in Ubuntu 22.04 [duplicate]

When I install QGIS-ltr version in ubuntu 22.04, the following error pops out and I have tried every solution previously given but of no use. Setting up qgis-providers (1:3.34.3+36jammy) ... /usr/lib/...
Maukthik Srivathsan J's user avatar
0 votes
0 answers
27 views

Error: Dependency is not satisfiable: libwxgtk3.2-1 (>=3.2.0) when trying to update PWSafe from V1.13 to V1.18.2 [duplicate]

I downloaded passwordsafe-ubuntu23-1.18.2-amd64.deb from sourceforge.net - the official site and tried to install it using Software Install, but no go. Learned about and installed gdebi and tried to ...
MitcheCA's user avatar
10 votes
1 answer
1k views

Unmet dependencies but "apt --fix-broken install" does not work

My nvidia-smi does not work: NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running. I tried the commands in ...
Satoru's user avatar
  • 221
-1 votes
1 answer
81 views

Cannot upgrade Ubuntu Studio 24.04 bcs of unmet dependencies [closed]

After an upgrade to Distributor ID: Ubuntu Description:Ubuntu Noble Numbat (development branch) Release: 24.04 Codename:noble apt won't update bcs of unmet dependencies. The following packages have ...
BluesBrother's user avatar
-1 votes
1 answer
102 views

apt install steam not working on Ubuntu 22.04 [duplicate]

I am trying to use sudo apt install steam for my install, but I get the following output: Reading package lists... Done Building dependency tree... Done Reading state information... Done Some packages ...
Lemma's user avatar
  • 7
-1 votes
1 answer
199 views

Unable to correct problems, you have held broken packages Ubuntu 22.04

Getting this error sudo pro enable fips-updates: Failed running command 'apt-get install --assume-yes --allow-downgrades -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-...
Adarsh S's user avatar
0 votes
1 answer
108 views

How to install gtk-recordmydesktop?

I've upgraded Linux to the newest version recently, and re-installed recordmydesktop, but I want to install gtk-recordmydesktop, the one that allows you to pause it and select what part of the screen ...
GlowstoneLove Pad's user avatar
0 votes
1 answer
51 views

dpkg: dependency problems prevent removal of r-base-core in ubuntu 20.4

I have attempted to install R new version from source code however it did not work. so I uninstalled and reinstalled R again using the amd64. R is still not woking when I run : $which R command not ...
sara's user avatar
  • 9
-1 votes
2 answers
112 views

Compiling with Libadwaita, GTK4 and C

After installing the libadwaita-1-dev package on Ubuntu 23.10, I tried to compile the example from the official documentation: gcc $(pkg-config --cflags --libs gtk4) $(pkg-config –-cflags --libs ...
Holger's user avatar
  • 1
0 votes
1 answer
150 views

How to install paprefs (PulseAudio Preferences)

Ubuntu 20.04 Installing paprefs gives the following errors: sudo apt install paprefs The following packages have unmet dependencies: paprefs : Depends: pulseaudio-module-gsettings but it is not going ...
Anton Samokat's user avatar
0 votes
0 answers
190 views

wine installation fails: Depends wine-staging (= 9.0~rc3~jammy-1)

I am trying to install wine on Ubuntu 22.04 and following the docs here: https://wiki.winehq.org/Ubuntu But when reaching this step: sudo apt install --install-recommends winehq-staging I get an ...
sunwarr10r's user avatar
  • 1,419
0 votes
0 answers
26 views

nodejs : Depends: libc6 (>= 2.28) but 2.27-3ubuntu1.6 is to be installed [duplicate]

I was trying to install node into wsl2 (ubuntu 18.04) using binary distribution command: curl -fsSL https://deb.nodesource.com/setup_18.x | sudo -E bash - &&\ sudo apt-get install -y nodejs ...
Damika's user avatar
  • 101
0 votes
0 answers
36 views

Openboard "Failed to start encoder" in the podcast feature

I have just installed Openboard 1.6.1 (via Software Manager) in Ubuntu 22.04 LTS. Once I try to start recording in the podcast feature, it says "Failed to start encoder" - the button with a ...
Andrey Chaves's user avatar
1 vote
1 answer
93 views

How do I install multiple architecture versions of a single package using synaptic?

I am trying to cross compile a program that uses GTK3. The host machine is x86_64 running Ubuntu 22.04. The target machine is arm64 or aarch64 running Debian (Bookworm). I have setup the cross-...
race_max's user avatar
0 votes
1 answer
49 views

does apt-mark hold prevent updates to package dependencies?

I have an old package on an old system, and I want to upgrade my OS. Getting the specific package to work on newer systems might be possible, but I don't want to mess with it right now, I still want ...
j0h's user avatar
  • 14.8k
0 votes
1 answer
282 views

CUDA package problems: Can't update Ubuntu 22 due to 'unmet dependecies'

So I am pretty new to Linux. I played around with installing CUDA libraries for some ML experiments on my linux system. However since a couple of weeks I have not been able to get updates to my system ...
Slinky's user avatar
  • 1
0 votes
0 answers
13 views

Getting issue while installing dependencies in ubuntu [duplicate]

neeraja@Ubuntu:~$ sudo apt install libgtkglext1-dev libglibmm-2.4-dev libgtkmm-2.4-dev libpangomm-1.4-dev Reading package lists... Done Building dependency tree Reading state information... ...
Neeraja Reddy's user avatar
0 votes
0 answers
31 views

Unable to install Zenmap due to other dependency on which python-gtk is dependent

I am unable to install the Zenmap in ubuntu 22.04 due to python-gtk dependency as python-gtk is dependent on python lower version i guess. Please have a look at the image attached for the reference.
Chetan Rajpurohit's user avatar
0 votes
0 answers
63 views

I am trying to install wine but accidentally installed the wrong version

i am trying to install wine and accidentally typed sudo wget -NP /etc/apt/sources.list.d/ https://dl.winehq.org/wine-builds/ubuntu/dists/jammy/winehq-jammy.sources which is for ubuntu version 22.04 ...
bob's user avatar
  • 1
0 votes
1 answer
139 views

Installing libgkt-4-dev on Ubuntu 23.10 results in libxfixes3 version mismatch

I'm trying to learn gtk4 application development, but even after a bunch of various attempts to fix it, sudo apt install libgtk-4-dev still returns the following output: Reading package lists... Done ...
grizeldi's user avatar
0 votes
1 answer
1k views

Unable to install gnome environment on ubuntu 23.10

I was using ubuntu 23.04 with gnome. After the update to ubuntu 23.10, it has shifted to budgie. I did not find any cog icon to switch environments on login page. Here is the command I ransudo apt ...
Alan George's user avatar
2 votes
0 answers
552 views

Forticlient VPN can't be installed on 23.10

To install the application, i follow the documentation available at this doc link. During the installation i found some errors: Wrong gpg key. solution Not installable libgconf-2-4. solution Not ...
Pedro Yamaguchi's user avatar
0 votes
0 answers
120 views

"Dependency failed for /home" 22.04

I wanted to expand the home partition on ubuntu 22.04 and create some free space on windows 11. Then trying to do, accidentally change the configuration for home partition in disk manager. At some ...
AGunhan's user avatar
0 votes
1 answer
142 views

How recover from `ERROR: ld.so: object '/path/to/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.`?

In order to prevent CustomerSideDecorations (CSD) I added nocsd to my Xubuntu 22.04: sudo apt -y install gtk3-nocsd. Also, I added this file ~/.xsessionrc to my home directory: # 2023-11-16 nach dem ...
Adalbert Hanßen's user avatar
0 votes
0 answers
43 views

Using ROCm in Asus M1605Y for Whisper AI

I recently bought an Asus vivobook M1605Y. I installed Ubuntu 22.04.3 because according to this page https://rocm.docs.amd.com/en/latest/release/gpu_os_support.html it is compatible with ROCm. When I ...
Ayar ʕʘ̅͜ʘ̅ʔ's user avatar
10 votes
1 answer
3k views

Problem with nvidia package dependencies

I have one problem with upgrading of nvidia package. After last updating of this package I faced with such message: $ sudo apt-get upgrade Reading package lists... Done Building dependency tree... ...
Vitalii Frolov's user avatar
0 votes
2 answers
753 views

23.04-23.10 Release upgrade dependent on held back packages [duplicate]

I am struggling to do my release upgrade from Ubuntu 23.04 to 23.10. The release upgrade depends on all packages being upgraded, and one upgrade is held back. $ sudo do-release-upgrade Checking for a ...
Mr.Cave's user avatar
0 votes
0 answers
69 views

Cannot install/purge/upgrade after problematic upgrade [duplicate]

I tried to upgrade my ubuntu version from 18 to 20. The upgrade process was finished, but in reality my OS was not fully upgraded. I still see the old GUI and several things do not work (backup, ...
Sakis's user avatar
  • 101
0 votes
0 answers
446 views

Installing WIneHQ on Ubuntu 22.04, how to escape this dependency hell?

I am trying to install WineHQ on Ubuntu 22.04.1. I followed instructions from winehq.org, but when I try to run: sudo apt install --install-recommends winehq-stable The following packages have unmet ...
daamian3's user avatar
0 votes
0 answers
8 views

libc-bin:i386 Issue [duplicate]

Ubuntu Jammy 22.04 I installed for an old game on lutris a new version (2.38) libc-bin:i386 from an external source. Now I destroy the system. I cant remove this package with apt or dpkg and i cant ...
nico_265's user avatar
-1 votes
1 answer
984 views

Cannot install ubuntu-desktop on Ubuntu 22.04 LTS

I am sorry for this newbie question. I removed my desktop manager and many gnome packages by mistake in my Ubuntu 22.04 LTS. I tried sudo apt install ubuntu-desktop, which leads to: Reading package ...
Davood Dorostkar's user avatar
0 votes
0 answers
444 views

Installing R on Ubuntu 23.04 [duplicate]

I have been trying to install R on Ubuntu 23.04 but have been getting the following errors: Reading package lists... Done Building dependency tree... Done Reading state information... Done Some ...
Usman Gulumbe's user avatar
-1 votes
1 answer
796 views

How to install webkitgtk-6.0 in Ubuntu 22.04

I am trying to install planify on Ubuntu 22.04. src/meson.build has dependency dependency('webkitgtk-6.0') Could anyone please tell me, where to get this package and how I can install it?
fedor.khandarov's user avatar
0 votes
1 answer
584 views

Cannot install `libdrm-dev` on Ubuntu 20.04 because it requires dependencies which are older than what I have

$ sudo apt install libdrm-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
Gabriel Staples's user avatar
0 votes
1 answer
3k views

Installing displaylink-driver on Ubuntu 20.04: unmet dependency `evdi`

I'm trying to follow my own installation instructions here: USB to HDMI adapter that works with Ubuntu. They work great on Ubuntu 22.04, but not 20.04. On 20.04 when I do the sudo apt install ...
Gabriel Staples's user avatar
0 votes
0 answers
676 views

Ubuntu 22.04 Jammy, libc6 breaks after update. How to recover half-installed libc6

After an update my libc6 broke, in particular /lib/x86_64-linux-gnu/ld-linux-x86-64.so.2 was deleted. I had to boot from a live distro to copy it back because no command was working anymore (now I ...
Overflow's user avatar
  • 101
-1 votes
1 answer
626 views

Trying to upgrade to Ubuntu 22.04 LTS apt (>= 2.1.10ubuntu0.3)

When upgrading from 20.10 to 22.04.3 LTS get message: Required Depends not installed the required dependency 'apt(>=2.1.10ubuntu0.3)'is not installed PC:~$ sudo apt install apt 2.1.10ubuntu0.3 ...
Jane Sutherland's user avatar
0 votes
1 answer
553 views

Ubuntu 22.04 desktop computer would not boot due to mount issue

Regards, I misplaced the USB backup drive, I guess due to a dependent binding mount point, it would not boot. A message did appear.... ( 13.098039) EXT4-fs (sdc1): VFS: Can't find ext4 filesystem ( ...
Nishnabe's user avatar
  • 389
1 vote
0 answers
224 views

Installing Spek on Ubuntu

I am trying to figure out how to get a tool called Spek - which hasn't been released yet (version still below 1.0) - on my Ubuntu setup. The app is not available in the software "store" nor ...
Makaveli84's user avatar

1
2 3 4 5
58