Questions tagged [dependencies]

In Ubuntu most applications have dependencies, programs that they depend on to run correctly. This means that installing a package sometimes requires other packages to be installed, and removing packages will cause others to be removed by APT to prevent them from breaking. Use this tag when asking about managing and resolving dependencies

Filter by
Sorted by
Tagged with
2
votes
0answers
20 views

Sudo stopped working after a failed dependency update

Sudo stopped working after I have tried to update a dependency from libc6XXXX to libc6YYYY, required by an experimental text editor. On the first try, it didn't work and apt-get suggested me to use ...
1
vote
2answers
45 views

How to install xpdf on Ubuntu 20.04

I was trying to install EPrints on my Ubuntu 20.04 desktop but it lacked the dependency package xpdf. I have tried multiple ways to install it but failed. Could anyone please tell me how to install ...
0
votes
0answers
13 views

php-curl install after Ubuntu upgrade to 18.04 reports unmet dependencies

After dist upgrade from 16.04 to 18.04 php-curl stopped working. I tied to install it again but faced broken dependencies problems: $ sudo apt-get install php-curl Reading package lists... Done ...
0
votes
0answers
23 views

Ubuntu Server 20.04 - Raspberry Pi 4 - Unmet Dependencies libjson-c-dev

I'm trying to install Netdata on my Raspberry Pi 4 using Ubuntu Server 20.04. At some point I get the following unmet dependicies error: The following packages have unmet dependencies: libjson-c-...
1
vote
0answers
96 views

Dependency errors while installing Zoom on Ubuntu 20.04 [duplicate]

I just upgraded to Ubuntu 20.04, I am trying to install zoom from zoom download, I wasn't able to install it through the "Ubuntu Software" So I went to terminal using sudo dpkg -i zoom_amd64.deb It ...
0
votes
1answer
19 views

Unable to install sgdclient on ubuntu [duplicate]

I get the below error when I try to install also i am not getting the below mentioned dependencies $ rpm -i sgdclient-5.40.941-1.el7.x86_64.rpm rpm: RPM should not be used directly install RPM ...
-1
votes
1answer
25 views

wine1.6-i386:i386 : Depends: wine1.6:any (= 1:1.6.2-0ubuntu14)

I have a problem with Wine. I can't install software and I these results: kamdem@kamdem-HP-EliteBook-8470p:~$ sudo apt-get --download-only dist-upgrade Reading package lists... Done Building ...
1
vote
1answer
54 views

Dependencies to install old .deb file

I am running Ubuntu 18.04 and I have an old .deb file that I'm trying to install. The Ubuntu Software app failed to install it, so I did sudo dpkg -i headoverheels_1.0.1-1_amd64.deb This resulted in:...
0
votes
0answers
27 views

How do I change permissions for all files associated with a program?

I'm trying to set up the DAW Bitwig Studio on my Ubuntu Laptop and when I run it from terminal it crashes due to some files associated with it not having permissions. Is there a way to change ...
0
votes
0answers
19 views

Unable to install audacity [duplicate]

Unable to install audacity from ppa, it shows some packages are not installable. This is the output. This happened when a recent update came and was unable to install. So I uninstalled and re-...
2
votes
1answer
49 views

ubuntu 18.04 Wine 5.0 various workarounds didn't work for me

I've followed the WineHQ guide than tried again adding this command: sudo apt-get install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:...
2
votes
2answers
126 views

Can't Install MySQL after stupid clash with mariaDB

It completely slipped my mind that MySQL was already installed on this particular computer and I installed MariaDB, I was also unaware of the consequences of having both packages on the same computer, ...
0
votes
0answers
23 views

How to exclude package from apt --fix-broken install (Don't tag it as a duplicate)

My last post tagged as duplicate, and I don't know how to delete that duplicate mark. If you think this is duplicate or already answered please comment first, don't immediately mark as duplicate. ...
0
votes
0answers
22 views

gvfs-backends : Depends: libsmbclient (>= 2:4.10.0+dfsg) but 2:4.7.6+dfsg~ubuntu-0ubuntu2.15 is to be installed

My problem is in the photo below Click here I tried sudo apt install libsmbclient And that was the output libsmbclient : Depends: samba-libs (= 2:4.11.6+dfsg-0ubuntu1.2) but it is not going to be ...
0
votes
2answers
81 views

Can't install libqt4-dev on Focal - “Package not available” despite appearing in launchpad

I'm trying to get Geant4 up and running, and one of the required dependencies is to have libqt4-dev. Despite the fact that it appears in launchpad (link), I keep on getting the following error: ...
0
votes
1answer
24 views

I delete qgis librarys manually, How can I install it again? in order to install qgis

I deled qgis librarys manually, How can I install them back again? in order to re install q gis Good day Ubuntu Community! I Used the comand rm -r in the root to delete the all qgis directories and ...
0
votes
0answers
33 views

Could not install Viber from their official website on Ubuntu 20.04 [duplicate]

I tried to install Viber by downloading .deb file from https://www.viber.com/en/download/. But there was error saying: Dependency is not satisfiable libssl 1.0.0.
1
vote
0answers
16 views

Display manager not working

I recently restarted my computer and the Display Manager stopped working. I got the login screen and as soon as I tried to log in the screen went black. I went to reinstall gdm3 but that failed to ...
1
vote
0answers
36 views

ubuntu 20.04 update error [duplicate]

I can't update the patches below . I get an error. How to solve this? Check if you are using third party repositories. If so disable them, since they are a common source of problems. Furthermore run ...
1
vote
1answer
62 views

Wine dependency woes

I'm trying to get Wine 5.0 installed on Ubuntu 16.04 64-bit. I've added i386 arch, added their PPA to apt, did apt-get update, and then tried apt-get install --install-recommends winehq-stable wine-...
0
votes
0answers
38 views

Trying to install Cisco packet tracer

I recently installed Ubuntu 20.04 and I am trying to install Cisco packet tracer but i keep on getting a unmet dependency packettracer : Depends: qt-at-spi but it is not installable I am completely ...
0
votes
1answer
25 views

Errors were encountered while processing: snapd

ubuntu@RHC-395:~$ sudo apt-get install snap Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The ...
1
vote
1answer
83 views

Can not install Wine on Lubuntu 20.04

I am not able to meet all the dependencies needed to install wine. I have followed all the instructions as on here but when i do sudo apt install winehq-stable my computer shows Reading package ...
0
votes
0answers
88 views

How to exclude package from apt --fix-broken install [duplicate]

Package packettracer is refer to Cisco Packet Tracer 7.3. My OS is ubuntu 20.04. I have a package packettracer that not clearly installed, but the package is working. $sudo dpkg -i ...
0
votes
0answers
492 views

Looking for qt-at-spi for ubuntu 20.04

Package packettracer is refer to Cisco Packet Tracer 7.3. My OS is ubuntu 20.04. I installed the packettracer, the package is required qt-at-spi package that I could not found on ubuntu 20.04 ...
0
votes
0answers
93 views

Problem with dependencies installing packet tracer 7.3 in Ubuntu 20.04 [duplicate]

I download the deb package from the official cisco's page, before run sudo dpkg -i PacketTracer_730_amd64.deb I get this error: Selecting previously unselected package packettracer. (Reading database ...
1
vote
1answer
30 views

building remmina teamviewer plugin ubuntu 20.04

I am trying to build the remmina teamviewer plugin in my fresh ubuntu 20.04 install after getting an unspecified unmet dependency trying to install the remmina-plugin-teamviewer_1.0.0.2-1_amd64.deb ...
0
votes
0answers
38 views

Being stopped on LibreOffice when trying to update Lubuntu

The following packages have unmet dependencies: libreoffice-core : Depends: libreoffice-common (> 1:6.3.5) but 1:6.3.2-0ubuntu2 is installed libreoffice-help-common : Depends: libreoffice-common (...
1
vote
0answers
19 views

“The Package System is Broken” on Ubuntu 19.10

I got a window pop up onto my screen, and it said "Updated software is available for this computer. Do you want to install it now?" So I clicked "Install Now",which led to this window; The package ...
0
votes
1answer
174 views

On ubuntu 20.04 LTS can not install postgis

When i try to install postgis with sudo apt install postgresql-12-postgis-2.5 I run into an error postgresql-12-postgis-2.5 : Depends: libgdal20 (>= 2.0.1) but it is not going to be installed E:...
0
votes
0answers
17 views

Ubuntu 18.04 (Bionic) Server Unmet dependencies “are not going to be installed” [duplicate]

I'm trying to spruce up my newly developed server (see details in subject above) by installing things like python, etc. WiFi access = Yes. Successfully pinged some websites and apt-get update works ...
1
vote
0answers
42 views

Restore Manually Downgraded Packages

How do I upgrade (restore) the manually downgraded downgrade packages in Ubuntu? I was trying to install open-cv on a Jetson TX2(OS-Ubuntu 18.04.4 LTS), and there were some dependencies' version ...
0
votes
2answers
36 views

16.04 unmet dependencies

I have 16.04 on a dell 390 . 16.04 was installed 2 or 3 yrs ago and a number of updates were done over time. At some point i believe updates stopped. I have recently tried to fully update and i get a ...
-1
votes
0answers
33 views

package dependency problem: libdav1d1_1%3a0.3.1-dmo1_i386.deb' has premature member 'control.tar.xz' [duplicate]

While installing package libdav1d1 i get this error: dpkg-deb: error: archive '/var/cache/apt/archives/libdav1d1_1%3a0.3.1-dmo1_i386.deb' has premature member 'control.tar.xz' before 'control.tar.gz',...
1
vote
2answers
113 views

Dependency Problem with LightWorks. Package libssl1.0.0 is not available

While installing lightworks using gdeb. It prompted for that the package have unmet dependency libssl1.0.0 So i tried installing libssl1.0.0 using the following command in terminal sudo apt install ...
1
vote
0answers
16 views

Wine errors and can't uninstall [duplicate]

so I was following this guide: https://www.youtube.com/watch?v=_Qf7BNTDKb8 to install LoL onto my chromebook through ubuntu and Wine. The issue I've found is that at the seventh step (the command line ...
1
vote
0answers
16 views

Lost Ubuntu 18.04 packages due to libwayland

In order to fix some driver nvidia gpu issue with steam, I tried installing libwayland as suggested in a forum, sudo apt-get install libwayland-client0:i386. Now I was running a 64 bit Ubuntu 18.04 ...
1
vote
1answer
109 views

ubuntu 20.04 missing dependencies [duplicate]

Attempting to install hplip-3.20.3.run on Ubuntu 20.04 missing dependencies: Package-Name Component Required/Optional pil scan OPTIONAL ...
-1
votes
0answers
69 views

Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin

I'm trying to remove python-setuptools in my tx2. But when I run: sudo apt-get remove python-setuptools The output was like this: Reading package lists... Done Building dependency tree ...
4
votes
1answer
1k views

qt4 / libqt4-* in Ubuntu 20.04

Ubuntu 20.04 dropped qt4 and all libqt4-* dependencies in its official repos. My knowledge about version conflict and install-breaking actions is limited, so before any unthoughtful action is taken, I ...
0
votes
0answers
21 views

Is it legal for a package to depend on a development package?

I have a package that needs dpkg-dev to be installed. So I've added it as a dependency and it works as expected, but now I'm wondering whether it is legal practice according to the Debian packaging ...
0
votes
0answers
63 views

Unable to Locate package: Installing MS SQL server on ubuntu 20.04 [duplicate]

I am following the official documentation to install mssqlserver in ubuntu. I have already set up the mssql server and the system service is loaded and is running. However, after this step, I have to ...
1
vote
2answers
231 views

Problem installing TeamViewer for Linux in Ubuntu 20.04 LTS

New convert from Windows 10 to Ubuntu so be gentle with me!!! I do work in IT support but have no experience with Linux other than just installing Ubuntu. I am trying to install Teamviewer for Linux ...
1
vote
0answers
84 views

Unmet dependencies ubuntu 20.04 [duplicate]

I've recently shifted from windows to ubuntu and it doesnt seem to be a smooth start. I've installed Ubuntu 20.04. Everytime I try to install a package,I get this following error: somal@Creator:~$ ...
0
votes
1answer
46 views

Certbot installation failed in Amazon Ubuntu 18.04

I have Amazon AWS running Ubuntu 18.04, I need to install Lets encrypt, so I tried following commands, when I install python3-certbot-apache it gives error of unmet dependencies. Can you please help ...
0
votes
1answer
34 views

sudo apt install errors

when i run sudo apt install build-essential zlib1g-dev libncurses5-dev libgdbm-dev libnss3-dev libssl-dev libreadline-dev libffi-dev libsqlite3-dev wget libbz2-dev -y && wget https://www....
1
vote
1answer
30 views

Cannot open Pinta on my Ubuntu 16:04

I tried purging the application and installing again, but it didn't work when I tried apt-get clean after removing Pinta again, here is the output gnome-icon-theme libglib2.0-cil libgtk2.0-cil ...
0
votes
1answer
118 views

Package conflict while installing ms-sql in ubuntu. Broken packages

I am trying to install ms sql in Ubuntu 20.04. Even I have got it installed in 20.04 successfully following this guide but I sometime I have this problem multiple time and not sure why is this ...
3
votes
1answer
20 views

Running Lucid (10.04) in virtualbox in 2020 - dependencies [duplicate]

Working from home during lockdown, I seem to need to use the Linux version of some proprietary software (Bruker OPUS). It's the only software that will read the proprietary file format. I don't have a ...
0
votes
0answers
19 views

Linux packages install via Terminal error (unmet dependencies)

I tried to install a new Point Cloud Library but got this error install error I also tried to install them separately with: # sudo apt install libboost-all-dev libvtk6-dev libvtk6-qt-dev just got ...

1
2 3 4 5
46