Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [configure]

Questions about configure scripts

2
votes
1answer
42 views

menuconfig and xconfig don't work!

when I try to use make menuconfig I get this: scripts/kconfig/mconf Kconfig init/Kconfig:1301: can't open file "usr/Kconfig" scripts/kconfig/Makefile:24: recipe for target 'menuconfig' failed make[1]:...
0
votes
1answer
23 views

configure wxFreeChart problem on Ubunut 16.04

I have problem with configure petat@UNUC:~/Plocha/wxFreeChart-master$ ./configure checking build system type... x86_64-unknown-linux-gnu checking host system type... x86_64-unknown-linux-gnu ...
1
vote
1answer
28 views

cannot configure or make install samtools 0.1.19

I need to install a certain version of samtools (0.1.19) (found at https://sourceforge.net/projects/samtools/). ./configure returns "no such file..." make works correctly (from what I can tell) sudo ...
0
votes
0answers
14 views

Unable to get Samsung M262x 282x Series printer to work

I have a Samsung M262x 282x Series mono laser printer which has worked perfectly well under Ubuntu versions up to and including 16.04. I recently upgraded to 18.04 and cannot get the printer correctly ...
1
vote
1answer
46 views

“libcurl not found” error message while trying to compile a package

I'm trying to compile a package and right at the ./configure step, I get : checking for LIBCURL... configure: error: Package requirements (libcurl >= 7.15.4) were not met: No package 'libcurl' ...
0
votes
0answers
622 views

Can't enable selinux on Ubuntu server 18.04

To start I'm a complete noobie in the matter of SElinux and ubuntu, so my problem is that I tried installing it on ubuntu server 18.04 using this tutorial: https://www.linode.com/docs/quick-answers/...
0
votes
1answer
70 views

openssl and PKG_CONFIG_PATH problems while configuring mongolite package from R

The package "mongolite" won't install itself when trying in RStudio. So I downloaded it from https://cran.r-project.org/web/packages/mongolite/, extracted it in the folder which manages the R packages ...
0
votes
0answers
90 views

Starting Apache…fail error when starting Apache server

XAMPP: Starting Apache...fail. XAMPP: Starting diagnose... XAMPP: Sorry, I've no idea what's going wrong. XAMPP: Please contact our forum http://www.apachefriends.org/f/ Last 10 lines of /opt/...
0
votes
2answers
54 views

configure error line 38: sort: No such file or directory

Using configure, ends with the following message: ./configure: line 38: sort: No such file or directory ./configure: line 35: sed: No such file or directory
2
votes
0answers
35 views

Installing BlackHat on Ubuntu 16.04 conflicts with Anaconda

I'm trying to install BlackHat on Ubuntu 16.04. I have no problem with qd but I can't configure BlackHat. I got Could not link test program to Python. Maybe the main Python library has been ...
0
votes
1answer
24 views

Gzip freezes during the execution of ./configure command

I am following the instructions of LFS book. I have unzip or untar many packages and install it. But when I do the same process for Gzip package It freezes. Everything is works fine until checking for ...
1
vote
0answers
59 views

Configuring services in Cubic chroot

There's an excellent "using Cubic" guide already posted, but it didn't get into how to configure services in the Cubic chroot. For instance, I would like to pre-configure a RabbitMQ server so that it'...
0
votes
2answers
39 views

unable to configure nor able to uninstall virtual box

I have installed virtual box from app manager and installed it on ubuntu 18. But i was uble to run any program on virtual box since it was giving a error. Kernel driver not installed (rc=-1908) To ...
0
votes
2answers
39 views

Printer misses file

How to solve the problem specified as: Printer state message is: 'File usr/lib/cups/backend/usb"not available: no such file or directory'. Warnings are listed below: There is a missing ...
0
votes
2answers
518 views

Error while installing Omnet++ on Ubuntu 16.04 : Cannot find osgEarth

I followed the installation guide and installed all the packages mentioned. However, I end up with this error message while running ./configure checking for osgEarth with CFLAGS=" -fPIC -fno-stack-...
3
votes
1answer
646 views

“git --version” still showing the older version of git

I downloaded git version 2.9.5 to replace my older version which is 2.7.4. I downloaded the .gz file from: https://mirrors.edge.kernel.org/pub/software/scm/git/ Turned out as I tried installing that ...
0
votes
0answers
28 views

How to see the configure command used for the standard repositories [duplicate]

I'm wondering if there is any way to see the configure command used for the packages in the standard repositories? It would be nice to be able to see how a package has been build. Have a nice day.
1
vote
1answer
1k views

libpng: C compiler cannot create executables

I am trying to call ./configure command. But, it shows this error: C compiler cannot create executables. Here the output: checking for a BSD-compatible install... /home/linuxbrew/.linuxbrew/bin/...
0
votes
0answers
214 views

Can't run CloclWorkMode Tether app in ubuntu

I have been trying for few hours to run CloclWorkMode Tether app for ubuntu. So I followed the instructions given by the application itself. My problem is when I try to make node modules before ...
0
votes
0answers
32 views

How to configure apt connection timeout [duplicate]

Sometimes a repository is unresponsive. In such occasions, apt currently hangs for a long time before declaring a time-out (around 1 or 2 minutes, I think). How can I configure it to time-out after, ...
1
vote
1answer
262 views

“Open in terminal” Keyboard Shortcut not working in 17.10

Keyboard shortcut for "open a terminal here" I followed the steps mentioned in in the top voted answer in the above link for my Ubuntu 16.04 and my custom keyboard shortcut for "open in ...
0
votes
0answers
37 views

How I configure correctly the keyboard in a laptop?

Every time I start Ubuntu I have to configure the keyboard with the following command in terminal : sudo dpkg-reconfigure keyboard-configuration And after that, I run the command setupcon in a ...
0
votes
1answer
237 views

How to get a Wacom Graphire4 to work in 17.10

I have been stuggling to get my elderly Wacom tablet to work properly in Artful. Goggling has yielded plenty of old, but not particularly useful info. So, has anyone been able to get a Wacom Graphire4 ...
2
votes
1answer
57 views

Where to find power option config file(s) for 17.10

Just upgraded to 17.10 because 17.04 hit EOL. Seems really nice except for one small basic thing that baffles me as to why it's hard-coded. The amount of time before the monitor goes blank (for some ...
0
votes
1answer
334 views

./configure --with-boost AND --prefix=$HOME/trentacoollime

I am trying to configure in my /trenta directory which is on a path $HOME/trentacoollime/trenta In order to configure in the trenta directory, I have to include option of --with-boost=../boost.1....
0
votes
1answer
549 views

./configure doesn't generate MAKEFILE when building x11spice

I am trying to enable x11spice in my Docker container, I followed the README but after ./configure, there is no MAKEFILE was generate, so make has an error output saying make: *** No targets specified ...
0
votes
1answer
318 views

Notification-bubbles in 17.10 waiting for user-action to autohide. How to disable that function?

On 17.10 gnome-notfication-bubbles are waiting for user-actions to autohide. In my case while listening music with Clementine - 17.10 needs permanent user-activity to show the latest song-notification....
2
votes
0answers
78 views

sudo dpkg --configure -a [duplicate]

sudo dpkg --configure -a On typing this command I am not able to resolve the problem dpkg-was-interrupted-run-sudo-dpkg-configure-a and the terminal window gets hanged. On CLTR + Z it says [2]+ ...
0
votes
1answer
59 views

where to stick libraries I install myself?

In building ffmpeg from source, I got the following error to ./configure --with-libcelt: ERROR: libcelt not found So I went to http://www.celt-codec.org/downloads/, cloned the repo, and ./autogen.sh;...
1
vote
1answer
1k views

.conf files comment

I am quite new to Ubuntu and I think this might be a stupid question to ask. But I wanted to confirm if # meant comments in Ubuntu .conf files. For instance in the code below: #send dhcp-client-...
1
vote
1answer
458 views

How to install PAPI on Ubuntu 16.04 and access performace monitoring counters?

I need to count L2 cache misses (my cpu is i5-3550), so I downloaded last PAPI version. I followed instructions contained in the archive to install it (./configure, make and make install) and it ...
0
votes
0answers
314 views

Can't configure hdf5 on Ubuntu

I'm very new to ubuntu and I downloaded hdf5 from the following (using the Linux download, see link below) and I opened up the tar.gz compressed file but haven't been able to use ./configure to get it ...
1
vote
1answer
675 views

Error:cannot find input file: `man/Makefile.in'

I was trying to install hdf4 and then python-hdf4. I am new to both Linux and Python. I need to read the hdf file. I though I need to install pyhdf since http://www.science-emergence.com/Articles/How-...
1
vote
1answer
86 views

Setting up WebServer with my domain name

I just bought my domain name from godaddy. I would like to use my ubuntu server that I've set up. Where do I start on setting and configuring my ubuntu web server? Thanks in advance for all your help.
1
vote
0answers
95 views

Compiling zsh from source has started spewing errors and warnings

I have a simple script written in bash to pull the latest changes in zsh's official github's repo and build it. I also have another script (still bash) which calls this and other scripts. Plus, I ...
0
votes
0answers
225 views

Vim from source with Python2.7

I installed vim80 from GitHub with the configuration settings --with-features=huge --enable-multibyte --enable-pythoninterp=yes --with-python-config-dir=/usr/lib/python2.7/config-x86_64-linux-gnu/...
1
vote
0answers
96 views

Compling tesseract 4 gives fatal error in ubuntu 16 64 bit

I installed leptonica 1.74 successfully from source. After that, I am trying to compile tesseract 4 from source (tar) on my ubuntu 16.04 64 bit machine. But I m not able to move forward bcz of this ...
1
vote
0answers
1k views

Compiling glibc-2.17 libraries

I hope you can help me. For my class project, I'm suppose to identify and fix GHOST vulnerability in GLIBC in Ubuntu 12.04; I did that. However, the instructor doesn't want the fix by just upgrading ...
14
votes
2answers
23k views

What does --prefix do exactly when used in ./configure?

So I just had a simple question that's probably going to make me look dumb, but I'm learning When I do a ./configure --prefix/usr/bin/ What is the prefix doing ? Is this just installing the ...
3
votes
0answers
322 views

Installing and Configuring DHCP server on Ubuntu 16.04 VPS from OVH

I rented a VPS from OVH to make a VPN Server on it using SoftEther. Everything works fine when I do this at home on a VirtualBox machine. When I went over to the VPS....I didn't know how to properly ...
1
vote
0answers
85 views

Postinstallation script exit error 10: ucf fails

When trying to install R on Ubuntu 16.04 xenial, I'm stuck because r-base-core can't be configured. I'm using the common manual. Apparently the postinstallation script fails when ucf is supposed to ...
0
votes
0answers
119 views

How do I get Ubuntu to recognize a newer version of Cogl?

I'm trying to install clutter-1.26.0 as a prerequisite for other things. When I run ./configure it gets held up here: configure: error: Package requirements (cogl-1.0 >= 1.21.2 cogl-path-1.0 cairo-...
1
vote
1answer
125 views

“Qt 3.x not found please set QT_INCLUDE, QT_LIB, MOC by hand” on my ubuntu14.04

I'm trying to install gmapping package from github https://github.com/nii2121/gmapping/blob/master/docs/Instructions.txt and after I run ./configure It turns out to be No 'CXX' environment ...
0
votes
2answers
120 views

Saving/copy back configurations from Apache, Mysql? Because I want to reinstall Ubuntu 14.04 server.

On my server I have installed Ubuntu 14.04. Bind9, Apache, MySql etc worked fine, until a few month ago I got some problems with mailman. I don't know what happened, but I can't install, remove or ...
0
votes
0answers
305 views

error in making from terminal

I have downloaded rcssserver-15.3.0.tar.gz for soccer simulation when I run ./configure it says checking for a BSD-compatible install... /usr/bin/install -c checking whether build environment is sane....
6
votes
7answers
2k views

Can't make Clockwordmod Tether on Ubuntu 16.10

I'm trying to install Clockwordmod Tether on my Ubuntu 16.10 laptop in order to facilitate USB tethering with the corresponding app on Google Play. I've downloaded and extracted the Tether tar file. ...
0
votes
1answer
276 views

trying to run ./configure and ./make for ecos bintuils -

I'm going from Building a toolchain for use with eCos and I've got to the point where I'm configuring and building the tools for binutils: ./configure --target=arm-elf --prefix=../gnutools -v &&...
1
vote
0answers
332 views

I need help. I am running Ubuntu 16.04 and have no idea how to fix this

So I've had trouble installing some drivers and updates and this is where the internet has led me, but I can't find a solution to these problems. When I put insudo dpkg --configure -a This is the ...
3
votes
0answers
641 views

How can I hide the clock on the Gnome 3 lock screen

I have looked at the dconf/gsettings keys available and cannot find a way to hide the clock on the lock screen. The clock interferes visually with the background image on my lock screen. Ubuntu 16....
7
votes
2answers
4k views

How do I install the latest version of nmap from source on Ubuntu?

I am running Ubuntu 16.04, and I am trying to install the latest nmap. I have a C compiler installed. I ran openssl version and found that this version was installed: OpenSSL 1.0.2g 1 Mar 2016 I ...