Questions tagged [bitcoin]

Questions pertaining to the digital currency payment network known as Bitcoin.

Filter by
Sorted by
Tagged with
0 votes
1 answer
644 views

How to launch Electrum after installing it from an AppImage?

To install the electrum wallet I've downloaded the appimage file from the electrum website. After exiting the wallet, how do I then start electrum again? re-running the appimage file prompts for re-...
user avatar
-7 votes
1 answer
62 views

bitcoin:// URI handling

I run bitcoin-qt all the time, so I set the browser to handle bitcoin:// URI with bitcoin-qt. Unfortunately that causes a new instance to be started, which fails coz it fails to get a lock on the ...
user avatar
  • 1
0 votes
1 answer
77 views

How to save a QR code generated from the Electrum Wallet directly as a PNG or JPG file?

How do I save and send the QR code: as a jpg or png? There are ways to use gimp and/or xclip but I would hope that I can just save the QR code directly to file. Is this possible? Notably, Windows ...
user avatar
0 votes
1 answer
247 views

Installed bitcoin-qt via snap, now can't find wallet folder

I'm trying to import in a old wallet to this new core. I tried looking in the ~/bitcoin/ and it says the directory doesn't exist. I also checked all the directories in ~/snap/bitcoin-core/ but see ...
user avatar
  • 407
0 votes
1 answer
146 views

Running Ubuntu 21.04, the snap version of bitcoin core just shows an empty window with no borders at startup

I just got me the SSD space to run a full node, so I figured I might swith from electrum to bitcoin core. I installed it as a snap, but when I run it, there is just a huge window titled "Welcome ...
user avatar
  • 1
0 votes
2 answers
2k views

bitcoind.service: Can't open PID file /run/bitcoind/bitcoind.pid (yet?) after start: Operation not permitted

On Ubuntu 20.04 LTS, I made a service / systemd unit for bitcoind, but when I start it, I get this error: Can't open PID file /run/bitcoind/bitcoind.pid (yet?) after start: Operation not permitted ...
user avatar
-1 votes
2 answers
1k views

Official bitcoin client fails to start with: Error initializing settings: Failed saving settings file:

I want to run a full bitcoin node on ubuntu focal. I was out of disk space so I bought a brand new 4TB USB hard drive for this. I've formatted it as ext4 using the "disks" GUI. It mounts ...
user avatar
  • 139
0 votes
2 answers
600 views

Why is apt-get unable to locate bitcoin and bitcoin-qt package?

when i run these: sudo apt-get install bitcoin OR sudo apt-get install bitcoin-qt i get "E: Unable to locate package" what do i do?
user avatar
  • 21
0 votes
2 answers
5k views

How to configure bitcoin-core and start it from the console?

I need to configure port forwarding, perhaps? Forwarding port 8333 To have a fully functional Bitcoin node, you need to forward incoming connections on port 8333 to the device running Bitcoin core. ...
user avatar
1 vote
0 answers
188 views

Is it possible to update Snap Bitcoin-Core datadir to NFS mount point under /media?

I couldn't find anything specific regarding NFS storage in /media for bitcoin-core snap on Ubuntu. From what I could gather with limited understanding is that only /home and /media folders on host ...
user avatar
0 votes
1 answer
818 views

Bitcoin Core scanning error

I recently upgraded my Lenovo PC (16-GB RAM; 2TB-HD) from Ubuntu 18.04 to 20.04. I had saved the ".bitcoin" directory (and subdirectories and files) to an external hard disk drive. Since then I have ...
user avatar
  • 941
0 votes
2 answers
1k views

Can't get Exodus (crypto wallet) to open in Ubuntu 20.04

I can't get Exodus (crypto wallet) to open. I am running Ubuntu 20.04 on my Lenovo pc - 16GB memory, 2TB hard-disk Because I was having booting problems I recently wiped my hard-drive and re-installed ...
user avatar
  • 941
3 votes
1 answer
2k views

Not Bitcoin-qt at Software repository 20.04

Even I've got Bitcoin-qt when I was running Ubuntu 18.04, is not anymore at Ubuntu 20.04 Does anyone knows why disappeared it? Thanks a lot.
user avatar
4 votes
2 answers
1k views

Issue installing Electrum on Ubuntu 18.04

I followed all the steps the docs suggest: sudo apt-get install python3-pyqt5 wget https://download.electrum.org/3.3.6/Electrum-3.3.6.tar.gz wget https://download.electrum.org/3.3.6/Electrum-3.3.6....
user avatar
  • 41
2 votes
0 answers
535 views

Getting ‘NO DEVICES FOUND: Press 'M' and '+' to add’ when running bfgminer

Yesterday I installed bfgminer on my Ubuntu 18.04 VServer to mine Bitcoins... I did this by cloning the github-repository (https://github.com/luke-jr/bfgminer) and installing the necessary ...
user avatar
2 votes
1 answer
703 views

Is there a Bitcoin calculator /price tracker widget to add to Gnome?

Is there a way to add something like an online Bitcoin to USD calculator to the Gnome desktop? I don't think the Software store has anything like that.
user avatar
  • 23
0 votes
1 answer
66 views

In apt-get, is there an option to assert that a package is a certain version number?

I'm running a Ubuntu-based Docker image to run a Bitcoin network in regtest mode. The docker image is in this github repo. After adding the PPA for Bitcoin, it seems that 0.15 of bitcoind installs ...
user avatar
1 vote
1 answer
110 views

Command in .bash_profile returns outdated result [duplicate]

The .bash_profile file has the alias below. ~# cat .bash_profile # other commands alias btcblock="echo $(bitcoin-cli getblockcount 2>&1)/$(wget -O - http://blockchain.info/q/getblockcount 2>...
user avatar
  • 113
2 votes
2 answers
3k views

Is it possible to install Minergate in Lubuntu, for 32-bit?

Has anyone been successful in running Minergate software in Lubuntu? I just want to maximize my extra workstation for Minergate only. My workstation is 32-bit and not 64-bit by the way.
user avatar
  • 31
1 vote
1 answer
7k views

How to uninstall Electrum?

I use Electrum as Bitcoin Wallet, and I want to update it. The best way to do it, I think, would be to uninstall the old version and install the new one. How can I do that? I use the 16.04 version of ...
user avatar
2 votes
1 answer
3k views

How can I ensure if there is no crypto currency mining script running on my ubuntu?

I feel that my newly (5 months old) bought Lenovo laptop is running very slow and hangs sometimes from last few days. The only applications running on my laptop are chrome & firefox browsers, ...
user avatar
7 votes
1 answer
2k views

Bitcoin mining attack

I think my server has been attacked and I appreciate any help. On the image Top process it shows strange processes. The output of netstat -tap shows multiple: tcp 0 1 myserver:47985 ...
user avatar
2 votes
2 answers
23k views

error while loading shared libraries: libboost_system.so.1.54.0: cannot open shared object file: No such file or directory

Been working with this issue when trying to run a program. What I did: Updated my system using the following commands: sudo apt-get update sudo apt-get upgrade Installed the necessary ...
user avatar
0 votes
3 answers
245 views

How to install server on /dev/sdb1 on ubuntu

On my ubuntu server, i have /dev/sda that has a single partition of /dev/sda1(30GB) and /dev/sdb that has a single partition of /dev/sdb1 (735GB). i installed bitcoin core on sda1 (default) and it ...
user avatar
0 votes
1 answer
339 views

Significant amount of RAM missing

I have an Ubuntu server that is using bitcoind to download the blockchain and some other tasks. The blockchain is fully synced. I know that it can be a memory hog which is why I've tried to limit the ...
user avatar
  • 101
0 votes
1 answer
373 views

Vertcoin-cli getinfo - gives me an error

I'm trying to check if my vertcoind is running and syncing. I get this command: vertcoin-cli getinfo Response: error code: -32601 error message: Method not found If I try to start vertcoind - ...
user avatar
0 votes
1 answer
946 views

I am having a problem running Exodus Wallet on Ubuntu 17.10

When attempting to run the binary in terminal, I get the following error: ./Exodus: error while loading shared libraries: libgconf-s.so.4: cannot open shared object file: No such file or directory.
user avatar
1 vote
1 answer
168 views

Ubuntu 17.04 - Changed hostname, now my bitcoin core won't work

I believe this occurred after I tried to change the name of my computer since it was a default and had a bunch of numbers after it. After changing it, I started to experience weird things with my ...
user avatar
  • 119
1 vote
0 answers
237 views

E: Sub-process /usr/bin/dpkg returned an error code (1) while doing gitian build

I'm trying to clone Litecoin and build a mock version of it In order to do that I'm trying to configure gitian builder from this link https://coinaxis.com/index.php/tutorials/entry/how-to-do-a-gitian-...
user avatar
1 vote
0 answers
19 views

How to install specific package version when it's defined by 2 different PPAs? [duplicate]

I want to install luke-dash-jr's BIP148 bitcoin PPA which can be found here. I've already added the unofficial Bitcoin PPA to my sources.list; that PPA can be found here. Both PPAs define a bitcoin ...
user avatar
1 vote
1 answer
962 views

How to restore exodus wallet on ubuntu

Is it possible to restore Exodus wallet from email link in ubuntu? when I click the link it ask to open with xdg-open, but then it does nothing, since its portable and not installed. Any helps ?
user avatar
  • 382
0 votes
1 answer
2k views

Can I run exodus wallet on Ubuntu 14.04 LTS?

I download it directly from the Exodus website but I can't run the software by double clicking or directly from the terminal
user avatar
3 votes
2 answers
8k views

Can I install exodus 'wallet' for ethereum & bitcoin on Ubuntu 16.04?

This looks a neat programme for managing cryptocurrency on Linux I've been using Ubuntu for 3 or 4 years, used the terminal parrot fashion for various functions and installs, but have v. little ...
user avatar
5 votes
2 answers
13k views

How to uninstall Bitcoin Core and remove data

I recently installed Bitcoin Core on my Ubuntu 16.04 system. It's taking up too much disk space. How do I completely uninstall the software and remove data to free up my hard drive space?
user avatar
0 votes
1 answer
1k views

Bitcoin Core/Armory installation trouble

Hello so yesterday I tyried to install Armory, a bitcoin desktop wallet, to house my bitcoins. I am doing this for the sake of undertsanding bitcoins a little more and I do not plan to put large ...
user avatar
0 votes
1 answer
1k views

How to enable GPU mining on a spare card not used for main display?

I am using an internal (Intel) video card for my main display. This is selected as per BIOS settings. I'd like to see how the GPU mining is on a AMD card I put into my PC. It's a "Cape Verde PRO [...
user avatar
  • 1,667
-2 votes
1 answer
10k views

What is the lightest software miner for bitcoin mining? [closed]

I have some hosted systems which most of the times don't have any work to do.I wanted to run some software miner on them, but I read a Warning in this stackoverflow post : How to install bitcoin ...
user avatar
1 vote
0 answers
692 views

G++ Compiling error when making from source?

I am trying to install bitcoin server using this guide https://www.sky-ip.org/configure-bitcoin-node-debian-ubuntu.html However when I make, I see the error g++: internal compiler error: Killed (...
user avatar
  • 11
2 votes
1 answer
94 views

Why doesn't Canonical/Ubuntu accept bitcoin contributions? [closed]

I see many questions here about alternatives to Paypal, but no concrete information about why bitcoin (aka universal, Open Source and Free, community-driven money which does not discriminate based on ...
user avatar
0 votes
2 answers
6k views

How to upgrade bitcoind (Bitcoin Core) in Ubuntu?

I would like to know all the options that exist to upgrade bitcoind (PPA or manually). I am running a full Bitcoin node and it's important for me to keep the last available version.
user avatar
2 votes
1 answer
2k views

Fixing libtool for -rpath problems

Hello i need to compile bitcoin on ubuntu 14.04 64bits but i have always this error 'Fixing libtool for -rpath problems.' I installed all dependency sudo apt-get install build-essential libtool ...
user avatar
  • 35
1 vote
1 answer
334 views

Ssl for bitcoind

Hello I need to use bitcoin in my website I compiled it and I use php json rpc for communication with the server and I use crontab each minute for a check of the deposit but in bitcoin wiki https://en....
user avatar
  • 35
0 votes
1 answer
5k views

Bitcoin miner for Ubuntu? [duplicate]

I use Ubuntu 14.04 LTS and I was wondering if there are any good Bitcoin mining software with a GUI that is easy to understand. Can anyone help me out?
user avatar
4 votes
1 answer
666 views

How to install GreenAddress Bitcoin Wallet in Ubuntu?

Can someone make a short tutorial about how to install the bitcoin wallet GreenAddress in Ubuntu?
user avatar
1 vote
1 answer
161 views

What software do I need to exchange Bitcoins?

I need software that could run on Ubuntu desktops and server; a command-line one. I am using Ubuntu 14.04 64-bit both on the desktop and on the server. What software can I use? I have tried ...
user avatar
1 vote
1 answer
2k views

How can I make coinprice-indicator open from startup?

I have coinprice-indicator, it is an indicator applet that shows the price of the BTC using API's from Kraken, BitStamp or BTC-E. It refresh form 3 to every 60 seconds. I start this applet from the ...
user avatar
1 vote
2 answers
4k views

bitcoin miner compatible with nvidia

I would try to start mining Bitcoin into a mining pool, and I'm looking for a client compatible with Linux (if it has a GUI would be better) and that admit to use my Nvidia GTX 860 graphic card. Any ...
user avatar
  • 141
2 votes
1 answer
9k views

Bitcoin Widget To Display Exchange Rate On Top Menu

Just wondering if anyone knows if there's a widget/app to display Bitcoin exchange rate on the top menu on Ubuntu. I would love it even though it's easy to check the rate on the web. When I search on ...
user avatar
  • 21
1 vote
0 answers
129 views

how to install bitcoin from downloaded static binary

due to the openssl problems my bitcoin is affected by the bug and i need to install using the statically linked bitcoin core from the binary on the bitcoin site. I downloaded the program and extracted ...
user avatar
  • 121
1 vote
0 answers
597 views

bitcoin HTTP request failed: Protocol https not supported or disabled in libcurl

I am new to Linux/Ubuntu (I'm running 14.04) and I installed this bitcoin wallet and I followed these steps. But I get the following error message: HTTP request failed: Protocol https not supported ...
user avatar
  • 19