Questions tagged [binutils]

Programs used to assemble, link and manipulate binary and object files. They may be used in conjunction with a compiler and various libraries to build programs.

Filter by
Sorted by
Tagged with
0
votes
0answers
962 views

I get an error why I try to compile D-Link drivers with `make`

I am running Lubuntu 17.04 inside a VMWare virtual machine. I am trying to compile and install the driver for my D-Link DUB-1312 Gigabit Ethernet Adapter. However, I get the error in the code block ...
0
votes
0answers
451 views

dpkg and insserv error when installing any package

When I try to install any package the following error occurs: insserv: There is a loop between service runlcactivator and dns-clean if started insserv: loop involving service dns-clean at depth 1 ...
0
votes
1answer
835 views

Unable to downgrade Binutils package

The Problem I'm currently on 16.04 LTS. binutils package of this distro is of version 2.26. But I need 2.25 (binutils of 15.10). I'm using PyBDF 0.1.1 python packages which depends on binutils 2.25. ...
0
votes
1answer
222 views

PyBFD cannot find Binutils in 16.04

I've upgraded my distro from 15.10 to 16.04 LTS. In 15.10 everything was okay. I am using pybfd 0.1.1 with binutils 2.26 (In 16.04). The python package pybfd used to be okay with binutils of 15.10. ...
2
votes
1answer
725 views

Problems making Afl-fuzzer using BinUtils on 14.04

Aim: I am trying to setup and run Afl Fuzzer (link), as part of following an online course. Info: I'm running Ubuntu 14.04 on dvd. In the video the teacher uses the BinUtils 2.25 package, and I ...
1
vote
0answers
240 views

Checksum failed while bitbake

I am using ubuntu 12.04 to build gumstix-microwindows-image. However I am getting this error when I do bitbake gumstix-microwindows-image NOTE: Handling BitBake files: | (4957/4958) [99 %]ERROR: ...
0
votes
3answers
629 views

How to get the list of binutils available in my system?

I want to know the list of binary tools available in my system.where are these binutils located?
1
vote
1answer
4k views

Unable to install gold linker

It seems I can't install gold linker for 13.10 anymore: $ sudo apt-get install binutils-gold Reading package lists... Done Building dependency tree Reading state information... Done Note, ...
23
votes
1answer
1k views

bfd.h should have included libiberty/ansidecl.h in Ubuntu 14.04?

binutils package seems to be changed, as it includes directory of libiberty.h has moved to /usr/include/libiberty, thus there is possible a wrong include in bfd.h regarding ansidecl.h. Getting those ...
1
vote
2answers
1k views

List of GNU binutils

How can I get such a list from command line, including the version of each utility? Are they by default in the same file by any chance?
3
votes
0answers
5k views

Installing objdump on Ubuntu that recognizes mach-o binaries?

Anyone know how to install a version binutils on Ubuntu that has an objdump that can recognize a mach-o binary? Currently when I run, objdump -P load binary, I get objdump: /path/to/binary: File ...
9
votes
0answers
4k views

Can I set the gold linker as the default one? [closed]

Before Ubuntu 13.10 (saucy), the /usr/bin/ld symlink was pointing to ld.gold when the binutils-gold package was installed. Gold now comes with the binutils package itself, and it installs the /usr/bin/...