Questions tagged [apt]

Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

Filter by
Sorted by
Tagged with
614
votes
14answers
1.2m views

How do I resolve unmet dependencies after adding a PPA?

Occasionally, when I'm installing stuff, I get an error like the following: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the ...
312
votes
12answers
1.0m views

Unable to correct problems, you have held broken packages

After upgrading from 10.04 to 12.04 I am trying to install different packages. For instance ia32-libs and skype (4.0). When trying to install these, I am getting the 'Unable to correct problems, you ...
299
votes
9answers
639k views

How can I fix a 404 Error when using a PPA or updating my package lists?

PPA seems to be constantly offline. Whenever I use sudo apt-get update, this error is shown: W: Failed to fetch http://ppa.launchpad.net/ 404 Not Found How do I fix these errors?
110
votes
5answers
339k views

What can I do if a repository/PPA does not have a Release file?

When updating, I get the following error message: W: The repository 'http://ppa.launchpad.net/mc3man/trusty-media/ubuntu xenial Release' does not have a Release file. Here, I find another statement ...
1120
votes
24answers
3.5m views

Unable to lock the administration directory (/var/lib/dpkg/) is another process using it?

I get this error when trying to use apt-get: E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable) E: Unable to lock the administration directory (/var/lib/dpkg/) is ...
82
votes
9answers
317k views

How do I remove a malformed line from my sources.list?

I have unistalled and reinstalled the Ubuntu Software Center as per info I found in a similar thread and I got the same response about line 91 or something like that. I just tried to upload a screen ...
457
votes
12answers
776k views

How do I fix the GPG error “NO_PUBKEY”?

I added some extra repositories with the Software Sources program. But when I reload the package database, I get an error like the following: W: GPG error: http://ppa.launchpad.net trusty InRelease:...
144
votes
4answers
148k views

dpkg error: “trying to overwrite file, which is also in…”

For example: $ sudo apt-get install curl Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The ...
370
votes
10answers
360k views

How do I fix a “Problem with MergeList” or “status file could not be parsed” error when trying to do an update?

The computer gave me this output in a window: E: Encountered a section with no Package: header E: Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_natty_main_binary-...
278
votes
6answers
2.2m views

“Unable to locate package” while trying to install packages with APT

When I try to install any package through the command line, I get an error. $ sudo apt-get install <package> Reading package lists... Done Building dependency tree Reading state ...
1430
votes
26answers
1.6m views

How can PPAs be removed?

I've added many PPAs using the add-apt-repository command. Is there a simple way to remove these PPAs? I've checked in /etc/apt/sources.list for the appropriate deb lines but they aren't there. This ...
429
votes
22answers
400k views

Trouble downloading packages list due to a “Hash sum mismatch” error

When I check for updates, I get a "Failed To Download Repository Information" error. This is what comes up under details: W: Failed to fetch gzip:/var/lib/apt/lists/partial/us.archive.ubuntu....
115
votes
7answers
782k views

Permission denied, are you root?

I get this error whenever I try to install programs using the terminal: home@ubuntu:~$ apt-get install myunity E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable ...
222
votes
6answers
267k views

How can I fix apt error “W: Target Packages … is configured multiple times”?

I just installed Ubuntu Gnome 16.04. I told it to save my documents - which worked. Some software had to be reinstalled. Now when I run sudo apt-get update I see this: W: Target Packages (main/binary-...
37
votes
3answers
95k views

How do I fix this “E: Type '*' is not known on line * in source list …” update error?

Every once in a while I see users having issues to update due to errors like this: E:Type 'ain' is not known on line 1 in source list /etc/apt/sources.list.d/some-ppa.list' with varying types/line ...
163
votes
15answers
193k views

My /boot partition hit 100% and now I can't upgrade. Can't remove old kernels to make room

My first issue was when I tried to apt-get update or apt-get upgrade. On upgrade I get the following error: You might want to run 'apt-get -f install' to correct these. The following packages have ...
2306
votes
23answers
4.3m views

How to list all installed packages

I'd like to output a list of all installed packages into a text file so that I can review it and bulk-install on another system. How would I do this?
214
votes
8answers
307k views

How can I get apt to use a mirror close to me, or choose a faster mirror?

Downloading from the main Ubuntu archive is slow even when it's not release day, how can I get apt-get to automatically use a mirror that is close to me?
368
votes
5answers
302k views

How can I accept the Microsoft EULA agreement for ttf-mscorefonts-installer?

After a recent update, ttf-mscorefonts-installer prompted me to accept its license agreement. ┌─────────────────┤ Configuring ttf-mscorefonts-installer ├─────────────────┐ │ ...
148
votes
17answers
697k views

apt-get update fails to fetch files, “Temporary failure resolving …” error

Err http://archive.canonical.com natty InRelease Err http://security.ubuntu.com oneiric-security InRelease Err http://extras.ubuntu.com natty InRelease ...
131
votes
6answers
97k views

What is the easiest way to resolve apt-get BADSIG GPG errors?

I frequently cross this issue, and always have to google for an answer. Does anyone have a permanent fix for BADSIG errors from apt-get? W: GPG error: http://download.virtualbox.org lucid ...
154
votes
6answers
178k views

“debconf: DbDriver ”config“: config.dat is locked by another process: Resource temporarily unavailable” while installing packages

I'm trying to install the flashybrid but when I enter the apt-get install flashybrid command, I get this error: root@user-desktop:/home/user# apt-get install flashybrid Reading package lists... Done ...
149
votes
4answers
471k views

E: Unable to correct problems, you have held broken packages

I am using Ubuntu 13.04 which I installed few days back. I am trying to install nodejs and npm. I tried to install from command line first and then uninstalled it. Then something broke. sudo apt-get ...
23
votes
8answers
43k views

Failed to download repository information due to missing CDROM

When updating I got this error message: W:Failed to fetch cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)/dists/oneiric/main/binary-i386/Packages Please use apt-cdrom to make this ...
87
votes
3answers
391k views

What does “Package <package> has no installation candidate” mean?

What does the above Error mean? What is an installation candidate? I was trying to do sudo apt-get install munin-memcached and I get this message: Reading package lists... Done Building ...
483
votes
5answers
677k views

What is “dist-upgrade” and why does it upgrade more than “upgrade”?

I was wondering why upgrade sometimes doesn't want to upgrade certain parts of the system, while dist-upgrade does. Here's an example after running apt-get upgrade: apt-get upgrade: rimmer@rimmer-...
1170
votes
22answers
1.0m views

“The following packages have been kept back:” Why and how do I solve it?

I just added a PPA repository for the development version of the GIMP, but I get this error: $ apt-get update && apt-get upgrade ... The following packages have been kept back: gimp gimp-...
193
votes
25answers
359k views

How to fix “W: Duplicate sources.list entry”?

I keep getting this warning whenever I try to run sudo apt-get update. W: Duplicate sources.list entry http://archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages (/var/lib/apt/lists/archive....
129
votes
7answers
138k views

How can I restore configuration files?

I would like to restore LightDM to its default state, because for some reason /etc/lightdm/unity-greeter.conf is now an empty file. Deleting /etc/lightdm/unity-greeter.conf and then running sudo apt-...
633
votes
9answers
1.8m views

What does “sudo apt-get update” do?

I am wondering what sudo apt-get update does? What does it update?
107
votes
7answers
74k views

No more updates for Google Chrome 32-bit

I am using Google Chrome 48.0 32-bit. Today when I launched Google Chrome, I got this message: This computer will soon stop receiving Google Chrome updates because this Linux system will no longer ...
154
votes
1answer
296k views

E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable) [duplicate]

I'm trying to run this command in the terminal: sudo apt install software-properties-common This is the error message I get: E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource ...
187
votes
5answers
190k views

How do I get and modify the source code of packages installed through apt-get?

I am assuming that all application installed through apt-get are open source; but for those that are available in that manner, where can I get the source code for these applications as well as update ...
643
votes
4answers
352k views

What is the difference between apt and apt-get?

I read about the new fancy progress bar which was added to apt 1.0 in Softpedia and how to enable it here. However on running sudo apt-get update, I did not see the fancy progress bars. On reading the ...
49
votes
6answers
84k views

Apt/Synaptic needs to reinstall package but can't find the archive for it

Running Synaptic I get the following error message: E: The package hl1440lpr needs to be reinstalled, but I can't find an archive for it. E: Internal error opening cache (1). Please report. Upon ...
79
votes
7answers
70k views

E: Problem executing scripts APT Update::Post-Invoke-Success error during apt-get update

I cannot install any package. It seems the command apt-get update must be run but it throws some errors: $ sudo apt-get update Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 ...
22
votes
6answers
30k views

Ubuntu system is broken after accidentally uninstalling many packages

I accidentally removed all the packages starting with the name jpeg with: sudo apt-get remove jpeg* This screwed up a lot of things, removed Unity, Firefox, Flash player etc. I somehow managed to ...
27
votes
10answers
107k views

Got NODATA issue: 'NODATA' (does the network require authentication?)

I can use my mobile broadband to access Internet with Firefox but when I want to install any package from terminal or make 'apt-get update' command I got the following error: got 'NODATA' (does the ...
223
votes
7answers
201k views

Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'xxx' doesn't support architecture 'i386'

Getting below error message while issuing : sudo apt-get update Get:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease [95.8 kB] Ign:2 http://repo.mongodb.org/apt/debian wheezy/mongodb-org/3.2 ...
21
votes
2answers
58k views

Restore default apt repositories in sources.list from command line

I am looking for the best method to restore /etc/apt/sources.list to default from the command line. Is there no way to reference the source code of the package which generates this file or something ...
120
votes
10answers
266k views

How to create a local APT repository?

I would like to build my own local repository on my LAN, so that machines on the LAN can update and upgrade from it. I want to download the packages and store them on my local server so that I can ...
371
votes
6answers
631k views

How to downgrade a package via apt-get?

How can I downgrade a package to an older version via apt-get? Other tools are also acceptable but apt-get is preferred.
51
votes
3answers
43k views

Ubuntu 16.04 slow boot (apt-daily.service)

My boot is horribly slow, and I don't know why. $ systemd-analyze Startup finished in 10.975s (kernel) + 49.732s (userspace) = 1min 708ms $ systemd-analyze blame 34.971s apt-daily.service ...
246
votes
16answers
163k views

Generating list of manually installed packages and querying individual packages

I'd like to get a list of packages installed manually by apt or aptitude and be able to find out whether a foobar package was installed manually or automatically. Is there any neat way of doing that ...
154
votes
14answers
246k views

How do you select the fastest mirror from the command line?

I want to update my sources.list file with the fastest server from the command line in a fresh Ubuntu Server install. I know this is trivially easy with the GUI, but there doesn't seem to be a simple ...
56
votes
12answers
191k views

'apt-get' does not work with Proxy

For the command sudo apt-get update I get following error: W: Failed to fetch http://ch.archive.ubuntu.com/ubuntu/dists/maverick-updates/multiverse/binary-i386/Packages.gz 407 Proxy ...
807
votes
9answers
2.5m views

How to install updates via command line?

When I log into my web server via SSH I see the information: 88 packages can be updated. 80 updates are security updates I tried apt-get update then apt-get upgrade but each time I log in I still ...
50
votes
6answers
37k views

apt-get remove with wildcard removed way more than expected. why?

Last night I was trying to burn CDs. Being annoyed with k3b and choosing to use brasero instead, I went to remove k3b. I typed in: sudo apt-get remove k3b I hit tab twice and saw that I had both ...
4
votes
2answers
10k views

What is the correct output of cat /etc/apt/sources.list?

I have Ubuntu 12.04 LTS. I need the correct output because I edited it because it wasn't working but it has only made it worse.
36
votes
2answers
113k views

Problem with sudo apt get update: The repository cdrom… does not have a Release file

Every time I try update (using sudo apt-get update) my Ubuntu I get this problem: W: The repository 'cdrom://Ubuntu 16.04 LTS _Xenial Xerus_ - Release amd64 (20160420.1) xenial Release' does not have ...

1
2 3 4 5
48