2022 Developer Survey is open! Take survey.

Questions tagged [appstream]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
39 views

How does appstream work and how to implement it?

I'm maintaining a GUI app and releasing it via a PPA. I already read Metadata quick start for appstream and I think I added it to my project correctly. The point is I don't get how it's working. First ...
user avatar
0 votes
1 answer
156 views

get error while sudo apt update in ubuntu 18.04 [duplicate]

My system is broken not able to work anything on that. Ubuntu online store shows empty when I try to update I get an error related to Appstream AppStream system cache was updated, but problems were ...
user avatar
1 vote
1 answer
500 views

How to handle appstream:// links in Ubuntu?

I have some AppStream links (for ex.: appstream://org.kde.k3b.desktop) that I want to open, I tried to find an app to open them but couldn't find any, so any ideas on how to do this ?
user avatar
1 vote
1 answer
139 views

How does Discover decide which applications it should feature?

Kubuntu's software management suite is called Discover (or plasma-discover if you're using a terminal) and is analogous to the Ubuntu Software Center (or gnome-software). Its main panel displays a ...
user avatar
  • 38.2k
2 votes
1 answer
1k views

Metadata and appstream Error while Updating

I am getting an error while updating as a root. After Update log below error was shown in terminal. AppStream system cache was updated, but problems were found: Metadata files have errors: /var/...
user avatar
1 vote
0 answers
327 views

Apt update failing after updating appstream [duplicate]

this issue is linked to how I can fix "AppStream cache update completed, but some metadata was ignored due to errors."?" I had similar problem as described in issue and the approved ...
user avatar
  • 121
-1 votes
2 answers
837 views

What does the apt update error mean? [duplicate]

After running "sudo apt update" it seems to work but I get this error "AppStream cache update completed, but some metadata was ignored due to errors." What does it mean? ubuntu 16.04 LTS Hit:1 http:/...
user avatar
  • 51
13 votes
2 answers
8k views

appstreamcli: AppStream system cache was updated, but problems were found: Metadata files have errors: /var/cache/app-info/xmls/fwupd.xml

How do I get rid of this? $ sudo apt-get update Hit:1 http://se.archive.ubuntu.com/ubuntu xenial InRelease Hit:2 http://se.archive.ubuntu.com/ubuntu xenial-updates InRelease ...
user avatar
  • 3,889
1 vote
0 answers
29 views

Updating package lists in 16.04 [duplicate]

I'm running 16.04 from a thumb drive and receiving an error message when I attempt to update package lists. ubuntu@ubuntu:~$ sudo apt-get update Ign:1 cdrom://Ubuntu 16.04.4 LTS _Xenial Xerus_ - ...
user avatar
1 vote
0 answers
37 views

Running command sudo apt-get update, getting error "Error while moving old databse out of the way" App stream cache update failed [duplicate]

Error while moving old database out of the way. App stream cache update failed
user avatar
80 votes
8 answers
73k views

E: Problem executing scripts APT Update::Post-Invoke-Success error during apt-get update

I cannot install any package. It seems the command apt-get update must be run but it throws some errors: $ sudo apt-get update Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 ...
user avatar
35 votes
2 answers
106k views

E: Problem executing scripts APT::Update::Post-Invoke-Success [duplicate]

I am getting the following error when I run sudo apt update Aborted (core dumped) Reading package lists... Done E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/...
user avatar
  • 351
0 votes
0 answers
456 views

AppStream problems found "Metadata files have errors: /var/cache/app-info/xmls/fwupd.xml" on Ubuntu 17.04 [duplicate]

I have researched this, and there are no other entries on the internet that I can find with this problem, so posting here. It may be that the wording in 17.04 is different leading to no hits. But ...
user avatar
11 votes
3 answers
20k views

Ubuntu 16.04: appstreamcli error while get-update [duplicate]

I am trying to enable WiFi. I tried sudo apt-get update. But I am getting this error: The AppStream system cache was updated, but some errors were detected, which might lead to missing metadata. ...
user avatar
3 votes
1 answer
328 views

Is it safe to upgrade appstream if APT has kept it back?

I ran apt upgrade the other day, and got this: The following packages have been kept back: appstream According to a related question somewhere on this site, appstream is safe to even remove. How ...
user avatar
28 votes
2 answers
10k views

What is AppStream? Why is it installed? What is it doing?

There's another question about AppStream that has —for better or worse— focussed on what seems to be a particular bug in AppStream but that left me realising I don't have a clue what this thing ...
user avatar
  • 280k
76 votes
2 answers
18k views

appstreamcli hanging with 100% CPU usage during update

appstreamcli is overheating my laptop by constantly using 100% of a core. My only solution is to kill it. Here's a screenshot of top: I can kill appstreamcli with either sudo kill pid or sudo killall ...
user avatar
3 votes
1 answer
3k views

appstreamcli: Detected colliding ids: XY.desktop was already added with the same priority

I have recently found that when running sudo apt-get update on Ubuntu GNOME 16.04 (though it is the same on all flavours) that this is the output: Get:1 http://gb.archive.ubuntu.com/ubuntu xenial ...
user avatar