Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now

Questions tagged [ahci]

Advanced Host Controller Interface (AHCI) is the particular way SATA controllers communicate with storage devices.

Filter by
Sorted by
Tagged with
1
vote
1answer
54 views

No hard drive detected during ubuntu 19.04 installation

I'm attempting to install Ubuntu 19.04 on a Dell Inspiron 7490 (2019). When I get to the point of selecting a partition to install on, the installer can't find any hard drive and I just see an empty ...
1
vote
0answers
239 views

Problem installing Ubuntu in a laptop with Intel Optane

I am new in Linux and I am trying to install Ubuntu 18.04 LTS in my laptop with a Dual Boot with Windows 10. My laptop is an Asus with 4GB RAM, 1TB HDD, and 16GB Intel Optane. The problem is that ...
1
vote
0answers
22 views

Stuck in grub_rescue and no access bios

I'm stuck in Grub_rescue on my laptop. I can only boot from Ubuntu Live USB, but in the installation, he does not recognise my SSD. Normally you should change the SATA-mode in the bios, but there is a ...
1
vote
0answers
63 views

CPU at 99-100% after installing Ubuntu

Yesterday I went to install ubuntu, but the screen would freeze during loading so I never really got to the installation screen. So I turned off the acpi as written in the link below and it worked. ...
0
votes
0answers
61 views

How to get Ubuntu to recognise an AHCI SSD using RAID mode

I have a RAID0 on my computer with Windows 10 installed, so in the BIOS it's in Intel RST. I happen to have a Samsung SM951 AHCI SSD which I want to put in and install Ubuntu on. However, I cannot see ...
0
votes
0answers
62 views

Black screen after new SATA card installation

I'm at a real loss right now... I don't even know how to move forward with troubleshooting. I have an old sata card that I swear used to work, but when I boot with it plugged into any of my boards ...
0
votes
0answers
327 views

Ubuntu got installed, but no GRUB screen?

I managed to install Ubuntu onto a SSD on AHCI mode. Alongside Win 10. Win 10 was pre-installed, has a boot loader in the UEFI, and in the UEFI there is nothing named Linux to begin with. How to get ...
1
vote
1answer
706 views

Installing dual boot Ubuntu 18.04 on dell xps 15 9570 RAID or AHCI

I have recently bought this a new dell xps15 9570 computer. I have partitioned the windows such that there is a partition with ~650GB empty. I have followed the instructions here When I start the ...
1
vote
1answer
967 views

Installing Ubuntu 18.04 alongside windows10, the SSD is not recognized

I have DELL Precision, with 512GB SSD. I did shrink the only Drive C, and made 125 GB of unallocated space to install Ubuntu on it. restarting the system choosing boot, install Ubuntu, the ...
0
votes
0answers
36 views

What Ubuntu Kernel Extensions were installed to enable SSD to run on non-AHCI motherboard?

A Dell Optiplex 390 is successfully outfitted with an SSD + 16.04. The internet indicates motherboard does not feature AHCI capability and that kernel extension are necessary to implement AHCI. ...
0
votes
0answers
19 views

AHCI absence confirmation

Do test results confirm AHCI absence? user@Brooklyn:~$ dmesg | grep -i ahci user@Brooklyn:~$ dmesg | grep -i scsi [ 0.128381] SCSI subsystem initialized [ 0.674506] Block layer SCSI generic (...
1
vote
0answers
117 views

How can I use SATA hot plugging in Ubuntu 16.04 on an Intel NUC NUC7i7DN board?

If I attach a SATA drive to the NUC(NUC7i7DN) after booting into Ubuntu 16.04, the drive is not recognised. Nothing shows up with lsblk or dmesg. If I restart, the drive shows up. Additionally, I am ...
3
votes
1answer
260 views

Dual Boot Windows 10 and Kubuntu - SATA AHCI vs RAID [error]

I dual installed Kubuntu on a computer with Windows 10, grub is on /dev/sda while the Windows boot manager is on /nvmesomethingsomething. To install it, I had to set SATA from RAID to AHCI in the ...
1
vote
0answers
813 views

RAID/AHCI Trouble installing Ubuntu alongside Windows 10 on Dell laptop

I need help installing Ubuntu on my Dell Inspiron 7577. Note, this laptop comes with windows 10 pre-installed on a SSD. I tried installing Ubuntu 17.10 using a USB device. But as I went on with the ...
3
votes
2answers
8k views

How to switch from IDE to AHCI [closed]

I have dualboot Xubuntu 16.04.03 and Windows 7, unfortunately SATA controller is switched to IDE and I would like to switch to AHCI for better performance and didn't find out how. When switched BIOS ...
0
votes
1answer
378 views

After Switching IDE to AHCI Ubuntu Installs But Won't Boot

So, after switching IDE to AHCI Ubuntu 16.04.03 installs fine, but won't boot. Just stays on purple screen. Here is my BootInfo summary.
4
votes
0answers
634 views

Long boot time on Dell XPS 13 9350

I installed Xubuntu 17.04 on my Dell XPS 13 9350. It looks like everything works fine except one thing. The boot time is more than 100 seconds. Here is the dmesg output. Scroll it to line 914: [ 4....
4
votes
1answer
3k views

SATA Drive is not detected when hotswapping

So from what I've read online, if AHCI is enabled in the BIOS, I should be able to hot-swap a SATA drive and it will supposedly "just work". However, that has not been my experience. When I hot-swap ...
2
votes
1answer
2k views

“No bootable device found” after Ubuntu installation hangs

Received my Dell XPS15 9550 today and the first thing on the todo list was installing Ubuntu 16. After some initial challenges which were fixed because the SSD was configured in the BIOS with "Raid ...
1
vote
0answers
786 views

Why doesn't the latest Ubuntu 16.04 build support AHCI out of the box?

So, in reference to this earlier question, which I can't comment on: https://askubuntu.com/questions/757142/16-04-kernel-support-for-ahci?newreg=b938c2416e6d40c8ac5c3233d16889e5 I am trying to PXE ...
0
votes
1answer
5k views

What is 'AHCI mode' - HP ProLiant MicroServer Gen8

I have just purchased this server and I would like to install Ubuntu Server on it. I would like to keep RAID support, although I'm currently only using one HDD which will have my files and OS on it. ...
1
vote
0answers
160 views

Strange SATA Problem / Ubuntu 14.04 / ASUS P8Z68V / OCZ Vertex 2

this is my first question, because i usually got things going myself. But this time i'm out of ideas. As mentioned in the thread title, i have a very strange problem with my SATA boot device. It ...
1
vote
1answer
414 views

Should I enable my Mobo Raid controller or leave it at AHCI?

I am setting up a raid storage volume, should I leave the sata controller on AHCI or switch it to raid when using Ubuntu's software side raid?
1
vote
1answer
624 views

Ubuntu + Windows 8 -> Dell 14z 5423 AHCI / ISRT

I just bought a Dell 14z 5423, which uses UEFI/GPT and Intel Smart Response on the Windows 8. I have been researching and studying how to use it as Dual boot. Thanks to this forum I was able to ...
5
votes
1answer
22k views

Does Ubuntu support SATA drives in AHCI mode?

I have a current installation of Ubuntu 13. Will it boot if I switch my SATA controller to AHCI in BIOS? (I installed Ubuntu in IDE mode) I have to wait until I fix my GRUB (Windows ate it), so I ...
1
vote
1answer
2k views

Best configuration for 1 SSD and 2 HDD's?

I'm going to be buying a sata 3 motherboard (Gigabyte GA-970A-DS3) and a new SSD (SATA 3) as my boot/programs disk. In addition, I will be using my 2 old maxtor diamondback 10's (7200 - 300gb each) ...
9
votes
2answers
11k views

Am I using IDE or AHCI?

I recently installed an SSD in my laptop, but according to what I've read AHCI mode is preferable to IDE mode for SATA drives, something that is set in the computer's BIOS. However, I don't have any ...
7
votes
1answer
1k views

Very slow copying Ubuntu 12.10, AHCI

I have two disks, SSD (Samsung 830 128GB) and normal HDD (WD 1TB) and Ubuntu 12.10 installed. AHCI enabled in the BIOS. I have a problem with extremely slow copying in all directions (Samsung->Samsung,...
1
vote
1answer
770 views

Why Ubuntu 12.04 shows me AHCI error?

I installed 64 bit Ubuntu 12.04 LTS and the computer won't boot. This is a Dell Precision Workstation 690 computer, which has a BIOS dated in 2006. It was running Red Hat EL 4 quite well. The Ubuntu ...
0
votes
1answer
410 views

MacBook Pro 6,2 12.04 running hot? AHCI

I've finally managed to get 12.04 running on my MacBook Pro with a 240GB SSD, I've heard that running an SSD in IDE on Ubuntu can make it run very hot, which I suspsect is what I'm experiencing. Is ...
1
vote
1answer
1k views

UEFI/GPT Win 7 Load Failure in Dual Boot and no GRUB2 [Ubuntu 12.04]

Configuration: MBB: ASRock X79 Extreme6 Win 7 installed on a INTEL 40GB SSD (GPT partitioned) Ubuntu 14.04 on a CORSAIR 30GB SSD (Ext4 and SWAP) I had Windows 7 installed previously in UEFI mode,...
0
votes
2answers
5k views

How to disable built-in driver “AHCI” when installing 12.04?

I need to change AHCI module in Ubuntu, and I've always uses ahci.blacklist=yes. But now it doesn't work bcause AHCI is built-in the kernel, and CONFIG_SATA_AHCI=y not CONFIG_SATA_AHCI=m. What can I ...