Questions tagged [add-apt-repository]

A command line utility to add and remove APT software repositories, such as PPAs. It is part of the software-properties-common package and installed in Ubuntu by default.

Filter by
Sorted by
Tagged with
1
vote
0answers
83 views

Can't install wine 6.0 in ubuntu 20.04

I followed the instructions in https://wiki.winehq.org/Ubuntu but still get the following error Certificate verification failed: The certificate is NOT trusted. The revocation or OCSP data are old and ...
0
votes
1answer
653 views

keep on getting '404 Not Found [IP: 91.189.95.85 80]' error when getting wine repository [duplicate]

I have been trying to download wine through https://wiki.winehq.org/Ubuntu and I keep on getting this error when adding the repository using this command: Sudo add-apt-repository 'deb https://dl....
0
votes
0answers
54 views

How to install older gcc package using APT from a repository?

I have GCC v9. But I'm trying to install a GCC 4.8.1 version to test a library compilation on that very old version of GCC. The version is not available in the official Ubuntu repos,it is deprecated, ...
0
votes
0answers
10 views

unable to install cudo miner to ubuntu [duplicate]

what i am trying to run: sudo su -c "bash <(wget -qO- https://download.cudo.org/tenants/135790374f46b0107c516a5f5e13069b/5e5f800fdf87209fdf8f9b61441e53a1/linux/x64/stable/install.sh)" ...
0
votes
1answer
79 views

Make add-apt-repository use python3.7 instead of python3

I am using Ubuntu 16.04 LTS. I'm trying to use sudo add-apt-repository , but I'm getting the module apt_pkg not found error: Traceback (most recent call last): File "/usr/bin/add-apt-repository&...
0
votes
1answer
802 views

How to install gnuplot 5.4 at ubuntu20.04

I'm using Ubuntu 20.04, I work with Gnuplot 5.2.8, but only some features are at the version most recent. My question-specific question is. How to upgrade Gnuplot 5.4.0 at ubuntu 20.04?. Thanks ...
0
votes
0answers
126 views

How to get the gpg key for a repository?

When adding a repository through add-apt-repository a new gpg key will be add. e,g: sudo add-apt-repository ppa:some-ppa You will be asked to press Enter to import the gpg key. I need to get the gpg ...
1
vote
2answers
311 views

“sudo apt-key add -” has no effect [duplicate]

This command: sudo add-apt-repository ppa:upubuntu-com/network -y returns: Cannot add PPA: ''This PPA does not support focal''. Then I'll jump straight to the point by skipping the elementary part ...
0
votes
1answer
529 views

add-apt-repository <ppa> always throws an error

I'm currently facing this issue with add-apt-repository. Whenever I try to do anything (adding or even removing repos), I get this error: Traceback (most recent call last): File "/usr/bin/add-...
0
votes
0answers
127 views

Can't add any apt repositories due to python3 error

I am trying to add an apt repository, but I get an error saying: Traceback (most recent call last): File "/usr/bin/add-apt-repository", line 11, in <module> from ...
0
votes
0answers
77 views

add-apt-repository not working in any way, shape or form. (Ubuntu 19.10)

Whenever I run sudo add-apt-repository regardless of arguments, it throws up this error: Traceback (most recent call last): File "/usr/bin/add-apt-repository", line 11, in <module> ...
1
vote
1answer
125 views

How do I get the pubkey for ksplice?

(I am aware that installing third-party bundles poses a theoretical security risk.) I am using ksplice to apply kernel updates for a running system. After installing, I cannot run sudo apt-get update ...
1
vote
0answers
309 views

Can't run software-properties-gtk or add repositories through Terminal

Today, I wanted to see how Elementary OS' Pantheon desktop environment would work with my workflow. I didn't care much for it, so I removed all traces (I could easily find on my own) using Synaptic. ...
1
vote
2answers
1k views

do-release-upgrade disables third party software sources. Easy way to re-enable them? [duplicate]

I recently upgraded my Ubuntu from 19.04 to 20.04. And as always, the first thing that happens is that all third party software sources are disabled. I'm sure there are good reasons to do that and I ...
0
votes
2answers
337 views

Remove apt repository?

Some while ago I may have accidentally added an apt repository with an invalid URL. Now, every time I run sudo apt update, the following error message shows at the bottom: E: The repository 'http://...
0
votes
1answer
25 views

Installing okular on a barebone ubuntu container where there is no add-apt-repository command

I have Ubuntu 18:04 Bionic installed in a Singularity container.(*) Via the Singularity definition file I try to add the Okular PDF viewer with the command line apt-get install -y okular However I ...
1
vote
1answer
3k views

aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Elementary/next

The following happens every time I want to add a repository - It is not working since I have installed (and then uninstalled) pantheon desktop :( $ sudo add-apt-repository ppa:appgrid/stable ...
3
votes
2answers
7k views

Error: 'multiverse' invalid + Error: 'universe' invalid

I have this Dockerfile: FROM node:11 USER root WORKDIR /tmp RUN apt-get update RUN apt-get install -y software-properties-common RUN add-apt-repository multiverse RUN add-apt-repository universe I ...
2
votes
1answer
1k views

add-apt-repository is throwing strange errors (18.03)

I was attempting to enable the wireshark repositories when following the guide that they give on their website, and when I ran sudo add-apt-repository ppa:Wireshark-dev/stable it returned these ...
1
vote
0answers
76 views

Installing Deepin Desktop Environment on Ubuntu 19.10 [duplicate]

I tried to install the Deepin Desktop Environment by following the instructions given in several websites, but when I started adding the PPA by executing the command: sudo add-apt-repository ppa:...
1
vote
2answers
2k views

Installation php5.6 on Ubuntu 19.10 doesn't work even with ppa:ondrej/php

I need to install php5.6 to my Ubuntu 19.10, found out a lot of variants in the internet and almost all of them was the same - to use ppa:ondrej/php I tried this variant: sudo add-apt-repository ppa:...
0
votes
0answers
113 views

I may installed wrong apt-repository and packages while reinstalling GPU drivers

A general question: If I think I've added wrong apt-repository and installed wrong GPU drivers, what I should do? About my situation: I have Kubuntu 19.04 and AMD R9 280X (HD 7970/8970). Because I ...
-1
votes
1answer
3k views

Unable to locate package libapache2-mod-php7.0 [closed]

I'm trying to install Rainloop Webmail on Debian. I've added the next package add-apt-repository ppa:ondrej/php This key was added: 4F4EA0AAE5267A6C But upon apt-get update: Reading package lists.....
0
votes
1answer
95 views

add-apt-repository gives no result, cursor keeps on blinking for long time

root@Gagan-PC:~# add-apt-repository ppa:slimbook/slimbook and I get no result after this, it just keeps on blinking
2
votes
1answer
153 views

Upgrading From Ubuntu 18.04.2 to 19.04 Using DVD

I hope someone can help. My SSD hard drive containing the OS failed but I was able to rescue most of my data using ddrescue. I restored the data for my old Ubuntu 18.04.2 (Bionic Beaver) to the ...
1
vote
0answers
993 views

Command add-apt-repository problems [duplicate]

I'm trying to do this: sudo add-apt-repository \ "deb [arch=amd64] https://download.docker.com/linux/ubuntu \ $(lsb_release -cs) \ stable" And getting: Traceback (most recent call last): ...
0
votes
1answer
2k views

sudo add-apt-repository hangs with no error Ubuntu 19.04

Whenever I try to run sudo add-apt-repository ppa:docky-core/ppa(for any ppa, not just this one) it just hangs indefinitely, without giving any sort of error, even with the -m flag. After I terminate ...
0
votes
0answers
21 views

how to fix W: Target packages and Target DEP-11 error on ubuntu 19.04 [duplicate]

when I tried to add a repository I'm getting these warning I don't know how to fix them. please help me on how to fix this warnings or errors. What can I do? (base) test@Batman:~$ sudo apt-add-...
0
votes
0answers
81 views

Unable to add PPA for DTS Audio in Ubuntu 19.04 [duplicate]

I have an AMD E1-2100 APU in 2GB RAM. I'm trying to use DTS Audio in my Ubuntu 19.04. I tried adding the appropriate PPA repo using add-apt-repository ppa:rebuntu16/avidemux+unofficial But I get ...
9
votes
1answer
14k views

Retrieving gpg Key timed out - What does this mean?

I am unable to install any packages thru the terminal. After doing sudo add-apt-repository, the terminal seems to run normally (after about 5-10 minutes however) and am asked to hit enter. After I hit ...
3
votes
2answers
10k views

Python can't find module named apt_pkg

I am running Ubuntu 16.04 and on my server I have 2 version of python , python3.5 and python3.6. What I already tried is: uninstalling python3-apt and reinstalling it, didn't help still the same ...
8
votes
2answers
9k views

sudo add-apt-repository hangs

I am running sudo add-apt-repository ppa:webupd8team/java in order to add the repository to install oracle jdk on my Ubuntu 18.4 machine. The command hangs and does not return. As far as I understand ...
2
votes
1answer
2k views

add-apt-repository command is suddenly very slow

There were no issues before, but today I started my computer and I removed the unstable OIBAF graphics drivers and tried to add stable OIBAF graphics PPA. I left for about 15 minutes and when I came ...
2
votes
1answer
5k views

Installing firebird 2.5 on ubuntu 18.10

I want to install firebird 2.5 server on ubuntu 18.10 I followed this installing firebird 2.5, but got stuck in sudo add-apt-repository ppa:mapopa it says error E: The repository 'http://ppa....
0
votes
1answer
4k views

How do I fix apt-add-repository “no such option: --allow-unauthenticated”? [duplicate]

I'm running 18.04, and I'm attempting to install Wine, which has an unsigned repository. I tried bypassing this by using the --allow-unauthenticated flag, but I get an error $ sudo apt-add-repository ...
32
votes
8answers
64k views

ModuleNotFoundError: No module named 'apt_pkg' error

I run below command on ubuntu 16.4 : sudo add-apt-repository ppa:noobslab/apps of below question: How to install PlayOnLinux on Ubuntu 16.04 and get below error: Traceback (most recent call last):...
1
vote
1answer
199 views

Solutions for risks when using external repository

This is a list of risks when using external repositories I found. Quality: Conflict between packages from external repositories and stable packages in system. Conflict between external repositories ...
0
votes
1answer
2k views

How to install BareOS on Ubuntu?

Many repository directories are organized as dists, pool etc. And anyone can simply edit sources.list file in order to add new repo. I need to add an extraordinarily structured repo like this. How ...
3
votes
1answer
868 views

UnicodeDecodeError: 'utf-8' codec can't decode byte 0xfc in position 17: invalid start byte

I want to install Nginx together with Let's Encrypt on Ubuntu 18.04 and already installed this package: software-properties-common When I try to use the command: sudo add-apt-repository ppa:certbot/...
4
votes
1answer
17k views

apt-add-repository: Command not found

If I try something like: sudo add-apt-repository ppa:graphics-drivers/ppa it raises an error: Command not found. So I installed the repository with: apt-get install software-properties-common and ...
3
votes
1answer
1k views

Wine 3.x repository 404 error

I've been trying to install wine but the repository doesn't get added. I have added the release key it doesn't seem to recognize that either. Please help... >.< $ sudo apt-add-repository https://...
7
votes
3answers
27k views

Can't install Unetbootin in Ubuntu 18.04 Live Boot Session

I booted my laptop with Ubuntu 18.04 (Try Ubuntu without installing method). Then, I ran the following command: sudo add-apt-repository universe sudo add-apt-repository multiverse sudo add-apt-...
1
vote
1answer
893 views

ModuleNotFoundError: No module named 'xml.sax' when I use add-apt-repository

When I run this command in terminal sudo add-apt-repository ppa:leaeasy/dde this problem appears: Traceback (most recent call last): File "/usr/bin/add-apt-repository", line 11, in <module> ...
1
vote
0answers
2k views

Error: retrieving gpg key timed out

$ sudo add-apt-repository ppa:git-core/ppa The most current stable version of Git for Ubuntu. For release candidates, go to https://launchpad.net/~git-ore/+archive/candidate . ...
3
votes
1answer
419 views

Can not add repositories in Ubuntu GNOME 17.04

I have tried adding various third party repositories, and I get the same error with all of them. When I try to add third party repositories through the GUI "Other Software" section, I can open the ...
1
vote
0answers
139 views

Why don't Software and Updates & add-apt-repository --remove delete PPA files?

I observe that removing a ppa with Software & Updates or with : sudo add-apt-repository --remove ppa:xxx/yyy merely empties the file one wants to remove and leaves an empty theuglyppa.list file ...
1
vote
1answer
54 views

Unfound repositories [duplicate]

Anytime I got to update my system or install a new theme into unity-tweak tool the error message: "cannot find repositories" appears. I have heard about solutions through making changes in the .list ...
2
votes
0answers
882 views

add-apt-repository gpg error: keybox created, keyserver receive failed: no data

I tired to add the webupd8team/java PPA using the command below, but got an error by gpg: $ sudo add-apt-repository ppa:webupd8team/java error occured gpg: keybox '/tmp/tmp7fgyev7b/pubring.gpg' ...
0
votes
1answer
1k views

Unable to add a Repository [duplicate]

So I am trying to add a ppa and when using add-apt-repository I get apt-add-repository: command not found I tried to do sudo apt-get Install apt-add-repository and there is no file ...
1
vote
1answer
384 views

Impossible for me to install aptitude and to add trusty repos

Trying to run sudo apt-get install aptitude: Package aptitude is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only ...